Affichage défectueux dans Bless sous Mint 20

French Forum

Moderator: Laurent85

Post Reply
Christian_B
Level 3
Level 3
Posts: 116
Joined: Mon May 12, 2014 6:06 pm

Affichage défectueux dans Bless sous Mint 20

Post by Christian_B »

Bonjour,
Depuis Mint 20, Bless (l'éditeur hexa) n'affiche plus que des codes caractères dans les 3 colonnes (adresses, hexa, ASCII).
Sur un autre forum, quelqu'un signale le même problème avec XPad.
Je suppose que ces applis utilisent une police standard du système qui est absente ou défectueuse sous Mint 20.
Enfin, je ne suis pas sûr que ce soit ça et je ne sais pas comment vérifier et trouver éventuellement quelle police c'est.
Une suggestion ? Merci.
Linux Mint 20 64-bits Mate 1.24.0. Carte Gigabyte H81N.
Intel Core i7-4770 : 4x2 cœurs + Xeon E3-1200 (= circuit 4600, sans carte graphique).
Mémoire 8 Go Dual channel, SSD 120Go, HD 2To.
1984 est passé, les émules de Big Brother nous surveillent.
Laurent85
Level 16
Level 16
Posts: 6951
Joined: Tue May 26, 2015 10:11 am

Re: Affichage défectueux dans Bless sous Mint 20

Post by Laurent85 »

Bonjour,
J'ai démarré sur le live d'installation de LM et installé bless je n'ai pas pu reproduire le problème.
Image
Christian_B
Level 3
Level 3
Posts: 116
Joined: Mon May 12, 2014 6:06 pm

Re: Affichage défectueux dans Bless sous Mint 20

Post by Christian_B »

Cela veut apparemment dire qu'il s'agit plutôt d'un problème de la mise à jour que j'ai faite à partir de Mint Mate 19.3.
A tout hasard j'ai désinstallé complètement et réinstallé Bless sans résultat.
Je ne sais pas où trouver de l'information sur la police utilisée par Bless.
Je vais essayer de vérifier s'il n'y aurait pas chez moi une police système manquante ou défectueuse.
Linux Mint 20 64-bits Mate 1.24.0. Carte Gigabyte H81N.
Intel Core i7-4770 : 4x2 cœurs + Xeon E3-1200 (= circuit 4600, sans carte graphique).
Mémoire 8 Go Dual channel, SSD 120Go, HD 2To.
1984 est passé, les émules de Big Brother nous surveillent.
Christian_B
Level 3
Level 3
Posts: 116
Joined: Mon May 12, 2014 6:06 pm

Re: Affichage défectueux dans Bless sous Mint 20 (suite)

Post by Christian_B »

Comme j'ai utilisé antérieurement Xpad, je l'ai relancé et mes notes s'affichent correctement (contrairement au constat d'un autre utilisateur). Donc ce type de problème dépend bien de la config des polices sur une installation donnée.

J'ai constaté que de nombreuses polices de Type 1 (mais pas toutes) n'affichaient que des codes de caractères dans Font Manager. C'est le cas notamment de certaines des polices URW (venant normalement du paquet fonts-urw-base35, standard dans Mint).
Exemple : Font Manager m'affiche une police URW Gothic (Demi Oblique) correctement et une police URW Gothic L (Book, Book Oblique, Demi, Demi-Oblique) avec des codes caractères.

Sous /usr/share/fonts/type1/urw-base35 Je trouve 4 couples (.afm et .t1) de fichiers URWGothic-<Variante> pouvant aussi bien correspondre à URW Gothic L ou, pour l'une, à URW Gothic. Les 4 variantes s'affichent correctement dans le répertoire (Par "Polices" = gnome-font-viewer). Mais pas moyen d'avoir les 4 dans Font Manager.
Edit : j'ai constaté que maintenant URW Gothic L correspondait aux fichiers a00100131.pfb, a001001331.pfb, a00100151.pfb a00100351.pfb sous /usr/share/fonts/type1/gsfonts, sans doute suite à la mise à jour de la config par fc-validate -r. Mais le résultat est le même :cry:

Il y a donc des incohérences, peut-être responsables des défauts constatés :?: , mais je ne sais pas comment en venir à bout. La réinstallation de fonts-urw-base35 et les commandes fc-cache -r et font-manager -u n'ont rien changé.
Linux Mint 20 64-bits Mate 1.24.0. Carte Gigabyte H81N.
Intel Core i7-4770 : 4x2 cœurs + Xeon E3-1200 (= circuit 4600, sans carte graphique).
Mémoire 8 Go Dual channel, SSD 120Go, HD 2To.
1984 est passé, les émules de Big Brother nous surveillent.
Laurent85
Level 16
Level 16
Posts: 6951
Joined: Tue May 26, 2015 10:11 am

Re: Affichage défectueux dans Bless sous Mint 20

Post by Laurent85 »

Crée un nouvel utilisateur et ouvre une session pour tester le comportement de bless dans un profil par défaut.
Image
Christian_B
Level 3
Level 3
Posts: 116
Joined: Mon May 12, 2014 6:06 pm

Re: Affichage défectueux dans Bless sous Mint 20

Post by Christian_B »

Je n'avais pas vu ta réponse, je ne sais pourquoi.
Le problème est le même avec un nouvel utilisateur.
Peut-être faudrait-il que je regarde de près sous /etc/fonts/conf.d/, mais ça a l'air compliqué. A moins que ce problème ne soit connu et qu'il y ait une aide quelque part à ce sujet (pas trouvé pour le moment), je pense que je vais attendre la version Mint 20.1 pour voir si ça s'arrange.
Linux Mint 20 64-bits Mate 1.24.0. Carte Gigabyte H81N.
Intel Core i7-4770 : 4x2 cœurs + Xeon E3-1200 (= circuit 4600, sans carte graphique).
Mémoire 8 Go Dual channel, SSD 120Go, HD 2To.
1984 est passé, les émules de Big Brother nous surveillent.
Post Reply

Return to “Français (French)”