[RESOLU] wine ne fonctionne plus correctement

French Forum

Moderator: Laurent85

Post Reply
stormy732
Level 1
Level 1
Posts: 7
Joined: Fri Sep 18, 2020 12:35 pm

[RESOLU] wine ne fonctionne plus correctement

Post by stormy732 »

Bonjour

Comme je voulais réorganiser mes partitions, je viens de faire une réinstall complète de Linux Mint 20.

Le problème, c'est que je n'arrive plus à lancer le programme LTSpice (logiciel de simulation électronique) avec Wine. Wine lance bien l'executable d'installation et tout fonctionne bien, mais l'executable installé refuse de se lancer, aussi bien depuis le menu Démarrer qu'en ligne de commande (qui n'affiche aucune erreur).

Avant que je fasse la réinstallation du système, le logiciel fonctionnait correctement.

Auriez-vous des pistes ? Ca commence à me prendre la tête !... :lol: Je ne parviens pas à comprendre l'origine du problème.

Merci. :wink:
Last edited by stormy732 on Sat Oct 03, 2020 11:50 am, edited 1 time in total.
stormy732
Level 1
Level 1
Posts: 7
Joined: Fri Sep 18, 2020 12:35 pm

Re: wine ne fonctionne plus correctement

Post by stormy732 »

En lançant la commande

Code: Select all

WINEDEBUG=err wine "C:\\LTspiceXVII\\XVIIx86.exe" &> fichier_log_ltspice.txt
Voici ce que le fichier contient :

Code: Select all

0009:fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"!
0009:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0009:fixme:ver:GetCurrentPackageId (0x1bf19fc (nil)): stub
Je ne sais pas si ce sont des infos pertinentes ?
User avatar
Drugwash
Level 4
Level 4
Posts: 298
Joined: Fri Jun 07, 2019 6:40 am
Location: Ploieşti, RO

Re: wine ne fonctionne plus correctement

Post by Drugwash »

[Modération]
Traduction Google :
1. Quelle version de Wine avez-vous installée cette fois; est-ce la même chose que précédemment? Est-ce 4.x ou 5.x? Est-ce stable, en cours de développement ou en développement? Essayez d'en installer un autre.
2. Vous essayez de lancer l'exécutable 32 bits - avez-vous créé un profil Wine 32 bits et y avez-vous installé l'application? Les applications 32 bits peuvent ne pas fonctionner correctement sous un profil Wine 64 bits.
3. Exécutez winecfg pour le profil actuel et assurez-vous que la version de Windows - par défaut ou spécifique à cet exécutable LTspice - est au moins 7.
4. Lors de l'installation précédente, il se peut que des bibliothèques spécifiques aient été définies sur natives et vous avez peut-être installé des packages Windows natifs à un moment donné.
5. Il peut y avoir des polices manquantes dans une installation Wine propre, que l'application requiert; essayez d'installer le package de polices MS.

Il peut y avoir d'autres raisons d'échec - c'est tout ce à quoi je pouvais penser du haut de ma tête. J'espère que ce serait utile. Bonne chance!
[/Modération]

[Modération]
Cette section du forum est en langue française. Utilise un traducteur en ligne avant de poster :idea:
[/Modération]
Last edited by Laurent85 on Tue Sep 29, 2020 5:32 am, edited 2 times in total.
Reason: Google translation
stormy732
Level 1
Level 1
Posts: 7
Joined: Fri Sep 18, 2020 12:35 pm

Re: wine ne fonctionne plus correctement

Post by stormy732 »

J'ai tout recommencé à zéro, mais sans succès...

Code: Select all

sudo apt-get purge ^wine
rm -rf ~/.wine
sudo apt-get install wine-stable
cd ~/tmp
wget http://ltspice.linear-tech.com/software/LTspiceXVII.exe
Puis, ça :

Code: Select all

wine LTspiceXVII.exe
Ca fonctionne.

Mais ça :

Code: Select all

wine ~/.wine/drive_c/LTspiceXVII/XVIIx86.exe
Ca ne fait rien du tout. Ca rend la main.

Après recherches sur le net, ça semble fonctionner chez tout le monde... sauf chez moi. :twisted:

Code: Select all

wine --version
wine-5.0 (Ubuntu 5.0-3ubuntu1)
J'ai un PC portable (sous Linux Mint 20 aussi) sur lequel LTspice est également installé. Les paquets sont à jour. Et LTspice fonctionne aussi.

Je me demande bien ce qui provoque ce problème sur mon PC de bureau... Problème de config ? Mais où ? :roll:
stormy732
Level 1
Level 1
Posts: 7
Joined: Fri Sep 18, 2020 12:35 pm

Re: wine ne fonctionne plus correctement

Post by stormy732 »

Me revoilou.

Suite un gros crash, à cause d'une mauvaise utilisation de Synaptic (honte à moi ! :oops: ), et après avoir réinstallé des paquets qui ont été supprimés malgré moi, cela a bizarrement résolu le problème de Wine. J'aurais quand même aimé savoir ce qui posait problème. Mais bon... C'est de l'histoire ancienne maintenant. :wink:
Post Reply

Return to “Français (French)”