Sortie audio analogique indisponible (ALC887)

French Forum

Moderator: Laurent85

Post Reply
Sylvain-X86
Level 1
Level 1
Posts: 3
Joined: Tue Dec 15, 2020 5:25 pm

Sortie audio analogique indisponible (ALC887)

Post by Sylvain-X86 »

Bonjour,

suite à l'installation de Gnu/Linux Mint 20 Mate,
la sortie audio analogique n'est pas disponible dans les préférences du son
avec une carte son intégrée Realtek ALC887, seul choix disponible : Sortie numérique S/PDIF.
La carte son fonctionne parfaitement bien avec la version Mint 17 Mate.

Retour de la commande suivante :

Code: Select all

cat /proc/asound/pcm

Code: Select all

00-00: ALC887-VD Analog : ALC887-VD Analog : playback 1 : capture 1
00-01: ALC887-VD Digital : ALC887-VD Digital : playback 1
00-02: ALC887-VD Alt Analog : ALC887-VD Alt Analog : capture 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 0 : HDMI 0 : playback 1
01-08: HDMI 0 : HDMI 0 : playback 1
01-09: HDMI 0 : HDMI 0 : playback 1

Retour de la commande suivante :

Code: Select all

lspci -v

Code: Select all

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
	Subsystem: ASUSTeK Computer Inc. M5A78L LE
	Flags: bus master, slow devsel, latency 64, IRQ 16, NUMA node 0
	Memory at fbff8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

Retour de la commande suivante :

Code: Select all

sudo modprobe snd-

Code: Select all

modprobe: FATAL: Module snd- not found in directory /lib/modules/5.4.0-58-generic

Retour de la commande suivante :

Code: Select all

dmesg | grep snd

Code: Select all

[   16.182613] snd_hda_intel 0000:00:14.2: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
[   16.182842] snd_hda_intel 0000:01:00.1: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
[   16.182874] snd_hda_intel 0000:01:00.1: Disabling MSI
[   16.182877] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[   16.343076] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[   16.343078] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   16.343080] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   16.343080] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   16.343081] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x0
[   16.343082] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   16.343083] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[   16.343085] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[   16.343086] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a


Je ne parviens pas à dépanner, faudrait-il réinstaller Pulse audio ?

Une idée ?

Merci de votre aide :)
User avatar
MrEen
Level 22
Level 22
Posts: 16685
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sortie audio analogique indisponible (ALC887)

Post by MrEen »

Bonjour Sylvain-X86, et bienvenue sur le forum.

Installez si nécessaire et exécutez pavucontrol. Changez le profil de l'onglet Configuration en duplex stéréo analogique.
Sylvain-X86
Level 1
Level 1
Posts: 3
Joined: Tue Dec 15, 2020 5:25 pm

Re: Sortie audio analogique indisponible (ALC887)

Post by Sylvain-X86 »

Bonjour MrEen

Merci pour votre aide réactive :D

Après l'installation de "Pavucontrol"
puis, le changement de profil dans l'onglet "Configuration"
la sortie audio analogique est à nouveau disponible dans les préférences du son,
et l'audio fonctionne parfaitement !

Après redémarrage de la machine, la configuration de Pavucontrol n'est pas mémorisé.

- Pourquoi dans le profil Audio interne est indiqué "Unavailable"
- Comment mémoriser l'état de la configuration par défaut avec "Duplex stéréo analogique" ?

Merci

Image
Sylvain-X86
Level 1
Level 1
Posts: 3
Joined: Tue Dec 15, 2020 5:25 pm

Re: Sortie audio analogique indisponible (ALC887)

Post by Sylvain-X86 »

* La mémorisation de l'état de la configuration par défaut est résolue, en modifiant le fichier de configuration de Pulseaudio

Lecture du fichier default.pa :

Code: Select all

 sudo nano /etc/pulse/default.pa 

Puis en ajoutant la ligne suivante :

Code: Select all

 set-card-profile 1 output:analog-stereo
Image

Sauvegarde avec CTRL + o


Merci :D
Post Reply

Return to “Français (French)”