Page 1 of 1

impossibilité d'installer HPLIP

Posted: Sun Dec 27, 2020 10:55 am
by zibozibo
Bonjour,

Je rencontre de gros soucis pour installer HPLIP

J’étais auparavant sur Xubuntu, j’ai donc installé Linux Mint pour voir si l’affaire allait s’arranger : que nenni.

Après avoir tenté d’installer autant de version que ce peut de HPLIP, depuis .13 jusqu’à .20, j’ai également tenté d’installer un driver .exe de hp pour window via Wine : peine perdue.

L’imprimante dont je dispose est HP Smart Tank 530 series (elle est neuve), pour laquelle hplip-3.19.6.run semble le plus recommandé.

Attention : je ne suis actuellement pas en présence de l’imprimante qui se trouve dans un autre lieu. L’autre dit lieu ne dispose pas d’internet.

Le retour de

Code: Select all

cd Téléchargement 
sh  hplip-3.19.6.run
est :

Code: Select all

jerry@jerry-ThinkPad-L440:~$ cd Téléchargements
jerry@jerry-ThinkPad-L440:~/Téléchargements$ sh hplip-3.19.6.run
Creating directory hplip-3.19.6
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.6 Self Extracting Archive...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
/home/jerry/Téléchargements/hplip-3.19.6/base/utils.py:2061: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if weburl is "" or weburl is None:

HP Linux Imaging and Printing System (ver. 3.19.6)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Sat-26-Dec-2020_21:18:30.log

/home/jerry/Téléchargements/hplip-3.19.6/installer/core_install.py:2060: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if home_dir is "":
Traceback (most recent call last):
  File "./install.py", line 241, in <module>
    text_install.start(language, auto, test_depends, test_unknown, assume_network, max_retries, enable, disable)
  File "/home/jerry/Téléchargements/hplip-3.19.6/installer/text_install.py", line 63, in start
    core = CoreInstall(MODE_INSTALLER, INTERACTIVE_MODE)
  File "/home/jerry/Téléchargements/hplip-3.19.6/installer/core_install.py", line 240, in __init__
    self.passwordObj = password.Password(ui_mode)
  File "/home/jerry/Téléchargements/hplip-3.19.6/base/password.py", line 113, in __init__
    self.__readAuthType()  # self.__authType
  File "/home/jerry/Téléchargements/hplip-3.19.6/base/password.py", line 135, in __readAuthType
    distro_name = get_distro_name().lower()
  File "/home/jerry/Téléchargements/hplip-3.19.6/base/password.py", line 81, in get_distro_name
    os_name = platform.dist()[0]
AttributeError: module 'platform' has no attribute 'dist'
jerry@jerry-ThinkPad-L440:~/Téléchargements$ 

Quelqu’un a-t-il ou t-elle un éclaircissement à cette affaire ?

Re: impossibilité d'installer HPLIP

Posted: Sun Dec 27, 2020 1:58 pm
by zardoz45
bonjour,
après la montée de version de LM en 20.0 Cinnamon, j'ai ré-installé HPLIP en juillet 2020 pour mon imprimante HP Photosmart 5520 (un modèle de 2013)
j'ai installé Hplip 3.20.3 à partir de Logithèque (Gestionnaire de logiciels), qui s'installe et fonctionne sans PB

Re: impossibilité d'installer HPLIP

Posted: Sun Dec 27, 2020 5:38 pm
by zibozibo
Je n'avais pas encore essayé, si simple cela paraisse.

Effectivement apparaisent les programmes:
HPLIP-GUI
HPLIP

Cependant,

Hplip-gui est non disponible,
et
Hplip, patine en cours d'installation depuis 2heures.
ça tourne pour rien.


ça cache quelque chose..

Re: impossibilité d'installer HPLIP

Posted: Tue Dec 29, 2020 1:01 am
by Christian_B
Bonjour, Tu ne précises pas comment tu as installé HPLIP ni quelle version. HPLIP a besoin d'être à jour (en fonction de la distribution) pour que tout marche.
J'avais fait l'erreur de l'installer par le paquet hplip (avec Synaptic).
Cela provoquait effectivement des problèmes lors d'une mise à jour à partir du site de HP.
La désinstallation du paquet hplip était incomplète et j'ai dû bidouiller un peu pour que ça marche. (je pourrai rechercher pour préciser si tu es dans ce cas).
Par ailleurs la nouvelle version 3.20.11 de HPLIP est annoncée compatible Mint 20.1 (donc pour les prochains jours) ici :
https://www.linuxmint.com/rel_ulyssa_mate_whatsnew.php (chercher hplip)
Pour le moment je suis en 3.20.6, j'attends pour plus de sûreté Mint 20.1 pour mettre à jour.
Si tu n'es pas passé par le site HP, voir :
https://developers.hp.com/hp-linux-imag ... g/gethplip
pour charger l'installateur (à rendre exécutable).
A placer dans un répertoire spécifique sinon il prend des libertés avec les fichiers présents.

Re: impossibilité d'installer HPLIP

Posted: Tue Dec 29, 2020 7:39 am
by Christian_B
En relisant ta demande, il m'est venu d'autres observations :
1) Tu veux installer HPLIP pour une imprimante qui n'est pas visible sur la machine. Ennuis assurés à la fin du script sauf peut-être si tu réponds u à la question : Do you want to setup printer in GUI mode? (u=GUI mode*, i=Interactive mode)

2) Il n'y a pas de raison de mettre une ancienne version de HPLIP, surtout avec une imprimante récente et (je suppose) une version récente de Mint. Les nouvelles versions ajoutent des imprimantes et la compatiblité avec des distributions plus récentes.
N-B : Il vaudrait mieux que tu fasses une signature avec les principales caractéristiques de ton système si tu continues avec Mint.

3) J'ai vu que ton imprimante fait scanner. Il est recommandé de supprimer sur Mint 20 le paquet ippusbxd qui perturbe les scanners et sera supprimé sous Mint 20.1

4) J'ai finalement essayé d'installer hplip-3.20.11. Le script rame sur la désinstallation d'une version précédente (dont la version annoncée est d'ailleurs erronée). Assez habituel pour HPLIP, en tout cas sous Mint. Si c'est ton cas :

=> Nettoyage manuel énergique car même l'aide à la désinstallation dans la doc HPLIP n'est pas fiable :
• Faire les commandes :

Code: Select all

apt purge hplip
apt purge hplip-data
sudo apt autoremove
sudo aptitude clean
(Je ne suis pas sûr que les deux dernières sont indispensables. Mais apt autoremove supprime chez moi un tas de trucs inutiles).

• Vérifications : supprimer s'ils sont encore présents :
~/.hplip
~/hp-check.log
Et sous root (prudemment, avec sudo ou su - ou éventuellement le mode Administrateur de Caja si tu es sous Mate) :
/usr/share/hplip
/usr/share/ppd/hplip
/etc/hp/hplip.conf (et éventuellement fichiers analogues comme hplip.conf.dpkg-old)
/usr/lib/cups/backend/hp (et éventuellement hp-fax si ton imprimante fait fax, je n'ai pas vu)

(Ne pas supprimer /usr/share/ppd/HP)

Ouf! Chez moi maintenant ça marche ... en allumant l'imprimante quand il demande :
Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit)

Re: impossibilité d'installer HPLIP

Posted: Thu Dec 31, 2020 5:03 am
by cpedretti
Un lien bien pratique => https://doc.ubuntu-fr.org/hplip