[Résolu] Wifi Désactivé apres passage à linuxmint 20

French Forum

Moderator: Laurent85

Post Reply
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

[Résolu] Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonjour,

j'ai éffectué un passage de linuxmint 19.3 vers linuxmint 20.
depuis j'ai le Réseau Wifi Désactivé .
Pourtant le driver est bien installé :

Code: Select all

Admin@USS:~$ inxi -N
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx 

Admin@USS:~$ lspci -nnk | grep -iA2 net
00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
	DeviceName: Onboard - Ethernet
	Subsystem: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:02a4]
	Kernel driver in use: iwlwifi
--
02:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
	Subsystem: Micro-Star International Co., Ltd. [MSI] QCA8171 Gigabit Ethernet [1462:1219]
	Kernel driver in use: alx
	Kernel modules: alx
Je ne trouves pas de menu pour activerou desactiver le wifi...
Merci por votre Aide.
Last edited by christg69 on Tue Jan 19, 2021 1:14 pm, edited 2 times in total.
sleeper12
Level 14
Level 14
Posts: 5217
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by sleeper12 »

Publiez les résultats de:

Code: Select all

 inxi -Fxxxz && rfkill list && mokutil --sb-state 
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonsoir,

voici le resultat de la commande :
inxi -Fxxxz && rfkill list && mokutil --sb-state

Code: Select all

Admin@USS:~$  inxi -Fxxxz && rfkill list && mokutil --sb-state 
System:    Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: MATE 1.24.0 info: mate-panel 
           wm: marco 1.24.0 dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: Micro-Star product: GL63 8RC v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-16P6 v: REV:1.0 serial: <filter> UEFI [Legacy]: American Megatrends v: E16P6IMS.101 
           date: 02/28/2018 
Battery:   ID-1: BAT1 charge: 35.8 Wh condition: 39.4/43.2 Wh (91%) volts: 11.6/10.8 model: MSI Corp. MS-16P6 type: Li-ion 
           serial: N/A status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36799 
           Speed: 900 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 900 2: 901 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Micro-Star MSI driver: nvidia v: 455.38 bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa compositor: marco 
           v: 1.24.0 resolution: 1600x900~60Hz 
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k5.4.0-58-generic 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: 3000 
           bus ID: 02:00.0 chip ID: 1969:10a1 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 227.47 GiB (19.4%) 
           ID-1: /dev/sda vendor: Toshiba model: THNSNJ256G8NY size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: 0101 
           scheme: MBR 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: SDM1 
Partition: ID-1: / size: 233.73 GiB used: 40.62 GiB (17.4%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A gpu: nvidia temp: 41 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 248 Uptime: 7h 18m Memory: 15.49 GiB used: 2.56 GiB (16.6%) Init: systemd v: 245 runlevel: 5 Compilers: 
           gcc: 9.3.0 alt: 7/9 Shell: bash v: 5.0.17 running in: mate-terminal inxi: 3.0.38 
0: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
EFI variables are not supported on this system
Je comprends que le Wifi est bloqué via le soft...
Mais je ne sais pas le débloquer

Joyeux Réveillon et Bonne Année à vous.
Last edited by Laurent85 on Sat Jan 02, 2021 8:26 am, edited 1 time in total.
Reason: Code tags
sleeper12
Level 14
Level 14
Posts: 5217
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by sleeper12 »

Essayer:

Code: Select all

 rfkill unblock all 
User avatar
ToutAlu
Level 3
Level 3
Posts: 135
Joined: Tue May 23, 2017 4:14 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by ToutAlu »

J'utilise ceci sur une vieux portable ASUS dont le wifi se coupe aléatoirement (carte wifi Realtek qui ne fonctionne bien qu'avec Windows) :

Code: Select all

sudo /etc/init.d/network-manager restart
Image
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20(Résolu)

Post by christg69 »

Merci pour vos reponses.
J'ai essayer les deux solutions mais ca ne fonctionnais pas.

mais finalement, il suffisait de redemarrer pour que le Wifi fonctionne.

Le probléme est resolu.

Merci encore.
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonsoir,

en fin de matinée, Je pensais que mon probléme etait résolu, mais pas completement.
J'ai eteint mon pc entre 12h et 18h.
ce soir,le wifi etait de nouveau désactivé. aucun nom de reseau wifi proposé.

aprés avoir saisi la commande pour demarrer le reseau :
sudo /etc/init.d/network-manager restart
j'ai retrouvé la liste des réseau wifi disponible et ai pu me connecter.

Dans le centre de controle, section matériel, je n'ai pas le choix 'Réseau' mais simplement le choix 'Réseau Avancé'

Merci par avance pour vos suggestions.
sleeper12
Level 14
Level 14
Posts: 5217
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by sleeper12 »

Qu'est-ce que cela montre:

Code: Select all

 iwconfig 
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonjour,

voici le resultat de iwconfig :

Code: Select all

admin@USS:~$ iwconfig
wlo1      IEEE 802.11  ESSID:"labastide"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: dd:dd:dd:dd:dd:dd   
          Bit Rate=72.2 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=56/70  Signal level=-54 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:92   Missed beacon:0

enp2s0    no wireless extensions.

lo        no wireless extensions.
admin@USS:~$ 
Aprés plusieurs essais , je peux dire que le wifi se trouve désactivé si :
Je me deconnecte du réseau wifi
et J'eteint le PC.
Au redemarrage du PC, le wifi est desactivé, je dois le reactiver avec un sudo /etc/init.d/network-manager restart

Si j'etaint le PC sans me deconecter du reseau wifi aucun souci au redemarrage du PC, le wifi est actif.

Bonne réception.
Last edited by Laurent85 on Sat Jan 02, 2021 8:27 am, edited 1 time in total.
Reason: Code tags
sleeper12
Level 14
Level 14
Posts: 5217
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by sleeper12 »

Désactivez la gestion de l'alimentation:

Code: Select all

 sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf 
Reboot
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonjour,

j'ai effectuée cette commande.
mais depuis, je n'arrives plus a activer le wifi.
etant de retour chez moi, j'utilise la connexion filaire.

comment re-activer la gestion de l'alimentation?

Malgré tout, Merci pour votre aide.
sleeper12
Level 14
Level 14
Posts: 5217
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by sleeper12 »

Autant que je sache, la gestion de l'alimentation doit rester désactivée. Est-ce que cela fait fonctionner le wifi:

Code: Select all

 sudo ifconfig wlo1 up 
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonjour,

Avec cette commande, j'ai un message d'erreur :
admin@USS:~$ sudo ifconfig wlo1 up
[sudo] Mot de passe de admin :

SIOCSIFFLAGS: Opération impossible du fait de RF-kill

admin@USS:~$
sleeper12
Level 14
Level 14
Posts: 5217
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by sleeper12 »

Voyons à nouveau:

Code: Select all

 rfkill list && iwconfig 
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonjour,

J'ai finalement résolu le probleme d'une maniere radicale.

J'avais une mise a jour de LinuxMint 20 vers 20.1 à faire.

Aujourd'hui, je n'ai pas fait la mise à jour, mais effectuer une installation compléte de LinuxMint 20.1

J'ai retrouvé le Wifi, et un systéme plus réactif. :D

Merci a tous pour votre aide.
User avatar
ToutAlu
Level 3
Level 3
Posts: 135
Joined: Tue May 23, 2017 4:14 pm

Re: Wifi Désactivé apres passage à linuxmint 20

Post by ToutAlu »

Super !
Maintenant, tu peux éditer ton premier post et ajouter [Résolu] dans son titre !
Image
christg69
Level 1
Level 1
Posts: 11
Joined: Thu Nov 14, 2019 4:27 am

Re: [Résolu] Wifi Désactivé apres passage à linuxmint 20

Post by christg69 »

Bonjour,

Désolé, petit oubli de ma part.
Maintenant , c'est fait

Encore Merci pour votre aide. :D
Post Reply

Return to “Français (French)”