Pas de grub au démarrage

French Forum

Moderator: Laurent85

Post Reply
Lyzozyme
Level 1
Level 1
Posts: 14
Joined: Mon Jul 30, 2018 7:52 am

Pas de grub au démarrage

Post by Lyzozyme »

Bonjour,

J'ai récemment reçu un nouveau SSD et j'ai donc voulu réinstaller le dual-boot que j'avais précédemment. J'ai commencé par installer windows (aucun souci tout s'est bien passé) puis j'ai voulu installer Mint. J'ai partitionné le SSD de façon à laisser 150Go disponibles à Linux en ext4 bien sûr. Jusque là pas de souci.
Le problème c'est que quand j'ai voulu redémarrer mon PC, le grub ne s'est pas affiché et le PC a directement démarré sur Windows comme si aucun autre OS n'était présent sur le disque.

J'ai donc essayé les manips classiques suivantes :
  • Aller checker les priorités de boot dans le BIOS (ici il semble bien détecter un linux mais même en le rendant prioritaire ça ne change rien)
  • Démarrer sur une clé linux live afin de lancer l'outil boot-repair, mais là encore rien ne change
  • J'ai également testé le "update-grub" mais celui-ci me renvoie une erreur de la sorte :
    error: failed to get canonical path of /cow.
Et c'est là que je suis à court d'idées, j'ai déjà trouvé quelques problèmes similaires sur différents forums mais les réponses que j'ai pu y trouver ne règlent pas mon problème.

Voilà pourquoi je vous demande de bien vouloir m'aider à résoudre ce petit problème. N'hésitez pas à me demander différents éléments, je ne savais pas quoi vous fournir donc je n'ai encore rien mis.

Merci d'avance pour le temps que vous m'accorderez! :D

Lyzozyme
User avatar
jjcojax
Level 3
Level 3
Posts: 143
Joined: Fri Apr 03, 2015 6:01 am
Location: Belgium

Re: Pas de grub au démarrage

Post by jjcojax »

Bonjour,

Pour bien répondre ...

PC UEFI (2012+) ou PC BIOS (avant 2012) ?
Partition MBR (max 4) ou GPT (max128) ? (tu peux le voir avec Gparted)

Windows et Linux doit être installé de la même manière.

En mode MBR, le MBR est fait pour allez chercher la suite du Boot dans la partition Linux. (tu dois réparer le démarrage de Windows si tu enlèves Linux)

En mode UEFI, une partition cachée en FAT 32 (partition EFI) contient les fichiers .efi pour lancer Windows et d'autres fichiers .efi pour lancer Linux (ton BIOS te permet de choisir l'un ou l'autre via une des touches fonctions au démarrage (souvent F8 ou F2 ou Esc)(tu vois ton manuel du PC pour savoir quelle touche est celle pour choisir)(si tu formates la partition d' un système, l'autre garde tout ce qu'il faut pour démarrer)

Seul les versions 64 bits de Linux conviennent aux partitions GPT .
Si tu as installer Windows sans voir d'abord le système de partitions de ton SSD, Windows est peut être installé à l'ancienne.

Suite si...

jjcpjax
Lyzozyme
Level 1
Level 1
Posts: 14
Joined: Mon Jul 30, 2018 7:52 am

Re: Pas de grub au démarrage

Post by Lyzozyme »

jjcojax wrote:
Sat Jan 23, 2021 8:39 am
Bonjour,

Pour bien répondre ...

PC UEFI (2012+) ou PC BIOS (avant 2012) ?
Partition MBR (max 4) ou GPT (max128) ? (tu peux le voir avec Gparted)

Windows et Linux doit être installé de la même manière.

En mode MBR, le MBR est fait pour allez chercher la suite du Boot dans la partition Linux. (tu dois réparer le démarrage de Windows si tu enlèves Linux)

En mode UEFI, une partition cachée en FAT 32 (partition EFI) contient les fichiers .efi pour lancer Windows et d'autres fichiers .efi pour lancer Linux (ton BIOS te permet de choisir l'un ou l'autre via une des touches fonctions au démarrage (souvent F8 ou F2 ou Esc)(tu vois ton manuel du PC pour savoir quelle touche est celle pour choisir)(si tu formates la partition d' un système, l'autre garde tout ce qu'il faut pour démarrer)

Seul les versions 64 bits de Linux conviennent aux partitions GPT .
Si tu as installer Windows sans voir d'abord le système de partitions de ton SSD, Windows est peut être installé à l'ancienne.

Suite si...

jjcpjax
Tout d'abord, merci de ta réponse :D

J'ai un PC en UEFI et le SSD est partitionné en GPT. Je vois en effet une partition EFI (en FAT32) et lorsque je démarre via le boot manager (ça je ne savais pas merci d'en avoir parlé), je peux en effet choisir de démarrer sur mon linux.

Mais un petit truc m'interpelle lorsque je suis dans le boot manager, je me retrouve face à 3 options :
  • UbuntuShimx64, celle ci ne fait rien, si je démarre dessus le PC boot sur windows
  • Windows boot manager (qui fait son job)
  • Linux (qui boot sur mon linux mint)
Je me demande donc ce qu'est ce "UbuntuShimx64" et si il est vraiment utile. D'ailleurs, lorsque je suis dans le gestionnaire de priorité de boot du BIOS, c'est sur "EFI File Boot 0: UbuntuShimx64" que je mettais la priorité en espérant qu'il boot sur linux...

J'ai également vu qu'il existait des alternatives au grub (notamment rEFInd je crois), est-ce qu'en essayant ça je pourrais avoir un résultat?

Lyzozyme
User avatar
jjcojax
Level 3
Level 3
Posts: 143
Joined: Fri Apr 03, 2015 6:01 am
Location: Belgium

Re: Pas de grub au démarrage

Post by jjcojax »

Bonjour,

Un peu de tout...

Pour réinstaller grub.

En mode efi (place le Linux actif en 1er dans la nvram) (si tu as Mint et Ubuntu, ce sera un grub avec Mint ou Ubuntu en 1er)

Code: Select all

sudo grub-install
En mode MBR (il faut indiquer un périphérique qui contient le MBR à la sauce grub)

Code: Select all

sudo grub-install /dev/sda
---
Laisse les fichiers en place dans la partition efi (c'est des petits fichiers dont l'ensemble fait qu'au moins un conviendra au BIOS de ta machine)
---
Si tu veux ajouter refind, depuis Linux Mint, tu recherches refind dans les "soft" à ajouter en haut du nenu Mint.

Une fois installé, au lieu du menu grub, tu auras un menu dans lequel tu choisis ce qui peut être lancé (aussi une clé USB si elle est branchée)

Image

tu y vois Windows, Ubuntu, Mint, et une clé avec Clonezilla tout en pouvant rentrer dans le menu du BIOS.
Via Esc, tu peux même changer de clé USB.
---
Dans le BIOS UEFI, tu peux également changer l'ordre de démarrage (il suffit de mettre Linux au dessus de Windows avec la souris comme tu ferais avec des icônes)
---
C'est la dernière méthode que tu essayes qui prend le dessus, et une grosse mise à jour de Linux (ou Windows) peux à nouveau changer l'ordre de démarrage.
---
Pour l’accès aux fichiers de ton Windows, il faut désactiver le démarrage rapide de Win10 (car sinon il se comporte comme un Windows mis en veille = accès en lecture seule)
(+ pour les PC performants, désactiver le compactage des fichiers système (voir compact.exe /compactos)(sinon Linux pense que ton Windows est sur une partition avec des milliers de fichiers détruits = in-out error)

jjcojax
Lyzozyme
Level 1
Level 1
Posts: 14
Joined: Mon Jul 30, 2018 7:52 am

Re: Pas de grub au démarrage

Post by Lyzozyme »

Bonjour,

Et bien toujours pas...

Lorsque je fais un "sudo grub-install", rien ne change et je n'ai toujours pas de grub et lorsque je tente d'installer rEFInd c'est tout pareil, je n'ai rien au démarrage... Je rappelle que le linux que je vois dans les priorités de boot du BIOS est bien positionné avant Windows boot manager.

Cependant j'ai remarqué que lorsque je démarre sur linux via le boot manager (F12 au démarrage), un grub s'affiche et me laisse le choix entre démarrer sur linux ou sur windows, est-ce que ce serait pas le grub que je cherche depuis le début? Et dans ce cas est-ce qu'il serait installé au mauvais endroit?

Je vous donne un BootInfo généré par boot-repair, peut-être que ça pourra aider! https://paste2.org/7YIXc6eh

Merci,
Lyzozyme
User avatar
jjcojax
Level 3
Level 3
Posts: 143
Joined: Fri Apr 03, 2015 6:01 am
Location: Belgium

Re: Pas de grub au démarrage

Post by jjcojax »

Bonjour,

Je regarde ton rapport en détail plus tard, mais comme Linux est actuellement sur le second disque, peux tu inverser les disques ou inverser les connecteurs "data" entre tes 2 disques ?

et puis refaire le grub-install

Sur mon PC, je fais...

Code: Select all

sudo grub-install
Mot de passe de jjcojax : 
Installation pour la plate-forme x86_64-efi.
Installation terminée, sans erreur.

Une page d'info Ubuntu peut aussi t'aider -> https://doc.ubuntu-fr.org/uefi

Ci cela ne passe pas, indique le modèle de PC car un PC n'est pas l'autre.

jjcojax
Laurent85
Level 16
Level 16
Posts: 6984
Joined: Tue May 26, 2015 10:11 am

Re: Pas de grub au démarrage

Post by Laurent85 »

Bonjour,
Le pc ne démarre pas dans le bon mode par défaut. Va dans le bios et désactive le mode de démarrage appelé legacy ou csm ou bios ou hybrid. Laisse uniquement le mode de démarrage UEFI.
Image
Post Reply

Return to “Français (French)”