LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

French Forum

Moderator: Laurent85

Post Reply
Karibou1312
Level 1
Level 1
Posts: 21
Joined: Thu Nov 28, 2019 9:31 am

LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Karibou1312 »

Bonjour,
J'ai voulu faire essayer puis installer LMDE 4 à mes filles, sur leur EeeBook Asus E200HA (32Go eMMC et 4Go RAM).

MAIS :
L'installation de LMDE 4 plante dès le début, au moment de la création des partitions (je laisse les partitions par défaut) sur emmblk0 : Voici le message obtenu :
"'ascii codec can't decode byte 0xc3 in position 14 : ordinal not in range (128)"

Image

Et rien à faire... Impossible d'installer LMDE 4.

Voici les partitions bizarres qu'il voit :

Image

Et j'ai essayé de supprimer ces partitions bizarres et de formater via GParted ... Rien à faire :

Image

EDIT :
Même en LMDE 3 ne peut pas s'installer... :(
Linux Mint 20.1 Ulyssa (Cinnamon) s'installe sans problème ! Mais je préfèrerais installer LMDE 4.

Questions :
Est-il prévu que Linux Mint corrige ce Bug ?
Y a t'il une solution pour réussir à installer LMDE 4 ?

Merci pour votre aide.
Karibou1312
Level 1
Level 1
Posts: 21
Joined: Thu Nov 28, 2019 9:31 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Karibou1312 »

Bonjour,
Est-ce que quelqu'un pourrait m'aider ?
y a t'il un moyen pour réussir à installer LMDE 4 sur un ASUS E200HA avec eMMC ?
Il plante lors du partitionnement, avec le nom du disque mmcblk0.
Alors que Linux Mint (Base Ubuntu) s'installe normalement.
Merci pour votre aide.
Cordialement
Karibou1312
franck35
Level 2
Level 2
Posts: 69
Joined: Thu Jan 09, 2020 6:16 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by franck35 »

Bonjour,

J'ai fait le même essai sur mon ASUS T200TA :

Laptop Asus T200TA-CP004H_Linux Mint 20.1 Cinnamon-64 bit
CPU : Intel Atom Série Z3700-64 bit _ 2 Go de RAM _ eMMC 32 Go (tablette) + DD 500 Go (dock)

Tout comme toi, l'installation plante. Je ne sais plus à quel moment mais je n'ai jamais réussi à installer LMDE dessus. En revanche, çà fonctionne avec le live. Je n'ai pas insisté et installé LM 20.1.
Desktop Dell Optiflex 790_LMDE 4 Cinnamon-64 bit
CPU : Intel© Core™ i5-2400 CPU @ 3.10GHz × 4_8 Go de RAM_SSD 240 Go (LM) + DD 750 Go (Data)
User avatar
Cyberbleuet
Level 1
Level 1
Posts: 29
Joined: Tue Jan 10, 2017 12:55 pm
Location: Alma, Québec

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Cyberbleuet »

Salut a tu fait un essai en choisissant partitionnement manuel...

Salutation!
Laptop:Acer Aspire-A115-31 15'', Intel Celeron N4000 graphic Intel, eMMC 64G, 4G mémoire Os / Libres

Infiniment libre :)
Karibou1312
Level 1
Level 1
Posts: 21
Joined: Thu Nov 28, 2019 9:31 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Karibou1312 »

Bonjour,
Oui, j'ai essayé le partitionnement manuel... Rien donné.
J'ai même créé une clé USB GParted puis j'ai booté dessus et j'ai tout effacé via cette clé et rien à faire... :(
J'ai encore essayé ce soir :(
Pourtant Linux Mint 20 s'installe sans Pb...
Merci pour votre aide.
Karibou1312
Aztaroth
Level 1
Level 1
Posts: 9
Joined: Mon Jan 11, 2021 1:48 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Aztaroth »

Bonjour,
J'ai eu le meme pb en voulant installer LMDE4 avec partitionnement automatique sur l'ordi d'un ami (alors qu'il tourne parfaitement sur les miens), sauf que c'était la position 8 (au lieu de la 14). Un partitionnement manuel 'simulé' n'avait rien résolu non plus.
Les renseignements que j'ai pu glaner disent que le bug n'est pas lié au partitionnement, mais à un décodage ascii défaillant dans un programme Python (lié à l'installation dans notre cas).
Je me suis alors demandé pourquoi Python avait tant tant de haine pour la bécane de mon copain et tant d'amour pour les miennes, puisque je n'avais jamais eu de pb.
Je pense que cela vient du fait je n'utilise jamais le partitionnement automatique, mais un 'vrai' partitionnement manuel,à savoir au minimum une partition root (/), une partition (/home) et une partition swap, voire une partition supplémentaire si le disque est gros.
J'ai reproduit cela sur l'ordi de mon collègue, ça a résolu le problème et installé LMDE4 et ça tourne bien depuis 1 mois maintenant. Certes c'était à la position 8, mais qui sait ...
Karibou1312
Level 1
Level 1
Posts: 21
Joined: Thu Nov 28, 2019 9:31 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Karibou1312 »

Bonjour et Merci Aztaroth pour ton message qui me redonne un peu d'espoir :D

Je n'ai jamais créé un partitionnement manuel.

Tu les crées comment ? Au moment de l'installation ? Ou bien avant l'installation via une clé USB GParted ?

Est-ce que je pourrais installer Linux Mint 20.1 puis me servir de ces partitions pour installer LMDE 4 sans avoir à en créer des nouvelles ?

J'ai pourtant essayé de créer un partionnement manuel mais ça n'a pas marché...

Tu peux me donner STP que je dois créer ?
EFI : combien ? Chemin : /efi/boot ? Type : ?
/ : combien ? Chemin : / ? Type : ?

Merci pour ton aide.

Karibou1312
Aztaroth
Level 1
Level 1
Posts: 9
Joined: Mon Jan 11, 2021 1:48 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Aztaroth »

Bonsoir,
Dans l'ordre de tes préoccupations :
- le partitionnement se fait au début de l'installation de LMDE4. Je te détaillerai la procédure si tu le souhaites.
- à propos de l'installation d'Ulyssa (LM20.1), tu peux faire coexister les 2 OS au démarrage, mais pas sur la même partition. Il faut autant de partitions root (/) que de systèmes d'exploitation que tu comptes installer. SI tu veux en installer 10, chacun devra disposer de son propre root.
- il est même fort probable qu'il te faille 2 répertoires utilisateurs (/home) car c' est assez compliqué de réussir à faire partager un même répertoire utilisateur à 2 OS sans mettre la pagaille.
- il y a quelques différences entre les 2 OS que tu dois connaître : LMDE4 te demandera de mettre un peu plus les mains dans le cambouis que la version principale. Par exemple, le noyau Linux avec lequel il est livré est anti-déluvien (4.19). Si ta machine l'est aussi, pas de pb. Sur une machine récente, il faudra probablement un noyau plus récent et LMDE4 n'ayant pas de gestionnaire de noyaux, il faut le faire par l'intermédiaire de commandes du terminal (même si ce n'est pas insurmontable). Comme le dit le proverbe, c'est en forgeant... Encore faut-il avoir le temps et l'envie de forger.
- pour la taille de tes partitions, ton efi/boot, pas touche (si Mint 20 s'installe, c'est qu'il est bon). Pour les autres, il faudrait connaître la taille de ton disque dur pour être plus précis, mais ton root (/) doit avoir entre 30 Go mini et 100 confort, ton /swap la taille de ta RAM, ton /home au moins 100 Go,mais ça dépend aussi de tes documents de travail. C'est évidemment pas pareil si tu travailles sur des textes dans LibreOffice ou si tu fais du montage vidéo. A moins que tu ne préfères créer une partition supplémentaire dans laquelle tu mettras les données que tu souhaites accessibles à tous les OS que tu comptes installer.
En fait, à la lecture de ce qui précède, tu comprendras que le plus difficile n'est pas la partie technique, mais de savoir ce à quoi tu comptes destiner ton ordi.
Aztaroth
Level 1
Level 1
Posts: 9
Joined: Mon Jan 11, 2021 1:48 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Aztaroth »

Un petit lien de la doc officielle de Mint en français au sujet du partitionnement manuel :
https://linuxmint-installation-guide.re ... oning.html
Karibou1312
Level 1
Level 1
Posts: 21
Joined: Thu Nov 28, 2019 9:31 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Karibou1312 »

Bonjour !!! :D

Merci beaucoup Aztaroth de tes conseils ! Et merci à tous !

J'ai réussi à installer LMDE 4 sur le E200HA ! :D :D :D

Ce que j'ai fait : J'ai un disque dur eMMC de 32Go (29,12 GiB)


1) Méthode 1 : Partitionnement Manuel avec seulement 2 partitions (EFI et /) :
=============

J'ai installé Linux Mint 20.1 (donc celle basée sur Ubuntu).
Cette installation m'a servi d'avoir des partitions propres pour une future installation ! Car j'avais déjà essayé un partitionnement manuel, mais quelque chose n'allait pas... Plantage systématique... Mais en faisant comme ça, j'ai réussi.
Ensuite j'ai vérifié les partitions créées : J'ai trouvé 2 partitions ( /boot/efi : 512MiB et / : 28,62GiB)

Image

J'ai inséré la clé bootable LMDE 4 , et j'ai commencé le processus d'installation.
Au moment de la création des partitions, je choisis partitionnement manuel.
Je vois les partitions créées par Linux Mint 20.1 et je les formate avec GParted (je ne touche à rien d'autre, je laisse les systèmes de fichiers tels quels).
J'affecte / à la partition de 28,62GiB (via clic droit)
Je lance l'installation, et tout se passe bien !!! :D :D :D


Méthode 2 : Partitionnement Manuel avec 3 partitions (EFI, Swap, et /) :
===========

J'ai préféré testé une installation en créant une partition Swap en plus des 2 autres.

J'ai inséré la clé bootable LMDE 4, et j'entame le processus d'installation.
Au moment de la création des partitions, je choisis partitionnement manuel.
J'efface TOUTES les partitions existantes.
Je crée mes partitions avec GParted comme suit :

Image

Ca donne ça au moment de l'installation :

Image

Voici la synthèse au moment de l'installation :

Image

IMPORTANT :
Il faut affecter le "point de montage" dans l'installateur via le clic droit :
partition emmcblk0p1 (en FAT32) : point de montage ---> clic droit : /boot/efi
partition emmcblk0p2 (en Swap) : point de montage ---> clic droit : swap
partition emmcblk0p3 (en Ext4) : point de montage ---> clic droit : /

Et voici l'état des disques après installation :

Image


Et Merci à Aztaroth pour tes conseils !!! c'est grace à ton aide précieuse que j'ai réussi :D :D :D


=================
Problème restant :
=================

Le son ne marche pas... J'avais déjà eu ce Pb avec Debian 10 (noyau 4.19) mais le son ne fonctionnait pas...
Comme LMDE 4 a le noyau 4.19, le son ne marche pas non plus...
Ce qui est sûr, c'est qu'il est fonctionnel à partir du noyau 5.4 !
J'ai installé le noyau 5.4 et 5.10 (depuis Synaptic) mais le son n'a pas fonctionné...
J'ai juste installé les noyaux... Je n'ai rien fait d'autre... Dois je faire autre chose ?
Voici mon Post ouvert sur le Forum de Debian-Facile :
https://debian-facile.org/viewtopic.php ... 03#p355603

Merci pour votre aide !
Last edited by Karibou1312 on Thu Mar 04, 2021 2:35 pm, edited 2 times in total.
Aztaroth
Level 1
Level 1
Posts: 9
Joined: Mon Jan 11, 2021 1:48 am

Re: LMDE 4 sur EeeBook avec eMMC : Pb lors d'installation - Bug lié au partitionnement

Post by Aztaroth »

Content que mon aide t'ai pu apporter quelque chose.
A propos de ton pb audio, qqun semble avoir le meme ici :
viewtopic.php?f=63&t=343426&sid=8d8f43b ... ac354a5c6e
et nous sommes qques uns à luii avoir fait des suggestions.
Si tu peux y trouver ton bonheur.
Post Reply

Return to “Français (French)”