Kein Ton mehr in Linux Mint 18

German Forum

Moderator: karlchen

kaie
Level 2
Level 2
Posts: 60
Joined: Fri Dec 09, 2016 3:21 pm

Kein Ton mehr in Linux Mint 18

Postby kaie » Fri May 19, 2017 12:52 am

Hallo,

bis vor ein paar Tagen hat alles geklappt, jetzt habe ich plötzlich Probleme mit dem Ton. Ich schaue mir einen Film in VLC an und alles ist in Ordnung, schaue ich mir einen zweiten Film an, ist kein Ton mehr da. Das selbe bei youtube, QuodLibet und dem gmusicbrowser. Nach einem Neustart des PCs geht es wieder. Das ist aber nicht immer der Fall, sondern nur manchmal.

In VLC habe ich das so gelöst, daß ich als Ausgabegerät HDA Intel PCH eingestellt habe. Scheint bisher zu funktionieren.

Bei QuodLibet kam die Meldung "GStreamer-Pipeline konnte nicht angelegt werden." Ich habe mal nachgesehen, scheinbar braucht das eine Version 0.10. War installiert lt. Anwendungsverwaltung. Ich habe es deinstalliert und dann wieder neu installiert, hat nichts gebracht.

Der gmusicbrowser macht es wie Firefox, die meckern nicht, spielen aber auch keinen Ton.

Momentan läuft es wieder, da ich den PC neu gestartet habe, aber das ist ja keine Dauerlösung.

Weiß jemand, woran das liegen könnte?

Vielen Dank.

Gruß
kaie


Ergänzung: Gerade habe ich mir ein Album in QuodLibet angehört und als das letzte Lied gespielt wurde auf das erste geklickt und schon kommt der blöde Fehler wieder. Jetzt müßte ich schon wieder einen Neustart machen, um einen Ton zu hören. Der VLC-Player spielt aber noch. Irgendwie müßte ich Linux dazu bringen, das selbe zu machen, wie der VLC-Player. Nur wie?

Ergänzung2: Ich habe versucht, mit der rechten Maustaste auf das Lautsprechersymbol zu klicken und dann auf Klangeinstellungen, aber da tut sich nichts. Ich kann aber Stumm schalten und die Lautstärke ändern. Sollte sich da was tun? Eigentlich schon, oder?

Ergänzung3: Nach einem Neustart sind die Klangeinstellungen wieder da. Scheinbar gehen die im laufen Betrieb verloren. Warum? Bis vor ein paar Tagen ging es doch auch.



############################################

Helfen diese Angaben etwas?

System: Host: benutzer01 Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
Desktop: MATE 1.14.1 (Gtk 3.18.9-1ubuntu3.3) info: mate-panel dm: mdm
Distro: Linux Mint 18 Sarah
Machine: Mobo: ASUSTeK model: P8H61-M LE v: Rev x.0x
Bios: American Megatrends v: 0506 date: 03/31/2011
CPU: Dual core Intel Core i3-2100 (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12369
clock speeds: min/max: 1600/3100 MHz 1: 1657 MHz 2: 2074 MHz
3: 1982 MHz 4: 1721 MHz
Memory: No dmidecode memory data: try newer kernel.
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
bus-ID: 00:02.0 chip-ID: 8086:0102
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1440x900@60.00hz
GLX Renderer: Mesa DRI Intel Sandybridge Desktop
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1c20
Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: e000
bus-ID: 04:00.0 chip-ID: 10ec:8168
IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
WAN IP: <filter> IF: enp4s0 ip-v4: <filter> ip-v6: <filter>
Drives: HDD Total Size: 3120.6GB (43.1% used)
ID-1: /dev/sda model: KINGSTON_SHFS37A size: 120.0GB serial: 50026B72550A0238
ID-2: /dev/sdb model: WDC_WD30EZRZ size: 3000.6GB serial: WD-WCC4N6CRC827
Optical: /dev/sr0 model: HL-DT-ST DVDRAM GH22NS50
rev: TN04 dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 48x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 103G used: 16G (16%) fs: ext4 dev: /dev/sda1
label: N/A uuid: aff9ff5e-45c8-4aec-bf5f-f82b0905fb06
ID-2: /media/benutzer01/Daten size: 2.7T used: 1.3T (46%) fs: fuseblk dev: /dev/sdb2
label: Daten uuid: 5AD6D9F6D6D9D1FD
ID-3: swap-1 size: 8.50GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
label: N/A uuid: 7bac9d6e-c222-4ab0-a8a2-139991cbffd8
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Unmounted: ID-1: /dev/ram0 size: 0.07G label: N/A uuid: N/A
ID-2: /dev/ram1 size: 0.07G label: N/A uuid: N/A
ID-3: /dev/ram2 size: 0.07G label: N/A uuid: N/A
ID-4: /dev/ram3 size: 0.07G label: N/A uuid: N/A
ID-5: /dev/ram4 size: 0.07G label: N/A uuid: N/A
ID-6: /dev/ram5 size: 0.07G label: N/A uuid: N/A
ID-7: /dev/ram6 size: 0.07G label: N/A uuid: N/A
ID-8: /dev/ram7 size: 0.07G label: N/A uuid: N/A
ID-9: /dev/ram8 size: 0.07G label: N/A uuid: N/A
ID-10: /dev/ram9 size: 0.07G label: N/A uuid: N/A
ID-11: /dev/ram10 size: 0.07G label: N/A uuid: N/A
ID-12: /dev/ram11 size: 0.07G label: N/A uuid: N/A
ID-13: /dev/ram12 size: 0.07G label: N/A uuid: N/A
ID-14: /dev/ram13 size: 0.07G label: N/A uuid: N/A
ID-15: /dev/ram14 size: 0.07G label: N/A uuid: N/A
ID-16: /dev/ram15 size: 0.07G label: N/A uuid: N/A
ID-17: /dev/sdb1 size: 0.13G label: N/A uuid: N/A
ID-18: /dev/sdb3 size: 52.43G label: WIN_ALT uuid: 4A9A20369A202145
ID-19: /dev/sdb4 size: 26.21G
label: Auslagerung uuid: 86BE2A22BE2A0AEF
Sensors: System Temperatures: cpu: 43.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 187 Uptime: 9 min Memory: 799.7/7895.8MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Shell (bash 4.3.421 running in mate-terminal) inxi: 2.2.35

uli27
Level 1
Level 1
Posts: 1
Joined: Fri May 19, 2017 2:20 am

Re: Kein Ton mehr in Linux Mint 18

Postby uli27 » Fri May 19, 2017 2:27 am

Ich habe genau das gleiche Problem mit Mint 18.1. Bei einem Asus X556U mit i5-7200U CPU 2.50GHz. Es verschwindet einfach der Sounchip und ind er Lautstärkeregelung findet man eine Dummy-Ausgabe. Vielleicht hatt jemand eine Idee.

ehtron
Level 4
Level 4
Posts: 247
Joined: Thu Apr 14, 2016 8:15 am

Re: Kein Ton mehr in Linux Mint 18

Postby ehtron » Fri May 19, 2017 3:28 am

Hi :)
ich würde es einfach mal mit einem neueren kernel versuchen..
aktualisierungsverwaltung > anzeigen > linux kernel
und reboot ;)

oder
sound weg
in alsamixer schauen ob betreffende regler runter oder aus sind
pulse im ordner
.config/pulse löschen und reboot

Code: Select all

sudo alsa force-reload

Code: Select all

pulseaudio --kill
Lg. Ehtron :)

User avatar
Pjotr
Level 18
Level 18
Posts: 8114
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Kein Ton mehr in Linux Mint 18

Postby Pjotr » Fri May 19, 2017 4:59 am

Benutzt du vielleicht Firejail als Sandkasten für eine oder mehrere Anwendungen? Wenn ja:
https://sites.google.com/site/easylinux ... y-Firejail
(Punkt 4, links).
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

kaie
Level 2
Level 2
Posts: 60
Joined: Fri Dec 09, 2016 3:21 pm

Re: Kein Ton mehr in Linux Mint 18

Postby kaie » Fri May 19, 2017 2:24 pm

Vielen Dank. An Firejail habe ich heute während der Arbeit auch gedacht, weil das ja das einzige ist, das ich wirklich geändert habe die letzten Tage.

Jetzt muß ich überlegen, bringt das wirklich soviel mehr Sicherheit, wenn ich jedesmal den Sound fixen muß, oder lasse ich das einfach? Die Soundprobleme sind bis jetzt der einzige Unterschied, den ich bemerkt habe mit Firejail.

User avatar
Pjotr
Level 18
Level 18
Posts: 8114
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Kein Ton mehr in Linux Mint 18

Postby Pjotr » Fri May 19, 2017 2:43 pm

kaie wrote:Jetzt muß ich überlegen, bringt das wirklich soviel mehr Sicherheit, wenn ich jedesmal den Sound fixen muß, oder lasse ich das einfach? Die Soundprobleme sind bis jetzt der einzige Unterschied, den ich bemerkt habe mit Firejail.

Firejail bringt tatsächlich mehr Sicherheit: die Standartsicherheit von Linux Mint ist schon "sehr gut", aber mit Firejail wird das "vorzüglich".

Die benötigte Änderung für Ton ist nur ein einmaliger Akt, der keine Wiederholung bedürft. Einmal geändert bleibt geändert, auch nach Neustart des Systemes. Also das ist doch keine Mühe, oder? :)
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

kaie
Level 2
Level 2
Posts: 60
Joined: Fri Dec 09, 2016 3:21 pm

Re: Kein Ton mehr in Linux Mint 18

Postby kaie » Fri May 19, 2017 4:33 pm

Ach so, ich dachte, das muß ich jedesmal machen, wenn mal wieder kein Ton läuft.

Wäre es denn nicht auch sinnvoll, Thunderbird ebenfalls in Firejail laufen zu lassen, falls das möglich ist?

User avatar
Pjotr
Level 18
Level 18
Posts: 8114
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Kein Ton mehr in Linux Mint 18

Postby Pjotr » Fri May 19, 2017 4:47 pm

kaie wrote:Wäre es denn nicht auch sinnvoll, Thunderbird ebenfalls in Firejail laufen zu lassen, falls das möglich ist?

Ist möglich, und in der Tat sinnvoll. :)
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

kaie
Level 2
Level 2
Posts: 60
Joined: Fri Dec 09, 2016 3:21 pm

Re: Kein Ton mehr in Linux Mint 18

Postby kaie » Sat May 20, 2017 8:02 am

Vielen Dank für eure Hilfe. Momentan klappt wieder alles.


Return to “Deutsch (German)”

Who is online

Users browsing this forum: No registered users and 3 guests