Touchpad funtioniert nicht

Support-Forum für deutschsprachige Benutzer

Moderator: karlchen

ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Touchpad funtioniert nicht

Post by ragman1976 »

Hallo,

ich habe einen neuen Laptop gekauft Eckdaten und Sysinfo unten) und habe Linux Mint installiert. Allerdings funktioniert das Touchpad nicht.
Was kann ich an der Stelle tun?
Danke vorab.

Code: Select all

System:    Kernel: 5.4.0-91-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 5.2.7 
           wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: HUAWEI product: BOD-WXX9 v: M1010 serial: <filter> 
           Mobo: HUAWEI model: BOD-WXX9-PCB-B3 v: M1010 serial: <filter> UEFI: HUAWEI v: 2.29 
           date: 04/21/2022 
Battery:   ID-1: BAT1 charge: 36.2 Wh condition: 43.3/41.6 Wh (104%) volts: 12.0/11.5 
           model: Sunwoda-H HB4692J5ECW-31 serial: <filter> status: Discharging 
           Device-1: hidpp_battery_0 model: Logitech M510 serial: <filter> 
           charge: 5% (should be ignored) status: Discharging 
CPU:       Topology: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP 
           arch: Tiger Lake rev: 1 L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44851 
           Speed: 3973 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 3857 2: 3864 3: 3773 
           4: 3828 5: 3806 6: 3872 7: 3842 8: 3823 
Graphics:  Device-1: Intel vendor: QUANTA driver: N/A bus ID: 00:02.0 chip ID: 8086:9a49 
           Display: x11 server: X.Org 1.20.11 driver: fbdev unloaded: modesetting,vesa 
           resolution: 1920x1080~77Hz 
           OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.2.6 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: Intel vendor: QUANTA driver: sof-audio-pci bus ID: 00:1f.3 chip ID: 8086:a0c8 
           Sound Server: ALSA v: k5.4.0-91-generic 
Network:   Device-1: Intel driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:a0f0 
           IF: wlp0s20f3 state: down mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           bus ID: 1-4:2 chip ID: 0bda:8153 
           IF: enx00e04c099bc6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 715.24 GiB used: 6.40 GiB (0.9%) 
           ID-1: /dev/nvme0n1 model: 311CD0512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
           ID-2: /dev/sda type: USB vendor: Generic model: MassStorageClass size: 238.30 GiB 
           serial: <filter> 
Partition: ID-1: / size: 7.72 GiB used: 4.29 GiB (55.6%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb https: //mirror.init7.net/linuxmint una main upstream import backport
           2: deb http: //ftp.hosteurope.de/mirror/archive.ubuntu.com focal main restricted universe multiverse
           3: deb http: //ftp.hosteurope.de/mirror/archive.ubuntu.com focal-updates main restricted universe multiverse
           4: deb http: //ftp.hosteurope.de/mirror/archive.ubuntu.com focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 270 Uptime: 16m Memory: 15.44 GiB used: 2.27 GiB (14.7%) Init: systemd 
           v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Client: Unknown python3.8 client 
           inxi: 3.0.38
          
User avatar
rincewind256
Level 3
Level 3
Posts: 191
Joined: Tue Jun 18, 2019 12:11 am
Location: Unseen University of Ankh-Morpork

Re: Touchpad funtioniert nicht

Post by rincewind256 »

Dein Computer benötigt einen moderneren Kernel. Wechsle auf die 5.15er-Reihe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Das hat soweit schon mal funktioniert.
Danke.

Allerdings funktioniert der Ton nicht. Unter Audodevice wird nur "dummy" angezeigt?

Code: Select all

System:    Kernel: 5.15.0-33-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 5.2.7 
           wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: HUAWEI product: BOD-WXX9 v: M1010 serial: <filter> 
           Mobo: HUAWEI model: BOD-WXX9-PCB-B3 v: M1010 serial: <filter> UEFI: HUAWEI v: 2.29 
           date: 04/21/2022 
Battery:   ID-1: BAT1 charge: 36.1 Wh condition: 43.3/41.6 Wh (104%) volts: 13.1/11.5 
           model: Sunwoda-H HB4692J5ECW-31 serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP 
           arch: Tiger Lake rev: 1 L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44851 
           Speed: 1153 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1171 2: 1500 3: 1173 
           4: 1275 5: 1078 6: 1225 7: 1314 8: 1132 
Graphics:  Device-1: Intel vendor: QUANTA driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:9a49 
           Display: x11 server: X.Org 1.20.13 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.6 
           direct render: Yes 
Audio:     Device-1: Intel vendor: QUANTA driver: sof-audio-pci-intel-tgl bus ID: 00:1f.3 
           chip ID: 8086:a0c8 
           Sound Server: ALSA v: k5.15.0-33-generic 
Network:   Device-1: Intel driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:a0f0 
           IF: wlp0s20f3 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 23.27 GiB (4.9%) 
           ID-1: /dev/nvme0n1 model: 311CD0512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
Partition: ID-1: / size: 91.41 GiB used: 23.24 GiB (25.4%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] https: //dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb https: //mirror.init7.net/linuxmint una main upstream import backport
           2: deb http: //ftp.fau.de/ubuntu focal main restricted universe multiverse
           3: deb http: //ftp.fau.de/ubuntu focal-updates main restricted universe multiverse
           4: deb http: //ftp.fau.de/ubuntu focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 316 Uptime: 45m Memory: 15.43 GiB used: 2.94 GiB (19.0%) Init: systemd 
           v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Client: Unknown python3.8 client 
           inxi: 3.0.38 
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
teste mal

Code: Select all

sudo modprobe -r snd_hda_intel
und

Code: Select all

sudo modprobe -v snd_hda_intel
die ausgaben bitte jeweils als codeblock </> hier bringen.

alternativ mal kernel 5.13 testen.. könnte ein problem mit dem aktuellen 5.15er sein.
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Hallo,

Code: Select all

root@manuel-BOD-WXX9:~# modprobe -r snd_hda_intel
root@manuel-BOD-WXX9:~#

Code: Select all

modprobe -v snd_hda_intel
insmod /lib/modules/5.15.0-33-generic/kernel/sound/pci/hda/snd-hda-intel.ko 
root@manuel-BOD-WXX9:~# 
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
ohohoh.. gewöhne dir bloss nicht an ständig als root zu arbeiten.
du gefährdest damit deine home rechte.

und? danach sound da?
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Hi,

ok, ich werde es versuchen.

Nein, die Lautsprecher bleiben stumm :-(

Kein Testklang..nichts.
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Hi,

ich habe, wie auf der verlinkten Seite beschrieben, den "pulse" Ordner geläscht -> reboot etc. und auch die angegebenen Befehle ausgeführt.
Ton funktioniert leider immer noch nicht.

Unter Audioeinstellungen bekomme ich auch nur ein Dummy-Device angezeigt.

Image
Attachments
Bildschirmfoto vom 2022-06-24 09-11-57.png
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
und wie vorgschlagen den 5.13er mal getestet?
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Hi,

ja, sorry hatte ich vergessen zu erwähnen, habe ich gleiches Bild.

PS: Also ich habe den 5.13 Kernel installiert und diesen dann im Grub Menü beim Booten ausgewählt.
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
kam der sound mit dem 5.4er?
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Hi,

nö...funktioniert auch nicht :-(

Weiß nicht ob es was zur Sache tut, habe es bisher auch nicht erwähnt.

Es handelt sich um ein Dual-Boot System (Win11)
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
virtuelle faust.. genau zwischen die augen ;)

bios / firmware
fastboot und secureboot aus!
win$ richtig runter fahren.. siehe 1000ende tuts dafür im netz.
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

ok, die Faust ist angekommen..geholfen hat es allerdings nicht. :-)

Secure Boot habe ich ausgeschaltet, eine Option für FastBoot gibt es nicht.

Hier noch ein Bild des BIOS

Image
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
kein bild bitte... verstopft nur den server. jede firmware ist anders.
suche nach handbuch...

fastboot in win$ ausgeschaltet? und richtig runter gefahren?
win$ fährt normaler weise nicht richtig / vollständig runter.
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Fast Boot habe ich in Windows deaktiviert...das wars auch nicht.

Wie fährt man Windows "richtig" runter?
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
die frage verstehe ich nicht. keine suchmaschine?
https://www.startpage.com/sp/search?que ... ge=deutsch
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
ragman1976
Level 1
Level 1
Posts: 11
Joined: Wed Jun 22, 2022 1:51 am

Re: Touchpad funtioniert nicht

Post by ragman1976 »

Hi,

ich habe Windows nach allen Regeln der Kunst "richtig" heruntergefahren. Linux bleibt allerdings weiterhin stumm. :(
User avatar
ehtron
Level 9
Level 9
Posts: 2677
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Touchpad funtioniert nicht

Post by ehtron »

Hi :)
mit 5.15er kernel laufen und sound module wie geschrieben neu geladen? und auch die anderen sound dinge gemacht?

ansonsten habe ich keine andere idee, als einen neueren mainline kernel zu nutzen.
da kann ich mangels erfahrungen nicht helfen.
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
Post Reply

Return to “Deutsch - German”