[gelöst] AppImage

Support-Forum für deutschsprachige Benutzer

Moderator: karlchen

Post Reply
Skychaser
Level 1
Level 1
Posts: 43
Joined: Wed Aug 10, 2022 6:00 am

[gelöst] AppImage

Post by Skychaser »

Huhu,

brauche ich für ein heruntergeladenes AppImage einen Launcher oder sowas?

Ich besitze einen creality c30 printmill 3D Drucker und versuche die ganze Zeit das Ding über den Idea Maker zum laufen
zu bekommen. Nun habe ich herausgefunden das es von creality ein AppImage für ubuntu gibt.

Ich nehme mal an das die Installation hier anders funktioniert als über die Anwedungsverwaltung oder ein skript in der Konsole.
Wäre nett wenn mal jemand kurz erklärt wie ich das installieren kann.

Grüße Stephan

Systeminfo:

Code: Select all

System:
  Kernel: 5.15.0-48-generic x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: Cinnamon 5.4.12
    tk: GTK 3.24.33 wm: Mutter dm: LightDM Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy
Machine:
  Type: Laptop System: LENOVO product: 82C7 v: Lenovo V15-ADA serial: <superuser required>
    Chassis: type: 10 v: Lenovo V15-ADA serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700WIN serial: <superuser required> UEFI: LENOVO
    v: E8CN34WW date: 04/28/2022
Battery:
  ID-1: BAT0 charge: 26.6 Wh (80.9%) condition: 32.9/35.3 Wh (93.1%) volts: 8.5 min: 7.6
    model: CPT-COS L16C2PB1 serial: <filter> status: Charging
CPU:
  Info: dual core model: AMD Athlon Silver 3050U with Radeon Graphics bits: 64 type: MCP
    arch: Zen/Zen+ note: check rev: 1 cache: L1: 192 KiB L2: 1024 KiB L3: 4 MiB
  Speed (MHz): avg: 3087 high: 3189 min/max: 1400/2300 boost: enabled cores: 1: 3189 2: 2986
    bogomips: 9182
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series] vendor: Lenovo
    driver: amdgpu v: kernel pcie: speed: 8 GT/s lanes: 16 ports: active: HDMI-A-1 off: eDP-1
    empty: none bus-ID: 03:00.0 chip-ID: 1002:15d8
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-5:4 chip-ID: 174f:1176
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: amdgpu,ati
    unloaded: fbdev,modesetting,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96
  Monitor-1: HDMI-A-0 mapped: HDMI-A-1 model: Samsung res: 2560x1440 dpi: 35
    diag: 1271mm (50.1")
  OpenGL: renderer: AMD RAVEN2 (LLVM 13.0.1 DRM 3.42 5.15.0-48-generic) v: 4.6 Mesa 22.0.5
    direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:15de
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
    driver: snd_pci_acp3x v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
    speed: 8 GT/s lanes: 16 bus-ID: 03:00.6 chip-ID: 1022:15e3
  Sound Server-1: ALSA v: k5.15.0-48-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo
    driver: rtw_8822ce v: N/A pcie: speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0
    chip-ID: 10ec:c822
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-6:5
    chip-ID: 0bda:c123
  Report: hciconfig ID: hci0 rfk-id: 3 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 41.5 GiB (3.5%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530 SDBPMPZ-256G-1101 size: 238.47 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 29.9 C
  ID-2: /dev/sda vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB speed: 6.0 Gb/s
    serial: <filter>
Partition:
  ID-1: / size: 233.18 GiB used: 41.5 GiB (17.8%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 511 MiB used: 5.2 MiB (1.0%) fs: vfat dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002
  Device-1: 1-2:2 info: Logitech M90/M100 Optical Mouse type: Mouse driver: hid-generic,usbhid
    rev: 2.0 speed: 1.5 Mb/s chip-ID: 046d:c05a
  Device-2: 1-4:3 info: XP-Pen 10 inch PenTablet type: Mouse,HID driver: hid-generic,usbhid
    rev: 1.1 speed: 12 Mb/s chip-ID: 28bd:0907
  Device-3: 1-5:4 info: Syntek Integrated Camera type: Video driver: uvcvideo rev: 2.0
    speed: 480 Mb/s chip-ID: 174f:1176
  Device-4: 1-6:5 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb rev: 1.0
    speed: 12 Mb/s chip-ID: 0bda:c123
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): N/A
Repos:
  Packages: 2462 apt: 2444 flatpak: 18
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb https: //mirror.bauhuette.fh-aachen.de/linuxmint vanessa main upstream import backport
    2: deb http: //archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
    3: deb http: //archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
    4: deb http: //archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse
    5: deb http: //security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
  Processes: 227 Uptime: 3h 23m Memory: 5.67 GiB used: 1.94 GiB (34.2%) Init: systemd v: 249
  runlevel: 5 Compilers: gcc: 11.2.0 alt: 11 Client: Unknown python3.10 client inxi: 3.3.13
Nachtrag hab gerade etwas rumprobiert nach dem was ich im Internet gefunden habe und den Startversuch aus der Konsole :

Code: Select all

stephan@stephan-Lenovo-V15-ADA:~/creality c-30$ chmod a+x Creality_Print-v3.11.1-Ubutu-x86_64-Release.AppImage

stephan@stephan-Lenovo-V15-ADA:~/creality c-30$ ./Creality_Print-v3.11.1-Ubutu-x86_64-Release.AppImage
"/home/stephan/.local/share//Creality_Print-v3/Log/"
Speicherzugriffsfehler (Speicherabzug geschrieben)
stephan@stephan-Lenovo-V15-ADA:~/creality c-30$ 
Ich nehme also mal an das Problem liegt an dem Image ist das richtig?
Last edited by Skychaser on Tue Oct 04, 2022 12:45 pm, edited 2 times in total.
User avatar
db91595
Level 2
Level 2
Posts: 66
Joined: Mon Jun 28, 2021 5:48 am
Location: Germany

Re: AppImage

Post by db91595 »

Hi Skychaser,

das AppImage ist mit einer "Win Exe" vergleichbar.
Ich habe mein "Conky AppImage" mit den nötigen Parametern aufgerufen. Natürlich muss das AppImage als "ausführbar" markiert werden.

Jetzt kommt es nur darauf an, WAS dein AppImage "machen" soll. Braucht es Parameter? etc.
LG
Dietmar

Ich versuche "Hilfe" zur "Selbsthilfe" zu geben. Wenn es gelingt - freue ich mich. :-)
Skychaser
Level 1
Level 1
Posts: 43
Joined: Wed Aug 10, 2022 6:00 am

Re: AppImage

Post by Skychaser »

Hi db91595,

tja da fängt das Problem an^^
habe das nur so beim rumgoogeln zufällig auf der Creality Seite gefunden für Ubuntu halt wie es aussieht.

Dokumentation von Creality Seite = Fehlanzeige

Eigentlich sollte den Slicer für den 3D Drucker öffnen wo ich dann meine Modelle reinlegen kann, ausführbar wurde es schon gemacht.
Es startet und er versucht anscheinend Druckerprofile zu laden. Dann beendet sich halt einfach wieder mit der Speicherfehlermeldung in der
Konsole.

Leider kann ich das Logfile hier wegen übergrösse nicht einstellen 250.000 Zeichen von 60.000

Code: Select all

[2022-09-25 11:54:41.249] [cxlog] [debug] ["----------> START LOG <-----------"]
[2022-09-25 11:54:41.249] [cxlog] [debug] [OS LINUX pre setDynamicLoadPath]
[2022-09-25 11:54:41.249] [cxlog] [debug] [Linux get the APPDIR :  "/tmp/.mount_CrealihQY2Hd"]
[2022-09-25 11:54:41.252] [cxlog] [debug] [Pre Dynamic import paths:]
[2022-09-25 11:54:41.252] [cxlog] [debug] [("/tmp/.mount_CrealihQY2Hd/plugins")]
[2022-09-25 11:54:41.380] [cxlog] [debug] [applicationDir  "/tmp/.mount_CrealihQY2Hd"]
[2022-09-25 11:54:41.380] [cxlog] [debug] [OS LINUX setDynamicLoadPath]
[2022-09-25 11:54:41.380] [cxlog] [debug] [Qml import paths:]
[2022-09-25 11:54:41.380] [cxlog] [debug] [("/tmp/.mount_CrealihQY2Hd", "qrc:/qt-project.org/imports", "/tmp/.mount_CrealihQY2Hd/qml", "/tmp/.mount_CrealihQY2Hd/lib/", "/tmp/.mount_CrealihQY2Hd/qml/")]
[2022-09-25 11:54:41.380] [cxlog] [debug] [Dynamic import paths:]
[2022-09-25 11:54:41.380] [cxlog] [debug] [("/tmp/.mount_CrealihQY2Hd/plugins", "/tmp/.mount_CrealihQY2Hd/plugins", "/tmp/.mount_CrealihQY2Hd", "/tmp/.mount_CrealihQY2Hd", "/tmp/.mount_CrealihQY2Hd/lib/")]
[2022-09-25 11:54:41.381] [cxlog] [debug] [start...]
[2022-09-25 11:54:41.381] [cxlog] [debug] ["/home/stephan/.local/share/Creality/Creative3D/sliceconfig"]
[2022-09-25 11:54:41.394] [cxlog] [debug] [settings initialize over]
[2022-09-25 11:54:41.458] [cxlog] [debug] [--------------------------------]
[2022-09-25 11:54:41.458] [cxlog] [debug] [buildAbi:  "x86_64-little_endian-lp64"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [buildCpuArchitecture:  "x86_64"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [currentCpuArchitecture:  "x86_64"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [kernelType:  "linux"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [kernelVersion:  "5.15.0-48-generic"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [machineHostName:  "stephan-Lenovo-V15-ADA"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [prettyProductName:  "Linux Mint 21"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [productType:  "linuxmint"]
[2022-09-25 11:54:41.458] [cxlog] [debug] [productVersion:  "21"]
[2022-09-25 11:54:41.458] [cxlog] [debug] ["" -1 -1 -1]
[2022-09-25 11:54:41.458] [cxlog] [debug] [--------------------------------
]
[2022-09-25 11:54:41.458] [cxlog] [debug] [write_folder =  "/home/stephan/.local/share/Creality/Creative3D"]
[2022-09-25 11:54:41.463] [cxlog] [debug] [install command]
[2022-09-25 11:54:41.464] [cxlog] [debug] [start add commands list]
[2022-09-25 11:54:41.469] [cxlog] [debug] [kernelUI constructor over]
[2022-09-25 11:54:41.490] [cxlog] [debug] [remove all buttons but last one]
[2022-09-25 11:54:41.512] [cxlog] [debug] [remove all buttons but last one]
[2022-09-25 11:54:41.537] [cxlog] [debug] [remove all commands]
[2022-09-25 11:54:41.537] [cxlog] [debug] [remove all commands]
[2022-09-25 11:54:41.537] [cxlog] [debug] [add commands list over. total have add  0   commands]
[2022-09-25 11:54:41.537] [cxlog] [debug] [install rclick menu]
[2022-09-25 11:54:41.537] [cxlog] [debug] [DeleteModelAction init success!!]
[2022-09-25 11:54:41.549] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/manipulate.geom"]
[2022-09-25 11:54:41.549] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/manipulate.tcs"]
[2022-09-25 11:54:41.549] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/manipulate.tes"]
[2022-09-25 11:54:41.549] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pickFace.geom"]
[2022-09-25 11:54:41.549] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pickFace.tcs"]
[2022-09-25 11:54:41.549] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pickFace.tes"]
[2022-09-25 11:54:41.550] [cxlog] [debug] [remove all commands]
[2022-09-25 11:54:41.641] [cxlog] [debug] [Surface setClearColor  QColor(ARGB 0, 0, 0, 0)]
[2022-09-25 11:54:41.645] [cxlog] [debug] [ColorPicker::setTextureRenderTarget  QObject(0x0)]
[2022-09-25 11:54:41.651] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelwireframe.tcs"]
[2022-09-25 11:54:41.651] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelwireframe.tes"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/support.geom"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/support.tcs"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/support.tes"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pickFaceFlag.geom"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pickFaceFlag.tcs"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pickFaceFlag.tes"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelline.geom"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelline.tcs"]
[2022-09-25 11:54:41.652] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelline.tes"]
[2022-09-25 11:54:41.662] [cxlog] [debug] [remove all commands]
[2022-09-25 11:54:41.662] [cxlog] [debug] [install UI]
[2022-09-25 11:54:41.662] [cxlog] [debug] [current path application dir =  "/tmp/.mount_CrealihQY2Hd"]
[2022-09-25 11:54:41.662] [cxlog] [debug] [current path current =  "/home/stephan/Downloads"]
[2022-09-25 11:54:42.103] [cxlog] [debug] [current path application dir =  "/tmp/.mount_CrealihQY2Hd"]
[2022-09-25 11:54:42.103] [cxlog] [debug] [current path current =  "/home/stephan/Downloads"]
[2022-09-25 11:54:43.133] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pure.geom"]
[2022-09-25 11:54:43.133] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pure.tcs"]
[2022-09-25 11:54:43.133] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/pure.tes"]
[2022-09-25 11:54:43.133] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/printergrid.geom"]
[2022-09-25 11:54:43.133] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/printergrid.tcs"]
[2022-09-25 11:54:43.133] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/printergrid.tes"]
[2022-09-25 11:54:43.134] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/printerbottom.geom"]
[2022-09-25 11:54:43.134] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/printerbottom.tcs"]
[2022-09-25 11:54:43.134] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/printerbottom.tes"]
[2022-09-25 11:54:43.134] [cxlog] [warning] [libpng warning: iCCP: known incorrect sRGB profile]
[2022-09-25 11:54:43.143] [cxlog] [debug] [CreativePluginCenter nameFilters :  ("libplugin*.so")]
[2022-09-25 11:54:43.143] [cxlog] [debug] [CreativePluginCenter searchPathes :  ("/tmp/.mount_CrealihQY2Hd/plugins", "/tmp/.mount_CrealihQY2Hd/plugins", "/tmp/.mount_CrealihQY2Hd", "/tmp/.mount_CrealihQY2Hd", "/tmp/.mount_CrealihQY2Hd/lib/")]
[2022-09-25 11:54:43.144] [cxlog] [debug] ["CreativePluginCenter try find in path: [/tmp/.mount_CrealihQY2Hd/plugins]->[0]"]
[2022-09-25 11:54:43.144] [cxlog] [debug] ["CreativePluginCenter try find in path: [/tmp/.mount_CrealihQY2Hd/plugins]->[0]"]
[2022-09-25 11:54:43.145] [cxlog] [debug] ["CreativePluginCenter try find in path: [/tmp/.mount_CrealihQY2Hd]->[0]"]
[2022-09-25 11:54:43.145] [cxlog] [debug] ["CreativePluginCenter try find in path: [/tmp/.mount_CrealihQY2Hd]->[0]"]
[2022-09-25 11:54:43.145] [cxlog] [debug] ["CreativePluginCenter try find in path: [/tmp/.mount_CrealihQY2Hd/lib/]->[13]"]
[2022-09-25 11:54:43.150] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_cx3d_exporter.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.154] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_extend_mesh.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.156] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_info.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.176] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_laser.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.184] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_letter.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.189] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_localnet.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.191] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_log.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.252] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_meshio_common.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.254] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_pick_bottom.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.258] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_repairnew.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.261] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_simple_support.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.326] [cxlog] [debug] [sendcorebu Myrunthread(0x2326c00)]
[2022-09-25 11:54:43.326] [cxlog] [debug] [CXMsgCbImpl set Myrunthread(0x2326c00)]
[2022-09-25 11:54:43.326] [cxlog] [debug] [running Myrunthread(0x2326c00) Myrunthread(0x2326c00)]
[2022-09-25 11:54:43.326] [cxlog] [debug] [has QCoreApplication::instance()]
[2022-09-25 11:54:43.425] [cxlog] [debug] [Mysender QThread(0x95dec0)]
[2022-09-25 11:54:43.428] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/slicepreviewNoTess.geom"]
[2022-09-25 11:54:43.428] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/slicepreviewNoTess.tcs"]
[2022-09-25 11:54:43.428] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/slicepreviewNoTess.tes"]
[2022-09-25 11:54:43.429] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelsimple.geom"]
[2022-09-25 11:54:43.429] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelsimple.tcs"]
[2022-09-25 11:54:43.429] [cxlog] [warning] [Could not read shader source file: ":/renderhelper/shaders/modelsimple.tes"]
[2022-09-25 11:54:43.429] [cxlog] [debug] [Surface setClearColor  QColor(ARGB 0, 0, 0, 0)]
[2022-09-25 11:54:43.430] [cxlog] [debug] [ColorPicker::useSelfCameraSelector  true]
[2022-09-25 11:54:43.430] [cxlog] [debug] [ColorPicker::setFilterKey  "r2t"  =  0]
[2022-09-25 11:54:43.430] [cxlog] [debug] [ColorPicker::setClearColor  QColor(ARGB 0, 0, 0, 0)]
[2022-09-25 11:54:43.430] [cxlog] [debug] [ColorPicker::resize  QSize(400, 300)]
[2022-09-25 11:54:43.430] [cxlog] [debug] [ColorPicker::setTextureRenderTarget  QObject(0x0)]
[2022-09-25 11:54:43.430] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_slice_fdm.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.443] [cxlog] [debug] ["/tmp/.mount_CrealihQY2Hd/lib/libplugin_split.so"  QPluginLoader sucess.]
[2022-09-25 11:54:43.452] [cxlog] [debug] [imagePathPrefix =file:///./photo/]
[2022-09-25 11:54:43.452] [cxlog] [debug] [onCompleted-currentTheme: -1]
[2022-09-25 11:54:43.516] [cxlog] [debug] [windows GLQuickItem  --> QThread(0x95dec0)]
[2022-09-25 11:54:43.732] [cxlog] [debug] [Source Han Sans CN]
[2022-09-25 11:54:43.732] [cxlog] [debug] [qrc:/UI/fonts/]
[2022-09-25 11:54:43.875] [cxlog] [debug] [Preview way changed !!]
[2022-09-25 11:54:43.885] [cxlog] [debug] [Preview way changed !!]
Hier mal ein Auszug aus dem log file, viele Nachrichten wie das mit dem renderhelper wiederholen sich ständig.

Grüße Stephan
User avatar
ehtron
Level 10
Level 10
Posts: 3021
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: AppImage

Post by ehtron »

Hi :)
wirst du es eingentlich nochmal lernen
version und desktop anzugeben? :oops:
Lg. Ehtron :)
Keine Hilfe bei fehlender System / Desktop Angabe.
Ich gebe Hilfe zur Selbsthilfe.
Skychaser
Level 1
Level 1
Posts: 43
Joined: Wed Aug 10, 2022 6:00 am

Re: AppImage

Post by Skychaser »

Hi,

habe den Startpost geändert.
wirst du es eingentlich nochmal lernen
version und desktop anzugeben? :oops:
Bleib ruhig Fury, denk an deinen Blutdruck und ausserdem is Sonntag :wink:

Grüße Stephan
User avatar
db91595
Level 2
Level 2
Posts: 66
Joined: Mon Jun 28, 2021 5:48 am
Location: Germany

Re: AppImage

Post by db91595 »

Ich frage mich WO findet er "renderhelper"

[warning] [Could not read shader source file: ":/renderhelper/

Hast du mal den Link wo die AppImage her ist?
LG
Dietmar

Ich versuche "Hilfe" zur "Selbsthilfe" zu geben. Wenn es gelingt - freue ich mich. :-)
Skychaser
Level 1
Level 1
Posts: 43
Joined: Wed Aug 10, 2022 6:00 am

Re: AppImage

Post by Skychaser »

Huhu,

klar hab ich den Link : https://www.creality.com/pages/download ... 3d-printer

einfach ganz nach unten scrollen ;)

Grüße Stephan
User avatar
db91595
Level 2
Level 2
Posts: 66
Joined: Mon Jun 28, 2021 5:48 am
Location: Germany

Re: AppImage

Post by db91595 »

Positiv: das PDF konte ich downloaden. Erkenntnisgewinn: den Aufbau des Printers konnte
ich erfassen.

Dann - Ubuntu-Drucker aber Ubuntu-Slicer?
Hängen die Warning im Log damit zusammen?

Kurz: nicht mein Metiere (absoluter Laie!)
Einzige Hoffnung: meine Laien-Anmerkungen helfen dir evtl. die richtigen Fragen zu stellen. Sorry! :?: :?: :?:
LG
Dietmar

Ich versuche "Hilfe" zur "Selbsthilfe" zu geben. Wenn es gelingt - freue ich mich. :-)
Skychaser
Level 1
Level 1
Posts: 43
Joined: Wed Aug 10, 2022 6:00 am

Re: AppImage

Post by Skychaser »

Huhu db91595,

alles gut ich hab nen Plan :lol:

also was ich herausfinden konnte ist das die wohl eine ältere und umgemodelte Version von Ultimaker Cura ist.
Cura aus dem Flatpak würde auch laufen, jedoch lädt der mir auch nicht die selbst zusammengestrickten Profile.

Ich werde mal versuchen anders an die Sache ranzugehen und Windows anwerfen, dort die Software Installieren und
versuchen den Drucker zu kallibrieren. Wenn das Erfolg hat und er brauchbare Ergebnisse liefert und ich sicher bin das
ein Fehlverhalten des Druckers ausgeschlossen ist werde ich dann das Profil, müsste ich mir halt händisch notieren,
auf den Idea Maker zu übertragen. Der läuft ja Einwandfrei unter Linux und dort kann ich dann in den Einstellungen
rumpielen solang bis es funzt. Ein Grundprofil für den C30 wird dort auch unterstützt.

Grüße Stephan
User avatar
Bleys
Level 2
Level 2
Posts: 70
Joined: Wed Apr 20, 2022 4:17 am
Location: Essen, Germany

Re: AppImage

Post by Bleys »

Zum Thema Appimages kann ich noch den Appimage-Launcher empfehlen: https://linuxnews.de/2021/05/appimages- ... tegrieren/

Der erste Start eines Appimage wird automatisch erkannt und angeboten das Appimage ins System einzubinden. Inkl. der Möglichkeit das Appimages per Klick wieder aus dem System zu entfernen:
sc1_000.png
sc1_000.png (33.16 KiB) Viewed 403 times
Ryzen 5 3400G, 16GB RAM, SanDisk Extrem Pro 1TB nvme, ASUS Prime B450M-A, Samsung Odyssey 49", Linux Mint 21
Skychaser
Level 1
Level 1
Posts: 43
Joined: Wed Aug 10, 2022 6:00 am

Re: [gelöst] AppImage

Post by Skychaser »

Hi Leute,

also ich gehe davon aus das dieses App Image fehlerhaft bzw nicht für diesen Kernel geeignet ist.

Das Ding wird / wurde von Creality bereitgestellt und hat sich seit der Auslieferung der Drucker nicht verändert.
Es ist auch auf dem mitgeliefterten USB Stick der auch den Slicer für Windows und Mac enthält und hatte bis
2021 dieselbe Versionsnummer wie die beiden anderen Versionen, jetzt ist es aber meilenweit hinterher und
wird anscheinend auch nicht mehr weiter gepflegt oder geupdatet.

Die Lösung ist aber denkbar einfach denn man braucht den Mist in meinem Fall nicht.

Der 3D Drucker funktioniert ohne Probleme mit Bordmitteln aus der Anwendungsverwaltung :

- IdeaMaker ist für meinen Drucker der Slicer der Wahl
- Ultimaker Cura ist auch hier vorhanden, kann aber keine 45 grad nozzle und das Template lässt sich auch nicht aus dem Win Ultimaker importieren
Ist aber sicher für andere 3D Drucker geeignet und bietet auch eine Menge an Fremddruckern die unterstützt werden.

In meinem Fall hat sich das also erledigt.

Grüße Stephan
Post Reply

Return to “Deutsch - German”