Problem bei der Installation von Monodevelop

German Forum

Moderator: karlchen

User avatar
pkm
Level 1
Level 1
Posts: 7
Joined: Mon May 18, 2015 5:56 am

Problem bei der Installation von Monodevelop

Postby pkm » Fri Aug 04, 2017 5:18 am

Ich versuche auf meinem Computer mit Linux Mint gerade Mono zu installieren. Ich habe dazu ein Tutorial gefunden:

https://www.youtube.com/watch?v=mqzZkS95ZCE

Ich habe folgende Linux Mint Version:

Code: Select all

RELEASE=17.3
CODENAME=rosa
EDITION="Cinnamon 32-bit"
DESCRIPTION="Linux Mint 17.3 Rosa"
DESKTOP=Gnome
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_rosa_cinnamon_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_rosa_cinnamon.php
USER_GUIDE_URL=help:linuxmint
GRUB_TITLE=Linux Mint 17.3 Cinnamon 32-bit



Wenn ich bei apt-get install bin, passoert folgendes:

Code: Select all

Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 monodevelop : Hängt ab von: libglade2.0-cil (>= 2.12.10-1ubuntu1) soll aber nicht installiert werden
               Hängt ab von: libgnome-vfs2.0-cil (>= 2.24.0) soll aber nicht installiert werden
               Hängt ab von: libgnome2.24-cil (>= 2.24.0) soll aber nicht installiert werden
               Hängt ab von: libmono-corlib4.5-cil (>= 4.0.0~alpha1) aber 3.2.8+dfsg-4ubuntu1.1 soll installiert werden
               Hängt ab von: libmono-microsoft-build-engine4.0-cil (>= 3.2.1) soll aber nicht installiert werden
               Hängt ab von: libmono-microsoft-build-framework4.0-cil (>= 3.6.0) soll aber nicht installiert werden
               Hängt ab von: libmono-microsoft-build-utilities-v4.0-4.0-cil (>= 3.6.0) soll aber nicht installiert werden
               Hängt ab von: libmono-microsoft-csharp4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-microsoft-web-infrastructure1.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-posix4.0-cil (>= 4.0.0~alpha1) aber 3.2.8+dfsg-4ubuntu1.1 soll installiert werden
               Hängt ab von: libmono-system-componentmodel-dataannotations4.0-cil (>= 4.0.0~alpha1) soll aber nicht installiert werden
               Hängt ab von: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) aber 3.2.8+dfsg-4ubuntu1.1 soll installiert werden
               Hängt ab von: libmono-system-core4.0-cil (>= 4.0.0~alpha1) aber 3.2.8+dfsg-4ubuntu1.1 soll installiert werden
               Hängt ab von: libmono-system-data-entity4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-data-linq4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-data-services-client4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-data4.0-cil (>= 4.0.0~alpha1) soll aber nicht installiert werden
               Hängt ab von: libmono-system-design4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-runtime-caching4.0-cil (>= 4.0.0~alpha1) soll aber nicht installiert werden
               Hängt ab von: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) soll aber nicht installiert werden
               Hängt ab von: libmono-system-runtime4.0-cil (>= 2.10.1) soll aber nicht installiert werden
               Hängt ab von: libmono-system-servicemodel4.0a-cil (>= 3.2.3) soll aber nicht installiert werden
               Hängt ab von: libmono-system-web-extensions4.0-cil (>= 2.10.3) soll aber nicht installiert werden
               Hängt ab von: libmono-system-web-services4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-web4.0-cil (>= 2.10.3) soll aber nicht installiert werden
               Hängt ab von: libmono-system-windows-forms4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-xaml4.0-cil (>= 1.0) soll aber nicht installiert werden
               Hängt ab von: libmono-system-xml4.0-cil (>= 3.12.0) aber 3.2.8+dfsg-4ubuntu1.1 soll installiert werden
               Hängt ab von: libmono-system4.0-cil (>= 4.0.0~alpha1) aber 3.2.8+dfsg-4ubuntu1.1 soll installiert werden
               Hängt ab von: libmono-windowsbase4.0-cil (>= 3.0.6) soll aber nicht installiert werden
               Hängt ab von: monodoc-base (>= 3.2.1) soll aber nicht installiert werden


Ich bin ein ziemlicher Laie, könnte mir jemand einen Tipp geben, woran das liegen könnte?

hcentaur13
Level 3
Level 3
Posts: 121
Joined: Sat May 18, 2013 5:13 pm

Re: Problem bei der Installation von Monodevelop

Postby hcentaur13 » Sun Aug 06, 2017 2:19 am

synaptic löst Abhängigkeiten gründlicher auf als apt-get. Apt-get fehlen einige Installationsauftröge zm die Installation ordentlich abschließen zu können. synaptic mit der Einstellung "empfohlene Pakete als Abhängigkeiten vorsehen" erledigt das automatisch mit.

User avatar
pkm
Level 1
Level 1
Posts: 7
Joined: Mon May 18, 2015 5:56 am

Re: Problem bei der Installation von Monodevelop

Postby pkm » Tue Sep 26, 2017 4:07 am

Ich habe nun Visual Studio Code für Linux installiert. Wenn ich aber ein C#-Programm Deguggen will, heißt es immer, dass .NET-CLI nicht installiert ist, ich habe dieses daher heruntergeladen, d. h. von guthub geklont. Was soll ich aber jetzt tun?


Return to “Deutsch (German)”

Who is online

Users browsing this forum: No registered users and 2 guests