Shutdown : braucht manchmal sehr lange

German Forum

Moderator: karlchen

malabarista
Level 2
Level 2
Posts: 92
Joined: Thu May 19, 2016 3:56 am
Contact:

Shutdown : braucht manchmal sehr lange

Postby malabarista » Mon Sep 04, 2017 6:49 am

Mein System:

Code: Select all

System:    Host: xxxxxx Kernel: 4.4.0-53-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.2.7  Distro: Linux Mint 18.1 Serena
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: F2A88X-D3HP v: x.x
           Bios: American Megatrends v: F2 date: 12/24/2015
CPU:       Quad core AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G (-MCP-) cache: 8192 KB
           clock speeds: max: 3700 MHz 1: 2400 MHz 2: 1700 MHz 3: 1700 MHz
           4: 1700 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1024x768@75.08hz
           GLX Renderer: Gallium 0.4 on AMD KAVERI (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: 1c:1b:0d:67:bc:f7
Drives:    HDD Total Size: 2000.4GB (29.2% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 1000.2GB
           ID-2: USB /dev/sdb model: External_USB_3.0 size: 1000.2GB
Partition: ID-1: / size: 681G used: 280G (44%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 7.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 14.9C mobo: N/A gpu: 14.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 229 Uptime: 2:14 Memory: 1665.5/6918.9MB
           Client: Shell (bash) inxi: 2.2.35

Mein Problem:
Der Shutdown braucht manchmal sehr lange. Und zwar immer dann, wenn ich mit Firefox nur mal kurz im Internet etwas nachgesehen habe.
Wenn ich GIMP oder LibreOffice oder andere Software verwendet habe, fährt er einwandfrei und sofort herunter.

Ursprünglich dachte ich, dass gar kein Shutdown erfolgt, aber nachdem etwa fünf Minuten lang das Mint-Logo angezeigt wurde, fährt er herunter und schaltet sich ab.
Ich vermute, dass er auf irgendeinen Prozess wartet, und nach einem timeout das Warten abbricht. Aber auf welchen Prozess?

Deshalb meine Frage: in welchem Log kann ich dazu Informationen finden ?

User avatar
karlchen
Level 18
Level 18
Posts: 8027
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Shutdown : braucht manchmal sehr lange

Postby karlchen » Mon Sep 04, 2017 8:14 am

Hallo, malabrista.

Auch wenn ich noch keine Lösung anbieten kann:
Du bist nicht allein. Auch mir ist schon aufgefallen, dass
+ mein Ubuntu 16.04 64-bit Unity
+ mein Linux Mint 18.1 32-bit / 64-bit
üblicherweise innerhalb von höchsten 15 Sekunden den Rechner runtergefahren und abgeschaltet haben, nachdem ich auf "Herunterfahren" geklickt habe, dass es aber ab und an passiert, dass dann stattdessen 2 Minuten lang
+ das Ubuntu Logo
+ das Mint Logo
auf dem Bildschirm angezeigt wird, und dann plötzlich doch das Abschalten erfolgt.
Immer kurz bevor ich auf die Console gehe, um nachzuschauen, was denn da hängen könnte.
Auf 5 Minuten bin ich noch nicht gekommen, aber eben auf 2. Was auch elendig lange erscheint, wenn man nichts sieht außer einem Logo.

In Zeiten vor Ubuntu 16.04 war es mal gerne der modem-manager, der das Herunterfahren torpediert hat, auch wenn weit und breit kein Modem mehr zu sehen war. Ob der auch 2017 noch seine Fingerchen im Spiel haben könnte, weiß ich nicht.

Bis Mint 17.3 / Ubuntu 14.04 hatte ich im Systemstop, kurz bevor auch rsyslogd beendet wird und darum auch nichts mehr protokolliert wird, ein kleines Script, das einfach die noch laufenden Prozesse auflistete, um so Verdächtige identifizieren zu können.
Einen evtl. noch geladenen modem-manager hat das Script mittels "kill -9" terminiert und das auch protokolliert.
Witzigerweise hat die kurze Verzögerung durch das zusätzliche Script zu 98% ausgereicht, um die Symptome verschwinden zu lassen.

Ich muß mal herausfinden, ob ich das Script auch unter systemd wieder in das Ende des Herunterfahrens einklinken kann, direkt bevor das root Filesystem ausgehängt wird.

Grüße
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

User avatar
k-314
Level 2
Level 2
Posts: 97
Joined: Sun Aug 06, 2017 4:42 am
Location: Germany

Re: Shutdown : braucht manchmal sehr lange

Postby k-314 » Mon Sep 04, 2017 8:54 am

Ist das so etwas hier?

https://debianforum.de/forum/viewtopic.php?f=12&t=166434&p=1143066&hilit=shutdown#p1143066

Hatte das des öfteren unter Jessie und Stretch erlebt. Nur das da halt die Meldung "A stop job is running ..." auf dem screen erschien.

Gruß KH
ASUS P5QL + Intel Core Duo E6750 @2.66GHz, Nvidia GEFORCE GT730
8GB DDR2-800, SSD 60GB, HDD 2TB, 250GB. Linux Mint 18.2 - Xfce

User avatar
karlchen
Level 18
Level 18
Posts: 8027
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Shutdown : braucht manchmal sehr lange

Postby karlchen » Mon Sep 04, 2017 9:38 am

Hallo, KH.

Wenn es wieder mal aufgetreten ist, kann ich ja das Kommando journalctl -b -1 nach dem nächsten Start anwenden. Mal sehen, was da evtl hängen geblieben ist beim Runterfahren.

Grüße,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

malabarista
Level 2
Level 2
Posts: 92
Joined: Thu May 19, 2016 3:56 am
Contact:

Re: Shutdown : braucht manchmal sehr lange

Postby malabarista » Tue Sep 05, 2017 6:17 am

Seit ich jetzt BackInTime deinstalliert habe, tritt der Effekt bei jedem(!) Shutdown auf.


Return to “Deutsch (German)”