autopep8 und flake8 für Atom installieren

German Forum

Moderator: karlchen

Post Reply
LimitedModz
Level 1
Level 1
Posts: 1
Joined: Tue Apr 24, 2018 11:28 am

autopep8 und flake8 für Atom installieren

Post by LimitedModz » Tue Apr 24, 2018 11:58 am

Hallo,

ich habe Linux erst in den letzten Tagen für mich entdeckt und bin dementsprechend noch ein richtiger Noob (also seid nicht zu streng mit mir :D).

Mein Problem ist ich würde gerne autopep8 und flake8 für den Editor "Atom" installieren, laut Anleitung ziemlich einfach: "pip install autopep8/flake8".
Jedoch erhalte ich eine Fehlermeldung in der Konsole:

Code: Select all

pip install autopep8
Collecting autopep8
  Using cached https://files.pythonhosted.org/packages/b7/0c/20cf0a438d5273bfd2d607ada3a7a782845ab3776c1c83c1d3baca05535e/autopep8-1.3.5.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ImportError: No module named setuptools
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-G7RuWO/autopep8/

pip install flake8
Collecting flake8
  Using cached https://files.pythonhosted.org/packages/b9/dc/14e9d94c770b8c4ef584e906c7583e74864786a58d47de101f2767d50c0b/flake8-3.5.0-py2.py3-none-any.whl
Collecting pyflakes<1.7.0,>=1.5.0 (from flake8)
  Using cached https://files.pythonhosted.org/packages/d7/40/733bcc64da3161ae4122c11e88269f276358ca29335468005cb0ee538665/pyflakes-1.6.0-py2.py3-none-any.whl
Requirement already satisfied: enum34; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from flake8) (1.1.2)
Collecting configparser; python_version < "3.2" (from flake8)
  Using cached https://files.pythonhosted.org/packages/7c/69/c2ce7e91c89dc073eb1aa74c0621c3eefbffe8216b3f9af9d3885265c01c/configparser-3.5.0.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ImportError: No module named setuptools
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-BeVtOc/configparser/

Pip habe ich vorher mit dem Befehl "apt install python-pip" installiert.
Ich benutze Linux Mint 18.3 64bit mit der Oberfläche MATE

Und nun weiß ich nicht weiter, vielleicht kann mir ja jemand von euch helfen.

Post Reply

Return to “Deutsch (German)”