[gelöst] Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

German Forum

Moderator: karlchen

Post Reply
User avatar
it-place
Level 1
Level 1
Posts: 13
Joined: Thu Jul 05, 2018 4:42 am

[gelöst] Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by it-place » Wed Nov 14, 2018 2:44 am

Hallo zusammen,

ich habe Probleme unter Linux Mint 19, die aktuellen Updates einzuspielen. :( Dabei erhalte ich die folgende Fehlermeldung:
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic:
linux-image-generic hängt ab von linux-modules-extra-4.15.0-39-generic; aber:
Paket linux-modules-extra-4.15.0-39-generic ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes linux-image-generic (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-generic:
linux-generic hängt ab von linux-image-generic (= 4.15.0.39.41); aber:
Paket linux-image-generic ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes linux-generic (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert

Fehler traten auf beim Bearbeiten von:
linux-image-generic
linux-generic
Eigentlich sollte der Update-Prozess das Paket linux-modules-extra-4.15.0-39-generic doch automatisch mit installieren, oder? Hat jemand eine Idee? :?

Viele Grüße - Oliver
Last edited by it-place on Thu Nov 15, 2018 4:52 pm, edited 1 time in total.

User avatar
ehtron
Level 5
Level 5
Posts: 772
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by ehtron » Wed Nov 14, 2018 8:04 am

Hi :)
versuche mal dein apt system zu reparieren

Code: Select all

sudo dpkg --configure -a

Code: Select all

sudo apt-get -f install
Lg. Ehtron :)

gm10
Level 13
Level 13
Posts: 4566
Joined: Thu Jun 21, 2018 5:11 pm

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by gm10 » Wed Nov 14, 2018 8:15 am

it-place wrote:
Wed Nov 14, 2018 2:44 am
Eigentlich sollte der Update-Prozess das Paket linux-modules-extra-4.15.0-39-generic doch automatisch mit installieren, oder? Hat jemand eine Idee? :?
Ne, macht er nicht, der Update Manager ist buggy und teilt kernel updates in 2 separate Einträge auf, die beide ausgewählt werden müssen, damit das Update funktioniert. Falls Du den zweiten Teil nicht siehst: Ein zusätzlicher Bug identifiziert kernel updates nicht richtig, so daß der entsprechende Filter nicht korrekt funktioniert.

User avatar
ehtron
Level 5
Level 5
Posts: 772
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by ehtron » Wed Nov 14, 2018 8:46 am

Hi :)
Ne, macht er nicht, der Update Manager ist buggy und teilt kernel updates in 2 separate Einträge auf, die beide ausgewählt werden müssen, damit das Update funktioniert.
auf welschem stand bist du denn? ;)
die aktualisierungsverwaltung arbeitet einwandfrei in sachen kernel...
ich halte es aber für sinnvoll die kernel automatik abzuschalten...

einzig das automatische update macht hin und wieder probleme und schrottet den den dpkg stack...
Lg. Ehtron :)

gm10
Level 13
Level 13
Posts: 4566
Joined: Thu Jun 21, 2018 5:11 pm

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by gm10 » Wed Nov 14, 2018 9:33 am

ehtron wrote:
Wed Nov 14, 2018 8:46 am
auf welschem stand bist du denn? ;)
Ich bin auf meinem eigenen Stand, wo das Problem behoben ist: https://github.com/linuxmint/mintupdate/pull/405 :P (Du hast gefragt)

Aber Ihr seid auf dem hier und habt es noch: viewtopic.php?p=1552531#p1552531 ;)

User avatar
ehtron
Level 5
Level 5
Posts: 772
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by ehtron » Wed Nov 14, 2018 10:41 am

Hi :)
ok.. das prob scheint wohl erst ab -39 aufzutreten...
habe nicht upgedatet, da für mein system nicht notwendig.
Lg. Ehtron :)

gm10
Level 13
Level 13
Posts: 4566
Joined: Thu Jun 21, 2018 5:11 pm

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by gm10 » Wed Nov 14, 2018 10:57 am

ehtron wrote:
Wed Nov 14, 2018 10:41 am
ok.. das prob scheint wohl erst ab -39 aufzutreten...
Nicht, daß wir das ausdiskutieren müssten, aber es tritt tatsächlich mit allen Versionen auf, solange Du eines der Kernelmetapakete installiert hast:
um-kernel-bug-4.4.png
War damals ein Problem with 4.15.0-24, Ubuntu hatte den wegen Fehlern zurückgezogen (viele Leute steckten am schwarzen Boot-Bildschirm fest, falls Du Dich erinnerst) aber Mint's Update Manager hat das ignoriert und den weiter angeboten. Ist derselbe Bug.

User avatar
ehtron
Level 5
Level 5
Posts: 772
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by ehtron » Wed Nov 14, 2018 11:07 am

Hi :) na warten wir mal ab... in lmu ist bisher nichts derartiges aufgelaufen.
Lg. Ehtron :)

User avatar
it-place
Level 1
Level 1
Posts: 13
Joined: Thu Jul 05, 2018 4:42 am

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by it-place » Wed Nov 14, 2018 4:21 pm

Leider lässt sich der Fehler bei mir derzeit nicht mit den üblichen Bordmitteln beheben. :shock: Mit dem Befehl

Code: Select all

sudo apt-get --fix-broken
bleibt das Problem leider bestehen. Ich habe zum Glück immer ein aktuelles CloneZilla-Image und bin jetzt zu letzten Stand zurückgegangen. Bis auf weiteres lasse ich folgende Pakete beim Update weg:
linux-4.15.0.39.41
linux-libc-dev
Linux-Kernel 4.15.0-39.42

User avatar
ehtron
Level 5
Level 5
Posts: 772
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by ehtron » Wed Nov 14, 2018 4:31 pm

Hi :)
linux-modules-extra-4.15.0-39-generic ist nicht installiert
ich gehe davon aus, dass du das beachtet hast.. sprich installiert hast.
Lg. Ehtron :)

User avatar
karlchen
Level 19
Level 19
Posts: 9497
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by karlchen » Wed Nov 14, 2018 8:17 pm

Hallo, it-place.

So wie ich das aus deinem ersten Post entnehme, genauer aus den dpkg Beschwerden, wären die Lösungsschritte
  1. das fehlende Paket linux-modules-extra-4.15.0-39-generic zu installieren.
    Z.B. mittels Kommandozeile:

    Code: Select all

    apt update
    apt install linux-modules-extra-4.15.0-39-generic
  2. dann das beliebte

    Code: Select all

    sudo dpkg --configure -a
  3. danach

    Code: Select all

    sudo apt-get --fix-broken install
  4. Falls das alles fehlerfrei abgeschlossen ist, sollte sich der Rest des Kernelupdates aus 4.15.0-39 sogar per Update Manager installieren lassen.
Falls es bei einem der Schritte hakt, bitte Rückmeldug mit ausgeführtem Kommando und vollständiger Fehlermeldung.

Grüße
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

User avatar
it-place
Level 1
Level 1
Posts: 13
Joined: Thu Jul 05, 2018 4:42 am

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by it-place » Thu Nov 15, 2018 1:28 pm

karlchen wrote:
Wed Nov 14, 2018 8:17 pm

Code: Select all

apt install linux-modules-extra-4.15.0-39-generic
Hallo Karl,
leider schlägt die Installation des o.g. Paketes auf meinem PC fehl mit der folgenden Fehlermeldung:
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/linux-modules-extra-4.15.0-39-generic_4.15.0-39.42_amd64.deb (--unpack):
»/lib/modules/4.15.0-39-generic/kernel/drivers/isdn/mISDN/mISDN_core.ko.dpkg-new« kann nicht geöffnet werden: Vorgang nicht zulässig
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/linux-modules-extra-4.15.0-39-generic_4.15.0-39.42_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Komisch ist allerdings, dass das gleiche Kommando in einer VM mit einem frisch installierten Mint 19 fehlerfrei durchläuft. :roll:

Viele Grüße - Oliver

gm10
Level 13
Level 13
Posts: 4566
Joined: Thu Jun 21, 2018 5:11 pm

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by gm10 » Thu Nov 15, 2018 1:40 pm

Das ist ja mal eine unspezifische Fehlermeldung... hast Du noch genug Platz auf der Partition?

Code: Select all

df /
Wenn's das nicht ist, dann versuch mal

Code: Select all

apt clean
apt update
sudo rm -rf /lib/modules/4.15.0-39-generic/
apt install dpkg
apt install linux-modules-extra-4.15.0-39-generic 

User avatar
ehtron
Level 5
Level 5
Posts: 772
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by ehtron » Thu Nov 15, 2018 1:49 pm

Hi :)
auch auf lmu ist den tag über keine derartige fehlermeldung mit dem neuen kernel aufgetaucht..
vermutlich hattest du relevante pakete entfernt.
Lg. Ehtron :)

User avatar
it-place
Level 1
Level 1
Posts: 13
Joined: Thu Jul 05, 2018 4:42 am

Re: Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by it-place » Thu Nov 15, 2018 4:49 pm

Hallo zusammen,

vielen Dank für Eure Geduld! :) Die Sache mit meiner VM hat mich stutzig gemacht und daher habe ich meinen PC gerade neu installiert. Das Update läuft nun fehlerfrei durch. Vermutlich ist also wohl doch etwas kaputt gewesen... :?

Viele Grüße - Oliver

User avatar
it-place
Level 1
Level 1
Posts: 13
Joined: Thu Jul 05, 2018 4:42 am

Re: [gelöst] Update-Fehler: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-generic

Post by it-place » Fri Nov 16, 2018 9:17 am

Hallo nochmal,

der Vollständigkeit halber sei hier noch erwähnt, dass die eigentliche Ursache für das Problem der Online-Access-Scanner von Sophos-Antivirus war, der das Paket fälschlicherweise geblockt hatte... :oops:

Viele Grüße - Oliver

Post Reply

Return to “Deutsch (German)”