X230 kein WLAN mit Mint 19.1 Cinnamon

German Forum

Moderator: karlchen

Post Reply
_the_muff_
Level 1
Level 1
Posts: 10
Joined: Thu May 23, 2019 4:23 am

X230 kein WLAN mit Mint 19.1 Cinnamon

Post by _the_muff_ » Fri May 31, 2019 2:17 am

Hallo !

Was muss getan werden um Websites via Wifi aufzurufen ?
Die Netzwerkverbindung besteht, die Authentifizierung erfolgt ebenfalls. Jedoch kein Netzwerktraffic.

Code: Select all

m8tin@m8tin-ThinkPad-X230:~$ inxi -Fxz

System: Host: m8tin-ThinkPad-X230 Kernel: 4.15.0-50-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10
Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: LENOVO product: 23255T8 v: ThinkPad X230 serial: <filter>
Mobo: LENOVO model: 23255T8 serial: <filter> UEFI [Legacy]: LENOVO v: G2ETA1WW (2.61 ) date: 04/22/2014
Battery: ID-1: BAT0 charge: 34.0 Wh condition: 34.5/57.7 Wh (60%) model: LGC 45N1025 status: Unknown
CPU: Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20751
Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1197
Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.8 direct render: Yes
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus ID: 00:1b.0
Sound Server: ALSA v: k4.15.0-50-generic
Network: Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: 3.2.6-k port: 5080 bus ID: 00:19.0
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: efa0 bus ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives: Local Storage: total: 465.76 GiB used: 17.81 GiB (3.8%)
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
Partition: ID-1: / size: 457.45 GiB used: 17.81 GiB (3.9%) fs: ext4 dev: /dev/sda1
Sensors: System Temperatures: cpu: 47.0 C mobo: N/A
Fan Speeds (RPM): cpu: 1779
Info: Processes: 196 Uptime: 25m Memory: 15.37 GiB used: 2.30 GiB (14.9%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0
Shell: bash v: 4.4.19 inxi: 3.0.27
m8tin@m8tin-ThinkPad-X230:~$
______________________________

Code: Select all

m8tin@m8tin-ThinkPad-X230:~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
m8tin@m8tin-ThinkPad-X230:~$

__________________________

i

Code: Select all

wm8tin@m8tin-ThinkPad-X230:~$ iwconfig
lo no wireless extensions.

enp0s25 no wireless extensions.

wlp3s0 IEEE 802.11 ESSID:"HITRON-A7E0"
Mode:Managed Frequency:2.437 GHz Access Point: 84:94:8C:FA:A7:E8
Bit Rate=58.5 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=70/70 Signal level=-24 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:311 Missed beacon:0

m8tin@m8tin-ThinkPad-X230:~$

___________________________________

Code: Select all

lsm8tin@m8tin-ThinkPad-X230:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b2eb Chicony Electronics Co., Ltd
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

m8tin@m8tin-ThinkPad-X230:~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
02:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 07)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
m8tin@m8tin-ThinkPad-X230:~$

Code: Select all

root@m8tin-ThinkPad-X230:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
valid_lft forever preferred_lft forever
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether 3c:97:0e:7e:77:e4 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 84:3a:4b:93:34:80 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.19/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp3s0
valid_lft 604756sec preferred_lft 604756sec
inet6 fd00:8494:8cfa:a7e2:99fd:d96b:b788:27ef/64 scope global temporary dynamic 
valid_lft 535427sec preferred_lft 86127sec
inet6 fd00:8494:8cfa:a7e2:a2f5:71fd:6b98:fc4e/64 scope global dynamic mngtmpaddr noprefixroute 
valid_lft 535427sec preferred_lft 401570sec
inet6 2a02:8108:4740:d5a0:99fd:d96b:b788:27ef/64 scope global temporary dynamic 
valid_lft 5399sec preferred_lft 2699sec
inet6 2a02:8108:4740:d5a0:b17a:c99a:8215:98ac/64 scope global dynamic mngtmpaddr noprefixroute 
valid_lft 5399sec preferred_lft 2699sec
inet6 fe80::f6cd:a2ea:4127:a8ec/64 scope link noprefixroute 
valid_lft forever preferred_lft forever
root@m8tin-ThinkPad-X230:~# 
root@m8tin-ThinkPad-X230:~# ip r
default via 192.168.0.1 dev wlp3s0 proto dhcp metric 20600 
169.254.0.0/16 dev wlp3s0 scope link metric 1000 
192.168.0.0/24 dev wlp3s0 proto kernel scope link src 192.168.0.19 metric 600 
root@m8tin-ThinkPad-X230:~# 
root@m8tin-ThinkPad-X230:~# 
root@m8tin-ThinkPad-X230:~# iptables -n
iptables v1.6.1: no command specified
Try `iptables -h' or 'iptables --help' for more information.
root@m8tin-ThinkPad-X230:~#

Code: Select all

root@m8tin-ThinkPad-X230:~# ping https://clicktime.symantec.com/38UUi56poJjgCt4ysLhEm9o6H2?u=www.lala.de
ping: www.lala.de: Der Name oder der Dienst ist nicht bekannt
root@m8tin-ThinkPad-X230:~#
Last edited by karlchen on Fri May 31, 2019 3:19 am, edited 1 time in total.
Reason: Title: corrected spelling of Cinnamon; message: added [code] tags where appropriate

User avatar
ehtron
Level 5
Level 5
Posts: 954
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by ehtron » Fri May 31, 2019 8:17 am

HI :)
vermute deine auflösung über den dns funktioniert nicht..

Code: Select all

ping 216.58.210.3
was zeigt netzwerk als dns adresse?

ggf. mal einen dns server vergeben... 8.8.8.8
dhcp einstellungen des routers checken..

hast du irgendwas in sachen netzwerk verändert? läuft es unter lan? (netzwerkkabel)
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

_the_muff_
Level 1
Level 1
Posts: 10
Joined: Thu May 23, 2019 4:23 am

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by _the_muff_ » Thu Jun 13, 2019 3:21 pm

Moin !

Also

Ping auf die IP =

root@hoagie-ThinkPad-X230:~# ping 216.58.210.3
PING 216.58.210.3 (216.58.210.3) 56(84) bytes of data.
64 bytes from 216.58.210.3: icmp_seq=1 ttl=54 time=19.7 ms
64 bytes from 216.58.210.3: icmp_seq=2 ttl=54 time=21.7 ms
64 bytes from 216.58.210.3: icmp_seq=3 ttl=54 time=21.6 ms
64 bytes from 216.58.210.3: icmp_seq=4 ttl=54 time=20.1 ms
64 bytes from 216.58.210.3: icmp_seq=5 ttl=54 time=22.9 ms
64 bytes from 216.58.210.3: icmp_seq=6 ttl=54 time=21.9 ms
64 bytes from 216.58.210.3: icmp_seq=7 ttl=54 time=19.9 ms
64 bytes from 216.58.210.3: icmp_seq=8 ttl=54 time=19.8 ms
64 bytes from 216.58.210.3: icmp_seq=9 ttl=54 time=27.8 ms
^C
--- 216.58.210.3 ping statistics ---
9 packets transmitted, 9 received, 0% packet loss, time 8012ms
rtt min/avg/max/mdev = 19.737/21.736/27.818/2.405 ms
root@hoagie-ThinkPad-X230:~#
root@hoagie-ThinkPad-X230:~# ping 216.58.210.3
PING 216.58.210.3 (216.58.210.3) 56(84) bytes of data.
^C
--- 216.58.210.3 ping statistics ---
12 packets transmitted, 0 received, 100% packet loss, time 11264ms

root@hoagie-ThinkPad-X230:~#


via LAN funktioniert die Verbindung via WLAN nicht.

Ich habe den Router in Verdacht.
Eine Verbindung über das Smartphone als Accesspoint funktioniert.

Im Networkmanager wird der Router als DNS Server hinterlegt.
Die Vergabe von 8.8.8.8 manuell in den IPv4 Settings interessiert nicht. Ein Ping auf 216.58.210.3 kommt weiterhin nicht durch.

Was ich interessant finde ist, dass im Menü des Routers keine IPv4 Adresse hinterlegt ist. Der Router kommuniziert ausschließlich via IPv6.
An sich ja ok. via LAN funktioniert die Verbindung ja.
Im Router sehe ich immer wieder mal Einträge wie "had deauthenticated". Dann gibt es wieder eine Vielzahl von erfolgreichen Verbindungen.

DHCP des Routers ist auf "automatisch" eingestellt. Eine gültige IP Adresse wird dem Gerät zugewiesen.

User avatar
ehtron
Level 5
Level 5
Posts: 954
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by ehtron » Thu Jun 13, 2019 3:29 pm

Hi :)
wenn der ping auf die ip läuft, funktioniert die wlan verbindung
Die Vergabe von 8.8.8.8 manuell in den IPv4 Settings interessiert nicht. Ein Ping auf 216.58.210.3 kommt weiterhin nicht durch.
da hast du was falsch gemacht...
der dns server wird nur gebraucht um namen aufzulösen... die ip sollte immer gehen.
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

_the_muff_
Level 1
Level 1
Posts: 10
Joined: Thu May 23, 2019 4:23 am

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by _the_muff_ » Fri Jun 14, 2019 2:49 am

Der ping auf die IP läuft gerade nicht.

Bei wlan Verbindung habe ich dieses Bild.

root@hoagie-ThinkPad-X230:~#
root@hoagie-ThinkPad-X230:~# ping 216.58.210.3
PING 216.58.210.3 (216.58.210.3) 56(84) bytes of data.
^C
--- 216.58.210.3 ping statistics ---
12 packets transmitted, 0 received, 100% packet loss, time 11264ms

User avatar
ehtron
Level 5
Level 5
Posts: 954
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by ehtron » Fri Jun 14, 2019 9:03 am

Hi :)
sorry ich kann nicht folgen..
vorher zeigst du das es geht... und nur die änderung des dns servers, sollte das ping auf die ip nicht berühren..
# ping 216.58.210.3
wenn du ständig als root unterwegs bist, wirst du dir über kurz oder lang dein system zerstören... hast es evtl schon getan.

https://www.ehlertronic.de/linux/tipps- ... .html#c640
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

_the_muff_
Level 1
Level 1
Posts: 10
Joined: Thu May 23, 2019 4:23 am

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by _the_muff_ » Fri Jun 14, 2019 10:36 am

Oh.. sorry.
Der Weg, wo es geklappt hat war via LAN.

Das System hab ich nochmals neu betankt. Jedoch ohne Veränderung.
Der Ping auf Google.de verläuft im Nirvana.
Ich hab den Vodafone Support kontaktiert. Mal schauen was von dort kommt.

Bin echt neugierig, ob es jemals klappen wird. :-D

User avatar
ehtron
Level 5
Level 5
Posts: 954
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by ehtron » Fri Jun 14, 2019 10:50 am

Hi :)
was heisst betankt?
Der Ping auf Google.de verläuft im Nirvana.
du solltest ja auch mit der ip pingen... google.de geht nur wenn der dns server erreicht wird und auflöst.

da andere APs funktionieren, denke ich an eine fehlkonfiguration des routers.

wlan aus und wieder an und

Code: Select all

nmcli dev wifi list
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

_the_muff_
Level 1
Level 1
Posts: 10
Joined: Thu May 23, 2019 4:23 am

Re: X230 kein WLAN mit Mint 19.1 Cinnamon

Post by _the_muff_ » Mon Jun 24, 2019 1:17 pm

Moin !

Hab nen Tip von einem Kollegen bekommen.
Mein x230 bzw. der Chip mag kein Wifi 11-mixed Mode.
Nachdem ich den Router auf 11 B/G eingestellt habe und "N" exkludiert ist, funzt Wifi unmittelbar. :roll:

Ist das ein bekanntes Problem, gibt es da Workarounds ?

Post Reply

Return to “Deutsch (German)”