Booten dauert plötzlich sehr lange

German Forum

Moderator: karlchen

Post Reply
Mintuser_2017
Level 1
Level 1
Posts: 10
Joined: Thu Nov 23, 2017 2:12 pm

Booten dauert plötzlich sehr lange

Post by Mintuser_2017 » Fri May 31, 2019 9:45 am

Das Booten dauert seit kurzem ungewöhnlich lange

Ein Kernel Update von 4.15 auf 5.0 hat nicht geholfen.
Es wurden von mir keine nennenswerten Änderungen am System vorgenommen.


Ich hoffe dies sind alle nötigen Informationen:

Linux Mint 19.1 Cinnamon
Kernel: 5.0.0-15-generic
CPU Q9550 @ 3,41 GHz × 4
Ram: 4.8 GiB
Radeon HD 6450


~ $ systemd-analyze
Startup finished in 38.194s (kernel) + 3min 574ms (userspace) = 3min 38.769s
graphical.target reached after 1min 44.777s in userspace


dmesg -T
Nur die Teile mit deutlichen Verzögerungen:

[Fri May 31 14:38:21 2019] xor: measuring software checksum speed
[Fri May 31 14:38:21 2019] prefetch64-sse: 13844.000 MB/sec
[Fri May 31 14:38:21 2019] generic_sse: 12213.000 MB/sec
[Fri May 31 14:38:21 2019] xor: using function: prefetch64-sse (13844.000 MB/sec)
[Fri May 31 14:38:21 2019] Btrfs loaded, crc32c=crc32c-generic
[Fri May 31 14:38:53 2019] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[Fri May 31 14:38:53 2019] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[Fri May 31 14:38:53 2019] systemd[1]: Detected architecture x86-64.


[Fri May 31 14:38:54 2019] input: HDA Intel Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input18
[Fri May 31 14:38:54 2019] input: HDA Intel Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input19
[Fri May 31 14:38:54 2019] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input20
[Fri May 31 14:38:54 2019] input: HDA Intel Line Out Front as /devices/pci0000:00/0000:00:1b.0/sound/card0/input21
[Fri May 31 14:38:54 2019] input: HDA Intel Line Out Surround as /devices/pci0000:00/0000:00:1b.0/sound/card0/input22
[Fri May 31 14:38:54 2019] input: HDA Intel Line Out CLFE as /devices/pci0000:00/0000:00:1b.0/sound/card0/input23
[Fri May 31 14:38:54 2019] input: HDA Intel Line Out Side as /devices/pci0000:00/0000:00:1b.0/sound/card0/input24
[Fri May 31 14:38:54 2019] input: HDA Intel Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input25
[Fri May 31 14:40:23 2019] sky2 0000:02:00.0 enp2s0: enabling interface
[Fri May 31 14:40:23 2019] skge 0000:05:04.0 enp5s4: enabling interface
[Fri May 31 14:40:24 2019] radeon_dp_aux_transfer_native: 116 callbacks suppressed
[Fri May 31 14:40:24 2019] sdb: sdb1


Ich habe noch nicht einmal eine Idee, wie ich das Problem lösen kann.
Vielleicht könnt ihr mir helfen?

qbit
Level 2
Level 2
Posts: 90
Joined: Thu Jan 10, 2019 12:14 pm

Re: Booten dauert plötzlich sehr lange

Post by qbit » Fri May 31, 2019 11:41 am

Das Booten dauert seit kurzem ungewöhnlich lange

Ein Kernel Update von 4.15 auf 5.0 hat nicht geholfen.
Es wurden von mir keine nennenswerten Änderungen am System vorgenommen.
Mit allem Vorbehalt, meine idee mag ein Schuss ins Blaue sein. Entfernen Sie mal alle kabelgebundenen bzw. steckbaren Peripherie-Geräte , die zum Hochfahern nicht unbedingt erforderlich sind (Drucker, externe Laufwerke, Ethernet.....) und testen.

Ich hatte nämlich einmal einen ähnlichen Effekt, da versuchte das System einen Drucker zu initialisieren, was nicht gelang und auch nicht vorgesehen war, Hochfahren dauerte ungewöhnlich lang..

Mintuser_2017
Level 1
Level 1
Posts: 10
Joined: Thu Nov 23, 2017 2:12 pm

Re: Booten dauert plötzlich sehr lange

Post by Mintuser_2017 » Fri May 31, 2019 5:03 pm

ohne Logitech (Maus und Tastatur)
Startup finished in 36.585s (kernel) + 3min 472ms (userspace) = 3min 37.057s
graphical.target reached after 1min 43.962s in userspace

ohne LAN
Startup finished in 38.595s (kernel) + 3min 6.791s (userspace) = 3min 45.387s
graphical.target reached after 3min 6.782s in userspace

Mehr ist nicht angeschlossen.

User avatar
ehtron
Level 5
Level 5
Posts: 953
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Booten dauert plötzlich sehr lange

Post by ehtron » Fri May 31, 2019 5:16 pm

Hi :)
älteren kernel versucht?

irgendwelche änderungen an partitionen und / oder fstab?
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

qbit
Level 2
Level 2
Posts: 90
Joined: Thu Jan 10, 2019 12:14 pm

Re: Booten dauert plötzlich sehr lange

Post by qbit » Sat Jun 01, 2019 3:49 pm

graphical.target reached after 1min 43.962s in userspace

graphical.target reached after 3min 6.782s in userspace
Hmm, ich möchte vorschlagen, einmal im recovery mode (s. Grub menu) mal zu booten und die Zeit mal zu vergleichen, mehr nicht.

Es ist da noch der "btrfs loaded" Eintrag über den aber vielleicht jemand anderes mehr sagen kann im Zusammenhang mit den nachfolgenden EXT4 infos. (s. die Angaben oben in der ersten Post)

Schließlich würde ich ruhig einmal einen Mint-Installations usb stick hernehmen um nur mal zu schauen ob es neue Auffälligkeiten gibt, keine Neu Inst. nur zur Diagnostik, Null invasiv.

SoulInfernoDE
Level 1
Level 1
Posts: 11
Joined: Tue Jul 09, 2019 4:49 pm

Re: Booten dauert plötzlich sehr lange

Post by SoulInfernoDE » Tue Jul 09, 2019 5:24 pm

Also ich hatte mit meinen Laptops selbiges Problem. Nachdem ich auch mit blame , etc. versucht habe alles Mögliche zu korrigieren haben zwei Dinge zum Erfolg geführt:

Die Datei editieren:
/etc/systemd/system.conf

Die Zeilen suchen:

#DefaultTimeoutStartSec=90s
#DefaultTimeoutStopSec=90s

abändern auf:

DefaultTimeoutStartSec=10s
DefaultTimeoutStopSec=10s


Also auf 10s ändern und die #Raute entfernen.


Dann musste ich noch die SWAP Partition neu erstellen da diese bei mir irgendwie nicht mehr funktioniert hat:

Um die SWAP Partition neu ins System einzubinden muss diese neu formatiert werden. Geänderte UUID muss anschließend in die /etc/initramfs-tools/conf.d/resume und in die /etc/fstab eingetragen werden und abschließend mit sudo update-initramfs -u -k all Änderungen übernehmen.


Details dazu gibts hier schon zum nachlesen:

https://forum.ubuntuusers.de/topic/swap ... mfs-tools/

User avatar
ehtron
Level 5
Level 5
Posts: 953
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: Booten dauert plötzlich sehr lange

Post by ehtron » Tue Jul 09, 2019 5:53 pm

Hi :)
Geänderte UUID muss anschließend in die /etc/initramfs-tools/conf.d/resume
in 18.04 nicht mehr zutreffende information...

hier alles aktuell und nicht veraltet zu erlesen
https://www.ehlertronic.de/linux/tipps- ... stand.html

mal abgesehen davon, dass sich der TE eh nicht mehr gemeldet hat......
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

SoulInfernoDE
Level 1
Level 1
Posts: 11
Joined: Tue Jul 09, 2019 4:49 pm

Re: Booten dauert plötzlich sehr lange

Post by SoulInfernoDE » Mon Jul 15, 2019 1:05 am

Moin,
das wusste ich ja noch gar nicht dass die resume Datei hinfällig geworden ist - danke hierfür! :D

:arrow: Ah sehr schön detaillierter Artikel den hab ich mir mal in meinen Favoriten gespeichert auch hierfür Danke!

Post Reply

Return to “Deutsch (German)”