Mancanza di rete dopo aggiornamento

Italian Forum
Post Reply
Pelzian
Level 2
Level 2
Posts: 77
Joined: Thu Jul 27, 2017 9:42 am

Mancanza di rete dopo aggiornamento

Post by Pelzian »

Salve, come da oggetto all'ultimo aggiornamento di oggi la rete non è accessibile e non c'è possibilità di comunicare con il modem via browser.

Avete qualche soluzione? Cos'è un problema di impostazione di DHCP?

Grazie

Pelzian
Level 2
Level 2
Posts: 77
Joined: Thu Jul 27, 2017 9:42 am

Re: Mancanza di rete dopo aggiornamento

Post by Pelzian »

Allora ho notato che tale problema sembra persistere dopo l'aggiornamento fatto alla versione del kernel 5.4.0-42 Generic, mentre con quella precedente la 5.3.0-62 la connessione sembra funzionare. Qualche suggerimento??
Grazie

Pelzian
Level 2
Level 2
Posts: 77
Joined: Thu Jul 27, 2017 9:42 am

Re: Mancanza di rete dopo aggiornamento

Post by Pelzian »

azz...visto i vari aggiornamenti con suggerimento a passare al finale aggiornamento funziona sto forum ?

User avatar
eternauta
Level 3
Level 3
Posts: 135
Joined: Thu Mar 26, 2020 9:34 am

Re: Mancanza di rete dopo aggiornamento

Post by eternauta »

Pelzian wrote:
Fri Jul 24, 2020 3:45 am
Salve, come da oggetto all'ultimo aggiornamento di oggi la rete non è accessibile e non c'è possibilità di comunicare con il modem via browser.

Avete qualche soluzione? Cos'è un problema di impostazione di DHCP?

Grazie
Guarda, il forum funziona ;-) solo che non tutti sono in grado di risolvere ogni problema. Ad esempio io di reti ci capisco una mazza e poco di più di moduli del kernel che non vengono caricati (che penso sia il tuo problema).
Però faresti bene a cominciare col dire, a chi vorrà (e sarà in grado di) darti una mano, almeno quale tipo di connessione hai fra il PC e il modem: WiFi, ethernet, altro?

Ciao!
A questo mondo niente rimane uguale, la notte più lunga eterna non è. (Bertolt Brecht)
Sperem...Image

Pelzian
Level 2
Level 2
Posts: 77
Joined: Thu Jul 27, 2017 9:42 am

Re: Mancanza di rete dopo aggiornamento

Post by Pelzian »

Ciao , scusa hai ragione, ma tutto questo mi sta accadendo dopo l'aggiornamento alla ultima versione del kernel 5.4.0-42 Generic, ma accade anche sporadicamente con quella precedente che ho provato ad usare la 5.3.0-62.
La connessione è Ethernet, cavo diretta dal pc al modem Tim. Premetto che prima di questi problemi usavo addirittura la powerlinde di Tp-Link (AV-500) senza mai avere avuto un problema di connessione. Quindi come forse, come hai suggerito tu, non vengono caricati dei moduli giusti per la connessione, ma pure io ci capisco poco nulla. Per quello che sono qui.

cladall63
Level 1
Level 1
Posts: 24
Joined: Sun Aug 28, 2016 5:52 am

Re: Mancanza di rete dopo aggiornamento

Post by cladall63 »

Dovresti provare ad avviare il gestore dei driver e vedere se ti viene raccomandato qualcosa di diverso da quello in uso.
Il problema è che se non puoi collegarti a internet non riesci nemmeno a scaricare i driver consigliati allora bisogna avviare con l'ultimo kernel che ti permette di usare la rete e riprovare con il gestore dei driver.

User avatar
eternauta
Level 3
Level 3
Posts: 135
Joined: Thu Mar 26, 2020 9:34 am

Re: Mancanza di rete dopo aggiornamento

Post by eternauta »

Pelzian wrote:
Sat Aug 01, 2020 1:12 pm
La connessione è Ethernet, cavo diretta dal pc al modem Tim. Premetto che prima di questi problemi usavo addirittura la powerlinde di Tp-Link (AV-500) senza mai avere avuto un problema di connessione...
Allora potrebbe anche essere un problema di configurazione del modem. Prova a guardare su questa pagina se trovi il tuo modem: https://assistenzatecnica.tim.it/at/por ... sumer_root#
Segui le istruzioni per entrare nella configurazione tramite browser. L'indirizzo del modem può cambiare da una marca all'altra. Una volta entrato controlla nella sezione "LAN" che la voce "Server DHCP" o "DHCP" sia attiva.
Hai altri dispositivi collegati a quella LAN? Funzionano?
Posta anche l'output di:

Code: Select all

lspci
Così vediamo se la scheda ethernet è riconosciuta.
A questo mondo niente rimane uguale, la notte più lunga eterna non è. (Bertolt Brecht)
Sperem...Image

Pelzian
Level 2
Level 2
Posts: 77
Joined: Thu Jul 27, 2017 9:42 am

Re: Mancanza di rete dopo aggiornamento

Post by Pelzian »

Allora ho fatto delle verifiche, ma quando non c'è rete è impossibile accedere al modem. Verificando poi che tipo di modulo è caricato scopro che

Code: Select all

dmesg |grep enp7s0
[    1.093228] r8169 0000:07:00.0 enp7s0: renamed from eth0
[    8.789210] r8169 0000:07:00.0 enp7s0: Link is Down
[   11.688411] r8169 0000:07:00.0 enp7s0: Link is Up - 1Gbps/Full - flow control rx/tx
[   11.688424] IPv6: ADDRCONF(NETDEV_CHANGE): enp7s0: link becomes ready
mentre trovo queste informazioni su rapporti di sistema:

Code: Select all

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: f000 bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Facendo una ricerca su Internet/rete di Ubuntu leggo che il driver "r8169" è carico di bug e si consiglia di caricare l'r8168 o l'r8101 a seconda della scheda realtek che è installata. Ma non capisco perché si richiami l'r8169 quando invece mi risulta installato l'r8168 (mistero!).
Però a questo punto mi fermo e mi sto leggermente sclerando perché ho come la sensazione che non sia tanto un problema di driver, quando piuttosto una questione di modem che dopo il trasloco (anche di linea) fa queste bizze. La stessa cosa capita anche con Windows 10, non viene caricato la scheda di rete e o riavvio oppure agisco un paioi di volte sulla risoluzione dei problemi. Avete qualche consiglio?

Grazie

Errata Corrige.
Ho scritto una stiupidaggine. Il driver è proprio l'r8169, mentre la scheda è la RTL r8111/8411

Post Reply

Return to “Italiano (Italian)”