malfunzionamento CPU dopo lo stacco dall' alimentazione

Gli utenti italiani possono parlare la loro lingua madre qui
Post Reply
Filippo
Level 2
Level 2
Posts: 90
Joined: Fri Nov 06, 2020 3:38 am

malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by Filippo »

ciao, ho un problema che mi persiste da orami qualche mese.
premetto che ho un pc portatile, e che lo tengo la maggior parte del tempo attaccato all'alimetnazione.
il problema sorge quando stacco l'alimentazione da pc acceso, infatti una volta non piu in carica, noto che ad intervalli regolari di circa 10-15 secondi la grafica del pc va a rilento per circa 5 secondi. solitamente per risolvere questo è necessario riavviare il pc. per curiosita quindi sono andato a vedere il monitor di sistema, e nella parte dei grafici delle cpu vedo che un core va al 100% e ci resta quasi immobile. la particolarita è che il core cambia di volta in volta, anche se noto che capita maggiormente sul primo il quarto e l'ottavo core.
dopodichè ho dato un occhiata ai processi con il comando top e sembrerebbe che il processo che crea questo malfunzionamento sia l'ambiente desktop Cinnamon (con un consumo pari a 40).
dopo mesi purtroppo non sono ancora riuscito a risolvere, qualcuno sarebbe capace di aiutarmi?
grazie in anticipo. :D

p.s. nel mio pc ho anche altri problemi, se puo aiutare con la diagnosi, (e intanto se sapete come risolverli una mano sarebbe gradita :D ) questi problemi, presenti anch'essi da molto, sono: quando sospendo il pc non sempre si riprende (quasi mai), la particolarità è che succede anche con windows, ma con arch linux sembrerebbe di no (ho un multi boot), e l'altro problema è una instabilità di connessione a periodi alterni.

p.p.s sembrerebbe che la faccenda del bug dopo lo stacco dall'alimentazione avvenga quando il pc è al 100% da un po. ma è un'informazione molto imprecisa, perche non solo, ma comunque maggiormente.

queste sono un paio di info sul mio sistema.

Code: Select all

System:    Kernel: 5.8.0-50-generic x86_64 bits: 64 compiler: gcc v: 10.2.1 
           Desktop: Cinnamon 4.8.6 tk: GTK 3.24.20 wm: muffin dm: LightDM 
           Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: HP product: HP Pavilion Laptop 15-cs2xxx v: Type1ProductConfigId 
           serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 84C1 v: 15.32 serial: <filter> UEFI: Insyde v: F.23 date: 12/25/2020 
Battery:   ID-1: BAT0 charge: 22.6 Wh condition: 27.8/27.8 Wh (100%) volts: 11.8/11.6 
           model: HP Primary serial: N/A status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake 
           note: check rev: B L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999 
           Speed: 3323 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 3323 2: 3332 3: 3366 
           4: 3329 5: 3338 6: 3315 7: 3351 8: 3331 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3ea0 
           Device-2: NVIDIA GP108M [GeForce MX250] vendor: Hewlett-Packard driver: nvidia 
           v: 460.73.01 bus ID: 02:00.0 chip ID: 10de:1d13 
           Device-3: Lite-On HP Wide Vision FHD Camera type: USB driver: uvcvideo bus ID: 1-3:3 
           chip ID: 04ca:7086 
           Display: x11 server: X.Org 1.20.9 driver: loaded: modesetting,nvidia 
           unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.2.6 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8 
           Sound Server: ALSA v: k5.8.0-50-generic 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Hewlett-Packard 
           driver: rtw_8822be v: N/A port: 4000 bus ID: 03:00.0 chip ID: 10ec:b822 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 04:00.0 
           chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 
           bus ID: 00:17.0 chip ID: 8086.282a 
Drives:    Local Storage: total: 565.59 GiB used: 188.03 GiB (33.2%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8H size: 476.94 GiB 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 27.9 C 
           ID-2: /dev/sda type: USB model: Multiple Card Reader size: 59.75 GiB serial: <filter> 
           ID-3: /dev/sdd type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.9 GiB 
           serial: <filter> 
Partition: ID-1: / size: 263.24 GiB used: 134.26 GiB (51.0%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-2: /boot/efi size: 511 MiB used: 88.2 MiB (17.3%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 chip ID: 1d6b:0002 
           Device-1: 1-2:2 info: Logitech M90/M100 Optical Mouse type: Mouse 
           driver: hid-generic,usbhid rev: 2.0 chip ID: 046d:c05a 
           Device-2: 1-3:3 info: Lite-On HP Wide Vision FHD Camera type: Video driver: uvcvideo 
           rev: 2.0 chip ID: 04ca:7086 
           Hub-2: 1-4:6 info: Genesys Logic 4-port hub ports: 4 rev: 2.1 chip ID: 05e3:0610 
           Device-1: 1-4.2:9 info: Kingston DataTraveler 100 G3/G4/SE9 G2 type: Mass Storage 
           driver: usb-storage rev: 2.1 chip ID: 0951:1666 
           Device-2: 1-4.3:7 info: Genesys Logic HP Wide Vision FHD Camera type: Mass Storage 
           driver: usb-storage rev: 2.1 chip ID: 05e3:0749 
           Device-3: 1-4.4:8 info: Fresco Logic USB2.1 Hub type: Billboard driver: N/A rev: 2.0 
           chip ID: 1d5c:7102 
           Device-4: 1-6:4 info: Alcor Micro Multi Flash Reader type: Mass Storage 
           driver: usb-storage rev: 2.0 chip ID: 058f:6366 
           Device-5: 1-10:5 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb rev: 1.1 
           chip ID: 0bda:b00b 
           Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     Packages: 3245 apt: 3218 flatpak: 27 
           No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           1: deb https: //dl.winehq.org/wine-builds/ubuntu/ focal main
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http: //dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/microsoft-prod.list 
           1: deb [arch=amd64,arm64,armhf] https: //packages.microsoft.com/ubuntu/20.10/prod groovy main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb https: //mirror.init7.net/linuxmint ulyssa main upstream import backport
           2: deb http: //mirror.easyname.at/ubuntu-archive focal main restricted universe multiverse
           3: deb http: //mirror.easyname.at/ubuntu-archive focal-updates main restricted universe multiverse
           4: deb http: //mirror.easyname.at/ubuntu-archive focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
           Active apt repos in: /etc/apt/sources.list.d/opera-stable.list 
           1: deb https: //deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
           Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
           1: deb [arch=amd64] https: //repo.skype.com/deb stable main
           Active apt repos in: /etc/apt/sources.list.d/spotify.list 
           1: deb http: //repository.spotify.com stable non-free
           Active apt repos in: /etc/apt/sources.list.d/teams.list 
           1: deb [arch=amd64] https: //packages.microsoft.com/repos/ms-teams stable main
           Active apt repos in: /etc/apt/sources.list.d/teamviewer.list 
           1: deb https: //linux.teamviewer.com/deb stable main
           Active apt repos in: /etc/apt/sources.list.d/vscode.list 
           1: deb [arch=amd64,arm64,armhf] http: //packages.microsoft.com/repos/code stable main
Info:      Processes: 319 Uptime: 36m Memory: 15.53 GiB used: 3.02 GiB (19.5%) Init: systemd 
           v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 8/9 Client: Unknown python3.8 client 
           inxi: 3.2.02 
 
sleeper12
Level 16
Level 16
Posts: 6513
Joined: Thu May 25, 2017 3:22 pm

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by sleeper12 »

Che tipo di instabilità della connessione, wifi?
Filippo
Level 2
Level 2
Posts: 90
Joined: Fri Nov 06, 2020 3:38 am

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by Filippo »

per quanto riguarda il wifi generalmente funziona ma ci sono momenti in cui non riesce proprio a connettersi (dandomi il messaggio "impossibile connettersi", ed anche riavviando il pc continua a non funzionare, e dopo un po torna tutto normale. se dovessi dire in che situazione succede direi letteralemente a caso. so solo che con windows non succede.

avresti qualche idea per gli altri problemi? perche per il wifi posso conviverci (se hai una soluzione però ben venga) ma per gli altri faccio un po fatica a conviverci perche sono un po più invalidanti.
sleeper12
Level 16
Level 16
Posts: 6513
Joined: Thu May 25, 2017 3:22 pm

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by sleeper12 »

Cosa mostra questo:

Code: Select all

 iwconfig 
Filippo
Level 2
Level 2
Posts: 90
Joined: Fri Nov 06, 2020 3:38 am

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by Filippo »

Code: Select all

filippo@filippo-HP-Pavilion-Laptop-15-cs2xxx:~$ iwconfig
lo        no wireless extensions.

eno1      no wireless extensions.

wlo1      IEEE 802.11  ESSID:"CN15"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: DC:39:6F:FE:25:72   
          Bit Rate=78 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=46/70  Signal level=-64 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:576   Missed beacon:0

vmnet1    no wireless extensions.

vmnet8    no wireless extensions.
sleeper12
Level 16
Level 16
Posts: 6513
Joined: Thu May 25, 2017 3:22 pm

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by sleeper12 »

Sembra a posto, quindi non ho soluzione.
sleeper12
Level 16
Level 16
Posts: 6513
Joined: Thu May 25, 2017 3:22 pm

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by sleeper12 »

Puoi provare questo per vedere se aiuta il wifi:

Disabilita IPv6
Alcuni vecchi modem e router non sono in grado di gestire correttamente l'IPv6 moderno. Ciò potrebbe causare una cattiva connessione instabile o addirittura un completo fallimento nello stabilire una connessione. In tal caso, disabilita IPv6 in questo modo:

Menu - Preferenze - Connessioni di rete

Fare clic sul nome della connessione corrente - fare clic sul pulsante Modifica
Scheda Impostazioni IPv6 - Metodo: cambialo in Ignora

Fare clic sul pulsante Salva e quindi sul pulsante Chiudi

Disconnettiti e ricollegati o semplicemente riavvia il computer.
Filippo
Level 2
Level 2
Posts: 90
Joined: Fri Nov 06, 2020 3:38 am

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by Filippo »

mh no non funziona purtroppo
Paolo_C
Level 4
Level 4
Posts: 339
Joined: Sat Feb 10, 2018 11:20 am

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by Paolo_C »

Salve,
dopodichè ho dato un occhiata ai processi con il comando top e sembrerebbe che il processo che crea questo malfunzionamento sia l'ambiente desktop Cinnamon (con un consumo pari a 40).
dopo mesi purtroppo non sono ancora riuscito a risolvere, qualcuno sarebbe capace di aiutarmi?
Guarda questo video, forse può esserti utile:
https://www.youtube.com/watch?v=keNii_57trc
Simonxxx84
Level 1
Level 1
Posts: 20
Joined: Tue Jan 05, 2021 1:23 pm

Re: malfunzionamento CPU dopo lo stacco dall' alimentazione

Post by Simonxxx84 »

Hai attivo lo screensaver?
Post Reply