WordPress App ed errore "GPU process isn't usable"

Forum di supporto per utenti di lingua italiana
Post Reply
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

WordPress App ed errore "GPU process isn't usable"

Post by bybias »

Salve a tutti,
uso Linux Mint Cinnamon (Edge) dove ho fatto l'upgrade a Vanessa (Mint 21) su un Acer Aspire 5 (AMD Ryzen 5 con AMD Radeon) ed ho provato ad installare WordPress (sia tramite il Gestore Applicazioni che facendo direttamente il download dal sito (apps.wordpress.com/desktop/).
Su un vecchio Acer che avevo mi funzionava perfettamente ma ora è andato nel paradiso dei computer, adesso su questo Laptop nuovo, in entrambi i casi, tutte le volte che lo apro mi si richiude subito. Ho provato ad avviarlo da terminale e mi esce questo errore: Il processo figlio è stato interrotto dal segnale 5. e [13514:0923/145628.436385:FATAL:gpu_data_manager_impl_private.cc(415)] GPU process isn't usable. Goodbye.

Ho cercato in google ed ho trovato alcuni links (tipo questo: https://github.com/LedgerHQ/ledger-live ... -926215043) ma, francamente, non ci ho capito niente; un po' per il mio inglese scarsissimo ma soprattutto perché non sono molto competente in cose tecniche, non so dove mettere le mani :?

Qualcuno mi può aiutare magari descrivendomi i vari passaggi da fare spiegandomelo in un italiano semplice da capire anche per uno che non ci capisce nulla?
Scusate la mia incompetenza, sorry :(
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
Paolo_C
Level 5
Level 5
Posts: 592
Joined: Sat Feb 10, 2018 11:20 am
Location: Italy [Emilia-Romagna]

Re: WordPress App ed errore "GPU process isn't usable"

Post by Paolo_C »

Salve,
ho letto di un errore uguale al tuo, ma relativo ad un’altro programma.
E’ stata trovata una soluzione temporanea modificando il collegamento sulla Scrivania.
Clic con il Dx del mouse sull’icona del collegamento sulla Scrivania di wordpress; nella finestra che si apre clic su “Apri con” e poi “Editor di testo”; vai alla riga che inizia con “Exec=”.
Copia la riga e postala.
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

Re: WordPress App ed errore "GPU process isn't usable"

Post by bybias »

Paolo_C wrote:
Fri Sep 23, 2022 12:55 pm
...
Clic con il Dx del mouse sull’icona del collegamento sulla Scrivania di wordpress; nella finestra che si apre clic su “Apri con” e poi “Editor di testo”; vai alla riga che inizia con “Exec=”.
Copia la riga e postala.
Eccola qua: Exec=/opt/WordPress.com/wpcom %U
Grazie :wink:
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
Paolo_C
Level 5
Level 5
Posts: 592
Joined: Sat Feb 10, 2018 11:20 am
Location: Italy [Emilia-Romagna]

Re: WordPress App ed errore "GPU process isn't usable"

Post by Paolo_C »

Salve,
fai questa prova:
aggiungi alla riga la stringa --no-sandbox, in modo che diventi:

Code: Select all

Exec=/opt/WordPress.com/wpcom --no-sandbox %U
Fonte: https://github.com/Automattic/simplenot ... ssues/3044
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

Re: WordPress App ed errore "GPU process isn't usable"

Post by bybias »

Paolo_C wrote:
Sun Sep 25, 2022 5:46 am
Salve,
fai questa prova:
aggiungi alla riga la stringa --no-sandbox, in modo che diventi:

Code: Select all

Exec=/opt/WordPress.com/wpcom --no-sandbox %U
Fonte: https://github.com/Automattic/simplenot ... ssues/3044
Ciao Paolo_C,
avevo letto quell'articolo ma ci avevo capito poco. Comunque ho provato a fare quello che mi hai detto ma purtroppo non funziona, WordPress si apre e si richiude subito :( . Se lo apro da terminale (anche lì aggiungendo --no-sandbox) mi da sempre quell'errore che ho descritto nel post iniziale.

Può darsi che sia un errore dipeso dal fatto che ho aggiornato a Mint 21 (Vanessa), o che il mio Laptop sia troppo nuovo (quando ho installato Mint ho dovuto usare la versione EDGE), perché prima, nel mio vecchio Laptop, funzionava egregiamente.
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
andrea111
Level 4
Level 4
Posts: 208
Joined: Sat Jul 10, 2021 6:13 am

Re: WordPress App ed errore "GPU process isn't usable"

Post by andrea111 »

Una cosa che non sono riuscito a capire con mint 21 è lo stato di avanzamento nel passaggio tra Xorg (X11) e Wayland come server grafico.
Prima era che potevi selezionare uno dei due al login, ora non capisco più come gestiscono la questione.

@ Paolo_C
Tu usi mint 21?
Se dai

Code: Select all

echo $XDG_SESSION_TYPE
dpkg-query -l | grep -i wayland
che risposta ottieni?
E se volessi installare wayland come server grafico predefinito, che procedura duvresti seguire?

Perché trovo che il problema di bybias vada inquadrato in quest'ottica. Con cosa lavora mint 21: Xorg o Wayland?
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

Re: WordPress App ed errore "GPU process isn't usable"

Post by bybias »

Ciao andrea111

Se lo do io mi viene questo:

Code: Select all

x11
ii  kwayland-data                                 4:5.98.0-0ubuntu1~ubuntu22.04~ppa2         all          Qt library wrapper for Wayland libraries - data files
ii  kwayland-integration:amd64                    4:5.24.5-0ubuntu1~ubuntu22.04~ppa1         amd64        kwayland runtime integration plugins
ii  layer-shell-qt                                5.24.6-0ubuntu0.1                          amd64        use the Wayland wl-layer-shell protocol.
ii  libgtk-layer-shell0                           0.7.0-1                                    amd64        Wayland Layer Shell protocol desktop component library
ii  libkf5waylandclient5:amd64                    4:5.98.0-0ubuntu1~ubuntu22.04~ppa2         amd64        Qt library wrapper for Wayland libraries
ii  libkf5waylandserver5:amd64                    4:5.98.0-0ubuntu1~ubuntu22.04~ppa2         amd64        Qt library wrapper for Wayland libraries
ii  libkwaylandserver5:amd64                      5.24.6-0ubuntu0.1                          amd64        Qt library wrapper for Wayland libraries
ii  liblayershellqtinterface5                     5.24.6-0ubuntu0.1                          amd64        use the Wayland wl-layer-shell protocol.
ii  libqt5waylandclient5:amd64                    5.15.3-1                                   amd64        QtWayland client library
ii  libqt5waylandcompositor5:amd64                5.15.3-1                                   amd64        QtWayland compositor library
ii  libva-wayland2:amd64                          2.14.0-1                                   amd64        Video Acceleration (VA) API for Linux -- Wayland runtime
ii  libwayland-client++0:amd64                    0.2.8-2                                    amd64        wayland compositor infrastructure - client library C++ bindings
ii  libwayland-client0:amd64                      1.20.0-1ubuntu0.1                          amd64        wayland compositor infrastructure - client library
ii  libwayland-client0:i386                       1.20.0-1ubuntu0.1                          i386         wayland compositor infrastructure - client library
ii  libwayland-cursor++0:amd64                    0.2.8-2                                    amd64        wayland compositor infrastructure - cursor library C++ bindings
ii  libwayland-cursor0:amd64                      1.20.0-1ubuntu0.1                          amd64        wayland compositor infrastructure - cursor library
ii  libwayland-cursor0:i386                       1.20.0-1ubuntu0.1                          i386         wayland compositor infrastructure - cursor library
ii  libwayland-egl++0:amd64                       0.2.8-2                                    amd64        wayland compositor infrastructure - EGL library C++ bindings
ii  libwayland-egl1:amd64                         1.20.0-1ubuntu0.1                          amd64        wayland compositor infrastructure - EGL library
ii  libwayland-egl1:i386                          1.20.0-1ubuntu0.1                          i386         wayland compositor infrastructure - EGL library
ii  libwayland-server0:amd64                      1.20.0-1ubuntu0.1                          amd64        wayland compositor infrastructure - server library
ii  libwayland-server0:i386                       1.20.0-1ubuntu0.1                          i386         wayland compositor infrastructure - server library
ii  qtwayland5:amd64                              5.15.3-1                                   amd64        QtWayland platform plugin
ii  xwayland                                      2:22.1.1-1ubuntu0.2                        amd64        X server for running X clients under Wayland
Riguardava il mio problema? Dalla tua risposta non capisco.
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
Paolo_C
Level 5
Level 5
Posts: 592
Joined: Sat Feb 10, 2018 11:20 am
Location: Italy [Emilia-Romagna]

Re: WordPress App ed errore "GPU process isn't usable"

Post by Paolo_C »

Salve,
@andrea111
Tu usi mint 21?
non ancora. Attendo sempre le versioni .1 prima di aggiornare.
Sono su cinnamon 20.3 e ti posto da qui l'uscita dei comandi che mi chiedi:
~$ echo $XDG_SESSION_TYPE
x11

~$ dpkg-query -l | grep -i wayland
ii libgtk-layer-shell0 0.1.0-3 amd64 Wayland Layer Shell protocol desktop component library
ii libva-wayland2:amd64 2.7.0-2 amd64 Video Acceleration (VA) API for Linux -- Wayland runtime
ii libwayland-client0:amd64 1.18.0-1ubuntu0.1 amd64 wayland compositor infrastructure - client library
ii libwayland-cursor0:amd64 1.18.0-1ubuntu0.1 amd64 wayland compositor infrastructure - cursor library
ii libwayland-egl1:amd64 1.18.0-1ubuntu0.1 amd64 wayland compositor infrastructure - EGL library
ii libwayland-server0:amd64 1.18.0-1ubuntu0.1 amd64 wayland compositor infrastructure - server library
ii xwayland

Per quanto riguarda:
E se volessi installare wayland come server grafico predefinito, che procedura duvresti seguire?
Per ora non ne ho idea.
andrea111
Level 4
Level 4
Posts: 208
Joined: Sat Jul 10, 2021 6:13 am

Re: WordPress App ed errore "GPU process isn't usable"

Post by andrea111 »

@bybias
hai parecchia roba di wayland, fai il confronto con quello che ha postato Paolo_C.
Hai roba relativa a KDE, lo hai installato tu?

Prova questo: alla schermata del login guarda se individui un'icona (di solito in forma di ingranaggio o di chiave inglese), clic sull'icona e vedi che opzioni ti presenta (Xorg o Wayland).
Paolo_C
Level 5
Level 5
Posts: 592
Joined: Sat Feb 10, 2018 11:20 am
Location: Italy [Emilia-Romagna]

Re: WordPress App ed errore "GPU process isn't usable"

Post by Paolo_C »

Salve,
a che punto è Linux Mint con Wayland, potrete leggerlo su questo topic:
viewtopic.php?p=2095372
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

Re: WordPress App ed errore "GPU process isn't usable"

Post by bybias »

Ciao Andrea 111,

Si, avevo provato ad installare Plasma un mesetto fa seguendo le istruzioni dai video di MorroLinux su youtube e altre reperite in internet su vari forum, ma dava alcuni problemi e mi avevano consigliato nel Forum in inglese di disinstallarlo che con Mint dava problemi, che era meglio installare una Distro già con Plasma. Non l'ho mai disinstallato in quanto, quando lo installai, avevo fatto un po' di casino (come al solito metto le mani dove non so o dovrei :roll: ) installandolo due volte in modi diversi (direttamente ed anche con kubuntu-plasma o qualcosa del genere) ed adesso ho paura a disinstallarlo.

Per il confronto delle cose di Wailand con Paolo_C lo farò questa sera quando avrò tempo, ma ti dico subito che NON CI CAPISCO NIENTE :( !!!

Al Login non mi appare nessuna delle due opzioni da te scritte (Xorg o Wayland), mi viene la scelta tra Cinnamon, Plasma e Kodi (vedi screenshot qui).
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
andrea111
Level 4
Level 4
Posts: 208
Joined: Sat Jul 10, 2021 6:13 am

Re: WordPress App ed errore "GPU process isn't usable"

Post by andrea111 »

@bybias
rileggendo da principio la tua situazione;
1) Hai fatto l'upgrade da mint 20 cinnamon EDGE a mint 21 di cui se non sbaglio la versione EDGE non esiste, vediamo il kernel attuale posta

Code: Select all

uname -a
2) i driver video installati nella 20 quali erano? (proprietari o open?) è buona regola, quando si fanno gli avanzamenti, rimuovere i driver proprietari installati e anche applicazioni installate tramite ppa esterni.
3) il nuovo PC è recente, a mqggior ragione avresti dovuto provare la versione EDGE di mint, che per mint 21 non c'è ancora (o sbaglio?)
4) hai scelto di installare Plasma, cioè KDE che con mint non lega bene, avresti fatto meglio a scegliere Gnome come desktop manager.

Visto che il problema è di natura grafica, vediamo l'assetto attuale, posta

Code: Select all

sudo lshw -c video
E posta anche

Code: Select all

xlsclients
che serve
to find which programs are running in XWayland—which programs aren't natively running on Wayland.
come dicono al collegamento postato da Paolo_C.
Giusto per farci un'idea.
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

Re: WordPress App ed errore "GPU process isn't usable"

Post by bybias »

Mio Dio, non volevo far lavorare qualcuno così per me, scusa :(
andrea111 wrote:
Tue Sep 27, 2022 1:10 pm
@bybias
rileggendo da principio la tua situazione;
1) Hai fatto l'upgrade da mint 20 cinnamon EDGE a mint 21 di cui se non sbaglio la versione EDGE non esiste, vediamo il kernel attuale posta

Code: Select all

uname -a
Infatti. Prima ho installato Mint 20.3 Cinnamon (Edge), poi ho fatto l'upgrade a Mint 21 Cinnamon (mi ha dato qualche errore ma l'aggiornamento è riuscito).
il Kernel attuale:

Code: Select all

Linux Acer 5.15.0-48-generic #54-Ubuntu SMP Fri Aug 26 13:26:29 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
2) i driver video installati nella 20 quali erano? (proprietari o open?) è buona regola, quando si fanno gli avanzamenti, rimuovere i driver proprietari installati e anche applicazioni installate tramite ppa esterni.
Francamente non lo so ma credo open, non ho dovuto installare niente di extra durante o dopo l'installazione. Ma sono incompetente per questo dico "credo" :oops:
3) il nuovo PC è recente, a mqggior ragione avresti dovuto provare la versione EDGE di mint, che per mint 21 non c'è ancora (o sbaglio?)
Infatti.
4) hai scelto di installare Plasma, cioè KDE che con mint non lega bene, avresti fatto meglio a scegliere Gnome come desktop manager.
L'ho scoperto più tardi, comunque Plasma non lo uso più.
Visto che il problema è di natura grafica, vediamo l'assetto attuale, posta

Code: Select all

sudo lshw -c video

Code: Select all

  *-display                 
       description: Display controller
       product: Lexa [Radeon 540X/550X/630 / RX 640 / E9171 MCM]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: c0
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list rom fb
       configuration: depth=32 driver=amdgpu latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:74 memory:fce0000000-fcefffffff memory:fcf0000000-fcf01fffff ioport:3000(size=256) memory:d0700000-d073ffff memory:d0740000-d075ffff
  *-display
       description: VGA compatible controller
       product: Lucienne
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: /dev/fb0
       version: c2
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list fb
       configuration: depth=32 driver=amdgpu latency=0 resolution=1920,1080
       resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:48 memory:fcc0000000-fccfffffff memory:fcd0000000-fcd01fffff ioport:1000(size=256) memory:d0400000-d047ffff
E posta anche

Code: Select all

xlsclients
che serve
to find which programs are running in XWayland—which programs aren't natively running on Wayland.
come dicono al collegamento postato da Paolo_C.
Giusto per farci un'idea.

Code: Select all

Acer  cinnamon-session
Acer  csd-wacom
Acer  csd-housekeeping
Acer  csd-clipboard
Acer  csd-automount
Acer  csd-power
Acer  csd-xsettings
Acer  csd-print-notifications
Acer  csd-keyboard
Acer  csd-background
Acer  csd-color
Acer  csd-screensaver-proxy
Acer  csd-media-keys
Acer  csd-a11y-settings
Acer  cinnamon-launcher
Acer  cinnamon
Acer  xapp-sn-watcher
Acer  nm-applet
Acer  nemo-desktop
Acer  polkit-gnome-authentication-agent-1
Acer  blueman-applet
Acer  evolution-alarm-notify
Acer  cinnamon-killer-daemon
Acer  fdm
Acer  blueman-tray
Acer  google-chrome-stable
Acer  xdg-desktop-portal-gtk
Acer  mintUpdate.py
Acer  tray.py
Acer  xdg-desktop-portal-gtk
Acer  scp-dbus-service.py
Acer  geany
Acer  gnome-terminal-server
Acer  kdeconnectd
Acer  kwalletd5
Acer  copyq
Comunque, come detto sopra, non voglio farti lavorare per me e farti perdere tempo prezioso. Se hai altro da fare lasciamo stare. Lascio tutto come è, cerco di disinstallare Plasma cercando sul Web, e uso Wordpress da Windows o da Browser, non c'è problema.
Non voglio essere assolutamente un peso per qualcuno se la cosa è complessa come credo di intuire. Dimmi semplicemente "Passo" e per me va bene.
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
andrea111
Level 4
Level 4
Posts: 208
Joined: Sat Jul 10, 2021 6:13 am

Re: WordPress App ed errore "GPU process isn't usable"

Post by andrea111 »

Sembrerebbe tutto a posto, i driver video sono corretti.
Non saprei che altro dirti se non tornare a mint 20 ed attendere la 21.1 di mint (sperando che abbiano risolto).
Alla prossima.
User avatar
bybias
Level 1
Level 1
Posts: 36
Joined: Mon Jun 06, 2022 7:08 am
Location: Emmendingen (Germany)

Re: WordPress App ed errore "GPU process isn't usable"

Post by bybias »

andrea111 wrote:
Tue Sep 27, 2022 8:42 pm
Sembrerebbe tutto a posto, i driver video sono corretti.
Non saprei che altro dirti se non tornare a mint 20 ed attendere la 21.1 di mint (sperando che abbiano risolto).
Alla prossima.
Cercherò di fare come mi hai detto e tornare a Mint 20.
Alla prossima e grazie mille :wink:
byBiaS
Linux Mint Cinnamon (Edge) upgraded to Vanessa (Mint 21) on Acer Aspire 5 (AMD Ryzen 5 & AMD Radeon)
neofetch
Post Reply

Return to “Italiano - Italian”