Page 1 of 1

Aggiornamento e rimozione cups

Posted: Tue Mar 28, 2017 11:44 pm
by erpomata
Ciao a tutti ho una mint 18.1 e dopo aver fatto l'ultimo aggiornamento mi ritrovo cups disinstallato automaticamente dal tool di aggiornamento.
Ora provo a reinstallarlo ma mi da questo errore:

Code: Select all

sudo apt-get install cups
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... 50%
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 cups : Dipende: libcups2 (= 2.1.3-4) ma la versione 2.1.3-4ubuntu0.2 sta per essere installata
        Dipende: cups-core-drivers (>= 2.1.3-4)
        Dipende: cups-daemon (>= 2.1.3-4)
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
Che posso fare? Grazie

Re: Aggiornamento e rimozione cups

Posted: Wed Mar 29, 2017 5:21 am
by ataulfo
Per "Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati." dai un:

Code: Select all

sudo apt-get install -f
Poi tenta con:

Code: Select all

sudo apt-get purge cups*
e dopo

Code: Select all

sudo rm -R /etc/cups
A questo punto reinstalla:

Code: Select all

sudo apt-get install cups
Se avevi una stampante configurata devi riaggiungerla.

Re: Aggiornamento e rimozione cups

Posted: Wed Mar 29, 2017 5:27 am
by erpomata
Grazie ho appena provato e questi cono i risultati:

Code: Select all

 sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Code: Select all

sudo apt-get purge cups*
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Note, selecting 'cupswrapperhl2070n' for glob 'cups*'
Note, selecting 'cupswrappermfc5440cn' for glob 'cups*'
Note, selecting 'cupswrapperfax4100' for glob 'cups*'
Note, selecting 'cupswrappermfc8820d' for glob 'cups*'
Note, selecting 'cupswrapperhl6050' for glob 'cups*'
Note, selecting 'cupswrappermfc8840d' for glob 'cups*'
Note, selecting 'cupswrapperhl5170dn' for glob 'cups*'
Note, selecting 'cups-pdf' for glob 'cups*'
Note, selecting 'cupswrappermfc410cn' for glob 'cups*'
Note, selecting 'cupswrapperhl5150d' for glob 'cups*'
Note, selecting 'cupswrappermfc8860dn' for glob 'cups*'
Note, selecting 'cupswrappermfc9030' for glob 'cups*'
Note, selecting 'cupswrappermfc9070' for glob 'cups*'
Note, selecting 'cupswrappermfc9160' for glob 'cups*'
Note, selecting 'cupswrapperhl5250dn' for glob 'cups*'
Note, selecting 'cupswrappermfc9180' for glob 'cups*'
Note, selecting 'cupswrapperfax1940cn' for glob 'cups*'
Note, selecting 'cupswrappermfc8660dn' for glob 'cups*'
Note, selecting 'cupswrapperdcp8065dn' for glob 'cups*'
Note, selecting 'cupswrappermfc6800' for glob 'cups*'
Note, selecting 'cupswrappermfc210c' for glob 'cups*'
Note, selecting 'cupsddk' for glob 'cups*'
Note, selecting 'cups-pk-helper' for glob 'cups*'
Note, selecting 'cupswrapperhl2030' for glob 'cups*'
Note, selecting 'cupswrapperhl2040' for glob 'cups*'
Note, selecting 'cupswrapperhl1870n' for glob 'cups*'
Note, selecting 'cupswrappermfc9660' for glob 'cups*'
Note, selecting 'cupswrappermfc9700' for glob 'cups*'
Note, selecting 'cupswrappermfc8460n' for glob 'cups*'
Note, selecting 'cupswrappermfc9760' for glob 'cups*'
Note, selecting 'cupswrapperhl5280dw' for glob 'cups*'
Note, selecting 'cupswrappermfc7225n' for glob 'cups*'
Note, selecting 'cupswrappermfc9800' for glob 'cups*'
Note, selecting 'cupswrappermfc9860' for glob 'cups*'
Note, selecting 'cups-backend-bjnp' for glob 'cups*'
Note, selecting 'cupswrappermfc3320cn' for glob 'cups*'
Note, selecting 'cupswrappermfc9880' for glob 'cups*'
Note, selecting 'cupswrapperfax2440c' for glob 'cups*'
Note, selecting 'cups-server-common' for glob 'cups*'
Note, selecting 'cupswrapperhl5030' for glob 'cups*'
Note, selecting 'cupswrapperhl5040' for glob 'cups*'
Note, selecting 'cupswrapperhl5050' for glob 'cups*'
Note, selecting 'cupswrapperhl5130' for glob 'cups*'
Note, selecting 'cupswrapperhl5140' for glob 'cups*'
Note, selecting 'cupswrappermfc3220c' for glob 'cups*'
Note, selecting 'cups-filters-lsb' for glob 'cups*'
Note, selecting 'cups-common' for glob 'cups*'
Note, selecting 'cupswrapperhl1470n' for glob 'cups*'
Note, selecting 'cupswrapperhl5240' for glob 'cups*'
Note, selecting 'cupswrappermfc3240c' for glob 'cups*'
Note, selecting 'cupswrapperdcp8020' for glob 'cups*'
Note, selecting 'cupswrapperdcp8040' for glob 'cups*'
Note, selecting 'cupswrapperdcp8060' for glob 'cups*'
Note, selecting 'cupswrapperfax4750e' for glob 'cups*'
Note, selecting 'cupswrapperdcp1000' for glob 'cups*'
Note, selecting 'cupswrapperhl5070n' for glob 'cups*'
Note, selecting 'cupswrapperdcp110c' for glob 'cups*'
Note, selecting 'cupswrapperfax3800' for glob 'cups*'
Note, selecting 'cupswrapperdcp8025d' for glob 'cups*'
Note, selecting 'cupswrapperhl1030' for glob 'cups*'
Note, selecting 'cups-filters' for glob 'cups*'
Note, selecting 'cupswrappermfc8420' for glob 'cups*'
Note, selecting 'cupswrappermfc8440' for glob 'cups*'
Note, selecting 'cupswrapperdcp8045d' for glob 'cups*'
Note, selecting 'cupswrappermfc8500' for glob 'cups*'
Note, selecting 'cups-ppdc' for glob 'cups*'
Note, selecting 'cupswrapperdcp1400' for glob 'cups*'
Note, selecting 'cupswrapperhl1230' for glob 'cups*'
Note, selecting 'cupswrapperhl1240' for glob 'cups*'
Note, selecting 'cupswrapperhl1250' for glob 'cups*'
Note, selecting 'cupswrappermfc7820n' for glob 'cups*'
Note, selecting 'cupswrapperhl5270dn' for glob 'cups*'
Note, selecting 'cupswrapperhl1430' for glob 'cups*'
Note, selecting 'cupswrapperhl1440' for glob 'cups*'
Note, selecting 'cupswrapperhl1450' for glob 'cups*'
Note, selecting 'cupsys-bsd' for glob 'cups*'
Note, selecting 'cupswrapperhl1650' for glob 'cups*'
Note, selecting 'cupswrapperfax1815c' for glob 'cups*'
Note, selecting 'cupswrapperfax1820c' for glob 'cups*'
Note, selecting 'cupswrapperhl1850' for glob 'cups*'
Note, selecting 'cupswrapperfax1835c' for glob 'cups*'
Note, selecting 'cupswrapperfax1840c' for glob 'cups*'
Note, selecting 'cupswrappermfc3820cn' for glob 'cups*'
Note, selecting 'cupswrapperdcp7010' for glob 'cups*'
Note, selecting 'cupswrapperdcp7020' for glob 'cups*'
Note, selecting 'cupswrapperdcp7025' for glob 'cups*'
Note, selecting 'cupswrappermfc3340cn' for glob 'cups*'
Note, selecting 'cupswrapperfax1920cn' for glob 'cups*'
Note, selecting 'cupswrappermfc4800' for glob 'cups*'
Note, selecting 'cupswrappermfc7220' for glob 'cups*'
Note, selecting 'cups-filters-core-drivers' for glob 'cups*'
Note, selecting 'cups-filters-invalid-mta' for glob 'cups*'
Note, selecting 'cupsys-client' for glob 'cups*'
Note, selecting 'cupswrapperdcp310cn' for glob 'cups*'
Note, selecting 'cupswrapperfax2820' for glob 'cups*'
Note, selecting 'cupswrapperfax2850' for glob 'cups*'
Note, selecting 'cupswrappermfc3420c' for glob 'cups*'
Note, selecting 'cupswrapperfax2900' for glob 'cups*'
Note, selecting 'cupswrapperfax2920' for glob 'cups*'
Note, selecting 'cupswrappermfc7420' for glob 'cups*'
Note, selecting 'cupswrapperhl1670n' for glob 'cups*'
Note, selecting 'cupswrappermfc620cn' for glob 'cups*'
Note, selecting 'cups-bsd' for glob 'cups*'
Note, selecting 'cupswrappermfc420cn' for glob 'cups*'
Note, selecting 'cups-core-drivers' for glob 'cups*'
Note, selecting 'cupswrappermfc8870dw' for glob 'cups*'
Note, selecting 'cups-daemon' for glob 'cups*'
Note, selecting 'cups-dbg' for glob 'cups*'
Note, selecting 'cups-x2go' for glob 'cups*'
Note, selecting 'cups' for glob 'cups*'
Note, selecting 'cupswrapperhl6050d' for glob 'cups*'
Note, selecting 'cups-client' for glob 'cups*'
Note, selecting 'cups-ipp-utils' for glob 'cups*'
Note, selecting 'cups-tea4cups' for glob 'cups*'
Note, selecting 'cupswrapperfax5750e' for glob 'cups*'
Note, selecting 'cupswrapperhl1270n' for glob 'cups*'
Note, selecting 'cupswrappermfc5840cn' for glob 'cups*'
Note, selecting 'cups-browsed' for glob 'cups*'
Note, selecting 'cups-filters-ippusbxd' for glob 'cups*'
Nota, viene selezionato "ippusbxd" al posto di "cups-filters-ippusbxd"
Il pacchetto "cupsddk" non è installato e quindi non è stato rimosso
Il pacchetto "cupsys-client" non è installato e quindi non è stato rimosso
Il pacchetto "cupsys-bsd" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp110c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp310cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax1815c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax1820c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax1835c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax1840c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax1920cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax1940cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax2440c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc210c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc3220c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc3240c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc3320cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc3340cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc3420c" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc3820cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc410cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc420cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc5440cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc5840cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc620cn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp7010" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp7020" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp7025" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp8060" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp8065dn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax2820" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax2920" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl2030" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl2040" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl2070n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5240" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5250dn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5270dn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5280dw" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc7220" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc7225n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc7420" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc7820n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8460n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8660dn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8860dn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8870dw" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp1000" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp1400" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp8020" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp8025d" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp8040" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperdcp8045d" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax2850" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax2900" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax3800" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax4100" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax4750e" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperfax5750e" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1030" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1230" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1240" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1250" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1270n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1430" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1440" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1450" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1470n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1650" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1670n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1850" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl1870n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5030" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5040" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5050" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5070n" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5130" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5140" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5150d" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl5170dn" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl6050" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrapperhl6050d" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc4800" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc6800" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8420" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8440" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8500" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8820d" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc8840d" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9030" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9070" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9160" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9180" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9660" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9700" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9760" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9800" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9860" non è installato e quindi non è stato rimosso
Il pacchetto "cupswrappermfc9880" non è installato e quindi non è stato rimosso
Il pacchetto "cups-filters-lsb" non è installato e quindi non è stato rimosso
Il pacchetto "cups-filters-invalid-mta" non è installato e quindi non è stato rimosso
Il pacchetto "cups-dbg" non è installato e quindi non è stato rimosso
Il pacchetto "cups-backend-bjnp" non è installato e quindi non è stato rimosso
Il pacchetto "cups-ipp-utils" non è installato e quindi non è stato rimosso
Il pacchetto "cups-pdf" non è installato e quindi non è stato rimosso
Il pacchetto "cups-tea4cups" non è installato e quindi non è stato rimosso
Il pacchetto "cups-x2go" non è installato e quindi non è stato rimosso
The following additional packages will be installed:
  foomatic-filters
Pacchetti raccomandati:
  cups-client | lpr | lprng | rlpr paps | cups | enscript | a2ps | mpage
I seguenti pacchetti saranno RIMOSSI:
  cinnamon* cups* cups-browsed* cups-bsd* cups-client* cups-common* cups-core-drivers* cups-daemon* cups-filters* cups-filters-core-drivers* cups-pk-helper* cups-ppdc* cups-server-common*
  mint-meta-cinnamon* printer-driver-foo2zjs*
I seguenti pacchetti NUOVI saranno installati:
  foomatic-filters
0 aggiornati, 1 installati, 15 da rimuovere e 0 non aggiornati.
È necessario scaricare 90,0 kB di archivi.
Dopo quest'operazione, verranno liberati 9.033 kB di spazio su disco.
Continuare? [S/n] n
Interrotto.
Non mi pare il caso di continuare visto che vuole eliminare cinnamon

Re: Aggiornamento e rimozione cups

Posted: Wed Mar 29, 2017 6:42 am
by ataulfo
La situazione che hai descritto è strana e il risultato che hai postato è comunque di un sistema compromesso.
Anche io non proseguirei nel remove dei pacchetti, ma nella necessità di dover installare/utilizzare cups e "sistemare" l'errore nel minor tempo possibile quello che potrei fare sarebbe:
1) Reinstallare mint (poco più di 20 minuti se hai già il supporto pronto)
2) Proseguire da terminale e reistallare le dipendenze che vuole togliere con:
ctrl+alt+F2 (inserisci login e pwd)
esegui i comandi che ti ho dato e nell'install aggiungi:

Code: Select all

sudo apt-get install cups mint-meta-cinnamon cinnamon 
ctrl+alt+F1
o

Code: Select all

sudo reboot
Nella seconda ipotesi potresti ritrovarti con cups funzionante ma modifiche nelle impostazioni di cinnamon che devi risolvere manualmente (forse riguardanti il tema, icone, font ecc.)
Passare direttamente al punto 1 non esclude il tentativo del punto 2.

Re: Aggiornamento e rimozione cups

Posted: Wed Mar 29, 2017 7:04 am
by erpomata
La cosa mi terrorizza un pochino cerco di trovare altre soluzioni poi posterò la decisione.

Grazie

Re: Aggiornamento e rimozione cups

Posted: Wed Mar 29, 2017 7:23 am
by erpomata
In effetti sembra esserci un baco da risolvere, io aspetterei qualche giorno prima di fare cavolate.

Qui

Grazei

Re: Aggiornamento e rimozione cups

Posted: Wed Mar 29, 2017 11:45 am
by ataulfo
In alto la descrizione del bug fa riferimento a quella originale che porta la data del 18-11-2016:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1642790
erpomata wrote:In effetti sembra esserci un baco da risolvere, io aspetterei qualche giorno prima di fare cavolate.

Qui

Grazei
"This appears to be due to libcups2 getting updated in Backports. I was able to remove libcups2, disable Backports, then install again from the regular Xenial repo."

Ti risulta di aver abilitato Backport nella repository?

Re: Aggiornamento e rimozione cups

Posted: Tue Apr 04, 2017 8:35 am
by pippopappo
L'unico comando che funziona è il seguente:

sudo apt-get install libcups2=2.1.3-4 cups libcupscgi1=2.1.3-4 libcupsimage2=2.1.3-4 libcupsmime1=2.1.3-4 libcupsppdc1=2.1.3-4 cups-core-drivers cups-daemon ghostscript cups-client=2.1.3-4 cups-ppdc cups-filters printer-driver-gutenprint cups-filters

Re: Aggiornamento e rimozione cups

Posted: Tue Apr 04, 2017 9:00 am
by erpomata
Infatti io ho usato quel comando e funziona.
Poi se cups si aggiornerà o meno mi cambia poco, l'importante è che stampi.