errore aggiornamenti

Italian Forum
mik
Level 1
Level 1
Posts: 1
Joined: Tue May 23, 2017 5:12 pm

errore aggiornamenti

Postby mik » Tue May 23, 2017 5:48 pm

salve, ho installato pochi giorni fà Linux 17.2 ,
quando provo a scaricare gli aggiornamenti


W: A error occurred during the signature verification. The repository is not updated and the previous index files
will be used. GPG error: http://packages.medibuntu.org oneiric InRelease: File /var/lib/apt/lists/partial/packages.medibuntu.org_dists_oneiric_InRelease doesn't start
with a clearsigned message

W: Failed to fetch http://packages.medibuntu.org/dists/oneiric/InRelease
Come posso risolvere questo errore?

coder123
Level 3
Level 3
Posts: 143
Joined: Sun Jun 21, 2015 7:33 pm

Re: errore aggiornamenti

Postby coder123 » Mon Jun 12, 2017 7:50 pm

Prova questo anda al terminale e digitare "sudo apt-get update && sudo apt-get upgrade" senza citazioni.
Linux and most of it's apps are the way it should be for the individual user. Free and and open source. And then there's Redhat for businesses that want to use Linux.

ataulfo
Level 3
Level 3
Posts: 121
Joined: Sun Apr 12, 2015 3:51 am

Re: errore aggiornamenti

Postby ataulfo » Tue Jun 13, 2017 12:58 am

Mi permetto:
la repository medibuntu non esiste più. Deve essere eliminata editando

Code: Select all

sudo nano /etc/apt/sources.list

L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.
Bisogna sempre usare l'update manager.

coder123
Level 3
Level 3
Posts: 143
Joined: Sun Jun 21, 2015 7:33 pm

Re: errore aggiornamenti

Postby coder123 » Tue Jun 13, 2017 5:23 pm

ataulfo wrote:L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.


Veramente? Sono stato usare il terminale per 2+ anni. La persona che ha introdotto mi al Linux preferisce usare il terminale con tutto. A mio capendo possiamo sceglire usare il terminale o update manager. Sono d'accordo che se mik e' nuovo al Linux deve usare update manager perche piu' semplice che il terminale ma solo per quello ragione.
Linux and most of it's apps are the way it should be for the individual user. Free and and open source. And then there's Redhat for businesses that want to use Linux.

ataulfo
Level 3
Level 3
Posts: 121
Joined: Sun Apr 12, 2015 3:51 am

Re: errore aggiornamenti

Postby ataulfo » Tue Jun 13, 2017 10:43 pm

coder123 wrote:L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.


Non è una mia opinione, ma un dato di fatto.
https://forums.linuxmint.com/viewtopic.php?t=235526

coder123
Level 3
Level 3
Posts: 143
Joined: Sun Jun 21, 2015 7:33 pm

Re: errore aggiornamenti

Postby coder123 » Wed Jun 14, 2017 2:11 am

ataulfo wrote:
coder123 wrote:L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.


Non è una mia opinione, ma un dato di fatto.
https://forums.linuxmint.com/viewtopic.php?t=235526


Oh vedo adesso grazie. E' piu' sicuro nella teoriza particolarmente se non credi i pacchetti che hai installato o i depositi hai aggiunto.
Linux and most of it's apps are the way it should be for the individual user. Free and and open source. And then there's Redhat for businesses that want to use Linux.

User avatar
minitux
Level 5
Level 5
Posts: 680
Joined: Tue Sep 12, 2017 10:05 am

Re: errore aggiornamenti

Postby minitux » Wed Sep 13, 2017 8:10 am

il ppa verosimilmente è in /etc/apt/sources.list.d lo rimuove e fa seguire l'update con

Code: Select all

sudo rm /etc/apt/sources.list.d/medibuntu* && sudo apt-get update


per l'aggiornamento da terminale con upgrade o dist-upgrade quoto ataulfo, non è una questione di ppa aggiunti o altro, è una questione di politiche di aggiornamento di mint, che di default non aggiorna i pacchetti di livello 4 e 5 , se tu usi l'upgrade o il dist-upgrade bypassi le impostazioni di mint e del suo gestore aggiornamenti e aggiorni anche tutto quello che mint non ti farebbe aggiornare in quanto ritenuto potenzialmente dannoso.

quindi se uno si installa mint e vuole mantenere le impostazioni di default, non deve usare upgrade e dist-upgrade.
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz


Return to “Italiano (Italian)”