Page 1 of 1

errore aggiornamenti

Posted: Tue May 23, 2017 5:48 pm
by mik
salve, ho installato pochi giorni fà Linux 17.2 ,
quando provo a scaricare gli aggiornamenti


W: A error occurred during the signature verification. The repository is not updated and the previous index files
will be used. GPG error: http://packages.medibuntu.org oneiric InRelease: File /var/lib/apt/lists/partial/packages.medibuntu.org_dists_oneiric_InRelease doesn't start
with a clearsigned message

W: Failed to fetch http://packages.medibuntu.org/dists/oneiric/InRelease
Come posso risolvere questo errore?

Re: errore aggiornamenti

Posted: Mon Jun 12, 2017 7:50 pm
by coder123
Prova questo anda al terminale e digitare "sudo apt-get update && sudo apt-get upgrade" senza citazioni.

Re: errore aggiornamenti

Posted: Tue Jun 13, 2017 12:58 am
by ataulfo
Mi permetto:
la repository medibuntu non esiste più. Deve essere eliminata editando

Code: Select all

sudo nano /etc/apt/sources.list
L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.
Bisogna sempre usare l'update manager.

Re: errore aggiornamenti

Posted: Tue Jun 13, 2017 5:23 pm
by coder123
ataulfo wrote: L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.
Veramente? Sono stato usare il terminale per 2+ anni. La persona che ha introdotto mi al Linux preferisce usare il terminale con tutto. A mio capendo possiamo sceglire usare il terminale o update manager. Sono d'accordo che se mik e' nuovo al Linux deve usare update manager perche piu' semplice che il terminale ma solo per quello ragione.

Re: errore aggiornamenti

Posted: Tue Jun 13, 2017 10:43 pm
by ataulfo
coder123 wrote:L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.
Non è una mia opinione, ma un dato di fatto.
viewtopic.php?t=235526

Re: errore aggiornamenti

Posted: Wed Jun 14, 2017 2:11 am
by coder123
ataulfo wrote:
coder123 wrote:L'aggiornamento in Mint da terminale con apt-upgrade è altamente sconsigliato perchè spesso installa pacchetti non richiesti, che possono causare instabilità.
Non è una mia opinione, ma un dato di fatto.
viewtopic.php?t=235526
Oh vedo adesso grazie. E' piu' sicuro nella teoriza particolarmente se non credi i pacchetti che hai installato o i depositi hai aggiunto.

Re: errore aggiornamenti

Posted: Wed Sep 13, 2017 8:10 am
by minitux
il ppa verosimilmente è in /etc/apt/sources.list.d lo rimuove e fa seguire l'update con

Code: Select all

sudo rm /etc/apt/sources.list.d/medibuntu* && sudo apt-get update
per l'aggiornamento da terminale con upgrade o dist-upgrade quoto ataulfo, non è una questione di ppa aggiunti o altro, è una questione di politiche di aggiornamento di mint, che di default non aggiorna i pacchetti di livello 4 e 5 , se tu usi l'upgrade o il dist-upgrade bypassi le impostazioni di mint e del suo gestore aggiornamenti e aggiorni anche tutto quello che mint non ti farebbe aggiornare in quanto ritenuto potenzialmente dannoso.

quindi se uno si installa mint e vuole mantenere le impostazioni di default, non deve usare upgrade e dist-upgrade.