Gimp non posso installarlo

Italian Forum
macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Gimp non posso installarlo

Post by macat72 » Sun Jul 28, 2019 7:41 pm

Salve ragazzi

ho scaricato da internet gimp 2.10 all'inizio andava bene poi ad un certo punto mi è comparsa questa scritta :
Apertura del file «/home/bruce/.var/app/org.gimp.GIMP/config/GIMP/2.10/controllerrc» non riuscita: open() non riuscita: Permesso negato
e il programma non si apre più

qualcuno può aiutarmi questo programmi mi serve grazie anticipatamente

ciao

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Thu Aug 01, 2019 10:15 am

Presumo che sei su Linux Mint 19,
ho installato Gimp 2.10 Flatpak da Gestore Applicazioni e funziona benissimo.

Provaci pure tu...

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Sat Aug 03, 2019 10:40 am

ciao Duracell

allora il programma si avvia solo dal terminale altrimenti non si avvia

Gimp Flatpak?? e che significa? come si scarica ?
mi fai capire meglio Duracell ?

grazie

User avatar
phd21
Level 19
Level 19
Posts: 9184
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Gimp non posso installarlo

Post by phd21 » Sat Aug 03, 2019 11:41 am

Ciao macat72,

Come hai installato la versione di Gimp che stai cercando di usare?

Puoi provare a usare il file AppImage di Gimp v2.10. Di seguito ho fornito un link per il download, salvare il file, concedere l'autorizzazione per eseguire il file e fare doppio clic per eseguirlo. Uso Gimp AppImage come molti altri.

Scarica l'attuale Gimp AppImage
https://github.com/aferrero2707/gimp-ap ... 4.AppImage


FYI: Release Continuous · aferrero2707/gimp-appimage
https://github.com/aferrero2707/gimp-ap ... continuous


Spero che questo ti aiuti ...
Last edited by phd21 on Mon Aug 05, 2019 1:59 pm, edited 1 time in total.
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

pasty
Level 1
Level 1
Posts: 2
Joined: Sat Aug 03, 2019 11:56 am

Re: Gimp non posso installarlo

Post by pasty » Sat Aug 03, 2019 12:05 pm

Credo che Macat72 abbia qualche problema a livello di installazione dei pacchetti.
Oltre a consigliarti di leggere qualche pagina di help sull'uso di APT per installare GIMP da riga di comando e' sufficiente che scrivi nel terminale
sudo apt install gimp
il pacchetto viene scaricato ed installato.
In alternativa puoi usare il Gestore Applicazioni o Synaptic da interfaccia grafica

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Sat Aug 03, 2019 1:23 pm

ragazzi grazie mille

ma veramente adesso non ci capisco piu niente purtroppo è da poco che mi sono affacciato nel mondo linux quindi per me è difficile capire queste cose
io posso solo avviarlo dal Terminale
sud gimp e si avvia se invece vado sull'icona mi diche : Apertura del file «/home/bruce/.config/GIMP/2.10/controllerrc» non riuscita: open() non riuscita: Permesso negato


comunque grazie a tutti

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Sun Aug 04, 2019 2:16 am

Fai in questo modo:
apri Menù > Gestore Applicazioni e clicca su Flatpak (vedi Immagine)

Image

si apre un elenco di applicazioni, scegli Gimp e clicca su Installa
non devi fare altro........

Prova e vedrai che in pochi minuti avrai il tuo Gimp perfettamente funzionante

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Mon Aug 05, 2019 9:39 am

Grazie mille Duracell ma niente da fare

se lo avvio dal Gestore applicazione non si apre , si apre una finestra come si può vedere nella foto in allegato

però dal terminale si apre se scrivo sudo gimp, però penso sempre che ci sta qualche problema

Duracell se puoi aiutami altrimenti non fa niente lo apro dal terminale

grazie 2000
Attachments
shutter.png

User avatar
phd21
Level 19
Level 19
Posts: 9184
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Gimp non posso installarlo

Post by phd21 » Mon Aug 05, 2019 2:06 pm

Ciao macat72,

Sembra che tu abbia problemi con la tua attuale installazione dell'editor di immagini Gimp. Prova l'opzione AppImage di seguito.

Scarica l'attuale Gimp AppImage facendo clic sul link in basso, quindi concediti l'autorizzazione per eseguire il programma facendo clic con il pulsante destro del mouse sul file, selezionare proprietà, scheda autorizzazioni, selezionare o modificare per consentire all'utente di eseguire, fare clic su app e ok. Quindi, fare doppio clic sul file per eseguirlo.
https://github.com/aferrero2707/gimp-ap ... 4.AppImage

How To Use AppImage in Linux [Complete Guide] - It's FOSS
Come usare AppImage in Linux [Guida completa] - È FOSS
https://itsfoss.com/use-appimage-linux/

Spero che questo ti aiuti...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Tue Aug 06, 2019 7:15 am

Forse, potrebbe darsi che sbaglio ma, se hai installato Gimp Flatpack e hai ugualmente l'errore allor sarei quasi sicuro che l'errore è di Mint.

L'installazione Flatpack porta con se tutti i pacchetti giusti per il programma e procede alla sua installazione senza interventi manuali quindi, se ci sono errori vanno addebitati ad altro.

Se fossi in te proverei l'Appimage consigliato da @phd21;
l'Appimage è un formato chiuso che porta con se tutto quello che serve per eseguire Gimp.
Vedo che sei alle primissime armi spiego come usarlo con altre parole:
-> Scarica il file
-> clic dx sul file e scegli Proprietà
-> nella finestra che si apre clic su tab Permessi
-> metti la spunta a Consentire l'esecuzione del file come programma
-> chiudi la scheda
-> Fatto.
Per far partire Gimp, clic dx sul file e scegli Apri.

Prova e facci sapere, ora sia io che anche @phd21 siamo curiosi di sapere...

P.S. La prima volta che apri Gimp Appimage ti chiederà se vuoi installarlo - rispondi NO - potrai tenere Appimage e anche altre versioni di Gimp.

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Tue Aug 06, 2019 8:05 am

Buon Giorno Ragazzi

e grazie mille per il vostro supporto ma purtroppo non anche seguendo tutte le indicazioni che mi avete dato

dopo aver scaricato il file Applmage e aver fatto tutti i passaggi alla lettera come mi avete detto si apre un altro file che non si capisce cos'è

come vedete nella foto, l'unico modo per aprire Gimp è quello di avviarlo dal Terminale

adesso lo scarico dinuovo e provo

comunque siete gentilissimo

grazie Duracell e grazie phd21

spero di poter risolvere questo problema anche perchè la settimana prossima devo partire e vorrei risolverlo prima della partenza

grazie mille un abbraccio
Attachments
applmage.png
applmage.png (16.24 KiB) Viewed 381 times

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Tue Aug 06, 2019 10:15 am

Ciao,
se anche Appimage da problemi allora è sicuro: il tuo Mint 19 ha qualcosa che non va.
Il consiglio è quello di reinstallare Mint avendo cura di controllare l'integrità del file .ISO;

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Tue Aug 06, 2019 11:12 am

Ciao Duracell

ci sta un modo per verificare se il file è integro , io ho scaricato la iso dal sito ufficiale sulla chiavetta e poi lo installata
ma può essere perchè lo installata sul disco D ?
sul disco C ho windows 7
può essere che si crea una sorta di contrasto?

grazie ancora duracell

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Wed Aug 07, 2019 12:40 am

Salve,
non so esattamente quale versione di Mint hai però la procedura è uguale per qualunque versione si sceglie.
Prima di tutto per fare un bel lavoro scarica nuovamente il file .ISO e pure il file contenente il codice per verificarne l'integrità, lo trovi cliccando dove indicato dalla freccia rossa:

Image

Ci sono tutte le indicazioni per scaricare il codice ed eseguire la verifica, non dovresti avere difficoltà.
macat72 wrote:
Tue Aug 06, 2019 11:12 am
io ho scaricato la iso dal sito ufficiale sulla chiavetta e poi lo installata
Mi suona strano, l'ISO va scaricata e poi masterizzata con apposito programma sulla chiavetta e poi installata - forse ti sei spiegato male.
macat72 wrote:
Tue Aug 06, 2019 11:12 am
ma può essere perchè lo installata sul disco D ?
Assolutamente NO!

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Wed Aug 07, 2019 6:20 am

Salve Duracell

grazie ancora per il tuo supporto sei gentilissimo

allora reinstallerò mint con i passaggi che mi hai fatto vedere

io comunque pensavo che era sottointeso il fatto che per mettere la iso sulla chiavetta c'era bisogno si un programma come Rufus, ma io ho usato UUI.

solo un ultima cosa , la verifica si fa cliccando prima sul "codice Verifica" e poi scaricarlo ? o devo scaricare la ISO e poi cliccare sul codice verifica ?

Grazie ancora Duracell .

P.S. dimenticavo adesso ho Mint 19.1 Tessa Cinnamon per 32bit , prima avevo Mint Mate che mi piaceva di più ma non andava bene, cioè avevo gli stessi problemi che sto avendo con questo , anche all'avvio devo avviarlo 2 volte .

Ciao grazie ancora

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Wed Aug 07, 2019 9:09 am

Dimmi quale PC hai e le specifiche hardware, processore, memoria ram, HD, scheda video etc.
Così posso consigliarti al meglio, per cercare di evitare quanto più possibile altri tentavivi infruttuosi.

macat72
Level 1
Level 1
Posts: 17
Joined: Sat Jul 06, 2019 5:10 am

Re: Gimp non posso installarlo

Post by macat72 » Thu Aug 08, 2019 8:00 am

Ciao duracell

allora io ho un Toshiba A300 32bit, il mio pc è nato come windows Vista ma poi ci ho installato windows 7,
ti mando un allegato con altri dati
spero che vada bene

Grazie mille Duracell del tuo aiuto
Attachments
dati computer.JPG

rjsrjs
Level 1
Level 1
Posts: 47
Joined: Sun Mar 17, 2019 6:47 pm

Re: Gimp non posso installarlo

Post by rjsrjs » Thu Aug 08, 2019 8:31 am

I tried to install a 32 bit mint 19.1 on a 32 bit machine(s) numerous times and always had some kind of glitch somewhere on the installations. So I got a Lenovo Thinkpad 64 bit from Newegg for around $200.00, installed Mint 19.1 and have no noticeable problems. Guess it's time to move over to 64 bit in my case.

User avatar
phd21
Level 19
Level 19
Posts: 9184
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Gimp non posso installarlo

Post by phd21 » Thu Aug 08, 2019 11:50 am

Ciao macat72,

Sarebbe utile sapere di più sulla configurazione del sistema. Su ogni computer che hai eseguito, esegui "inxi -Fxzd" e "lsusb" dal prompt del terminale della console, evidenzia i risultati, copia e incollali qui, che dovrebbero fornire informazioni sufficienti.

Il tuo computer Toshiba è probabilmente un computer a 64 bit e ci diranno i risultati dei comandi del terminale console. Puoi anche eseguire 'lscpu "e se mostra 32 e 64 bit, allora il computer è un computer a 64 bit. Lo vedo molto dove le persone installano una Linux Mint a 32 bit perché avevano un MS Windows a 32 bit su il loro computer quando in realtà il loro computer è a 64 bit. Un sacco di software è solo per computer a 64 bit.

Se il tuo computer è a 64 bit e hai installato una Linux Mint a 32 bit, ti consiglio di eseguire il backup di tutto ciò che desideri conservare e installare immediatamente una versione a 64 bit di Linux Mint.

Spero che questo ti aiuta ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

duracell
Level 1
Level 1
Posts: 40
Joined: Tue Nov 27, 2018 4:07 am

Re: Gimp non posso installarlo

Post by duracell » Thu Aug 08, 2019 11:59 am

Sì, fai come dice @phd21,
potrebbe senz'altro essere che il tuo sistema possa andare a 64 bit...scrivi questo codice nel terminale e posta il risultato:

Code: Select all

inxi -Fxzd

Post Reply

Return to “Italiano (Italian)”