Page 1 of 1

Non funziona nessuna perifica WIFI

Posted: Sun Jan 10, 2021 2:08 pm
by maury77
Buongiorno Amici,
Ho installato l'ultima versione di Linux Mint in un vecchio HP Elitebook 8530w

Non riesco a far funzionare nessuna periferica wifi, ne quella integrata, ne un antennino esterno

Mi date una mano ? (Nel BIOS ... UEFI disattivato)
Ecco le caratteristiche:

System:
Kernel: 5.4.0-60-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: Hewlett-Packard product: HP EliteBook 8530w v: F.20
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: Hewlett-Packard model: 30E7 v: KBC Version 90.27 serial: <filter>
BIOS: Hewlett-Packard v: 68PDV Ver. F.20 date: 12/08/2011
Battery:
ID-1: BAT0 charge: 67.2 Wh condition: 67.2/73.4 Wh (92%) volts: 16.7/14.4
model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full
CPU:
Topology: Dual Core model: Intel Core2 Duo T9400 bits: 64 type: MCP
arch: Penryn rev: 6 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10107
Speed: 798 MHz min/max: 800/2534 MHz Core speeds (MHz): 1: 798 2: 798
Graphics:
Device-1: NVIDIA G96GLM [Quadro FX 770M] vendor: Hewlett-Packard
driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:065c
Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
resolution: 1680x1050~60Hz
OpenGL: renderer: NV96 v: 3.3 Mesa 20.2.6 direct render: Yes
Audio:
Device-1: Intel 82801I HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:293e
Sound Server: ALSA v: k5.4.0-60-generic
Network:
Device-1: Intel 82567LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: 3.2.6-k port: 80e0 bus ID: 00:19.0 chip ID: 8086:10f5
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: NetGear A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
type: USB driver: usb-network bus ID: 2-1:2 chip ID: 0846:9052
serial: <filter>
Drives:
Local Storage: total: 232.89 GiB used: 9.51 GiB (4.1%)
ID-1: /dev/sda vendor: Seagate model: ST9250421AS size: 232.89 GiB
speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: HP15 scheme: MBR
Partition:
ID-1: / size: 227.74 GiB used: 9.51 GiB (4.2%) fs: ext4 dev: /dev/sda5
Sensors:
System Temperatures: cpu: 49.0 C mobo: N/A gpu: nouveau temp: 38 C
Fan Speeds (RPM): N/A
Info:
Processes: 173 Uptime: 39m Memory: 3.75 GiB used: 559.6 MiB (14.6%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: xfce4-terminal inxi: 3.0.38
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no


Grazie ancora

Re: Non funziona nessuna perifica WIFI

Posted: Sun Jan 10, 2021 9:44 pm
by sleeper12
Non vedo una scheda wifi interna. Quali sono i risultati di questo:

Code: Select all

 lspci -nnk | grep -iA3 net 

Re: Non funziona nessuna perifica WIFI

Posted: Sun Jan 10, 2021 9:53 pm
by sleeper12
Vedi se questo fa funzionare quello USB. Fai una riga alla volta:

Code: Select all

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo make dkms_install 
Reboot

Re: Non funziona nessuna perifica WIFI

Posted: Wed Jan 13, 2021 6:33 am
by maury77
Perfetto !! Funziona

grazie mille

Re: Non funziona nessuna perifica WIFI

Posted: Wed Jan 13, 2021 12:41 pm
by sleeper12
Bene, sono contento che abbia aiutato. :)