Maya + Wine + LTP1 dla programatora ELNEC | brak komunikacji

Polish Forum
DeKriss
Level 1
Level 1
Posts: 2
Joined: Mon Jan 06, 2014 4:21 am

Maya + Wine + LTP1 dla programatora ELNEC | brak komunikacji

Postby DeKriss » Mon Jan 06, 2014 5:04 am

Witam

Od kilku dni walczę z uruchomieniem pod Mintem 13 Maya x86 (z Mate) programatora ELNEC PREPROM-02aLV http://www.elnec.com/products/device-programmers/preprom-02alv/
Soft - do zassania stąd http://www.elnec.com/sw/pg4uwarc.exe - działa po Windowsami od W2k wzwyż.

Mimo wykonania wszystkich zalecanych czynności:
1. utworzenia dowiązanie symbolicznego do lp0 czy parport0 w .wine/dosdevices/
2. nadania uprawnień do korzystania z powyższych portów
nadal nie mam połączenia z programatorem.


Jedna ważna rzecz (jak sądzę) - po Win do prawidłowej pracy via LPT konieczne jest zainstalowanie sterownika do obsługi portu LPT dla programatora. Chodzi o plik pardrv.sys - w przypadku chęci korzystania z programatora z portem LTP po Win należy wybrać instalację zaawansowaną i zaznaczyć doinstalowanie powyższego sterownika.
Plik oczywiście instaluje również pod Wine ale sytuacja nie ulega zmianie - port LPT w oprogramowaniu ELNEC nadal jest niewidoczny.

Port LPT jest aktywny w biosie. Nie pomaga zmiana jego ustawień. Standardowo jest ustawiony jako ECP+EPP(1.9) pod adresem 378:

krzysztof-desktop w2kxp # dmesg | grep par
[ 0.000000] Booting paravirtualized kernel on bare hardware
[ 0.000000] vt handoff: transparent VT on vt#7
[ 0.172618] hpet0: 3 comparators, 64-bit 14.318180 MHz counter
[ 15.761504] parport_pc 00:05: reported by Plug and Play ACPI
[ 15.761550] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
[ 15.852841] lp0: using parport0 (interrupt-driven).
[ 16.040818] ppdev: user-space parallel port driver

[ 335.549835] pg4uw: sending ioctl 5305 to a partition!
[ 335.549843] pg4uw: sending ioctl 5305 to a partition!
[ 1368.059675] pg4uw: sending ioctl 5305 to a partition!
[ 1368.059683] pg4uw: sending ioctl 5305 to a partition!
[ 2214.880907] pg4uw: sending ioctl 5305 to a partition!
[ 2214.880913] pg4uw: sending ioctl 5305 to a partition!


Będę wdzięczny za jakieś sugestie co z tym zrobić. Przeszukałem setki stron www, przejrzałem dziesiątki wątków na różnych forach i nadal stoję w miejscu.

Dla jasności dodam jeszcze, że sam program uruchamia się bez najmniejszych problemów - czy to z uprawnieniami su czy też bez tych uprawnień.
W programie nie jest tylko widoczny port LPT.
Dla zobrazowania tego załączam dwa zrzuty ekranu
1. WinXP (jak widać port LPT1 jest widoczny i aktywny - program bez problemu komunikuje się z programatorem)
http://dekriss.strefa.pl/inne/wine_elnec/win.JPG
2. Mint 13 Maya x86 z Mate + Wine 1.7 (brak widocznego portu LTP, brak komunikacji z programatorem)
http://dekriss.strefa.pl/inne/wine_elnec/lin.jpg

Return to “Polski (Polish)”