Mapen NAS niet zichtbaar in o.a. VLC

Dutch Forum

Moderators: xenopeek, Moem

Post Reply
jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Sun May 11, 2014 4:00 pm

Hoi,

IK heb sinds kort linux mint 13 Mate geinstalleerd. Tot op heden alles prima. Nu probeer ik met mint mijn synology ds213+ te benaderen met o.a. VLC.

In VLC zie ik de netwerkschijf (NAS) helemaal niet terug terwijl de snelkoppeling naar netwerkschijven wel op het bureaublad staat. Als ik daar direct op klik kan ik de NAS wel benaderen.

Wat moet ik instellen om ook in o.a. VLC de NAS te kunnen benaderen?

User avatar
Kalyk
Level 5
Level 5
Posts: 770
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by Kalyk » Mon May 12, 2014 1:44 am

Hallo,
Het klinkt alsof hij al wel gekoppeld is (gemount) omdat de koppeling op het bureaublad staat.
Echter weet je niet exact waar je hem kunt vinden, die werkt iets anders dan onder Windows.
Volgens mij moet je door een rechtermuisklik op de snelkoppeling bij eigenschappen het pad kunnen zien naar die netwerkschijf.
Dat pad zul je waarschijnlijk in VLC moeten volgen om bij de inhoud te komen.

Ze zeggen altijd: onder Unix en Linux is alles een directory. Dus ook een gekoppelde schijf is ergens in de directory structuur terug te vinden.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.

jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Mon May 12, 2014 1:02 pm

Nou, zo mooi was het helaas ook weer niet. Op het bureaublad staat wel de snelkoppeling naar netwerkservers, maar niet direct naar de NAS. Die staat er wel onder als je op netwerkservers klikt.

Maar de snelkoppeling naar de NAS verwijst niet naar een directory als je er met de rechtermuisknop op klikt.

Moet je een NAS apart mounten dan?

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by mbohets » Mon May 12, 2014 2:23 pm

Bij een NAS moet je in VLC het volledige netwerkpad opgeven.
Bij mij is dat smb://marc@192.168.0.101/homes/marc/muziek
Als ik rechtstreeks in VLC een bestand dat op mijn NAS staat wil openen, krijg ik wel een foutmelding "you can only access local files"

Om muziek of films af te spelen gebruik ik mijn file manager en ik klik daar op het bestand om het af te spelen

Je moet om toegang tot de bestanden te hebben in VLC ook de NAS login en passwd opgeven
zie https://sites.google.com/site/marcshome ... plications
Dat is een site waar ik documenteer hoe ik bepaalde problemen heb opgelost,
zodat ik die dingen niet terug moet gaan opzoeken als ik een nieuwe linux versie installeer.
Niet teveel naar de layout kijken, daar heb ik niet echt veel aandacht aan besteed, het is vooral opgezet als geheugensteuntje voor mezelf.

Op de NAS zelf is in control panel/File Services/Win-Mac-nfs het volgende ingesteld
- Enable windows file services = aangevinkt
- Workgroup naam = WORKGROUP (wat de default instelling is bij Windows machines)

Je zou dat ook via NFS kunnen doen, maar dat heb ik zelf nog niet geprobeerd.
Je suis Charlie, how many more people have to die for religion

jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Mon May 12, 2014 2:43 pm

Via de filemanager kan ik de NAS inderdaad wel benaderen. Afspelen etc. lukt dan ook wel.

Ik heb de login en wachtwoord ook aan de "sleutelbos" gehangen en dat werkt ook allemaal wel goed. Maar bij het maken van een afspeellijst bijvoorbeeld in een programma zoals VLC, dan kom ik er niet bij.

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by mbohets » Mon May 12, 2014 2:54 pm

Vergeet mijn vorig antwoord, ik heb nog wat dingetjes uitgeprobeerd en iets gevonden waardoor je toch rechtstreeks vanuit VLC toegang hebt tot je nas.

Om je nas te mounten moet je het volgende doen:
Je moet telkens voor ieder commande sudo voorzetten omdat je dit als administrator moet doen, als gewone gebruiker kan je geen drives mounten.

sudo mkdir /mijn-nas
Hiermee maak je een directory aan op de plaats waar je de nas in je systeem wil hebben

sudo mount -t cifs -o username=marc,password=marc //192.168.0.101/homes/marc /mijn-nas
Hiermee mount je de nas in de directory die je met het vorige commando aangemaakt hebt
- mount -t cifs -o is het commando om de drive te mounten, cifs is een nieuwere versie van het samba protocol.
als het niet werkt moet je via je packet mgr samba, smbclient en cifs-utils installeren.
- username=marc,password=marc is de login waarmee je inlogt op je nas
- //192.168.0.101/homes/marc is het netwerkpad waar de bestanden op je nas zitten
- /mijn-nas is de plaats waar je de nas bestanden wil zien op je pc

Als je de nas wil mounten telkens je opstart moet je volgende lijn in het configuratiebestand /etc/fstab toevoegen
//192.168.0.101/homes/marc /mijn-nas cifs credentials=/etc/cifsmarc,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

Je moet dan ook een bestandje aanmaken waar je nas login gegevens staan
Vb /etc/cifsmarc
met onderstaande inhoud
username=marc
password=marc
Je suis Charlie, how many more people have to die for religion

jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Tue May 13, 2014 12:04 pm

Ok,

Bedankt voor je uitgebreide uitleg.

Even voor de check: Moet ik "mijn-nas" vervangen door de naam van mijn NAS of is dit vrij te kiezen?

Kan ik dat programma Samba gewoon via softwarebeheer installeren?

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by mbohets » Tue May 13, 2014 5:26 pm

jee-bee wrote: Even voor de check: Moet ik "mijn-nas" vervangen door de naam van mijn NAS of is dit vrij te kiezen?
De naam van de directory waar je de nas drive wil gaan op mounten en ook de plaats waar je die wil hebben is vrij te kiezen.
/mijn-nas is de plaats op je linux pc waar je de bestanden van je nas zal terugvinden, Je kan evengoed dit doen
sudo mkdir /home/marc/ditisdeplaatswaarikmijnnaswilmounten
sudo mount -t cifs -o username=marc,password=marc //192.168.0.101/homes/marc /home/marc/ditisdeplaatswaarikmijnnaswilmounten

en dan in fstab
//192.168.0.101/homes/marc /home/marc/ditisdeplaatswaarikmijnnaswilmounten cifs credentials=/etc/cifsmarc,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

dan zal je de bestanden die op je nas staan terugvinden in /home/marc/ditisdeplaatswaarikmijnnaswilmounten
jee-bee wrote:Kan ik dat programma Samba gewoon via softwarebeheer installeren?
ik heb eens nagekeken wat er bij mij van samba gerelateerde software geinstalleerd is:
cifs-utils, smbclient, libsmbclient, libwbclient0, samba, samba-common, samba-common-bin, winbind
Dat kan je allemaal met softwarebeheer installeren, zoek in softwarebeheer naar cifs en samba.
een aantal van die dingen zal al standaard geinstalleerd zijn denk ik.
Ik gebruik KDE en ken mate niet, maar ik veronderstel dat de samba gerelateerde software gelijk is voor alle grafische schillen ??
Je suis Charlie, how many more people have to die for religion

jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Thu May 15, 2014 12:35 pm

OK,

En in dit stukje:

cifsmarc,iocharset=utf8,file_mode=0777,dir_mode=0777 0

Daar staat cifsmarc. Moet is de naam marc achter cifs vervangen door mijn eigen naam?

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by mbohets » Thu May 15, 2014 1:54 pm

cifsmarc is het bestand waar ik de nas login ingezet heb.
--------------------------------------------------------------------------------------------------------------------------------------------------
Als je de nas wil mounten telkens je opstart moet je volgende lijn in het configuratiebestand /etc/fstab toevoegen
//192.168.0.101/homes/marc /mijn-nas cifs credentials=/etc/cifsmarc,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

Je moet dan ook een bestandje aanmaken waar je nas login gegevens staan
Vb /etc/cifsmarc
met onderstaande inhoud
username=marc (vervang marc door je eigen nas username)
password=marc (vervang marc door je eigen nas paswoord)
----------------------------------------------------------------------------------------------------------------------------------------------------
Dat bestandje cifsmarc waar de login gegevens instaan mag je noemen hoe je maar wil en op een plaats zetten waar je maar wil, op voorwaarde
dat de naam en de plaats in de fstab regel overeenkomen met hoe jij het op jouw pc genoemd hebt, zodat het systeem weet waar het je nas login gegevens kan vinden bij het opstarten.

Er zijn 2 manieren om een drive te mounten, ofwel ze je je login bij in het mount commando,
ofwel zet je je login gegevens in een apart textbestandje.

Ik heb de eerste methode gebruikt in het commando om de nas manueel te mounten,
en de 2de methode in de fstab regel, omdat ik de fstab lijn met de eerste methode niet direct aan de praat kreeg.
Dat komt waarschijnlijk wel wat verwarrend over.

Probeer eerst of je je nas manueel kan mounten, en als dat lukt zet dan die lijn in fstab, zodat je nas automatisch gemount wordt telkens als je je pc opstart.
Als linux opstart gaan er een aantal dingen uitgevoerd worden die zich in allerlei configuratiebestanden bevinden.
Hetgeen in het configuratiebestand fstab staat is er daar een van.
fstab bepaalt tot welke schijven je na het opstarten toegang hebt.
Je suis Charlie, how many more people have to die for religion

jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Fri May 16, 2014 2:31 pm

Ik ben er mee begonnen, maar bij het mounten krijg ik deze melding:

sudo mount -t cifs -o username=admin,password=geheim //192.168.2.117/homes/john /mijn-nas
mount: //192.168.2.117/homes/john is geen geldig blok-apparaat

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by mbohets » Sat May 17, 2014 1:52 pm

Ik heb het net bij mij nog eens geprobeerd, ik krijg geen foutmelding, en ik zie de inhoud van mijn nas.

marc@HP8570p:~ > sudo mount -t cifs -o username=admin,password=marc //192.168.0.101/homes/marc /mijn-nas
marc@HP8570p:~ > ls /mijn-nas
addressbook.csv mailsignature.txt
addressbook.vcf muziek
basis voor berekening brandverzekering.pdf My eBooks
Belgische tux met friet.png MyKubuntuCustomisation
contacts.CSV My Pictures
contacts.pst myvideos

Ik vrees dat ik je dan niet verder kan helpen, behalve dat je misschien nog eens extra moet nakijken of onderstaande dingen goed zijn:
- Staat je nas ingesteld zodat hij file sharing toelaat ?
screenshot nas https://sites.google.com/site/marcshome ... plications

- Heb je alle samba en cifs software geinstalleerd ?

Als ik bij het uitvoeren van commando's foutmeldingen krijg, zet ik de foutmelding gewoonlijk in google search,
en op die manier heb ik altijd wel een oplossing gevonden door wat dingetjes uit te proberen die je op die manier vindt.
Je zou bvb kunnen googelen op
nas not a valid block device
of
nas geen geldig blok-apparaat
Je suis Charlie, how many more people have to die for religion

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by mbohets » Sat May 17, 2014 2:07 pm

Kijk ook eens na of in het bestand /etc/samba/smb.conf de windows workgroup naam correct staat.
# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = WORKGROUP

Op mijn nas staat in de settings de windows workgroup naam ingesteld als WORKGROUP ingesteld
zie screenshot nas op https://sites.google.com/site/marcshome ... plications

De workgroup naam op je nas moet hetzelfde zijn als de workgroup naam in /etc/samba/smb.conf op je linux PC.
# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = WORKGROUP
Je suis Charlie, how many more people have to die for religion

jee-bee
Level 1
Level 1
Posts: 7
Joined: Sun May 11, 2014 3:54 pm

Re: Mapen NAS niet zichtbaar in o.a. VLC

Post by jee-bee » Sun May 18, 2014 6:46 am

Thanks. Ik zal het allemaal nog eens nalopen. Maakt het nog iets uit hoe de directory op de NAS er uit ziet?

Ik heb bijvoorbeeld Muziek op de NAS is de map Muziek staan. Dat is dan //volume1/Muziek

Als ik inlog op mijn NAS staat er 192.168.2.117:5000 in de adresregel. Maakt dat nog iets uit?

Post Reply

Return to “Nederlands (Dutch)”