Programmabeheer OPGELOST

Dutch Forum

Moderators: Moem, xenopeek

Post Reply
cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Programmabeheer OPGELOST

Post by cljbos » Mon Nov 26, 2018 10:43 am

Ik ben al een tijdje Mint gebruiker (18.3 Cinnamon 64bit, versie 3.6.6) en gebruik altijd de desktop, zeg maar op de Windows-manier door te klikken op de pictogrammen.
Nu werkt ineens (?) Programmabeheer niet meer: als ik klik op het icoon van programmabeheer zou je verwachten dat het programma gaat starten, en dat gebeurt niet. Ik heb het diverse malen al gebruikt om software te installeren, werd toen gevraagd een wachtwoord in te voeren voor authenticatie, maar nu krijg ik geen response.
Suggesties wat er aan de hand kan zijn ? Suggesties hoe dit te repareren ?
Last edited by cljbos on Thu Nov 29, 2018 5:45 am, edited 2 times in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer

Post by xenopeek » Mon Nov 26, 2018 10:51 am

Ik stel voor dat je probeert het vanaf de terminal op te starten door daar de opdracht:
mintinstall
te geven. Op de terminal krijg je verwacht ik dan een foutmelding welke de aard van het probleem zal aanwijzen. Deel de foutmeldingen hier voor verdere hulp (je kunt tekst selecteren en kopiëren vanuit de terminal middels het Edit / Bewerken menu).

Waarschijnlijk een fout in configuratie van je software bronnen. Heb je misschien recent geprobeerd een software bron (zoals PPA of andere repository) toe te voegen aan je systeem?
Image

cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Re: Programmabeheer

Post by cljbos » Tue Nov 27, 2018 2:50 pm

Recentelijk heb ik niets toegevoegd.
Mintinstall levert de volgende boodschappen op:

Detected system architecture: 'x86_64' (using 'x86_64')
Traceback (most recent call last):
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 2034, in <module>
app = Application()
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 59, in wrapper
res = func(*arg)
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 589, in __init__
self.load_cache()
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 59, in wrapper
res = func(*arg)
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 560, in load_cache
self.flatpak_appstream_pool.load()
GLib.Error: AsPool: Metadata files have errors: /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz (0)

Voldoende info zo ?

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer

Post by xenopeek » Tue Nov 27, 2018 3:42 pm

Dat lijkt een probleem met Flatpak lijst te zijn. Probeer deze opdracht eens om de Flatpak lijst te vernieuwen:
flatpak update --system --appstream --verbose

Deel hier weer wat de opdracht aan output toont.
Image

cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Re: Programmabeheer

Post by cljbos » Tue Nov 27, 2018 4:59 pm

F: Opening system flatpak installation at path /var/lib/flatpak
F: flathub:x86_64 appstream age 29233 is greater than ttl 0
Updating appstream data for remote flathub
F: Fetching summary file for remote ‘flathub’
F: Calling system helper: DeployAppstream

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer

Post by xenopeek » Tue Nov 27, 2018 5:22 pm

Dat klinkt alsof het goed ging. Als je nu weer mintinstall opdracht uitvoert, krijg je dan aan het einde deze fout nog steeds?
GLib.Error: AsPool: Metadata files have errors: /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz (0)
Image

cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Re: Programmabeheer

Post by cljbos » Tue Nov 27, 2018 5:42 pm

Zo te zien wel:
carol@Charly-HPMint ~ $ mintinstall
Detected system architecture: 'x86_64' (using 'x86_64')
Traceback (most recent call last):
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 2034, in <module>
app = Application()
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 59, in wrapper
res = func(*arg)
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 589, in __init__
self.load_cache()
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 59, in wrapper
res = func(*arg)
File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 560, in load_cache
self.flatpak_appstream_pool.load()
GLib.Error: AsPool: Metadata files have errors: /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz (0)

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer

Post by xenopeek » Wed Nov 28, 2018 3:45 am

Heb je Linux Mint in het Nederlands geinstalleerd of in het Engels? Ik lees elders iets dat problemen met dit bestand aan ingestelde taal kunnen liggen.
Image

cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Re: Programmabeheer

Post by cljbos » Wed Nov 28, 2018 10:32 am

Ik heb Linux in het nederlands geïnstalleerd

cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Re: Programmabeheer

Post by cljbos » Wed Nov 28, 2018 4:04 pm

Ik overweeg inmiddels om na een backup van mijn data een compleet schone installatie van Linux Mint 19 te doen, waarmee denk ik automatisch dit mankement is opgelost.

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer

Post by xenopeek » Thu Nov 29, 2018 1:55 am

Dat klinkt als een plan.

Ik heb slechts 1 andere 18.3 gebruiker (en nul met 19) kunnen vinden op het forum met dezelfde foutmelding. Onduidelijk hoe die z'n probleem al of niet heeft opgelost. Een andere erg er op lijkende foutmelding (exact zelfde tekst maar voor een ander Flatpak bestand) had het opgelost door het betreffende bestand te verwijderen. Dat zou je als laatste poging nog kunnen doen voordat je 19 installeert.
sudo rm -v /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz
Image

cljbos
Level 1
Level 1
Posts: 12
Joined: Mon Nov 26, 2018 9:24 am

Re: Programmabeheer OPGELOST

Post by cljbos » Thu Nov 29, 2018 5:42 am

Dit lijkt wel te werken. Ik heb de opdracht uitgevoerd en daarna Programmabeheer gestart. Weliswaar met enige vertraging, maar het werkt.
Dank voor het support. Ik wacht nog even met LM 19.

Charles_NL
Level 4
Level 4
Posts: 254
Joined: Sat Jul 18, 2015 12:42 pm
Location: The Hague, Netherlands.

Re: Programmabeheer OPGELOST

Post by Charles_NL » Thu Nov 29, 2018 9:36 am

Je hebt nu LM versie 18.3 en daar krijg je support (lees: updates en veiligheidsreparaties) voor t/m april 2021.
Er is dus geen noodzaak om op te waarderen naar versie LM19. Veel mensen willen wel graag de meest recente versie. maar echt nodig is het niet.
In elk geval goed nieuws dat het probleem verholpen is met hulp van andere forumleden.

En ook ik maak dankbaar gebruik van het werk van Pjotr.

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer OPGELOST

Post by xenopeek » Thu Nov 29, 2018 12:20 pm

Charles_NL wrote:
Thu Nov 29, 2018 9:36 am
En ook ik maak dankbaar gebruik van het werk van Pjotr.
Dat is helemaal goed maar ikke was hier aan het werk hé :-)
Image

User avatar
xenopeek
Level 24
Level 24
Posts: 24143
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Programmabeheer OPGELOST

Post by xenopeek » Thu Nov 29, 2018 12:24 pm

cljbos wrote:
Thu Nov 29, 2018 5:42 am
Dit lijkt wel te werken. Ik heb de opdracht uitgevoerd en daarna Programmabeheer gestart. Weliswaar met enige vertraging, maar het werkt.
Dank voor het support. Ik wacht nog even met LM 19.
Blij te lezen dat het zo op te lossen was, al had ik natuurlijk liever de exacte oorzaak kunnen aanwijzen. Voor de kerst mogen we de beta versie van LM 19.1 nog verwachten en zeker als je Cinnamon gebruikt is dat het afwachten even waard (en dan is er nog steeds geen haast), al heeft gm10 ook veel gedaan om Update Manager in LM 19.1 te verbeteren op meerdere vlakken en dat zal ook welkom zijn. Maar goed, zoals Charles_NL aangaf, er is absoluut geen haast en je kan nog prima LM 18.3 blijven gebruiken.
Image

Post Reply

Return to “Nederlands (Dutch)”