Problemas de dependencias impiden la configuración de git-daemon-run [Solucionado]

Spanish Forum

Moderator: JCSenar

Post Reply
User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Problemas de dependencias impiden la configuración de git-daemon-run [Solucionado]

Post by thejokerk » Sat Mar 10, 2018 9:30 pm

Hola a todos, he estado tratando de instalar S.W nuevo en el equipo, pero cuando intento instalar lo que sea, me devuelve un error con el cual no he podido encontrar nada en ninguna parte, incluso me pasa con las actualizaciones de S.W a alguien más le ha pasado, o alguien me puede explicar de que se trata? acá dejo lo que me devuelve el terminal


Code: Select all

joker@joker ~ $ sudo apt-get install  gcdemu cdemu-client 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  cdemu-daemon libmirage11 vhba-dkms
Se instalarán los siguientes paquetes NUEVOS:
  cdemu-client cdemu-daemon gcdemu libmirage11 vhba-dkms
0 actualizados, 5 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
2 no instalados del todo o eliminados.
Se necesita descargar 0 B/346 kB de archivos.
Se utilizarán 1.679 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Seleccionando el paquete vhba-dkms previamente no seleccionado.
(Leyendo la base de datos ... 253575 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../vhba-dkms_20170610-1ubuntu1~xenial1~ppa1_all.deb ...
Desempaquetando vhba-dkms (20170610-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete libmirage11 previamente no seleccionado.
Preparando para desempaquetar .../libmirage11_3.1.0-1ubuntu1~xenial1~ppa1_amd64.deb ...
Desempaquetando libmirage11 (3.1.0-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete cdemu-daemon previamente no seleccionado.
Preparando para desempaquetar .../cdemu-daemon_3.1.0-1ubuntu1~xenial1~ppa1_amd64.deb ...
Desempaquetando cdemu-daemon (3.1.0-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete cdemu-client previamente no seleccionado.
Preparando para desempaquetar .../cdemu-client_3.1.0-1ubuntu1~xenial1~ppa1_all.deb ...
Desempaquetando cdemu-client (3.1.0-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete gcdemu previamente no seleccionado.
Preparando para desempaquetar .../gcdemu_3.1.0-1ubuntu1~xenial1~ppa1_all.deb ...
Desempaquetando gcdemu (3.1.0-1ubuntu1~xenial1~ppa1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu10) ...
Procesando disparadores para shared-mime-info (1.5-2ubuntu0.1) ...
Procesando disparadores para man-db (2.7.5-1) ...
Procesando disparadores para gnome-menus (3.13.3-6ubuntu3.1) ...
Procesando disparadores para desktop-file-utils (0.22-1ubuntu5.1) ...
Procesando disparadores para mime-support (3.59ubuntu1) ...
Procesando disparadores para hicolor-icon-theme (0.15-0ubuntu1) ...
Procesando disparadores para libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
Procesando disparadores para libglib2.0-0:i386 (2.48.2-0ubuntu1) ...
Configurando runit (2.1.2-3ubuntu1) ...
start: Imposible conectar con Upstar: Failed to connect to socket /com/ubuntu/upstart: Conexión rehusada
dpkg: error al procesar el paquete runit (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
dpkg: problemas de dependencias impiden la configuración de git-daemon-run:
 git-daemon-run depende de runit; sin embargo:
 El paquete `runit' no está configurado todavía.

dpkg: error al procesar el paquete git-daemon-run (--configure):
 problemas de dependencias - se deja sin configurar
Configurando vhba-dkms (20170610-1ubuntu1~xenial1~ppa1) ...
Loading new vhba-20170610 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-116-generic
Building initial module for 4.4.0-116-generic
Done.

vhba:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.4.0-116-generic/kernel/updates/dkms/

depmod....

DKMS: install completed.
WARNING: Configuration already exists.
Configurando libmirage11 (3.1.0-1ubuntu1~xenial1~ppa1) ...
Configurando cdemu-daemon (3.1.0-1ubuntu1~xenial1~ppa1) ...
Configurando cdemu-client (3.1.0-1ubuntu1~xenial1~ppa1) ...
Configurando gcdemu (3.1.0-1ubuntu1~xenial1~ppa1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu10) ...
Se encontraron errores al procesar:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)
joker@joker ~ $ 

y cuando intento arreglarlo sale lo siguiente

Code: Select all

joker@joker ~ $ sudo apt-get -f install
[sudo] password for joker: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
2 no instalados del todo o eliminados.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
Configurando runit (2.1.2-3ubuntu1) ...
start: Imposible conectar con Upstar: Failed to connect to socket /com/ubuntu/upstart: Conexión rehusada
dpkg: error al procesar el paquete runit (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
dpkg: problemas de dependencias impiden la configuración de git-daemon-run:
 git-daemon-run depende de runit; sin embargo:
 El paquete `runit' no está configurado todavía.

dpkg: error al procesar el paquete git-daemon-run (--configure):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)
joker@joker ~ $ 

el error específico es el siguiente, pero está presente en todo lo que intento instalar.

Code: Select all

start: Imposible conectar con Upstar: Failed to connect to socket /com/ubuntu/upstart: Conexión rehusada
dpkg: error al procesar el paquete runit (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
dpkg: problemas de dependencias impiden la configuración de git-daemon-run:
 git-daemon-run depende de runit; sin embargo:
 El paquete `runit' no está configurado todavía.

dpkg: error al procesar el paquete git-daemon-run (--configure):
 problemas de dependencias - se deja sin configurar

Aclaro que esto empezó a suceder hace poco, antes de esto, no tuve inconveniente alguno instalando S.W, y siempre lo he hecho por la terminal, una que otra vez con dpkg.
Muchas gracias por cualquier colaboración que me puedan brindar.
Last edited by thejokerk on Mon Mar 12, 2018 8:12 pm, edited 2 times in total.
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
Sir Charles
Level 7
Level 7
Posts: 1827
Joined: Thu Jan 04, 2018 1:00 pm

Re: Explicación en instalación de paquetes

Post by Sir Charles » Sun Mar 11, 2018 9:22 am

Por lo menos, una parte del problema parece ser:

Code: Select all

dpkg: problemas de dependencias impiden la configuración de git-daemon-run:
 git-daemon-run depende de runit; sin embargo:
 El paquete `runit' no está configurado todavía.
Puede ser que el paquete ya esté desempaquetado pero no configurado.
Para configurarlo:

Code: Select all

sudo dpkg --configure runit
Se puede también intentar de reinstalarlo:

Code: Select all

sudo apt install --reinstall runit
Más info sobre dpkg:

Code: Select all

dpkg --help

Code: Select all

man dpkg
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Re: Explicación en instalación de paquetes

Post by thejokerk » Sun Mar 11, 2018 12:29 pm

Marziano wrote:
Sun Mar 11, 2018 9:22 am
Por lo menos, una parte del problema parece ser:

Code: Select all

dpkg: problemas de dependencias impiden la configuración de git-daemon-run:
 git-daemon-run depende de runit; sin embargo:
 El paquete `runit' no está configurado todavía.
Puede ser que el paquete ya esté desempaquetado pero no configurado.
Para configurarlo:

Code: Select all

sudo dpkg --configure runit
Se puede también intentar de reinstalarlo:

Code: Select all

sudo apt install --reinstall runit
Más info sobre dpkg:

Code: Select all

dpkg --help

Code: Select all

man dpkg
Muchas gracias, pero cada vez entiendo menos, este es el código que devuelve

Code: Select all

joker@joker ~ $ sudo dpkg --configure runit
[sudo] password for joker: 
Configurando runit (2.1.2-3ubuntu1) ...
start: Imposible conectar con Upstar: Failed to connect to socket /com/ubuntu/upstart: Conexión rehusada
dpkg: error al procesar el paquete runit (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
Se encontraron errores al procesar:
 runit
joker@joker ~ $ sudo apt install --reinstall runit
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
0 actualizados, 0 nuevos se instalarán, 1 reinstalados, 0 para eliminar y 0 no actualizados.
2 no instalados del todo o eliminados.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
E: Internal Error, No file name for runit:amd64
joker@joker ~ $ sudo dpkg --configure runit
Configurando runit (2.1.2-3ubuntu1) ...
start: Imposible conectar con Upstar: Failed to connect to socket /com/ubuntu/upstart: Conexión rehusada
dpkg: error al procesar el paquete runit (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
Se encontraron errores al procesar:
 runit
joker@joker ~ $ 
He intentado todo lo que sé de Linux y del terminal, he buscado en muchos sitios, pero sencillamente no he podido encontrar mayor cosa del tema, algo que me pueda solucionar esto, o al menos algo que me explique que es el famoso Runit, o algo que me puede dar una explicación de que es lo que está sucediendo, muchas gracias Marziano
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2820
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Explicación en instalación de paquetes

Post by JCSenar » Sun Mar 11, 2018 1:19 pm

thejokerk wrote:
Sat Mar 10, 2018 9:30 pm
Hola a todos, he estado tratando de instalar S.W nuevo en el equipo, pero cuando intento instalar lo que sea, me devuelve un error con el cual no he podido encontrar nada en ninguna parte, incluso me pasa con las actualizaciones de S.W a alguien más le ha pasado, o alguien me puede explicar de que se trata? acá dejo lo que me devuelve el terminal

Code: Select all

joker@joker ~ $ sudo apt-get install  gcdemu cdemu-client
Aclaro que esto empezó a suceder hace poco, antes de esto, no tuve inconveniente alguno instalando S.W, y siempre lo he hecho por la terminal, una que otra vez con dpkg.
Muchas gracias por cualquier colaboración que me puedan brindar.
He visto que no son paquetes disponibles en los repositorios oficiales y he encontrado una PPA para añadirlos (sudo add-apt-repository ppa:cdemu/ppa). Una vez hecho esto, en Linux Mint 18.3 Mate, el proceso funciona aparentemente bien:

Code: Select all

juancar@LM183M ~ $ sudo apt-get install  gcdemu cdemu-client
[sudo] password for juancar: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete gcdemu
E: No se ha podido localizar el paquete cdemu-client

Code: Select all

juancar@LM183M ~ $ sudo add-apt-repository ppa:cdemu/ppa
Está a punto de añadir el siguiente PPA:
 Unofficial CDEmu packages
 Más información: https://launchpad.net/~cdemu/+archive/ubuntu/ppa
Pulse Intro para continuar o Ctrl+C para cancelar

Executing: /tmp/tmp.yrRDA0xgJy/gpg.1.sh --keyserver
hkp://keyserver.ubuntu.com:80
--recv-keys
D782A00F
gpg: solicitando clave D782A00F de hkp servidor keyserver.ubuntu.com
gpg: clave D782A00F: clave pública "Launchpad PPA for CDEmu" importada
gpg: Cantidad total procesada: 1
gpg:               importadas: 1  (RSA: 1)

Code: Select all

juancar@LM183M ~ $ sudo apt-get update
Obj:1 http://ubuntu.cica.es/ubuntu xenial InRelease
Des:2 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial InRelease [17,5 kB]     
Ign:3 http://mirrors.evowise.com/linuxmint/packages sylvia InRelease           
Des:4 http://ubuntu.cica.es/ubuntu xenial-updates InRelease [102 kB]           
Des:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]     
Obj:6 http://archive.canonical.com/ubuntu xenial InRelease                     
Obj:7 http://mirrors.evowise.com/linuxmint/packages sylvia Release             
Des:8 http://ubuntu.cica.es/ubuntu xenial-backports InRelease [102 kB]         
Obj:9 http://ppa.launchpad.net/minecraft-installer-peeps/minecraft-installer/ubuntu xenial InRelease
Des:11 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main Sources [2.508 B]
Des:12 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main amd64 Packages [3.904 B]
Des:13 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main i386 Packages [3.900 B]
Des:14 http://ubuntu.cica.es/ubuntu xenial-updates/main amd64 Packages [740 kB]
Des:15 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main Translation-en [1.656 B]
Des:16 http://ubuntu.cica.es/ubuntu xenial-updates/main i386 Packages [687 kB] 
Des:17 http://ubuntu.cica.es/ubuntu xenial-updates/main Translation-en [307 kB]
Des:18 http://ubuntu.cica.es/ubuntu xenial-updates/universe amd64 Packages [596 kB]
Des:19 http://ubuntu.cica.es/ubuntu xenial-updates/universe i386 Packages [551 kB]
Des:20 http://ubuntu.cica.es/ubuntu xenial-updates/universe Translation-en [241 kB]
Des:21 http://ubuntu.cica.es/ubuntu xenial-backports/universe amd64 Packages [7.080 B]
Des:22 http://ubuntu.cica.es/ubuntu xenial-backports/universe i386 Packages [7.064 B]
Des:23 http://ubuntu.cica.es/ubuntu xenial-backports/universe Translation-en [3.812 B]
Descargados 3.476 kB en 5s (617 kB/s)                                          
Leyendo lista de paquetes... Hecho

Code: Select all

juancar@LM183M ~ $ sudo apt-get install  gcdemu cdemu-client
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  build-essential cdemu-daemon g++ g++-5 libmirage11 libstdc++-5-dev vhba-dkms
Paquetes sugeridos:
  g++-multilib g++-5-multilib gcc-5-doc libstdc++6-5-dbg libstdc++-5-doc
Se instalarán los siguientes paquetes NUEVOS:
  build-essential cdemu-client cdemu-daemon g++ g++-5 gcdemu libmirage11
  libstdc++-5-dev vhba-dkms
0 actualizados, 9 nuevos se instalarán, 0 para eliminar y 53 no actualizados.
Se necesita descargar 10,1 MB de archivos.
Se utilizarán 40,8 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] 
Des:1 http://ubuntu.cica.es/ubuntu xenial-updates/main amd64 libstdc++-5-dev amd64 5.4.0-6ubuntu1~16.04.9 [1.427 kB]
Des:2 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main amd64 vhba-dkms all 20170610-1ubuntu1~xenial1~ppa1 [9.796 B]
Des:3 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main amd64 libmirage11 amd64 3.1.0-1ubuntu1~xenial1~ppa1 [208 kB]
Des:4 http://ubuntu.cica.es/ubuntu xenial-updates/main amd64 g++-5 amd64 5.4.0-6ubuntu1~16.04.9 [8.333 kB]
Des:5 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main amd64 cdemu-daemon amd64 3.1.0-1ubuntu1~xenial1~ppa1 [60,5 kB]
Des:6 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main amd64 cdemu-client all 3.1.0-1ubuntu1~xenial1~ppa1 [32,7 kB]
Des:7 http://ubuntu.cica.es/ubuntu xenial/main amd64 g++ amd64 4:5.3.1-1ubuntu1 [1.504 B]
Des:8 http://ubuntu.cica.es/ubuntu xenial/main amd64 build-essential amd64 12.1ubuntu2 [4.758 B]
Des:9 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial/main amd64 gcdemu all 3.1.0-1ubuntu1~xenial1~ppa1 [35,0 kB]
Descargados 10,1 MB en 2s (5.022 kB/s)
Seleccionando el paquete libstdc++-5-dev:amd64 previamente no seleccionado.
(Leyendo la base de datos ... 230108 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../libstdc++-5-dev_5.4.0-6ubuntu1~16.04.9_amd64.deb ...
Desempaquetando libstdc++-5-dev:amd64 (5.4.0-6ubuntu1~16.04.9) ...
Seleccionando el paquete g++-5 previamente no seleccionado.
Preparando para desempaquetar .../g++-5_5.4.0-6ubuntu1~16.04.9_amd64.deb ...
Desempaquetando g++-5 (5.4.0-6ubuntu1~16.04.9) ...
Seleccionando el paquete g++ previamente no seleccionado.
Preparando para desempaquetar .../g++_4%3a5.3.1-1ubuntu1_amd64.deb ...
Desempaquetando g++ (4:5.3.1-1ubuntu1) ...
Seleccionando el paquete build-essential previamente no seleccionado.
Preparando para desempaquetar .../build-essential_12.1ubuntu2_amd64.deb ...
Desempaquetando build-essential (12.1ubuntu2) ...
Seleccionando el paquete vhba-dkms previamente no seleccionado.
Preparando para desempaquetar .../vhba-dkms_20170610-1ubuntu1~xenial1~ppa1_all.deb ...
Desempaquetando vhba-dkms (20170610-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete libmirage11 previamente no seleccionado.
Preparando para desempaquetar .../libmirage11_3.1.0-1ubuntu1~xenial1~ppa1_amd64.deb ...
Desempaquetando libmirage11 (3.1.0-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete cdemu-daemon previamente no seleccionado.
Preparando para desempaquetar .../cdemu-daemon_3.1.0-1ubuntu1~xenial1~ppa1_amd64.deb ...
Desempaquetando cdemu-daemon (3.1.0-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete cdemu-client previamente no seleccionado.
Preparando para desempaquetar .../cdemu-client_3.1.0-1ubuntu1~xenial1~ppa1_all.deb ...
Desempaquetando cdemu-client (3.1.0-1ubuntu1~xenial1~ppa1) ...
Seleccionando el paquete gcdemu previamente no seleccionado.
Preparando para desempaquetar .../gcdemu_3.1.0-1ubuntu1~xenial1~ppa1_all.deb ...
Desempaquetando gcdemu (3.1.0-1ubuntu1~xenial1~ppa1) ...
Procesando disparadores para man-db (2.7.5-1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu9) ...
Procesando disparadores para shared-mime-info (1.5-2ubuntu0.1) ...
Procesando disparadores para desktop-file-utils (0.22+linuxmint1) ...
Procesando disparadores para mime-support (3.59ubuntu1) ...
Procesando disparadores para hicolor-icon-theme (0.15-0ubuntu1) ...
Procesando disparadores para libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
Configurando libstdc++-5-dev:amd64 (5.4.0-6ubuntu1~16.04.9) ...
Configurando g++-5 (5.4.0-6ubuntu1~16.04.9) ...
Configurando g++ (4:5.3.1-1ubuntu1) ...
update-alternatives: utilizando /usr/bin/g++ para proveer /usr/bin/c++ (c++) en modo automático
Configurando build-essential (12.1ubuntu2) ...
Configurando vhba-dkms (20170610-1ubuntu1~xenial1~ppa1) ...
Loading new vhba-20170610 DKMS files...
First Installation: checking all kernels...
Building only for 4.10.0-38-generic
Building initial module for 4.10.0-38-generic
Done.

vhba:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.10.0-38-generic/kernel/updates/dkms/

depmod.......

DKMS: install completed.
Configurando libmirage11 (3.1.0-1ubuntu1~xenial1~ppa1) ...
Configurando cdemu-daemon (3.1.0-1ubuntu1~xenial1~ppa1) ...
Configurando cdemu-client (3.1.0-1ubuntu1~xenial1~ppa1) ...
Configurando gcdemu (3.1.0-1ubuntu1~xenial1~ppa1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu9) ...
juancar@LM183M ~ $ 
Con lo que si el problema no es la PPA, entonces es anterior. Habría que saber qué has instalado anteriormente y para qué necesitas el paquete runit (que no viene instalado por defecto en LM 18.X). Aun así, la solución puede ser esta:

https://askubuntu.com/a/772095

(Estás experimentando, pero bien, ¿eh? :lol: ¿Sabes que eso suele acabar en reinstalación, verdad? :mrgreen: )
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Re: Explicación en instalación de paquetes

Post by thejokerk » Mon Mar 12, 2018 12:21 pm

JCSenar wrote:
Sun Mar 11, 2018 1:19 pm

(Estás experimentando, pero bien, ¿eh? :lol: ¿Sabes que eso suele acabar en reinstalación, verdad? :mrgreen:
Normalmente si JCSenar, pero no estoy experimentando, estoy instalando S.W normal, de paso sea dicho desde que solucioné con ayuda de JOPETA y el foro lo de los gráficos de mi equipo, la máquina se ha comportado muy bien, y estoy muy contento con el desempeño de Mint, tanto así que lo llevé y estoy tratando de implementarlo donde tarbajo. Salvo esto que me empezó a pasar de un momento a otro cuando instalé un progarma muy compatible con todas las distros de Linux, el cual usted se dió cuenta cual era, sirve para montar imágenes, y antes había instalado Vivaldi, también compatible con Linux e instalé cheese que es nativo de Linux, y todo, absolutamente TODO lo que instalo desde el terminal o Synaptic, me está arrojando ese error, tiene razón hermano no es un paquete, y lo que me he dado cuenta, es que este error hace que el demonio no pueda iniciar, estoy muy sorprendido con esto, y no lo he podido solucionar.
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2820
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by JCSenar » Mon Mar 12, 2018 1:59 pm

thejokerk wrote:
Mon Mar 12, 2018 12:21 pm
Normalmente si JCSenar, pero no estoy experimentando, estoy instalando S.W normal
Espero no haberte ofendido. Todo sirve para seguir aprendiendo :D
thejokerk wrote:
Mon Mar 12, 2018 12:21 pm
lo que me he dado cuenta, es que este error hace que el demonio no pueda iniciar, estoy muy sorprendido con esto, y no lo he podido solucionar.
Entiendo lo que quieres decir. A mí sí me arranca:
Pantallazo.png
Pantallazo.png (25.14 KiB) Viewed 1209 times
Pero no tengo claro si has probado lo propuesto por mí en mi anterior mensaje.
thejokerk wrote:
Mon Mar 12, 2018 12:21 pm
Salvo esto que me empezó a pasar de un momento a otro cuando instalé un programa muy compatible con todas las distros de Linux, el cual usted se dio cuenta cual era, sirve para montar imágenes,
Si con lo anterior el problema no se soluciona habría que saber qué programa instalaste anteriormente que requería la instalación de runit. Sabiendo esto puedo probar a repetirlo a ver qué pasa.

(He cambiado el título para dejarlo más descriptivo)
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
JOPETA
Level 13
Level 13
Posts: 4915
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by JOPETA » Mon Mar 12, 2018 3:55 pm

Subject: Problemas de dependencias impiden la configuración de git-daemon-run
Hola a todos, he estado tratando de instalar S.W nuevo en el equipo,
La verdad no tengo ni repajolera idea de lo que quieres decir con instalar S.W (mi ignoracia casi no tiene límites) :roll:

Si te refieres al Subsistema de Windows para Linux entonces pudiera tratarse de este problema cuya solución se aporta en ese hilo, auque existe una variante por russalex que parecía dar resultados.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by thejokerk » Mon Mar 12, 2018 4:37 pm

JCSenar wrote:
Mon Mar 12, 2018 1:59 pm

Espero no haberte ofendido. Todo sirve para seguir aprendiendo :D


(He cambiado el título para dejarlo más descriptivo)
Para nada me has ofendido, antes pido disculpas si de pronto sonó prepotente, irrespetuoso o indebido lo que dije, todo lo contrario, mi pensar personal es que así uno sepa mucho de un tema, siempre hay más por aprender, en ese sentido, sigo o seguimos siendo novatos, por otro lado excelente idea haber cambiado el título del post, y por último muchas gracias por toda la ayuda que me has prestado, la valoro mucho.

P.D
Solo hice la parte de la reinstalación del gcdemu(no vi lo del git lo siento), ahora hago esa parte y pongo lo que me arroja la máquina.
Last edited by thejokerk on Mon Mar 12, 2018 4:47 pm, edited 1 time in total.
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by thejokerk » Mon Mar 12, 2018 4:42 pm

JOPETA wrote:
Mon Mar 12, 2018 3:55 pm
Subject: Problemas de dependencias impiden la configuración de git-daemon-run
Hola a todos, he estado tratando de instalar S.W nuevo en el equipo,
La verdad no tengo ni repajolera idea de lo que quieres decir con instalar S.W (mi ignoracia casi no tiene límites) :roll:
Jajajaja XD pensé nunca escuchar eso, te pido disculpas entonces, en mi país normalmente escribimos S.W=Software, para ahorrar tiempo al escribir(ya sé mala práctica al maltratar el castellano, en este caso un extranjerismo :lol: )

P.D
Muchas gracias a todos, no he vuelto a instalar más S.W después que me ha sucedido esto, ahora que salga del trabajo, reviso como va mi máquina y coloco todo el código que me arroja al instalar o tratar de instalar algo nuevo, saludos.
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2820
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by JCSenar » Mon Mar 12, 2018 4:56 pm

JOPETA wrote:
Mon Mar 12, 2018 3:55 pm
La verdad no tengo ni repajolera idea de lo que quieres decir con instalar S.W (mi ignoracia casi no tiene límites) :roll:
Creo que S.W. es SoftWare. Creo.

He intentado instalar runit en LM 18.3 y me da el mismo error.

Según este hilo, hay un problema con runit y systemd. runit, por lo visto, espera upstart, no systemd y por eso no termina de configurarse.

Dentro del hilo mencionado, he probado lo comentado en esta respuesta y me ha funcionado. Desinstalando upstart, runit se ha configurado (aunque no se si la falta de upstart afectará en algo al sistema :?: )

Code: Select all

juancar@LM183M ~ $ sudo dpkg -l | grep upstart
ii  upstart                                     1.13.2-0ubuntu21.1                           amd64        event-based init daemon - essential binaries
juancar@LM183M ~ $ sudo dpkg -l | grep fgetty
ii  fgetty                                      0.7-1                                        amd64        very small, efficient, console-only getty and login
juancar@LM183M ~ $ sudo apt-get remove --purge upstart
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
  upstart*
0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 58 no actualizados.
1 no instalados del todo o eliminados.
Se liberarán 1.694 kB después de esta operación.
¿Desea continuar? [S/n] 
(Leyendo la base de datos ... 231673 ficheros o directorios instalados actualmente.)
Desinstalando upstart (1.13.2-0ubuntu21.1) ...
Purgando ficheros de configuración de upstart (1.13.2-0ubuntu21.1) ...
Procesando disparadores para man-db (2.7.5-1) ...
Configurando runit (2.1.2-3ubuntu1) ...
juancar@LM183M ~ $ 
Al final del mismo hilo, otro usuario menciona que esta otra solución también le ha servido.

(parece que escribíamos a la vez :D )
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by thejokerk » Mon Mar 12, 2018 8:11 pm

Muchas gracias JCSenar, Marziano, JOPETA, y en general a todos los miembros del foro, la solución me la dió JCSenar con Esto, lo hice de la siguiente manera

Code: Select all

joker@joker ~ $ sudo apt-get purge runit
[sudo] password for joker: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete indicado a continuación se instaló de forma automática y ya no es necesario.
  fgetty
Utilice «sudo apt autoremove» para eliminarlo.
Los siguientes paquetes se ELIMINARÁN:
  git-daemon-run* runit*
0 actualizados, 0 nuevos se instalarán, 2 para eliminar y 7 no actualizados.
2 no instalados del todo o eliminados.
Se liberarán 1.162 kB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 253679 ficheros o directorios instalados actualmente.)
Desinstalando git-daemon-run (1:2.7.4-0ubuntu1.3) ...
Purgando ficheros de configuración de git-daemon-run (1:2.7.4-0ubuntu1.3) ...
warning: /etc/sv/git-daemon: unable to open supervise/ok: file does not exist
warning: /etc/sv/git-daemon/log: unable to open supervise/ok: file does not exist
warning: /etc/sv/git-daemon: unable to open supervise/ok: file does not exist
warning: /etc/sv/git-daemon/log: unable to open supervise/ok: file does not exist
rmdir: fallo al borrar '/var/log/git-daemon': No existe el archivo o el directorio
Desinstalando runit (2.1.2-3ubuntu1) ...
stop: Imposible conectar con Upstar: Failed to connect to socket /com/ubuntu/upstart: Conexión rehusada
Removing SV inittab entry...
Purgando ficheros de configuración de runit (2.1.2-3ubuntu1) ...
Procesando disparadores para man-db (2.7.5-1) ...
joker@joker ~ $ sudo apt-get purge git-all
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  apache2 apache2-bin apache2-data apache2-utils cvs cvsps emacs emacs24
  emacs24-bin-common emacs24-common emacs24-common-non-dfsg emacs24-el fgetty
  git git-arch git-cvs git-doc git-el git-email git-gui git-man git-mediawiki
  git-svn gitk gitweb libapr1 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libclass-factory-util-perl libclass-singleton-perl
  libcommon-sense-perl libdatetime-format-builder-perl
  libdatetime-format-iso8601-perl libdatetime-format-strptime-perl
  libdatetime-locale-perl libdatetime-perl libdatetime-timezone-perl
  libdbd-sqlite3-perl libdbi-perl liberror-perl libjson-perl libjson-xs-perl
  liblua5.1-0 libm17n-0 libmediawiki-api-perl libmodule-implementation-perl
  libmodule-runtime-perl libotf0 libpackage-deprecationmanager-perl
  libpackage-stash-perl libpackage-stash-xs-perl libparams-classify-perl
  libparams-util-perl libparams-validate-perl libserf-1-1 libsub-install-perl
  libsvn-perl libsvn1 libterm-readkey-perl libtry-tiny-perl
  libtypes-serialiser-perl libyaml-perl m17n-db tla tla-doc
Utilice «sudo apt autoremove» para eliminarlos.
Los siguientes paquetes se ELIMINARÁN:
  git-all*
0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 7 no actualizados.
Se liberarán 647 kB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 253603 ficheros o directorios instalados actualmente.)
Desinstalando git-all (1:2.7.4-0ubuntu1.3) ...
joker@joker ~ $ sudo apt-get purge git
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  apache2 apache2-bin apache2-data apache2-utils cvs cvsps emacs emacs24
  emacs24-bin-common emacs24-common emacs24-common-non-dfsg emacs24-el fgetty
  git-doc git-man libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
  libclass-factory-util-perl libclass-singleton-perl libcommon-sense-perl
  libdatetime-format-builder-perl libdatetime-format-iso8601-perl
  libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl
  libdatetime-timezone-perl libdbd-sqlite3-perl libdbi-perl liberror-perl
  libjson-perl libjson-xs-perl liblua5.1-0 libm17n-0 libmediawiki-api-perl
  libmodule-implementation-perl libmodule-runtime-perl libotf0
  libpackage-deprecationmanager-perl libpackage-stash-perl
  libpackage-stash-xs-perl libparams-classify-perl libparams-util-perl
  libparams-validate-perl libserf-1-1 libsub-install-perl libsvn-perl libsvn1
  libterm-readkey-perl libtry-tiny-perl libtypes-serialiser-perl libyaml-perl
  m17n-db tla tla-doc
Utilice «sudo apt autoremove» para eliminarlos.
Los siguientes paquetes se ELIMINARÁN:
  git* git-arch* git-cvs* git-el* git-email* git-gui* git-mediawiki* git-svn*
  gitk* gitweb*
0 actualizados, 0 nuevos se instalarán, 10 para eliminar y 7 no actualizados.
Se liberarán 33,0 MB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 253600 ficheros o directorios instalados actualmente.)
Desinstalando gitweb (1:2.7.4-0ubuntu1.3) ...
Conf gitweb disabled.
apache2_invoke prerm: Disable configuration gitweb
apache2_invoke gitweb postrm: No action required
Purgando ficheros de configuración de gitweb (1:2.7.4-0ubuntu1.3) ...
apache2_invoke postrm: Purging state for gitweb
Desinstalando git-svn (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-arch (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-cvs (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-el (1:2.7.4-0ubuntu1.3) ...
Remove git for emacs
Remove git for emacs24
remove/git: Handling removal of emacsen flavor emacs24
Purgando ficheros de configuración de git-el (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-email (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-gui (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-mediawiki (1:2.7.4-0ubuntu1.3) ...
Desinstalando gitk (1:2.7.4-0ubuntu1.3) ...
Desinstalando git (1:2.7.4-0ubuntu1.3) ...
Purgando ficheros de configuración de git (1:2.7.4-0ubuntu1.3) ...
Procesando disparadores para man-db (2.7.5-1) ...
joker@joker ~ $ sudo apt-get autoremove
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
  apache2 apache2-bin apache2-data apache2-utils cvs cvsps emacs emacs24
  emacs24-bin-common emacs24-common emacs24-common-non-dfsg emacs24-el fgetty
  git-doc git-man libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
  libclass-factory-util-perl libclass-singleton-perl libcommon-sense-perl
  libdatetime-format-builder-perl libdatetime-format-iso8601-perl
  libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl
  libdatetime-timezone-perl libdbd-sqlite3-perl libdbi-perl liberror-perl
  libjson-perl libjson-xs-perl liblua5.1-0 libm17n-0 libmediawiki-api-perl
  libmodule-implementation-perl libmodule-runtime-perl libotf0
  libpackage-deprecationmanager-perl libpackage-stash-perl
  libpackage-stash-xs-perl libparams-classify-perl libparams-util-perl
  libparams-validate-perl libserf-1-1 libsub-install-perl libsvn-perl libsvn1
  libterm-readkey-perl libtry-tiny-perl libtypes-serialiser-perl libyaml-perl
  m17n-db tla tla-doc
0 actualizados, 0 nuevos se instalarán, 56 para eliminar y 7 no actualizados.
Se liberarán 173 MB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 252804 ficheros o directorios instalados actualmente.)
Desinstalando apache2 (2.4.18-2ubuntu3.5) ...
Desinstalando apache2-bin (2.4.18-2ubuntu3.5) ...
dpkg: aviso: al desinstalar apache2-bin, el directorio «/var/lib/apache2» no está vacío, por lo que no se borra
Desinstalando apache2-data (2.4.18-2ubuntu3.5) ...
Desinstalando apache2-utils (2.4.18-2ubuntu3.5) ...
Desinstalando cvsps (2.1-6ubuntu1) ...
Desinstalando cvs (2:1.12.13+real-15ubuntu0.1) ...
Desinstalando emacs (46.1) ...
Desinstalando emacs24 (24.5+1-6ubuntu1.1) ...
Remove dictionaries-common for emacs24
remove/dictionaries-common: Purging byte-compiled files for flavour emacs24
Remove emacsen-common for emacs24
emacsen-common: Handling removal of emacsen flavor emacs24
Desinstalando emacs24-bin-common (24.5+1-6ubuntu1.1) ...
Desinstalando emacs24-el (24.5+1-6ubuntu1.1) ...
Desinstalando emacs24-common (24.5+1-6ubuntu1.1) ...
Desinstalando emacs24-common-non-dfsg (24.4+1-2) ...
Desinstalando fgetty (0.7-1) ...
Desinstalando git-doc (1:2.7.4-0ubuntu1.3) ...
Desinstalando git-man (1:2.7.4-0ubuntu1.3) ...
Desinstalando libsvn-perl (1.9.3-2ubuntu1.1) ...
Desinstalando libsvn1:amd64 (1.9.3-2ubuntu1.1) ...
Desinstalando libserf-1-1:amd64 (1.3.8-1) ...
Desinstalando libaprutil1-dbd-sqlite3:amd64 (1.5.4-1build1) ...
Desinstalando libaprutil1-ldap:amd64 (1.5.4-1build1) ...
Desinstalando libaprutil1:amd64 (1.5.4-1build1) ...
Desinstalando libdatetime-format-iso8601-perl (0.08-2) ...
Desinstalando libdatetime-format-builder-perl (0.8100-1) ...
Desinstalando libclass-factory-util-perl (1.7-3) ...
Desinstalando libdatetime-format-strptime-perl (1.6300-1) ...
Desinstalando libdatetime-perl (2:1.21-1build1) ...
Desinstalando libdatetime-timezone-perl (1:1.95-1+2016a) ...
Desinstalando libclass-singleton-perl (1.5-1) ...
Desinstalando libjson-xs-perl (3.010-2build1) ...
Desinstalando libtypes-serialiser-perl (1.0-1) ...
Desinstalando libcommon-sense-perl (3.74-1build1) ...
Desinstalando libdatetime-locale-perl (1:1.02-1) ...
Desinstalando libdbd-sqlite3-perl (1.50-1) ...
Desinstalando libdbi-perl (1.634-1build1) ...
Desinstalando liberror-perl (0.17-1.2) ...
Desinstalando libmediawiki-api-perl (0.41-1) ...
Desinstalando libjson-perl (2.90-1) ...
Desinstalando liblua5.1-0:amd64 (5.1.5-8ubuntu1) ...
Desinstalando libm17n-0:amd64 (1.7.0-3) ...
Desinstalando libparams-validate-perl (1.22-1) ...
Desinstalando libpackage-deprecationmanager-perl (0.15-1) ...
Desinstalando libpackage-stash-perl (0.37-1) ...
Desinstalando libmodule-implementation-perl (0.09-1) ...
Desinstalando libmodule-runtime-perl (0.014-2) ...
Desinstalando libotf0:amd64 (0.9.13-3) ...
Desinstalando libpackage-stash-xs-perl (0.28-2build2) ...
Desinstalando libparams-classify-perl (0.013-5build1) ...
Desinstalando libparams-util-perl (1.07-2build2) ...
Desinstalando libsub-install-perl (0.928-1) ...
Desinstalando libterm-readkey-perl (2.33-1build1) ...
Desinstalando libtry-tiny-perl (0.24-1) ...
Desinstalando libyaml-perl (1.15-1) ...
Desinstalando m17n-db (1.7.0-2) ...
Desinstalando tla (1.3.5+dfsg1-2) ...
Desinstalando tla-doc (1.3.5+dfsg1-2) ...
Desinstalando libapr1:amd64 (1.5.2-3) ...
Procesando disparadores para man-db (2.7.5-1) ...
Procesando disparadores para ufw (0.35-0ubuntu2) ...
Procesando disparadores para install-info (6.1.0.dfsg.1-5) ...
Procesando disparadores para doc-base (0.10.7) ...
Procesando 20 archivos doc-base eliminados...
Registrando documentos con scrollkeeper...
Procesando disparadores para gnome-menus (3.13.3-6ubuntu3.1) ...
Procesando disparadores para desktop-file-utils (0.22-1ubuntu5.1) ...
Procesando disparadores para mime-support (3.59ubuntu1) ...
Procesando disparadores para hicolor-icon-theme (0.15-0ubuntu1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu10) ...
joker@joker ~ $ sudo apt update
Des:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Ign:2 http://dl.google.com/linux/earth/deb stable InRelease                    
Obj:3 http://dl.google.com/linux/earth/deb stable Release                      
Obj:4 http://ppa.launchpad.net/cdemu/ppa/ubuntu xenial InRelease               
Ign:5 http://packages.linuxmint.com sarah InRelease                            
Obj:6 http://archive.ubuntu.com/ubuntu xenial InRelease                        
Obj:7 http://download.virtualbox.org/virtualbox/debian xenial InRelease        
Obj:8 http://packages.linuxmint.com sarah Release                              
Des:10 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]      
Ign:11 http://repo.vivaldi.com/stable/deb stable InRelease                     
Obj:12 http://repo.vivaldi.com/stable/deb stable Release                       
Obj:15 https://repo.skype.com/deb stable InRelease                             
Obj:16 https://deb.opera.com/opera-stable stable InRelease                     
Des:17 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]    
Ign:18 https://dl.bintray.com/resin-io/debian stable InRelease                 
Des:19 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [740 kB]
Des:20 https://dl.bintray.com/resin-io/debian stable Release [1.878 B]         
Obj:20 https://dl.bintray.com/resin-io/debian stable Release                   
Des:22 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [687 kB]
Des:23 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [596 kB]
Des:24 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [551 kB]
Des:25 http://archive.canonical.com/ubuntu xenial InRelease [11,5 kB]          
Des:26 http://archive.canonical.com/ubuntu xenial/partner amd64 Packages [3.132 B]
Des:27 http://archive.canonical.com/ubuntu xenial/partner i386 Packages [3.124 B]
Descargados 2.899 kB en 31s (90,8 kB/s)
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se pueden actualizar 7 paquetes. Ejecute «apt list --upgradable» para verlos.
N: Omitiendo el uso del fichero configurado «main/binary-i386/Packages» ya que el repositorio «http://dl.google.com/linux/earth/deb stable InRelease» no admite la arquitectura «i386»
joker@joker ~ $ sudo apt install git
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  git-man liberror-perl
Paquetes sugeridos:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk
  gitweb git-arch git-cvs git-mediawiki git-svn
Se instalarán los siguientes paquetes NUEVOS:
  git git-man liberror-perl
0 actualizados, 3 nuevos se instalarán, 0 para eliminar y 7 no actualizados.
Se necesita descargar 0 B/3.857 kB de archivos.
Se utilizarán 25,6 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Seleccionando el paquete liberror-perl previamente no seleccionado.
(Leyendo la base de datos ... 244435 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../liberror-perl_0.17-1.2_all.deb ...
Desempaquetando liberror-perl (0.17-1.2) ...
Seleccionando el paquete git-man previamente no seleccionado.
Preparando para desempaquetar .../git-man_1%3a2.7.4-0ubuntu1.3_all.deb ...
Desempaquetando git-man (1:2.7.4-0ubuntu1.3) ...
Seleccionando el paquete git previamente no seleccionado.
Preparando para desempaquetar .../git_1%3a2.7.4-0ubuntu1.3_amd64.deb ...
Desempaquetando git (1:2.7.4-0ubuntu1.3) ...
Procesando disparadores para man-db (2.7.5-1) ...
Configurando liberror-perl (0.17-1.2) ...
Configurando git-man (1:2.7.4-0ubuntu1.3) ...
Configurando git (1:2.7.4-0ubuntu1.3) ...
joker@joker ~ $ 
Luego instalé cheese nuevamente(obvio previa desinstalación :mrgreen: ) y vean la diferencia en el código de mi laptop, lo pueden verificar con la cantidad de errores que arrojaba cuando lo comparen con el código del primer post.

Code: Select all

joker@joker ~ $ sudo apt install cheese
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  cheese-common gnome-video-effects gstreamer1.0-clutter-3.0 libcheese-gtk25
  libcheese8 nautilus-sendto
Paquetes sugeridos:
  gnome-video-effects-frei0r gnome-video-effects-extra
Se instalarán los siguientes paquetes NUEVOS:
  cheese cheese-common gnome-video-effects gstreamer1.0-clutter-3.0
  libcheese-gtk25 libcheese8 nautilus-sendto
0 actualizados, 7 nuevos se instalarán, 0 para eliminar y 7 no actualizados.
Se necesita descargar 0 B/1.031 kB de archivos.
Se utilizarán 3.208 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Seleccionando el paquete cheese-common previamente no seleccionado.
(Leyendo la base de datos ... 244732 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../cheese-common_3.18.1-2ubuntu3_all.deb ...
Desempaquetando cheese-common (3.18.1-2ubuntu3) ...
Seleccionando el paquete libcheese8:amd64 previamente no seleccionado.
Preparando para desempaquetar .../libcheese8_3.18.1-2ubuntu3_amd64.deb ...
Desempaquetando libcheese8:amd64 (3.18.1-2ubuntu3) ...
Seleccionando el paquete gstreamer1.0-clutter-3.0 previamente no seleccionado.
Preparando para desempaquetar .../gstreamer1.0-clutter-3.0_3.0.18-1_amd64.deb ...
Desempaquetando gstreamer1.0-clutter-3.0 (3.0.18-1) ...
Seleccionando el paquete libcheese-gtk25:amd64 previamente no seleccionado.
Preparando para desempaquetar .../libcheese-gtk25_3.18.1-2ubuntu3_amd64.deb ...
Desempaquetando libcheese-gtk25:amd64 (3.18.1-2ubuntu3) ...
Seleccionando el paquete gnome-video-effects previamente no seleccionado.
Preparando para desempaquetar .../gnome-video-effects_0.4.1-3ubuntu1_all.deb ...
Desempaquetando gnome-video-effects (0.4.1-3ubuntu1) ...
Seleccionando el paquete cheese previamente no seleccionado.
Preparando para desempaquetar .../cheese_3.18.1-2ubuntu3_amd64.deb ...
Desempaquetando cheese (3.18.1-2ubuntu3) ...
Seleccionando el paquete nautilus-sendto previamente no seleccionado.
Preparando para desempaquetar .../nautilus-sendto_3.8.2-1ubuntu1_amd64.deb ...
Desempaquetando nautilus-sendto (3.8.2-1ubuntu1) ...
Procesando disparadores para hicolor-icon-theme (0.15-0ubuntu1) ...
Procesando disparadores para libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
Procesando disparadores para libglib2.0-0:i386 (2.48.2-0ubuntu1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu10) ...
Procesando disparadores para gnome-menus (3.13.3-6ubuntu3.1) ...
Procesando disparadores para desktop-file-utils (0.22-1ubuntu5.1) ...
Procesando disparadores para mime-support (3.59ubuntu1) ...
Procesando disparadores para man-db (2.7.5-1) ...
Configurando cheese-common (3.18.1-2ubuntu3) ...
Configurando libcheese8:amd64 (3.18.1-2ubuntu3) ...
Configurando gstreamer1.0-clutter-3.0 (3.0.18-1) ...
Configurando libcheese-gtk25:amd64 (3.18.1-2ubuntu3) ...
Configurando gnome-video-effects (0.4.1-3ubuntu1) ...
Configurando cheese (3.18.1-2ubuntu3) ...
Configurando nautilus-sendto (3.8.2-1ubuntu1) ...
Procesando disparadores para libc-bin (2.23-0ubuntu10) ...
joker@joker ~ $ 
Pudieron ver? ningún error, nuevamente digo la mejor comunidad del mundo, muchas gracias señores.
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2820
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by JCSenar » Tue Mar 13, 2018 9:03 am

thejokerk wrote:
Mon Mar 12, 2018 8:11 pm
Muchas gracias JCSenar, Marziano, JOPETA, y en general a todos los miembros del foro, la solución me la dió JCSenar con Esto,
Yo daría el tema por solucionado provisionalmente. Como ya comenté antes, parece que runit se instaló como dependencia de otro programa que instalaste (llamémoslo X). Las cuestiones son ahora:

1.- ¿Funciona X correctamente?

1.- A.- SÍ. Pues nada; runit no era imprescindible y el problema estará definitivamente solucionado.

1.- B.- NO. Pues habrá que reinstalar runit y terminar de configurarlo como comentaba en mi anterior mensaje.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
thejokerk
Level 4
Level 4
Posts: 212
Joined: Fri Feb 23, 2018 1:01 pm
Location: No soy de aquí ni soy de allá
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by thejokerk » Tue Mar 13, 2018 9:14 am

JCSenar wrote:
Tue Mar 13, 2018 9:03 am

Yo daría el tema por solucionado provisionalmente. Como ya comenté antes, parece que runit se instaló como dependencia de otro programa que instalaste (llamémoslo X). Las cuestiones son ahora:

1.- ¿Funciona X correctamente?

1.- A.- SÍ. Pues nada; runit no era imprescindible y el problema estará definitivamente solucionado.

1.- B.- NO. Pues habrá que reinstalar runit y terminar de configurarlo como comentaba en mi anterior mensaje.
Me deja pensando este razonamiento, el inconveniente, es que no recuerdo cual fue ¨X¨ en su momento, porque instalé varios programas prácticamente al mismo tiempo, pero lo que hice fue lo último que dices, y hasta ahora la laptop sigue funcionando de 10, de hecho he instalado varios programas más.

Igual muchas gracias.
Nadie es completamente un fracaso, siempre sirve de mal ejemplo ¨Anónimo¨

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2820
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas de dependencias impiden la configuración de git-daemon-run

Post by JCSenar » Tue Mar 13, 2018 9:18 am

thejokerk wrote:
Tue Mar 13, 2018 9:14 am
Me deja pensando este razonamiento, el inconveniente, es que no recuerdo cual fue ¨X¨ en su momento, porque instalé varios programas prácticamente al mismo tiempo, pero lo que hice fue lo último que dices, y hasta ahora la laptop sigue funcionando de 10, de hecho he instalado varios programas más.
Bueno, puede que no falle nada. Si lo hace, pues ya lo mirarás. Mientras, ¡a disfrutar! :D
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Post Reply

Return to “Español (Spanish)”