Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Spanish Forum

Moderator: JCSenar

Post Reply
willynux
Level 1
Level 1
Posts: 11
Joined: Wed May 18, 2016 6:51 pm

Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by willynux » Thu Dec 06, 2018 4:33 pm

Estimados.

Por favor, agradecería si alguien sabe cómo solucionar esto: instalé Mint 18.3 desde cero en mi Notebook Toshiba Satellite Dual Core I5 2,5 Ghz, 8 GB, 640 Gb.

Antes al iniciar la notebook encendía un led rojo que siempre permanecia indicando que el wifi estaba activado, desde que instalé Mint 18.3 no volvió a encender, es imposible activar el wifi, solo funciona internet por RJ45 (cable). Por lo que he aprendido buscando información parecería la falla está relacionada con el driver Realtek RTL8188CE.

Aquí debajo dejo información que espero sea útil:

Code: Select all

$ inxi -Fxz
System: Host: up Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia

Machine: System: TOSHIBA product: Satellite L755 v: PSK1WU-0YN048
Mobo: Intel model: N/A Bios: INSYDE v: 3.60 date: 06/26/2012

CPU: Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9978
clock speeds: max: 3100 MHz 1: 799 MHz 2: 799 MHz 3: 799 MHz
4: 799 MHz

Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic

Network: Card-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
driver: rtl8192ce port: 3000 bus-ID: 02:00.0
IF: wlp2s0 state: down mac: <filter>
Card-2: Qualcomm Atheros AR8152 v2.0 Fast Ethernet
driver: atl1c v: 1.0.1.1-NAPI port: 2000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>

Drives: HDD Total Size: 640.1GB (2.3% used)
ID-1: /dev/sda model: TOSHIBA_MK6475GS size: 640.1GB

Partition: ID-1: / size: 579G used: 6.3G (2%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.53GB used: 0.00GB (0%) fs: swap dev: /dev/sda5

RAID: No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors: System Temperatures: cpu: 42.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A

Info: Processes: 220 Uptime: 18 min Memory: 1245.7/7928.9MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
-------------------------------------------------------------------

Code: Select all

$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
-------------------------------------------------------------------

Code: Select all

$ iwconfig
wlp2s0  IEEE 802.11  ESSID:off/any  
Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
Retry short limit:7   RTS thr=2347 B   Fragment thr:off
Power Management:on
          
enp3s0  no wireless extensions.

lo  no wireless extensions.
-------------------------------------------------------------------

Tampoco funciona bien el sonido, se escucha bien por auriculares siempre, pero por los parlantes internos de la Notebook solo aveces por un rato, luego dejan de funcionar. Por lo que he aprendido buscando información parecería la falla también está relacionada con otro driver, el de audio.

Al ingresar al Administrador de Controladores muestra la imagen con el logo de Intel, que adjunto. Desconozco si tendrá algo ver con lo antes escrito.

Agradezco la atención. Si es necesaria más información por favor no duden en decirme.

Muchas gracias!

Saludos,

Willy
Attachments
administrador de controladores.png
Last edited by JCSenar on Fri Dec 07, 2018 12:53 am, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4909
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by JOPETA » Fri Dec 07, 2018 4:23 am

Como se comenta en numerosos hilos el problema de instalar la edición 18.3 reside en que el kernel incorporado a la ISO (4.10) no tiene soporte y deberás instalar o bien el kernel 4.4. recomendable en general para equipos maduritos o el kernel 4.15 recomendable para equipos mas recientes aunque puedes probar con ambos antes de decir con cual quedarte y desinstalar por completo el 4.10.

Hazlo de la forma gráfica recomendada y comprueba si los problemas con los dispositivos continúa. De ser a sí devuelve el resultado de inixi -Fxnznr tal cual se obtiene el la terminal.

Sobre el microcode de intel instálalo antes ya que tu BIOS está desfasada (Bios: INSYDE v: 3.60 date: 06/26/2012) y ayudará con el comportamiento general del equipo y la integración de los kernel comentados.

Respecto a la WIFI si una vez hecho lo anterior (microcode y kenel) si en la terminal sudo rfkill unblock all no tiene efectos, es decir en el rfkill list sigue apareciendo el bloqueo de la WIFI (Hard blocked: yes) revisa en al BIOS la existencia de un conmutador para la tarjeta WIFI (alguna función relativa a la WIFI o WLAN) o el uso de acceso directos directos de teclado (Fn + F?).
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

willynux
Level 1
Level 1
Posts: 11
Joined: Wed May 18, 2016 6:51 pm

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by willynux » Fri Dec 07, 2018 1:58 pm

Hola Jopeta, muchisimas gracias por responder y tu disposición ayudarme.

Siguiendo tus indicaciones primero instalé el microcode de Intel, reinicié con éxito.
Luego instalé por el Administrador de Actualizaciones el kernel serie 4.4. que tu sugeriste, que en la lista el más nuevo es el: 4.4.0-140.

Luego de reiniciar seguía activo el kernel antiguo y mostraba instalado el nuevo 4.4.0-140 pero no se activaba. Entonces instalé la otra versión que sugeriste: 4.15 y esa si quedó activa y es la que está funcionando actualmente: 4.15.0-42.

La forma que encontré para que active el kernel 4.4.0-140 es al iniciar por GRUB y seleccionarlo en opciones avanzadas. Pero al encender la notebook de forma normal (sin ingresar a GRUB) no incia con ese kernel 4.4.0-140 inicia con el kernel más nuevo que me dejo instalar el: 4.15.0-42.

Luego de cada instalación reiniciaba, veía si había novedades en la Bios y probaba el resultado de: sudo rfkill unblock all y luego: Rfkill list, como así también presionando Fn + F8 que es el acceso directo para "activar" wifi. A si mismo probaba si se solucionaba el problema del sonido.

En conclusión: el único cambio que noté fué que se instaló el microcode de Intel y el kernel nuevo: 4.15.0-42. En ningun momento se activó el wifi, el resultado de Rfkill list sigue siendo: Soft blocked: no Hard blocked: yes. Tampoco se resolvió la activación de los parlantes internos.

Que bueno que he podido instalar el micorcode de Intel y el kernel nuevo gracias a tu ayuda.

Devuelvo el resultado actual de la terminal:

Code: Select all

$ inxi -Fxz
System:    Host: up Kernel: 4.15.0-42-generic x86_64 (64 bit gcc: 5.4.0)
                 Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
                 Distro: Linux Mint 18.3 Sylvia

Machine:  System: TOSHIBA product: Satellite L755 v: PSK1WU-0YN048
                 Mobo: Intel model: N/A Bios: INSYDE v: 3.60 date: 06/26/2012

CPU:        Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB
                 flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9977
                 clock speeds: max: 3100 MHz 1: 1067 MHz 2: 832 MHz 3: 982 MHz
                 4: 903 MHz

Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
                 bus-ID: 00:02.0
                 Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
                 Resolution: 1366x768@60.00hz
                GLX Renderer: Mesa DRI Intel Sandybridge Mobile
                GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
               driver: snd_hda_intel bus-ID: 00:1b.0
               Sound: Advanced Linux Sound Architecture v: k4.15.0-42-generic

Network: Card-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
               driver: rtl8192ce port: 3000 bus-ID: 02:00.0
               IF: wlp2s0 state: down mac: <filter>
               Card-2: Qualcomm Atheros AR8152 v2.0 Fast Ethernet
               driver: atl1c v: 1.0.1.1-NAPI port: 2000 bus-ID: 03:00.0
               IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>

Drives:   HDD Total Size: 640.1GB (78.7% used)
               ID-1: /dev/sda model: TOSHIBA_MK6475GS size: 640.1GB temp: 33C

Partition: ID-1: / size: 579G used: 462G (84%) fs: ext4 dev: /dev/sda1
               ID-2: swap-1 size: 8.53GB used: 0.00GB (0%) fs: swap dev: /dev/sda5

RAID:     No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 45.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A

Info:        Processes: 192 Uptime: 56 min Memory: 785.2/7924.0MB
               Init: systemd runlevel: 5 Gcc sys: 5.4.0
               Client: Shell (bash 4.3.481) inxi: 2.2.35
Cualquier sugerencia será muy bien recibida.

Muchas gracias.

Saludos,

Willy
Last edited by JCSenar on Sat Dec 08, 2018 2:54 am, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4909
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by JOPETA » Fri Dec 07, 2018 3:32 pm

willynux wrote:
Fri Dec 07, 2018 1:58 pm
Luego de reiniciar seguía activo el kernel antiguo y mostraba instalado el nuevo 4.4.0-140 pero no se activaba. Entonces instalé la otra versión que sugeriste: 4.15 y esa si quedó activa y es la que está funcionando actualmente: 4.15.0-42.

La forma que encontré para que active el kernel 4.4.0-140 es al iniciar por GRUB y seleccionarlo en opciones avanzadas. Pero al encender la notebook de forma normal (sin ingresar a GRUB) no inicia con ese kernel 4.4.0-140 inicia con el kernel más nuevo que me dejo instalar el: 4.15.0-42.
Quizas sea una precisión que debería figurar en el tutorial de Wibol, por causar a menudo confusión. El menú GRUB no refleja el orden de instalación sino el orden numérico de los kernels instalados. Cuando el kernel que acabas de instalar es de menor numeración que el que tenías (4.4<4.10) aparece en la opciones avanzadas del menú GRUB. Por ese mismo motivo al instalar el 4.15 aparece como opción por defecto en primer lugar (4.15>4.10).

Si vas a permanecer con el kernel 4.15 deberías ejecutar en el terminal

Code: Select all

sudo update-usbids 
sudo update-pciids
Proprorciona el resultado de siguientes códigos usando la opción </> (Code) del editor como se indica aquí.

Code: Select all

inxi -Fxxznr
No comentas las opciones presentes en la BIOS sobre la WIFI y el atajo de teclado debería funcionar desbloqueandola (lo que se vería reflejado en el rfkill).

La tarjeta es una de esas problemáticas para las que debes instalar el controlador adecuado siguiendo las intrucciones de Pjotr en su Web (apartado 7?).

Sobre el tema de los altavoces deberías asegurar que está bien configurado el sonido Menú > Preferencias (Centro de Control) > Sonido la salida debe ser analógica a altavoces.
salida (pulseaudio).png
Te podría ayudar instalando pavucontrol(apt install pavucontrol) y ejecutalo como tal en la terminal (pavucontrol) La configuración debe ser estéreo analógica duplex
configuracion(pavucontrol).png
y la salida a altavoces.
salida (pavucontrol).png
Sería mejor que abrieras un hilo específico para esto de los altavoces si no funciona lo porpuesto y a este lo dejáramos sólo para lo WIFI añadiendo en el título del primer post (clic en el icono del lápiz) la tarjeta WIFI (RTL8192CE) :wink:
Last edited by JOPETA on Sun Dec 09, 2018 3:19 am, edited 5 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by Wibol » Fri Dec 07, 2018 7:09 pm

Así aparece en el tutorial desde que fue publicado:
Wibol wrote:
Sun Apr 03, 2016 3:23 am
En ese momento reiniciamos el equipo y si no intervenimos en el proceso de arranque, lo hará usando el más actual que hayamos añadido.
Wibol wrote:
Sun Apr 03, 2016 3:23 am
Si queremos iniciar usando un kernel diferente al más moderno debido a que queremos probarlo o porque el sistema no ha sido capaz de iniciarse adecuadamente, tenemos que seleccionarlo mediante la opción del GRUB “Opciones avanzadas para Linux Mint... ” donde aparecerá una lista con todos los kernels instalados, tanto en modo normal como en modo recuperación. Para acceder al GRUB en el caso de no tener arranque dual, es necesario mantener pulsada la tecla Mayúsculas durante el inicio hasta que aparezca el mismo. Si aún así no es posible, podemos editar el GRUB desde Mint con sudo nano /etc/default/grub y establecer los valores GRUB_TIMEOUT=5 y #GRUB_HIDDEN_TIMEOUT=0 lo que hará que se muestre durante 5 segundos en cada inicio. Después debemos actualizarlo con sudo update-grub.
Supongo que no habrá leído hasta el final.

Antes de realizar una consulta, no olvides:

User avatar
JOPETA
Level 13
Level 13
Posts: 4909
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by JOPETA » Sat Dec 08, 2018 4:56 am

Cierto Wibol, ya sabía que hablabas de esto y modifiqué la sugerencia inicial añadiendo de una forma mas elocuente, pero no envié el post modificado (cosas que pasan) :oops:
Quizas sea una precisión que debería figurar en el tutorial de Wibol de forma más elocuente por causar a menudo confusión.
La primera frase que citas puede ser mal interpretada (el mas actual que hayamos añadido como el último instalado) y tambien lo demás ser considerado como la selección de un kernel anterior (diferente al mas moderno, antiguo) no el que acabas de instalar.
El menú GRUB no refleja el orden de instalación sino el orden numérico de los kernels instalados. Cuando el kernel que acabas de instalar es de menor numeración que el que tenías (4.4<4.10) aparecerá en las Opciones Avanzadas del menú GRUB. Por ese mismo motivo al instalar el 4.15 aparece como opción por defecto en primer lugar(4.15>4.10)
En cualquier caso es sólo una sugerencia. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by Wibol » Sat Dec 08, 2018 5:59 am

En efecto, se prestaba a muchas interpretaciones. Creo que ahora quedó un poco mejor.

Gracias.

Antes de realizar una consulta, no olvides:

User avatar
JOPETA
Level 13
Level 13
Posts: 4909
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by JOPETA » Sat Dec 08, 2018 11:25 am

@Wibol

Gracias a ti por estar al quite. :D

@willynux
Si con la instalación del kernel y controlador apropiados, no consigues que las teclas de función activen la WIFI, observa en la siguiente imagen que la pulsación del atajo puede realizar varias acciones relativas tanto a la WIFI como al Bluetooth por lo que. deberás repetir su pulsación hasta cuatro veces dependiendo el estado de partida para confirmarlo.
teclas de función.png
SI el resultado es negativo deberías probar con

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
sudo systemctl restart network-manager.service
Hecho esto si el bloqueo por hardware persiste, es decir la tecla de función no tiene resultados, realiza las siguientes acciones y comprueba el resultado de cada una de ellas después de reiniciar y sobre la tecla de función:
a)Asegúrate de iniciar con el cable de red desconectado al menos una vez (muchos laptops desconectan la WIFI por defecto al detectar al conexión ethernet),

b)Ingresa en la BIOS y si en las opciones de la pestaña Exit tienes la posibilidad de cargar los valores optimizados por defecto selecciona esta opción y reinicia (F10)

c)Resetea la BIOS, es decir desconecta el cable de alimentación y extrae la batería. Presiona el botón de encendido al menos durante 10-12 segundos. Reconecta la batería y enciende el portátil.

d)En la BIOS, al menos inicialmente, desactiva el Bluetooth si existe esa posibilidad. Si no, mediante el acceso del teclado (sólo WIFI) y si esto no tiene efecto, al menos inicia con el bluetooth apagado (Menú>Centro de control>Bluetooth).
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

willynux
Level 1
Level 1
Posts: 11
Joined: Wed May 18, 2016 6:51 pm

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by willynux » Mon Dec 10, 2018 10:09 am

Hola, muchas gracias por responder.

Actualmente está activo kernel 4.4.0-140, sería bueno que instalara el 4.8 ?
Realicé todas las pruebas sugeridas en las respuestas anteriores desde: sudo update-usbid hasta el pié de página.
Las opciones presentes en Bios son: Built-in LAN y Wake up on LAN (activadas). F8 y Fn + F8 no activan wifi (las teclas por si solas o en otras convinaciones funcionan bien) el resultado Rfkill list es: Soft blocked: no Hard blocked: yes, incluso luego de realizar rfkill unblock all.

Respecto al sonido luego de realizar lo sugerido, los parlantes internos funcionaron (en algunas pruebas, no en todas) durante aprox. 10 seg. luego dejaban de sonar.

En mi humilde opinión pienso que estas fallas son por drivers privatorios, esta notebook antes con Win 7 wifi, sonido funcionaban bien.

Resultado de terminal:

Code: Select all

$ inxi -Fxxznr
System:    Host: up Kernel: 4.4.0-140-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.3 Sylvia
Machine:   System: TOSHIBA product: Satellite L755 v: PSK1WU-0YN048
           Mobo: Intel model: N/A Bios: INSYDE v: 3.60 date: 06/26/2012
CPU:       Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9976
           clock speeds: min/max: 800/3100 MHz 1: 826 MHz 2: 800 MHz 3: 898 MHz 4: 891 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:0126
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1c20
           Sound: Advanced Linux Sound Architecture v: k4.4.0-140-generic
Network:   Card-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
           driver: rtl8192ce port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8176
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR8152 v2.0 Fast Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: 2000 bus-ID: 03:00.0 chip-ID: 1969:2062
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 640.1GB (78.5% used)
           ID-1: /dev/sda model: TOSHIBA_MK6475GS size: 640.1GB serial: Z1LCS2T2S
Partition: ID-1: / size: 579G used: 461G (84%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.53GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 200 Uptime: 1:47 Memory: 1009.1/7930.5MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35
Muchas gracias.

Saludos,

Willy

User avatar
JOPETA
Level 13
Level 13
Posts: 4909
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by JOPETA » Tue Dec 11, 2018 4:31 am

1)Desconecta el cable de red y elimina las conexiones actuales (Clic sobre el icono de la red>Conexiones de red>Selecciona y Eliminar. Luego reinicia sin el cable conectado.

2)Respecto a la BIOS Las funciones que mencionan creo que se refieren a la tarjeta de Red ethernet y en cualquier caso son para el inicio en red de tenerla configurada(Wake up on LAN). Deberás buscar algo específico de la WLAN.

3)Respecto a los controladores de la WIFI como se menciona en la WEB de Pjotr si cambias de kernel debes reinstalarlo (esto con conexión a la red claro). Cuando lo hagas devuelve de nuevo el resultado iwconfig

4)En relación con el gestor de energía del la WIFI, en tu caso siendo LM 18.3 deberías hacerlo de la forma indicada en el post anterior o editando directamente

Code: Select all

gksudo gedit /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
y cambiar el 3 de la siguiente línea
[connection]
wifi.powersave = 3 >>>cámbialo por un 2
Guarda el archivo modificado, cierra el editor y reinicia para comprobar el resultado.
5)Sobre la tecla de función debes observar el efecto sobre rfkill list de cada una de las pulsaciones (ya te digo que son hasta cuatro las pulsaciones de Fn+F8 a comprobar) dejando la que muestre el Hard blocked: No si es que ocurre alguna de las veces. unblock solo tiene efecto sobre los bloqueos por software.

6)Deberías añadir la WIFI o el controlador en uso al título para llamar la atención de otros usuarios o colabores con experiencia en estas tarjetas. Algo como MINT 18.3 no activa WIFI RTL8188CE

7) Por último proporciona la información completa de la red (con conexión a la red claro) devolviendo la url resultante del último de los códigos siguientes (son dos líneas, copia y pega una cada vez en la terminal y presiona Intro)

Code: Select all

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info
cat wireless-info.txt | nc termbin.com 9999
El problema de los altavoces plantéalo en un hilo aparte como te he sugerido. Sigue lo indicado en el apartado 4 y siguientes párrafos de este hilo y de no tener resultados, acompaña el resultado de los códigos sugeridos y de capturas de pantalla de la configuración del sonido como se indica aquí.. :wink:
Last edited by JOPETA on Wed Dec 12, 2018 6:32 am, edited 2 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

willynux
Level 1
Level 1
Posts: 11
Joined: Wed May 18, 2016 6:51 pm

Re: MINT 18.3 no activa WIFI RTL8188CE (SOLUCIONADO)

Post by willynux » Tue Dec 11, 2018 11:06 am

Quedó solucionado! muchas gracias!

Realicé la reinstalación que sugeriste aquí arriba en el punto "3)Respecto a los controladores de la WIFI como se menciona en la WEB de Pjotr si cambias de kernel debes reinstalarlo..."

Gracias! nuevamente.

Saludos,

Willy

User avatar
JOPETA
Level 13
Level 13
Posts: 4909
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ayuda: Mint 18.3 no activa wifi. Sin sonido por parlantes.

Post by JOPETA » Wed Dec 12, 2018 3:53 am

Mealegra que lo solucionaras. :D

Por favor, para que el hilo aparezca como [solucionado] deberás editar el primer post, el que abre el hilo. Haz clic en el icono del lápiz a la derecha y añádelo al titulo de ese post al igual que la indicación de la tarjeta WIFI. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”