No se pudieron descargar todos los índices de los repositorios

Spanish Forum

Moderator: JCSenar

Post Reply
Atlante
Level 1
Level 1
Posts: 12
Joined: Thu Nov 01, 2018 2:57 pm
Location: Montevideo/Uruguay

No se pudieron descargar todos los índices de los repositorios

Post by Atlante » Sat Apr 13, 2019 2:13 pm

Hola a todos. Soy usuario de Linux Mint 19.1 Tessa con escritorio Cinnamon. Tengo un problemita igual al del título de este tema. Hace días que mi sistema operativo no actualiza, y es un problema igual o similar al del título, como ya os dije. El ícono en el panel del Administrador de actualizaciones me aparece con la típica crucecita roja. Le doy "refrescar" al Administrador, y al finalizar su tarea, se exhibe un cartel con la siguiente leyenda:

"No se pudieron descargar todos los índices de los repositorios

El repositorio quizá no esté disponible o no se pudo contactar con él por problemas en la red. Si hay disponible una versión más antigua del índice que falló, se usará esa versión. En caso contrario el repositorio se ignorará. Compruebe su conexión de red y que la dirección del repositorio esté escrita correctamente en las preferencias.


Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. Error de GPG: http://dl.google.com/linux/earth/deb stable Release: Las siguientes firmas no fueron válidas: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>Fallo al obtener http://dl.google.com/linux/earth/deb/di ... elease.gpg Las siguientes firmas no fueron válidas: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar."

Quisiera saber cómo resolver esta situación. Os agradezco muy atentamente por vuestra amable ayuda.

User avatar
JCSenar
Level 9
Level 9
Posts: 2965
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: No se pudieron descargar todos los índices de los repositorios

Post by JCSenar » Sun Apr 14, 2019 3:03 am

Atlante wrote:
Sat Apr 13, 2019 2:13 pm
Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. Error de GPG: http://dl.google.com/linux/earth/deb stable Release: Las siguientes firmas no fueron válidas: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>Fallo al obtener http://dl.google.com/linux/earth/deb/di ... elease.gpg Las siguientes firmas no fueron válidas: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar."
Ve a Menú > Administración > Fuentes de software y desmarca/elimina las entradas correspondientes a Google Earth.

Seguidamente haz Actualizar caché.

En el Administrador de actualizaciones pincha en Refrescar y debería funcionar.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Atlante
Level 1
Level 1
Posts: 12
Joined: Thu Nov 01, 2018 2:57 pm
Location: Montevideo/Uruguay

Re: No se pudieron descargar todos los índices de los repositorios

Post by Atlante » Sun Apr 14, 2019 2:42 pm

Gracias, JCSenar, lo voy a hacer, pero antes quería saber una cosa: ¿qué pasará con Google Earth? ¿dejará de actualizarse, no se actualizará más?, le pido disculpas si la pregunta es groseramente ignorante.

Gracias.

User avatar
JCSenar
Level 9
Level 9
Posts: 2965
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: No se pudieron descargar todos los índices de los repositorios

Post by JCSenar » Sun Apr 14, 2019 3:27 pm

Atlante wrote:
Sun Apr 14, 2019 2:42 pm
Gracias, JCSenar, lo voy a hacer, pero antes quería saber una cosa: ¿qué pasará con Google Earth? ¿dejará de actualizarse, no se actualizará más?, le pido disculpas si la pregunta es groseramente ignorante.

Gracias.
Habría que saber cómo instalaste Google Earth.

En LM 19.1 Google Earth está incluido en los repositorios oficiales y, una vez instalado (Gestor de software), se actualiza normalmente a través del Administrador de actualizaciones.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Atlante
Level 1
Level 1
Posts: 12
Joined: Thu Nov 01, 2018 2:57 pm
Location: Montevideo/Uruguay

Re: No se pudieron descargar todos los índices de los repositorios

Post by Atlante » Sun Apr 14, 2019 3:39 pm

Bien. Como no me acuerdo cómo ni cuando instalé esa aplicación, fui al Gestor de software a fijarme, y encontré dos paquetes para Google Earth. Uno de ellos, Google Earth (así lo dice simplemente), es el que está instalado. El otro, que dice Googleearth-package, no lo está. No sé si desinstalar el que ha creado problemas e instalar el otro, no sé si desaparecerán los problemas con los índices de repositorios o continuarán. Gracias, Juan Carlos.

User avatar
tomeu
Level 5
Level 5
Posts: 560
Joined: Wed Mar 29, 2017 12:03 pm

Re: No se pudieron descargar todos los índices de los repositorios

Post by tomeu » Mon Apr 15, 2019 4:07 am

Simplemente para aclarar conceptos:
  • 1. Tanto el "Gestor de Software" de Mint como "Synaptic", reconocerán un paquete como instalado aunque ya no esté en el repositorio, o éste haya cambiado
Por tanto, no se trata de desinstalar nada desde el Gestor de Software (a no ser que sea esto lo que quieras).
  • 2. Eliminar paquetes externos y/o reinstalar versiones de los repositorios oficiales
Desde el Administrador de Actualizaciones -> Opciones -> Fuentes de Software, tenemos el apartado "Mantenimiento", a mi modo de ver es el modo ideal para desinstalar paquetes DEB que no están en los repositorios o para poner las versiones que nos ofrecen los repositorios de Mint.
Lógicamente para que el sistema los tenga por "extraños" sus fuentes o repositorios han de estar desmarcadas (ya los PPA que hayamos añadido ya las fuentes adicionales).
En lo que afecta a Google Earth (y Google Chrome también) este fin de semana sus fuentes estaban con problemas, por lo que daba el fallo comentado.
Por cierto ese fallo no significa que el resto de fuentes o repositorios no hubiera sido comprobado.
Google Earth efectivamente está en los repositorios de Mint, pero está en la misma versión que en su día se puso sin actualizar; si por cualquier motivo se quiere tener actualizada a la última versión hay que hacerlo a través de la fuente adicional de Google.
Salvo error mío, esa fuente adicional la crea Google automáticamente por el mero uso del programa, aunque se haya instalado desde las fuentes de software, por lo que si no se quiere actualizar que desmarcarla en fuentes adicionales o eliminarla.
Linux Mint Tessa 19.1 64bits Cinnamon 4.0.10

Atlante
Level 1
Level 1
Posts: 12
Joined: Thu Nov 01, 2018 2:57 pm
Location: Montevideo/Uruguay

Re: No se pudieron descargar todos los índices de los repositorios

Post by Atlante » Mon Apr 15, 2019 2:19 pm

Bien. Ahora entiendo más cosas. No, mi intención no es desinstalar nada. Pretendo seguir usando Google Earth (hubiera querido usar Marble, pero lamentablemente, a determinada escala, sus imágenes se ven todas difusas).

Entré a Administración > Fuentes del software > Mantenimiento y se despliega una lista de opciones que es la siguiente: "Arreglar problemas de MargeList", "Purgar la configuración residual", "Eliminar entradas duplicadas", "Eliminar paquetes externos" y "Revertir paquetes externos". Mis dudas se ubican en estas tres últimas opciones. Pienso que alguna de estas tres últimas, podría ser la clave. No sé si estoy pensando correctamente y voy por buen camino.

Gracias, Tomeu.

User avatar
tomeu
Level 5
Level 5
Posts: 560
Joined: Wed Mar 29, 2017 12:03 pm

Re: No se pudieron descargar todos los índices de los repositorios

Post by tomeu » Tue Apr 16, 2019 7:36 am

Sí, por ahí van los tiros.
Ahora bien, si no lo quieres desinstalar, nada has de hacer. Además, el repositorio adicional para Google Earth ya funciona, por lo que ese fallo ya no debe darse.
repo-adicional.png
En cuanto al lugar adecuado de mantenimiento es "Paquetes externos", fijaté:
En esta imagen con el repo de G.Earth marcado y actualizado, NO ofrece revertir el paquete como externo.
externos-1.png
En esta segunda imagen desmarcado el repo de G.Earth y tras actualizar, sí lo tiene por "externo" y ofrece reinstalar el paquete con la versión del repositorio.
externos-2.png
Saludos.
Linux Mint Tessa 19.1 64bits Cinnamon 4.0.10

Atlante
Level 1
Level 1
Posts: 12
Joined: Thu Nov 01, 2018 2:57 pm
Location: Montevideo/Uruguay

Re: No se pudieron descargar todos los índices de los repositorios

Post by Atlante » Wed Apr 17, 2019 12:24 pm

Bien, Tomeu, bien. Ya tengo desmarcado a Google Earth como repositorio en Fuentes de software, como me dijo Juan Carlos. El sistema ahora está actualizando bien. Fui a Fuentes de software > Mantenimiento > Revertir paquetes externos y me señaló a Google Earth como uno de ellos, como a un paquete externo. Se desplegó un cartel señalándolo como tal, y un anuncio con la leyenda "La versión de los paquetes siguientes no coincide con la de los repositorios". Me da 2 descripciones: "Versión instalada" y "Versión del repositorio", la identificación del paquete de Google Earth, posee una casilla para marcar/desmarcar, y debajo aparecen 3 opciones: "Seleccionar todo", "Cancelar" y "Revertir" (esta última solo se apresta cuando se marca la casilla de este paquete de Google Earth).

Tal vez el sistema me esté dando una opción. Sigo con el paquete externo de Google Earth que no coincide con los repositorios, o hago la opción por cargar el paquete con la versión de los repositorios. Si optara por esta última, no desinstalo nada, y logro una conversión del paquete, que se actualizaría con los repositorios, lo cual sería doblemente ventajoso, porque me permitiría actualizar tanto a ese paquete, como a los demás del sistema . . . no sé si estoy razonando bien.

User avatar
JCSenar
Level 9
Level 9
Posts: 2965
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: No se pudieron descargar todos los índices de los repositorios

Post by JCSenar » Thu Apr 18, 2019 4:32 am

Atlante wrote:
Wed Apr 17, 2019 12:24 pm
Tal vez el sistema me esté dando una opción. Sigo con el paquete externo de Google Earth que no coincide con los repositorios, o hago la opción por cargar el paquete con la versión de los repositorios. Si optara por esta última, no desinstalo nada, y logro una conversión del paquete, que se actualizaría con los repositorios, lo cual sería doblemente ventajoso, porque me permitiría actualizar tanto a ese paquete, como a los demás del sistema . . . no sé si estoy razonando bien.
Estás razonando bien.

Instalaste Google Earth de una fuente distinta a los repositorios oficiales. Aún así, es posible que ese repositorio pueda funcionar y sea un fallo puntual, como comentaba tomeu. Puedes esperar y comprobarlo. Si el fallo persiste, utiliza el repositorio oficial y listo.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
tomeu
Level 5
Level 5
Posts: 560
Joined: Wed Mar 29, 2017 12:03 pm

Re: No se pudieron descargar todos los índices de los repositorios

Post by tomeu » Fri Apr 19, 2019 3:41 am

Quizás pare entenderlo no está de más atender qué es cada repositorio.
Tenemos los repositorios oficiales de Mint donde se compilan paquetes de programas por Mint y para Mint.
Luego los PPA, que incluyen esos paquetes, y otros más, especialmente diseñados para Ubuntu/Mint y derivadas de Ubuntu.
Y luego las fuentes adicionales, donde se permite la instalación y actualización de paquetes de programa más genéricos (Debian - RPM, etc..) como los de Google, o porque son privativos, etc etc
Digamos que lo mollar y más seguro son los primeros.
Todos esos paquetes se pueden actualizar y/o instalar/desinstalar desde las aplicaciones Synaptic, Apt, Fuentes Software...
Luego estarán los otros que no están en ninguno de esos tres grupos (por lo que en el Gestor de Software) siempre serán externos, como por ejemplo el deb para instalar el DNIe o programas como master-pdf-editor (privativo)
Tu elige la versión que más te guste o mejor te funcione; si está en los repos oficiales de Mint (por ejemplo firefox se actualiza casi a la vez que el de Mozilla) pues mejor, pero a veces resulta que no es así, por ejemplo LibreOffice no suele actualizarse, o lo hace muy poco, en los oficiales, por lo que si queremos estar con la última versión habrá que recurrir al PPA o a instalar los paquetes que ofrece la Fundación desde su web.
En lo que respecta a G.Earth las diferencias entre las versiones de los repositorios oficiales de Mint y las de Google me parecen que son muy pocas, o yo como usuario medio no noto las diferencias.
Linux Mint Tessa 19.1 64bits Cinnamon 4.0.10

Atlante
Level 1
Level 1
Posts: 12
Joined: Thu Nov 01, 2018 2:57 pm
Location: Montevideo/Uruguay

Re: No se pudieron descargar todos los índices de los repositorios

Post by Atlante » Fri Apr 19, 2019 2:34 pm

JCSenar wrote:
Thu Apr 18, 2019 4:32 am
Atlante wrote:
Wed Apr 17, 2019 12:24 pm
Tal vez el sistema me esté dando una opción. Sigo con el paquete externo de Google Earth que no coincide con los repositorios, o hago la opción por cargar el paquete con la versión de los repositorios. Si optara por esta última, no desinstalo nada, y logro una conversión del paquete, que se actualizaría con los repositorios, lo cual sería doblemente ventajoso, porque me permitiría actualizar tanto a ese paquete, como a los demás del sistema . . . no sé si estoy razonando bien.
Estás razonando bien.

Instalaste Google Earth de una fuente distinta a los repositorios oficiales. Aún así, es posible que ese repositorio pueda funcionar y sea un fallo puntual, como comentaba tomeu. Puedes esperar y comprobarlo. Si el fallo persiste, utiliza el repositorio oficial y listo.
Entiendo. Pero tengo más confianza en los repositorios del sistema. Además, ahora que lo dices lo recuerdo. Cada tanto, tanto tiempo, me aparece en el Administrador de actualizaciones este paquete externo para actualizar. Demora mucho en aparecer. No he probado el repositorio oficial, pero tal vez sea más ágil que el externo. Aunque solo sea por curiosidad, voy a probarlo, y así podré comparar también. Por lo menos, no tendré nada trancando a los otros repositorios del sistema. Creo que tengo mucho más para ganar, que para perder. Prefiero hacer la reversión de ese repositorio externo. Voy a hacer el siguiente recorrido: Fuentes del software > Mantenimiento > Revertir paquetes externos > Seleccionar todo (es el único paquete externo que tengo) > Revertir > S. Creo que ese es el procedimiento correcto para la conversión. Si es así, espero pronto poder editar este tema como "SOLUCIONADO".

Les agradezco mucho a ambos, a JCSenar y a Tomeu.

Post Reply

Return to “Español (Spanish)”