Problemas con Wine en 19.3

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Problemas con Wine en 19.3

Post by jomimaro »

Buenas gente,

Sí, soy otro de los que tiene problemas con wine en Mint 19.3 y como estos días no tengo demasiado que hacer me he decidido a intentar que funcione, con vuestra ayuda claro ;)

Antes de llegar aquí he intentado solucionarlo por mi cuenta, por lo que puedo haber roto algo más, pero el resto del sistema parece que funciona bien o sea que no habrá sido mucho :P

Lo último que he intentado es lo que dice aquí JCSenar:
viewtopic.php?p=1755767#p1755767
Bueno, en general me he leído ese post y los enlaces que tiene, pero de momento no he dado con la solución.

Y la respuesta de la última instrucción es esta:

Code: Select all

sudo apt install --install-recommends winehq-stable

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 winehq-stable : Depende: wine-stable (= 5.0.0~bionic)
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

La info del sistema es:

Code: Select all

inxi -Fxznr

System:    Host: SKYNET Kernel: 4.15.0-91-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: Acer product: Aspire E5-521 v: V1.01 serial: <filter> 
           Mobo: Acer model: Larne v: V1.01 serial: <filter> UEFI: Insyde v: 1.01 date: 05/27/2014 
Battery:   ID-1: BAT1 charge: 47.7 Wh condition: 47.7/55.9 Wh (85%) model: COMPAL PABAS0241231 status: Full 
CPU:       Topology: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics bits: 64 type: MCP arch: Puma rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 14372 
           Speed: 998 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 998 2: 998 3: 998 4: 998 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] vendor: Acer Incorporated ALI 
           driver: radeon v: kernel bus ID: 00:01.0 
           Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: AMD KABINI (DRM 2.50.0 4.15.0-91-generic LLVM 9.0.0) v: 4.5 Mesa 19.2.8 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:01.1 
           Device-2: Advanced Micro Devices [AMD] FCH Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k4.15.0-91-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: 2.3LK-NAPI port: 2000 bus ID: 01:00.1 
           IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Lite-On driver: ath9k v: kernel 
           port: 2000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-3: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb bus ID: 1-1.3:5 
           IF-ID-1: ztyqbqkj3a state: unknown speed: 10 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 223.57 GiB used: 96.95 GiB (43.4%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB temp: 29 C 
Partition: ID-1: / size: 171.00 GiB used: 96.92 GiB (56.7%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 45.2 C mobo: N/A gpu: radeon temp: 45 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           1: deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./
           Active apt repos in: /etc/apt/sources.list.d/megasync.list 
           1: deb https://mega.nz/linux/MEGAsync/xUbuntu_18.04/ ./
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://mirror6.layerjet.com/linuxmint/packages tricia main upstream import backport
           2: deb http://mirror.tedra.es/ubuntu bionic main restricted universe multiverse
           3: deb http://mirror.tedra.es/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://mirror.tedra.es/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
           Active apt repos in: /etc/apt/sources.list.d/zerotier.list 
           1: deb http://download.zerotier.com/debian/xenial xenial main
Info:      Processes: 205 Uptime: 15m Memory: 6.77 GiB used: 1.55 GiB (23.0%) Init: systemd runlevel: 5 Compilers: gcc: N/A 
           Shell: bash v: 4.4.20 inxi: 3.0.32
¿Veis algo raro?
¿Alguna idea?

Gracias de antemano ;)

User avatar
JCSenar
Level 10
Level 10
Posts: 3381
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas con Wine en 19.3

Post by JCSenar »

jomimaro wrote:
Thu Mar 26, 2020 12:57 pm
Buenas gente,

Sí, soy otro de los que tiene problemas con wine en Mint 19.3 y como estos días no tengo demasiado que hacer me he decidido a intentar que funcione, con vuestra ayuda claro ;)
Sigo sin entender qué problema está habiendo. A mi me sigue funcionando la solución que encontré:

Code: Select all

juancar@VM-LM193M:~$ sudo dpkg --add-architecture i386
[sudo] contraseña para juancar:        
juancar@VM-LM193M:~$  wget -nc https://dl.winehq.org/wine-builds/winehq.key
--2020-03-26 19:56:02--  https://dl.winehq.org/wine-builds/winehq.key
Resolviendo dl.winehq.org (dl.winehq.org)... 151.101.134.217
Conectando con dl.winehq.org (dl.winehq.org)[151.101.134.217]:443... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 3220 (3,1K) [application/pgp-keys]
Guardando como: “winehq.key”

winehq.key          100%[===================>]   3,14K  --.-KB/s    en 0s      

2020-03-26 19:56:03 (12,3 MB/s) - “winehq.key” guardado [3220/3220]

juancar@VM-LM193M:~$  sudo apt-key add winehq.key
OK
juancar@VM-LM193M:~$ sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
juancar@VM-LM193M:~$  sudo apt-get update && sudo apt-get install --install-recommends -y winehq-stable
Obj:1 http://archive.canonical.com/ubuntu bionic InRelease
Obj:2 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Obj:3 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Des:4 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6.259 B]      
Obj:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                
Obj:6 http://archive.ubuntu.com/ubuntu bionic-backports InRelease              
Ign:7 http://packages.linuxmint.com tricia InRelease                           
Obj:8 http://packages.linuxmint.com tricia Release     
Des:9 https://dl.winehq.org/wine-builds/ubuntu bionic/main i386 Packages [620 kB]
Des:10 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages [585 kB]
Descargados 1.212 kB en 1s (1.434 kB/s)                                        
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 winehq-stable : Depende: wine-stable (= 5.0.0~bionic)
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Code: Select all

juancar@VM-LM193M:~$  sudo apt-add-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main' 
juancar@VM-LM193M:~$  wget -nv https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key -O Release.key
2020-03-26 19:57:37 URL:https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key [1089/1089] -> "Release.key" [1]
juancar@VM-LM193M:~$  sudo apt-key add - < Release.key
OK
juancar@VM-LM193M:~$  sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./'
juancar@VM-LM193M:~$  sudo apt-get update
Obj:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Obj:2 http://archive.canonical.com/ubuntu bionic InRelease                     
Obj:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                
Obj:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease              
Obj:5 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Des:6 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease [1.562 B]
Ign:7 http://packages.linuxmint.com tricia InRelease                           
Obj:8 http://packages.linuxmint.com tricia Release     
Des:9 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ Packages [21,8 kB]
Descargados 23,4 kB en 1s (31,0 kB/s)                    
Leyendo lista de paquetes... Hecho
juancar@VM-LM193M:~$  sudo apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  gcc-8-base:i386 gstreamer1.0-plugins-base:i386 libasn1-8-heimdal:i386
  libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libatomic1:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libblkid1:i386 libbsd0:i386 libc6:i386 libcairo2:i386 libcap2:i386
  libcapi20-3 libcapi20-3:i386 libcdparanoia0:i386 libcom-err2:i386
  libcups2:i386 libdb5.3:i386 libdbus-1-3:i386 libdrm-amdgpu1:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386
  libedit2:i386 libegl-mesa0:i386 libegl1:i386 libelf1:i386 libexif12:i386
  libexpat1:i386 libfaudio0 libfaudio0:i386 libffi6:i386 libflac8:i386
  libfontconfig1:i386 libfreetype6:i386 libgbm1:i386 libgcc1:i386
  libgcrypt20:i386 libgd3:i386 libgl1:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libgmp10:i386 libgnutls30:i386
  libgpg-error0:i386 libgphoto2-6:i386 libgphoto2-port12:i386 libgpm2:i386
  libgsm1:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhogweed4:i386 libhx509-5-heimdal:i386 libicu60:i386 libidn2-0:i386
  libieee1284-3:i386 libjack-jackd2-0:i386 libjbig0:i386 libjpeg-turbo8:i386
  libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libldap-2.4-2:i386
  libllvm9:i386 libltdl7:i386 liblz4-1:i386 liblzma5:i386 libmount1:i386
  libmpg123-0:i386 libncurses5:i386 libnettle6:i386 libodbc1 libodbc1:i386
  libogg0:i386 libopenal1:i386 libopus0:i386 liborc-0.4-0:i386 libosmesa6
  libosmesa6:i386 libp11-kit0:i386 libpcap0.8:i386 libpciaccess0:i386
  libpcre3:i386 libpixman-1-0:i386 libpng16-16:i386 libpulse0:i386
  libroken18-heimdal:i386 libsamplerate0:i386 libsane1:i386 libsasl2-2:i386
  libsasl2-modules:i386 libsasl2-modules-db:i386 libsdl2-2.0-0:i386
  libselinux1:i386 libsensors4:i386 libsndfile1:i386 libsndio6.1:i386
  libspeexdsp1:i386 libsqlite3-0:i386 libssl1.1:i386 libstdc++6:i386
  libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386
  libtinfo5:i386 libudev1:i386 libunistring2:i386 libusb-1.0-0:i386
  libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libvisual-0.4-0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libwayland-client0:i386
  libwayland-cursor0:i386 libwayland-egl1:i386 libwayland-egl1-mesa:i386
  libwayland-server0:i386 libwebp6:i386 libwind0-heimdal:i386 libwrap0:i386
  libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
  libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
  libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
  libxkbcommon0:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386
  libxrender1:i386 libxshmfence1:i386 libxslt1.1:i386 libxss1:i386
  libxxf86vm1:i386 ocl-icd-libopencl1 ocl-icd-libopencl1:i386 wine-stable
  wine-stable-amd64 wine-stable-i386:i386 zlib1g:i386
Paquetes sugeridos:
  gvfs:i386 glibc-doc:i386 locales:i386 rng-tools:i386 libgd-tools:i386
  gnutls-bin:i386 gphoto2:i386 gpm:i386 krb5-doc:i386 krb5-user:i386
  libvisual-0.4-plugins:i386 gstreamer1.0-tools:i386 jackd2:i386 libmyodbc
  odbc-postgresql tdsodbc unixodbc-bin libmyodbc:i386 odbc-postgresql:i386
  tdsodbc:i386 unixodbc-bin:i386 libportaudio2:i386 opus-tools:i386 hplip:i386
  libsasl2-modules-gssapi-mit:i386 | libsasl2-modules-gssapi-heimdal:i386
  libsasl2-modules-ldap:i386 libsasl2-modules-otp:i386
  libsasl2-modules-sql:i386 lm-sensors:i386 sndiod:i386 opencl-icd
  opencl-icd:i386
Se instalarán los siguientes paquetes NUEVOS:
  gcc-8-base:i386 gstreamer1.0-plugins-base:i386 libasn1-8-heimdal:i386
  libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libatomic1:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libblkid1:i386 libbsd0:i386 libc6:i386 libcairo2:i386 libcap2:i386
  libcapi20-3 libcapi20-3:i386 libcdparanoia0:i386 libcom-err2:i386
  libcups2:i386 libdb5.3:i386 libdbus-1-3:i386 libdrm-amdgpu1:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386
  libedit2:i386 libegl-mesa0:i386 libegl1:i386 libelf1:i386 libexif12:i386
  libexpat1:i386 libfaudio0 libfaudio0:i386 libffi6:i386 libflac8:i386
  libfontconfig1:i386 libfreetype6:i386 libgbm1:i386 libgcc1:i386
  libgcrypt20:i386 libgd3:i386 libgl1:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libgmp10:i386 libgnutls30:i386
  libgpg-error0:i386 libgphoto2-6:i386 libgphoto2-port12:i386 libgpm2:i386
  libgsm1:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhogweed4:i386 libhx509-5-heimdal:i386 libicu60:i386 libidn2-0:i386
  libieee1284-3:i386 libjack-jackd2-0:i386 libjbig0:i386 libjpeg-turbo8:i386
  libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libldap-2.4-2:i386
  libllvm9:i386 libltdl7:i386 liblz4-1:i386 liblzma5:i386 libmount1:i386
  libmpg123-0:i386 libncurses5:i386 libnettle6:i386 libodbc1 libodbc1:i386
  libogg0:i386 libopenal1:i386 libopus0:i386 liborc-0.4-0:i386 libosmesa6
  libosmesa6:i386 libp11-kit0:i386 libpcap0.8:i386 libpciaccess0:i386
  libpcre3:i386 libpixman-1-0:i386 libpng16-16:i386 libpulse0:i386
  libroken18-heimdal:i386 libsamplerate0:i386 libsane1:i386 libsasl2-2:i386
  libsasl2-modules:i386 libsasl2-modules-db:i386 libsdl2-2.0-0:i386
  libselinux1:i386 libsensors4:i386 libsndfile1:i386 libsndio6.1:i386
  libspeexdsp1:i386 libsqlite3-0:i386 libssl1.1:i386 libstdc++6:i386
  libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386
  libtinfo5:i386 libudev1:i386 libunistring2:i386 libusb-1.0-0:i386
  libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libvisual-0.4-0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libwayland-client0:i386
  libwayland-cursor0:i386 libwayland-egl1:i386 libwayland-egl1-mesa:i386
  libwayland-server0:i386 libwebp6:i386 libwind0-heimdal:i386 libwrap0:i386
  libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
  libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
  libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
  libxkbcommon0:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386
  libxrender1:i386 libxshmfence1:i386 libxslt1.1:i386 libxss1:i386
  libxxf86vm1:i386 ocl-icd-libopencl1 ocl-icd-libopencl1:i386 wine-stable
  wine-stable-amd64 wine-stable-i386:i386 winehq-stable zlib1g:i386
0 actualizados, 178 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 190 MB de archivos.
Se utilizarán 1.351 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] 
Y se instala sin problemas.

La info (es una máquina virtual pero, para el caso, da lo mismo).

Code: Select all

juancar@VM-LM193M:~$ inxi -Fxzrn
System:
  Host: VM-LM193M Kernel: 5.3.0-42-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Virtualbox System: innotek product: VirtualBox v: 1.2 
  serial: <filter> 
  Mobo: Oracle model: VirtualBox v: 1.2 serial: <filter> BIOS: innotek 
  v: VirtualBox date: 12/01/2006 
CPU:
  Topology: Dual Core model: Intel Core i5-4590 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 13169 
  Speed: 3292 MHz min/max: N/A Core speeds (MHz): 1: 3292 2: 3292 
Graphics:
  Device-1: InnoTek Systemberatung VirtualBox Graphics Adapter 
  driver: vboxvideo v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1320x676~60Hz 
  OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.8 
  direct render: Yes 
Audio:
  Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0 
  v: kernel bus ID: 00:05.0 
  Sound Server: ALSA v: k5.3.0-42-generic 
Network:
  Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: 7.3.21-k8-NAPI 
  port: d010 bus ID: 00:03.0 
  IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge 
  driver: piix4_smbus v: N/A port: d200 bus ID: 00:07.0 
Drives:
  Local Storage: total: 200.00 GiB used: 28.91 GiB (14.5%) 
  ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 100.00 GiB 
  ID-2: /dev/sdb vendor: VirtualBox model: VBOX HARDDISK size: 100.00 GiB 
Partition:
  ID-1: / size: 97.93 GiB used: 10.13 GiB (10.3%) fs: ext4 dev: /dev/sdb1 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
  1: deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 157 Uptime: 7m Memory: 1.92 GiB used: 552.3 MiB (28.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 
juancar@VM-LM193M:~$ 
Aunque no creo que tenga que ver con este problema, tienes una repo de xenial (ubuntu 16.04) que no corresponde con LM 19.3:

Code: Select all

Active apt repos in: /etc/apt/sources.list.d/zerotier.list 
           1: deb http://download.zerotier.com/debian/xenial xenial main
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

Buenas,

He eliminado todos los repositorios externos con sus firmas por si las moscas antes de empezar.
También he purgado y le he dado a problemas de merge list desde fuentes de software.

Con esto he ido poniendo lo que indicabas:

Code: Select all

peo@SKYNET:~$ sudo dpkg --add-architecture i386
[sudo] contraseña para peo:       
peo@SKYNET:~$ wget -nc https://dl.winehq.org/wine-builds/winehq.key
--2020-03-27 17:51:58--  https://dl.winehq.org/wine-builds/winehq.key
Resolviendo dl.winehq.org (dl.winehq.org)... 151.101.134.217
Conectando con dl.winehq.org (dl.winehq.org)[151.101.134.217]:443... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 3220 (3,1K) [application/pgp-keys]
Guardando como: “winehq.key”

winehq.key          100%[===================>]   3,14K  --.-KB/s    en 0s      

2020-03-27 17:51:58 (16,5 MB/s) - “winehq.key” guardado [3220/3220]

peo@SKYNET:~$ sudo apt-key add winehq.key
OK
peo@SKYNET:~$ sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
peo@SKYNET:~$ sudo apt-get update && sudo apt-get install --install-recommends -y winehq-stable
Obj:1 http://archive.canonical.com/ubuntu bionic InRelease
Obj:2 http://mirror.tedra.es/ubuntu bionic InRelease                           
Obj:3 http://mirror.tedra.es/ubuntu bionic-updates InRelease                   
Obj:4 http://mirror.tedra.es/ubuntu bionic-backports InRelease                 
Ign:5 http://mirror6.layerjet.com/linuxmint/packages tricia InRelease          
Obj:6 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Obj:7 http://mirror6.layerjet.com/linuxmint/packages tricia Release            
Des:8 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6.259 B]      
Des:10 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages [585 kB]
Des:11 https://dl.winehq.org/wine-builds/ubuntu bionic/main i386 Packages [620 kB]
Descargados 1.212 kB en 8s (158 kB/s)                                          
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 winehq-stable : Depende: wine-stable (= 5.0.0~bionic)
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
peo@SKYNET:~$ sudo apt-add-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main' 
peo@SKYNET:~$ wget -nv https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key -O Release.key
2020-03-27 17:53:39 URL:https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key [1089/1089] -> "Release.key" [1]
peo@SKYNET:~$ sudo apt-key add - < Release.key
OK
peo@SKYNET:~$ sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./'
peo@SKYNET:~$ sudo apt-get update
Obj:1 http://mirror.tedra.es/ubuntu bionic InRelease
Obj:2 http://mirror.tedra.es/ubuntu bionic-updates InRelease                   
Obj:3 http://mirror.tedra.es/ubuntu bionic-backports InRelease                 
Ign:4 http://mirror6.layerjet.com/linuxmint/packages tricia InRelease          
Obj:5 http://archive.canonical.com/ubuntu bionic InRelease                     
Obj:6 http://mirror6.layerjet.com/linuxmint/packages tricia Release            
Obj:7 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Des:8 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease [1.562 B]
Des:10 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ Packages [21,8 kB]
Descargados 23,4 kB en 2s (12,9 kB/s)
Leyendo lista de paquetes... Hecho
peo@SKYNET:~$ sudo apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 winehq-stable : Depende: wine-stable (= 5.0.0~bionic)
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
peo@SKYNET:~$ 
Pero el resultado final no ha sido el mismo :P

Ahora mismo el sistema está así:

Code: Select all

peo@SKYNET:~$ inxi -Fxzrn
System:    Host: SKYNET Kernel: 4.15.0-91-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: Acer product: Aspire E5-521 v: V1.01 serial: <filter> 
           Mobo: Acer model: Larne v: V1.01 serial: <filter> UEFI: Insyde v: 1.01 date: 05/27/2014 
Battery:   ID-1: BAT1 charge: 47.7 Wh condition: 47.7/55.9 Wh (85%) model: COMPAL PABAS0241231 status: Full 
CPU:       Topology: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics bits: 64 type: MCP arch: Puma rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 14372 
           Speed: 998 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 998 2: 998 3: 998 4: 998 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] vendor: Acer Incorporated ALI 
           driver: radeon v: kernel bus ID: 00:01.0 
           Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: AMD KABINI (DRM 2.50.0 4.15.0-91-generic LLVM 9.0.0) v: 4.5 Mesa 19.2.8 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:01.1 
           Device-2: Advanced Micro Devices [AMD] FCH Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k4.15.0-91-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: 2.3LK-NAPI port: 2000 bus ID: 01:00.1 
           IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Lite-On driver: ath9k v: kernel 
           port: 2000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-3: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb bus ID: 1-1.3:5 
           IF-ID-1: ztyqbqkj3a state: unknown speed: 10 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 223.57 GiB used: 96.99 GiB (43.4%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB temp: 27 C 
Partition: ID-1: / size: 171.00 GiB used: 96.96 GiB (56.7%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 44.9 C mobo: N/A gpu: radeon temp: 45 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           1: deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://mirror6.layerjet.com/linuxmint/packages tricia main upstream import backport
           2: deb http://mirror.tedra.es/ubuntu bionic main restricted universe multiverse
           3: deb http://mirror.tedra.es/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://mirror.tedra.es/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 203 Uptime: 10m Memory: 6.77 GiB used: 1.35 GiB (20.0%) Init: systemd runlevel: 5 Compilers: gcc: N/A 
           Shell: bash v: 4.4.20 inxi: 3.0.32 
Si se os ocurre alguna cosilla más para probar estoy animado a hacerlo.
Para reinstalar el sistema siempre tengo tiempo :)

User avatar
JCSenar
Level 10
Level 10
Posts: 3381
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas con Wine en 19.3

Post by JCSenar »

jomimaro wrote:
Fri Mar 27, 2020 1:11 pm
Si se os ocurre alguna cosilla más para probar estoy animado a hacerlo.
Para reinstalar el sistema siempre tengo tiempo :)
:roll: :(
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

Una cosilla extra.
En principio no me importa demasiado la versión de Wine a instalar, al menos de momento, lo que tengo que ejecutar es un juego no demasiado exigente. Si hay una versión concreta que funcione bien, o al menos tenga más papeletas de funcionar, la pruebo.
Con PlayOnLinux la primera vez arrancó, pero sin audio y muy inestable, pero ya nunca más :(

User avatar
JCSenar
Level 10
Level 10
Posts: 3381
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas con Wine en 19.3

Post by JCSenar »

jomimaro wrote:
Sat Mar 28, 2020 6:28 am
Una cosilla extra.
En principio no me importa demasiado la versión de Wine a instalar, al menos de momento, lo que tengo que ejecutar es un juego no demasiado exigente. Si hay una versión concreta que funcione bien, o al menos tenga más papeletas de funcionar, la pruebo.
Con PlayOnLinux la primera vez arrancó, pero sin audio y muy inestable, pero ya nunca más :(
En el Gestor de Software lo tienes disponible también, aunque sea una versión anterior:

Pantallazo-2020-03-28 13-24-08.png
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

Por desgracia aparecen en el listado pero no están disponibles para instalar, ni "wine" ni "wine-stable".
Le he dado otra oportunidad a PlayOnLinux pero tampoco ha habido manera.

Si no hay más cosas para probar cierro el hilo y en cuanto pueda reinstalo el sistema para empezar desde el principio.

Gracias ;)

User avatar
JCSenar
Level 10
Level 10
Posts: 3381
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas con Wine en 19.3

Post by JCSenar »

jomimaro wrote:
Sat Mar 28, 2020 1:27 pm
Por desgracia aparecen en el listado pero no están disponibles para instalar, ni "wine" ni "wine-stable".
Curioso. A otro usuario le pasaba lo mismo. Ni le funcionaba la solución que he comentado ni podía instalar otras versiones desde el Gestor de Software.

A mí me funciona todo... :shock: :shock:
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
tomeu
Level 6
Level 6
Posts: 1219
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas con Wine en 19.3

Post by tomeu »

A mi se me ofrecen listas para instalar sin problema:
Wine entre blas recomendaciones del editor
Wine entre blas recomendaciones del editor
Wine instalando
Wine instalando
Play On LInux instalando
Play On LInux instalando
Image
Linux Mint Tricia 19.3 64bits Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

User avatar
tomeu
Level 6
Level 6
Posts: 1219
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas con Wine en 19.3

Post by tomeu »

Y más aún:
Q4wine preparandose para ser instalado
Q4wine preparandose para ser instalado
winetricks listo para instalar
winetricks listo para instalar

Hasta en "Debbie" (LMDE 4) los paquietes de Wine están OK en los repositorios (al menos hoy):
Paquetes ref Wine en LMDE 4 Debbie
Paquetes ref Wine en LMDE 4 Debbie
Image
Linux Mint Tricia 19.3 64bits Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

JCSenar wrote:
Sat Mar 28, 2020 2:05 pm
Curioso. A otro usuario le pasaba lo mismo. Ni le funcionaba la solución que he comentado ni podía instalar otras versiones desde el Gestor de Software.
Sí, es justo del hilo que cité al principio. Por ahí empecé a probar, quizás repliqué algo incorrecto y he terminado en la misma situación, quién sabe...

tomeu wrote:
Sun Mar 29, 2020 3:47 am
A mi se me ofrecen listas para instalar sin problema:
Ya, de verdad que no lo dudo, pero siempre tiene que haber alguien especial y me ha tocado a mi :)

Lo que sí se instala "bien" es PlayOnLinux, que instala "wine-development=3.6-1", "wine64-development=3.6-1" y "libwine-development=3.6-1". El problema es que al ejecutarlo termina pidiendo "wine32-development" que no está en el respositorio y es lo que provocó que buscara una solución instalando otra versión.


Bueno, lo dicho, si no se nos ocurre nada más, por mi parte podemos cerrar el hilo.

Gracias a los dos en cualquier caso ;)

User avatar
tomeu
Level 6
Level 6
Posts: 1219
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas con Wine en 19.3

Post by tomeu »

jomimaro wrote:
Sun Mar 29, 2020 7:31 am
Ya, de verdad que no lo dudo, pero siempre tiene que haber alguien especial y me ha tocado a mi :)
El "Gestor de Software" bebe de las mismas fuentes que "apt" y/o "synaptic". Por el "inxi" que has puesto hay un PPA de wine sacado de un servidor de OpenSuse, y luego usas los espejos de Layerjet y Tedra. Yo no tengo PPAs activados, y los repositorios originales.

Desactiva ese PPA y cambia los espejos de repositorios, actualiza la cache y prueba de nuevo.
Image
Linux Mint Tricia 19.3 64bits Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

tomeu wrote:
Sun Mar 29, 2020 12:35 pm
Desactiva ese PPA y cambia los espejos de repositorios, actualiza la cache y prueba de nuevo.
Sí porque ese informe es después de probar esa instalación, pero para no dejar basura después de cada prueba hago limpia. De hecho tenía dos que estoy utilizando (aparecen en el primer post) pero también han ido fuera para evitar posibles problemas.

En cualquier caso, como probar es gratis :) borro repos, ppa y firmas:

Code: Select all

peo@SKYNET:~$ inxi -Fxznr
System:    Host: SKYNET Kernel: 4.15.0-91-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: Acer product: Aspire E5-521 v: V1.01 serial: <filter> 
           Mobo: Acer model: Larne v: V1.01 serial: <filter> UEFI: Insyde v: 1.01 date: 05/27/2014 
Battery:   ID-1: BAT1 charge: 47.7 Wh condition: 47.7/55.9 Wh (85%) model: COMPAL PABAS0241231 status: Full 
CPU:       Topology: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics bits: 64 type: MCP arch: Puma rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 14372 
           Speed: 998 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 998 2: 998 3: 998 4: 998 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] vendor: Acer Incorporated ALI 
           driver: radeon v: kernel bus ID: 00:01.0 
           Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: AMD KABINI (DRM 2.50.0 4.15.0-91-generic LLVM 10.0.0) v: 4.5 Mesa 20.0.2 - kisak-mesa PPA 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:01.1 
           Device-2: Advanced Micro Devices [AMD] FCH Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k4.15.0-91-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: 2.3LK-NAPI port: 2000 bus ID: 01:00.1 
           IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Lite-On driver: ath9k v: kernel 
           port: 2000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-3: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb bus ID: 1-1.3:5 
           IF-ID-1: ztyqbqkj3a state: unknown speed: 10 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 223.57 GiB used: 106.29 GiB (47.5%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB 
Partition: ID-1: / size: 171.00 GiB used: 106.26 GiB (62.1%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A gpu: radeon temp: 50 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://mirror6.layerjet.com/linuxmint/packages tricia main upstream import backport
           2: deb http://mirror.tedra.es/ubuntu bionic main restricted universe multiverse
           3: deb http://mirror.tedra.es/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://mirror.tedra.es/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 220 Uptime: 2h 06m Memory: 6.77 GiB used: 2.20 GiB (32.5%) Init: systemd runlevel: 5 Compilers: gcc: N/A 
           Shell: bash v: 4.4.20 inxi: 3.0.32 
Y abro el gestor, pero paquetes como wine o wine-stable siguen apareciendo como "No disponible" :(
(No mando pantallazo porque el botón desactivado no genera mucha información :P )

User avatar
JOPETA
Level 16
Level 16
Posts: 6452
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con Wine en 19.3

Post by JOPETA »

Está indicado en este hilo. Quizás debiste leer la advertencia de las Notas de lanzamiento sobre wine y seguir las indicaciones.
Wine 4.0

Para instalar la versión estable de WINE desde WineHQ, abrir un terminal y copiar y pegar:

Code: Select all

apt install --install-recommends wine-installer
Entre otras cosas esto instalará wine-desktop-files, que añade entradas de menú para regedit, la unidad C:\ y otros items que se han perdido en la versión recibida respecto a la de WINE.

También puedes seguir las indicaciones de WineHQ, para instalar tanto la versión estable como la de pruebas y para desallodores y asegurar que wine-desktop-files está instalado.

Actualizando a la versión 4

Si tu ya tenías instalada la versión wine-stable 3.0 o wine-development 3.6 antes de que se añadiera la versión 4.0 al repositorio, aplica las actualizaciones pendientes para llevarlo a la versión 4.0 y ejecuta los siguiente códigos en la terminal para instalar los paquetes perdidos

Code: Select all

apt install --install-recommends wine-installer
Para limpiar ejecuta los siguientes códigos para listar todos los paquetes de wine 3.0:

Code: Select all

dpkg -l | grep wine | grep "3\."
Estos paquetes pueden ser eliminados.

También puedes reinstalar PlayOnLinux si fue eliminado durante la actualización.
Para los que recurran a la instalación de versiones mas actuales de Wine ( Win 5 por ejemplo) desde wineHQ como se indica, leer las advertencias que se realizan sobre el problema de dependencias en Ubuntu 18.04 (y derivados como LM19.X) y de cómo tratar de resolverlo en el enlace que suministran, así como los numerosos hilos existentes en el foro con los problemas que originan las instalaciones fallidas.

También tener en cuenta que la instalación de Playonlinux que se comenta al final de la cita permite la coexistencia de diferentes versiones de Wine y facilita la instalación de esas versiones diferentes a la 4.0.
Last edited by JOPETA on Wed Apr 01, 2020 2:08 am, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)

photon_man
Level 1
Level 1
Posts: 9
Joined: Mon Jun 26, 2017 12:08 pm

Re: Problemas con Wine en 19.3

Post by photon_man »

Me sumo al compañero que abrió el hilo... Tengo exactamente el mismo problema, con los mismos mensajes de error. Y si con algo de suerte consigo instalar Wine, una vez que está instalado, no consigo instalar ni ejecutar ni una sola de las aplicaciones de Windows que he probado.

Tendré que buscar información en inglés, porque en castellano la verdad es que no he visto nada útil todavía. Dejo constancia aquí de mi situación por si alguien en el futuro encuentra forma de arreglarlo...

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

JOPETA wrote:
Mon Mar 30, 2020 7:24 pm
Está indicado en este hilo. Quizas debiste leer la advertencia de las Notas de lanzamiento sobre wine y seguir las indicaciones
El hilo lo leí y estuve probando lo indicado antes de abrir este. Como estaba citado en el hilo que pongo al principio pasé por ahí también :)
Sobre las notas de lanzamiento, pues el tema es que cuando actualicé a 19.3 no sabía que iba a necesitar wine, por lo que me era un poco complicado valorarlo :-o

photon_man wrote:
Tue Mar 31, 2020 1:19 pm
Me sumo al compañero que abrió el hilo... Tengo exactamente el mismo problema, con los mismos mensajes de error. Y si con algo de suerte consigo instalar Wine, una vez que está instalado, no consigo instalar ni ejecutar ni una sola de las aplicaciones de Windows que he probado.
Mucho ánimo ;)

User avatar
tomeu
Level 6
Level 6
Posts: 1219
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas con Wine en 19.3

Post by tomeu »

jomimaro wrote:
Mon Mar 30, 2020 6:11 pm
En cualquier caso, como probar es gratis :) borro repos, ppa y firmas:

Code: Select all

peo@SKYNET:~$ inxi -Fxznr
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://mirror6.layerjet.com/linuxmint/packages tricia main upstream import backport
           2: deb http://mirror.tedra.es/ubuntu bionic main restricted universe multiverse
           3: deb http://mirror.tedra.es/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://mirror.tedra.es/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
Y abro el gestor, pero paquetes como wine o wine-stable siguen apareciendo como "No disponible" :(
(No mando pantallazo porque el botón desactivado no genera mucha información :P )
Los paquetes "oficiales" de wine no están en las PPA que eliminaste, a veces los "espejos" -aunque más rápidos- no nos dan lo mismo que los servidores principales.
Disculpas si no lo suficientemente claro en esto. Prueba con ello (poner los originales en lugar de layerjet y tedra); clic en "configuración predeterminada"
fuentes-soft.png
Image
Linux Mint Tricia 19.3 64bits Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

User avatar
JOPETA
Level 16
Level 16
Posts: 6452
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con Wine en 19.3

Post by JOPETA »

Este tipo de hilos son como el día de la marmota leido uno leido todos. Siguiendo las instrucciones de las notas de lanzamiento de Mint (es decir instalar wine-installer para instalar wine 4) o las que proporciona JCSenar para instalar wine 5 desde el principio no existen problemas de instalación..

Luego están los problemas "normales" que presenta el uso de Wine para los que se encontrarán soluciones en sus foros. Yo no soy jugón y no frecuento el subforo dedicado a juegos en el foro principal, sigo con Windows para esa aplicaciones especiales y prefiero el uso de Máquinas virtuales en caso de necesidad. Supongo que los "habituales" en este foro son parecidos ya que pocos aportan tutoriales o comparten soluciones a problemas específicos de wine, playonlinux, wintricks,... :roll: .

El problema de las dependencias al instalar se origina tanto tratando de instalar paquetes individuales del repositorio de Ubuntu como desde repositorios externos, mas si se siguen tutoriales que obvian lo mas esencial, Linux Mint no es el Ubuntu en que se basa (aunque por momentos haya menos diferencias) y Ubuntu a su vez no es Debian aunque se base en él.

Según los de wineHQ lo que hay que hacer es como dice jomimomaro,
jomimaro wrote:
Mon Mar 30, 2020 6:11 pm
para no dejar basura después de cada prueba hago limpia.
Sin embargo son pocos los que aseguran que dicha limpia se ha producido antes de volver a la carga con el resultado de los siguientes códigos.

Code: Select all

dpkg -l "*wine*" 
inxi -r | grep wine
El segundo código asegura que no se han olvidado repositorios no oficiales que hay que purgar y el primer código localiza los restos de paquetes de wine olvidados (precedidos de ii) que hay que eliminar completamente antes de volver a intentarlo desde cero sea con wine 4 o con wine 5.

Ante cualquier error a la hora de desinstalar que haga mención a paquetes nativos (como pulseaudio) o la desinstalación masiva de paquetes del sistema, requerirá de un cierto dominio en el arreglo de problemas de dependencias mas allá el simple apt install --fix-broken o apt install -f . En tales casos el uso de Timeshft para volver a una situación anterior al intento de instalación es lo mas rápido y aconsejable.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)

jomimaro
Level 1
Level 1
Posts: 14
Joined: Mon Sep 09, 2019 9:32 am

Re: Problemas con Wine en 19.3

Post by jomimaro »

tomeu wrote:
Wed Apr 01, 2020 1:06 am
Los paquetes "oficiales" de wine no están en las PPA que eliminaste, a veces los "espejos" -aunque más rápidos- no nos dan lo mismo que los servidores principales.
Disculpas si no lo suficientemente claro en esto. Prueba con ello (poner los originales en lugar de layerjet y tedra); clic en "configuración predeterminada"
Ah! Perdona, no te entendí.
Por desgracia la prueba tampoco ha ido bien :(

JOPETA wrote:
Wed Apr 01, 2020 4:59 am
Sin embargo son pocos los que aseguran que dicha limpia se ha producido antes de volver a la carga con el resultado de los siguientes códigos.

Code: Select all

dpkg -l "*wine*" 
inxi -r | grep wine
Pues es cierto que yo no los solía utilizar.
Suelo buscar con esto:

Code: Select all

apt list --installed|grep wine
Pero tampoco han devuelto resultados:

Code: Select all

peo@SKYNET:~$ sudo dpkg -l "*wine*" 
[sudo] contraseña para peo:       
dpkg-query: no se ha encontrado ningún paquete que corresponda con *wine*.
peo@SKYNET:~$ sudo inxi -r | grep wine
peo@SKYNET:~$ 
Y respecto a las copias de seguridad, de momento no he tenido que recuperar nada. Estoy en ese punto en el que soy lo suficientemente torpe como para no dar con una solución, pero no lo suficiente como para romper algo más :-o
Total, que wine no consigo que funcione, pero el resto no se ha inmutado de las pruebas :)

JOPETA wrote:
Wed Apr 01, 2020 4:59 am
Luego están los problemas "normales" que presenta el uso de Wine para los que se encontrarán soluciones en sus foros. Yo no soy jugón y no frecuento el subforo dedicado a juegos en el foro principal, sigo con Windows para esa aplicaciones especiales y prefiero el uso de Máquinas virtuales en caso de necesidad. Supongo que los "habituales" en este foro son parecidos ya que pocos aportan tutoriales o comparten soluciones a problemas específicos de wine, playonlinux, wintricks,... :roll: .
Lo mismo me pasa, intento utilizar windows lo menos posible y lo tengo instalado con una etiqueta de "usar solo en caso de necesidad" pero me ha surgido esto y quería intentar solucionarlo.
Como parece que la opción de wine en mi caso no da para más lo intentaré con una máquina virtual, pero mi pobre ordena no está para muchos trotes o sea que tampoco le auguro un futuro prometedor :P

De nuevo gracias por el esfuerzo ;)

Post Reply

Return to “Español (Spanish)”