Instalando Master pdf editor

Los usuarios de español pueden hablar su idioma nativo aquí

Moderator: tomeu

Post Reply
rayman
Level 1
Level 1
Posts: 3
Joined: Wed Jan 08, 2020 12:04 am

Instalando Master pdf editor

Post by rayman »

Hola, estoy intentando instalar Master PDF Editor y tomé varios consejos de acá (viewtopic.php?t=269922). Antes de ver el foro había descargado la versión 5.x y tenía muchas restricciones, por ello busqué información y bajé versiones en formatos que no supe instalar muy bien como los terminados en .tar.gz y otros más. Recientemente descargué uno terminado en .deb, pero al haber instalado otro sin éxito previo a éste, tengo mensajes de error que detallo:

Code: Select all

sudo dpkg -i master-pdf-editor-3.5.81_amd64.deb
Seleccionando el paquete master-pdf-editor3 previamente no seleccionado.
(Leyendo la base de datos ... 331944 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar master-pdf-editor-3.5.81_amd64.deb ...
Desempaquetando master-pdf-editor3 (3.5.81) ...
dpkg: problemas de dependencias impiden la configuración de master-pdf-editor3:
 master-pdf-editor3 depende de libqt4-network (>= 4.6.4); sin embargo:
  El paquete `libqt4-network' no está instalado.
 master-pdf-editor3 depende de libqtcore4 (>= 4.6.4); sin embargo:
  El paquete `libqtcore4' no está instalado.
 master-pdf-editor3 depende de libqtgui4 (>= 4.6.4); sin embargo:
  El paquete `libqtgui4' no está instalado.

dpkg: error al procesar el paquete master-pdf-editor3 (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Procesando disparadores para gnome-menus (3.36.0-1ubuntu1) ...
Procesando disparadores para desktop-file-utils (0.24+linuxmint1) ...
Procesando disparadores para mime-support (3.64ubuntu1) ...
Se encontraron errores al procesar:
 master-pdf-editor3
Por esto eliminé todo lo que tuviera que ver con master pdf editor excepto el archivo que me interesa instalar, pero sigo teniendo problemas. En synaptic vi que tenía un paquete Roto, que tiene que ver justamente con master-pdf-editor3, lo desinstalé completamente, pero cuando coloco "sudo dpkg -i master-pdf-editor-3.5.81_amd64.deb" en la consola vuelve a dar el mismo error en Synaptic.

Como me habla de paquetes que no están instalados (como libqt4-network) busqué la forma de hacerlo, pero resulta lo siguiente:

Code: Select all

sudo apt-get install libqt4-network
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete libqt4-network no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «libqt4-network» no tiene un candidato para la instalación
Alguien podría ayudarme? Creo que se nota que soy ignorante aún en lo que a linux se refiere, pero quisiera entender en qué me estoy equivocando. Muchas gracias!
User avatar
Ezee1015
Level 3
Level 3
Posts: 118
Joined: Fri Oct 23, 2020 7:38 pm
Location: Cerca del Planeta Tierra

Re: Instalando Master pdf editor

Post by Ezee1015 »

Te está sucediendo el gran problema que pasa con los .deb... Las dependencias. Para hacerlo simple: tienes una librería version 3 para un programa, pero el programa que deseas instalar utiliza la misma librería version 4, por lo que no te deja. La solución es instalar el programa en versión Flatpack, AppImage o Snap, donde ya tienen las librerías aisladas de las que tiene el sistema, por lo que podrás instalarte ese programa con ese tipo de paquetes. Lo encontré en Flatpack. Puedes Instalarlo desde este link o desde el centro de aplicaciones de Mint, pero asegurate que la fuente sea de Flathub en la descripción del centro. Espero haber sido de ayuda. Saludos
"La diferencia entre Windows y un virus es que el virus es gratis."
-------------------------------
"A computer is like air conditioning - it becomes useless when you open Windows" ~ Linus Torvalds
rayman
Level 1
Level 1
Posts: 3
Joined: Wed Jan 08, 2020 12:04 am

Re: Instalando Master pdf editor

Post by rayman »

Muchas gracias por tu respuesta! El asunto es que si instalo de la forma en que me señalas estaría instalando la versión 5.x, pero viene con restricciones que la versión 3.5.81 no trae (y que es la que estoy intentando hacer correr en mi computador). Busqué en la página que señalas esta versión pero no está :C
User avatar
tomeu
Level 6
Level 6
Posts: 1392
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Instalando Master pdf editor

Post by tomeu »

Prueba con la versión 4.3.89 (yo la uso sin problemas con LMint 20.1), tiene algunas limitaciones, pero pocas.
master_pdf_editor.png
Desde aquí: https://www.linuxuprising.com/2019/04/d ... linux.html
Image
Linux Mint Ulyssa 20.1 Cinnamon 4.8
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
Post Reply