Altavoces suenan mientras tengo conectados audifonos

Spanish Forum

Moderator: JCSenar

Post Reply
geovanni14
Level 1
Level 1
Posts: 3
Joined: Sat Aug 31, 2013 1:17 am

Altavoces suenan mientras tengo conectados audifonos

Post by geovanni14 » Sat Aug 31, 2013 1:50 am

Al conectar los audifonos a mi portatil no dejan de sonar los altavoces, necesito de su ayudaaaaa!

Adjunto imagen con la informacion del sistema.

Gracias!!
Attachments
Screenshot2.png
Last edited by geovanni14 on Sat Aug 31, 2013 1:18 pm, edited 1 time in total.

hectorsales
Level 4
Level 4
Posts: 291
Joined: Sun Jul 07, 2013 3:25 am

Re: Suenan los altavoces al conectar mis audifonos (cascos)

Post by hectorsales » Sat Aug 31, 2013 3:23 am

Hola que, tal a mi me ocurre exactamente lo mismo, lo he intentado por todos los métodos posibles pero no hay manera-a ver si tu tienes más suerte-por lo general esto funciona...

Consejo: Al final te he puesto los links desde donde he extraido la información no estaría mal que le echases un vistazo antes de hacer nada ....

1 ) Veamos el modelo de tu tarjeta. Abre la termina y escribe:
cat /proc/asound/modules

Con este comando veremos el driver de tu tarjeta que si no me equivoco visto la imagen adjunta es snd_intel8x0

2 ) Una vez tengamos claro el driver sólo hay que añadir este snd_intel8x0 al archivo /etc/modprobe.d/alsa-base.conf

En este paso dos antes de modificar, primero vamos hacer un respaldo o copia de seguridad de dicho archivo:

sudo cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.bak

Una vez hemos hecho la copia de seguridad por si metemos la pata al editar el archivo lo editamos ( yo lo he editado con el editor de texto pluma que viene por defecto en linux mint 13 Maya, tú lo has de editar con el que venga en linux mint 15) para ello escribimos en la terminal

gksudo pluma /etc/modprobe.d/alsa-base.conf

Nos pedirá la contraseña y escribimos esto al final del archivo

options snd-intel8x0

Le damos a guardar y cerramos.

3 -Matamos los procesos de pulseAudio abiertos y recargamos las ALSA

killall pulseaudio
sudo alsa force-reload


4-Reinicia y a ver si funciona.

Ya te digo que yo me he pasado bastantes horas recopilando información pero no he conseguido que a mi me funcione a mucha gente si le ha funcionado ....

Links desde donde he extraído la información:

http://www.lauraberdasco.com/2011/01/problemas-de-sonido-en-linux-mint/
http://ubuntuforums.org/showthread.php?t=1043568
http://ubuntuforums.org/showthread.php?t=1170537&highlight=vaio
http://www.ubuntu-es.org/node/168251#.UiGYzx1dXMZ
https://www.kernel.org/doc/Documentatio ... Models.txt

Saludos ... :wink:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

User avatar
hatteras
Level 9
Level 9
Posts: 2860
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: Suenan los altavoces al conectar mis audifonos (cascos)

Post by hatteras » Sat Aug 31, 2013 4:17 am

Instalar el paquete pavucontrol
http://hatteras.wordpress.com/2013/02/05/pavucontrol-control-de-volumen-de-pulse-audio/
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

hectorsales
Level 4
Level 4
Posts: 291
Joined: Sun Jul 07, 2013 3:25 am

Re: Suenan los altavoces al conectar mis audifonos (cascos)

Post by hectorsales » Sat Aug 31, 2013 4:27 am

Hola hatteras, yo ya tenía instalado el paquete pavucontrol y no me ha servido. En opción donde dice dispositivos de salida selecciono Auriculares y sigue saliendo el sonido por los altavoces..tanto reiniciando como sin reiniciar, también he probado en la terminal alsamixer y tampoco ... he incluso me lo he instalado graficamente paquete alsamixergui.. pero nada. No sé como solucionarlo, me gustaría hacer un inciso veo que el problema se da en la mayoría de equipos portátiles mi equipo es desktop (sobremesa) no sé si eso influye en el problema o es relevante a la hora de solucionar el problema ...

He abierto un hilo nuevo para no invadir el del compañero.

Saludos .... :wink:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

geovanni14
Level 1
Level 1
Posts: 3
Joined: Sat Aug 31, 2013 1:17 am

Re: Suenan los altavoces al conectar mis audifonos (cascos)

Post by geovanni14 » Sat Aug 31, 2013 12:49 pm

Hola hectorsales

Segui al pie de la letra todos los pasos que me describiste, al final reinicie pero sigue el problema.
Me parecen extraños los mensajes de error que me arroja al ingresar sudo alsa force-reload, adjunto imagen.

hatteras
Al igual que hectorsales, instale el paquete pavucontrol y no ha servido.Sigue saliendo el sonido por los altavoces mientras tengo conectados los audifonos.

:(

Gracias por sus aportes, siguo atento a sus comentarios y/o sugerencias.
Attachments
sudo alsa force-reload.png
Paso 3
options snd-intel8x0.png
Paso 2

hectorsales
Level 4
Level 4
Posts: 291
Joined: Sun Jul 07, 2013 3:25 am

Re: Altavoces suenan mientras tengo conectados audifonos

Post by hectorsales » Sat Aug 31, 2013 1:31 pm

Hola compañero aquí aporto más soluciones:

http://www.culturacuantica.com.ar/al-conectar-auriculares-no-se-desconectan-los-altavoces-ubuntu-solucionado/


Paso 1

Code: Select all

gksudo pluma /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

En este archivo vamos a buscar elemento Front, el cual controla la salida del speaker:

[Element Front]

switch = mute
volume = merge
override-map.1 = all-front
override-map.2 = front-left,front-right


Y reemplazamos por:

[Element Front]

switch = ignore
volume = ignore


Guardamos el archivo, reiniciamos la maquina y listo.

Paso 2

Esta configuración nos habilitará una nueva opción en las configuraciones de Sonido, Salida Analógica, y al seleccionar ésta los altavoces se silenciarán.

Saludos. :wink:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

geovanni14
Level 1
Level 1
Posts: 3
Joined: Sat Aug 31, 2013 1:17 am

Re: Altavoces suenan mientras tengo conectados audifonos

Post by geovanni14 » Sun Sep 01, 2013 1:45 pm

Hola hectorsales

Despues de seguir las instrucciones de la pagina que citas, el problema se mantiene.
Aunque en mi Linux Mint 15 la salida analogica aparece desde la instalacion
Realice los cambios sugeridos, reinicie el equipo y nada cambio.

:cry:

Adjunto imagen de las opciones de sonido, son muy distintas a las de el Ubuntu 11 de la pagina citada.

Saludos
Attachments
soundpref.png

hectorsales
Level 4
Level 4
Posts: 291
Joined: Sun Jul 07, 2013 3:25 am

Re: Altavoces suenan mientras tengo conectados audifonos

Post by hectorsales » Mon Sep 02, 2013 3:33 am

Hola que tal, he seguido investigando el tema creo que es complicado de solucionar por lo menos con mi chip de audio, escribe en la terminal : Nos mostrará el chip y codec de nuestra tarjeta de audio.

Code: Select all

cat /proc/asound/card0/codec#0 | grep Codec
Codec: VIA VT1708S


Esto es el chip y codec de mi tarjeta de audio.

Como te explico el problema no estan simple de soulucionar, entran en juego tres variables :pulseaudio, el kernel y el BIOS.

Veámos lo que se comento sobre el tema en foro: http://www.ubuntu-es.org/node/67248#.UiQ0kx1dXMZ

El problema no se resuelve con desinstalar pulseaudio, bueno depende, en mi situación con el mismo chip VIA VT1708B, los problemas eran 3; pulseaudio, el kernel y el BIOS. Usando Ubuntu 11.10 el kernel 3.0.0-13-generic y también aplica para el 3.0.0-14-generic.

**/Este problema está presente en (casi) todas las versiones de Ubuntu usando este chip, los tuve en Ubuntu 6.06, los tuve en Ubuntu 9.10, los tuve en Ubuntu 10.04, también por que no? en Ubuntu 11.04, puesto que usé esa versión aunque solo unas horas y no me detectó el chip./**

Desinstalé pulseaudio y lo problemas siguieron, empeoraron.

Después de muchos reinicios y de estar modificando el /etc/modprobe.d/alsa-base.conf. El problema se arregló cuando agregué esta línea:

snd-hda-intel options model=auto probe_mask=0x103 enable_msi=0

model=auto es el nombre de modelo que se debe dar a los chips VIA, que son configurados por el BIOS, según /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt, lo abres con zless.
probe_mask=0x103 es para forzar al driver de cargar el códec dentro de los "slots" 0 y 1, independientemente de lo que diga el BIOS, evidentemente esta opción se agrega cuando el BIOS este fallando.
enable_msi=0 este es para la calidad del audio en caso de que se escuche el sonido con interferencia y muy feo.


Esta información según: /usr/share/doc/alsa-base/driver/HD-Audio.txt, lo abres con zless.

Y cuando agregué la opción en /etc/default/grub dentro de GRUB_CMDLINE_LINUX_DEFAULT pci=use_crs

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

Este último por un posible bug en el kernel; https://bugs.launchpad.net/ubuntu/+sour ... bug/662299

Y el sonido no me ha fallado desde entonces, claro aún no instalo pulseaudio.
Esto es lo que hizo el compañero:

1 Edito el archivo /etc/modprobe.d/alsa-base.conf . Agrego al final de la línea:

snd-hda-intel options model=auto probe_mask=0x103 enable_msi=0

Nota: Perfectamente explicado lo que es cada opción.

2 Edito la el fichero /etc/default/grub y añadio a la linea: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" pci=use_crs

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

Una vez agragada procedió con un

Code: Select all

sudo update-grub
Nota: Aquí se esta hablando de un kernel 2.6 y versiones de ubuntu 11.xx-11.10. Mi kernel actual de 3.2 con lo cual esta opción no habría en teoría que ejecutarla. Aunque no estoy seguro ....

https://bugs.launchpad.net/ubuntu/+sour ... bug/662299

Esto es de momento lo que he encontrado, como ves el tema no es fácil de solucionar a simple vista por lo menos con mi chip y codec de audio Codec: VIA VT1708S.

Saludos :wink: :mrgreen:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

carlos77
Level 1
Level 1
Posts: 2
Joined: Mon Oct 08, 2018 11:40 am

Re: Suenan los altavoces al conectar mis audifonos (cascos)

Post by carlos77 » Mon Oct 08, 2018 12:07 pm

hectorsales wrote:
Sat Aug 31, 2013 3:23 am
Hola que, tal a mi me ocurre exactamente lo mismo, lo he intentado por todos los métodos posibles pero no hay manera-a ver si tu tienes más suerte-por lo general esto funciona...

Consejo: Al final te he puesto los links desde donde he extraido la información no estaría mal que le echases un vistazo antes de hacer nada ....

1 ) Veamos el modelo de tu tarjeta. Abre la termina y escribe:
cat /proc/asound/modules

Con este comando veremos el driver de tu tarjeta que si no me equivoco visto la imagen adjunta es snd_intel8x0

2 ) Una vez tengamos claro el driver sólo hay que añadir este snd_intel8x0 al archivo /etc/modprobe.d/alsa-base.conf

En este paso dos antes de modificar, primero vamos hacer un respaldo o copia de seguridad de dicho archivo:

sudo cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.bak

Una vez hemos hecho la copia de seguridad por si metemos la pata al editar el archivo lo editamos ( yo lo he editado con el editor de texto pluma que viene por defecto en linux mint 13 Maya, tú lo has de editar con el que venga en linux mint 15) para ello escribimos en la terminal

gksudo pluma /etc/modprobe.d/alsa-base.conf

Nos pedirá la contraseña y escribimos esto al final del archivo

options snd-intel8x0

Le damos a guardar y cerramos.

3 -Matamos los procesos de pulseAudio abiertos y recargamos las ALSA

killall pulseaudio
sudo alsa force-reload


4-Reinicia y a ver si funciona.

Ya te digo que yo me he pasado bastantes horas recopilando información pero no he conseguido que a mi me funcione a mucha gente si le ha funcionado ....

Links desde donde he extraído la información:

http://www.lauraberdasco.com/2011/01/pr ... inux-mint/
http://ubuntuforums.org/showthread.php?t=1043568
http://ubuntuforums.org/showthread.php? ... light=vaio
http://www.ubuntu-es.org/node/168251#.UiGYzx1dXMZ
http://www.mp3acuatico.online/

Saludos ... :wink:
Me ha funcionado!!! Tenía el mismo problema que el primer usuario y por suerte y gracias a este tema he podido darle solución. Muchas gracias de antemano!

Post Reply

Return to “Español (Spanish)”