Cuelgues amule en 18.1

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Cuelgues amule en 18.1

Post by butiflauta » Mon Apr 17, 2017 5:34 am

Hola amigos,

me gustaría instalar amule en mi Linux Mint 18.1. Lo he hecho a través del gestor de software y me ha instalado una versión llamada SVN. El caso es que se queda congelado y colgado en el mejor de los casos y cuando no es este caso se apaga y desaparece directamente.
Buscando un poco por la red he visto que es una especie de versión beta y en la web de amule aparece la versión 2.3.2. Me he descargado de la misma web el archivo aMule-2.3.2.tar.xz que parece ser la última versión estable pero no soy ningún experto y no tengo ni idea de como instalarla. Alguien podría ayudarme?

jmarinho
Level 1
Level 1
Posts: 28
Joined: Mon Apr 11, 2016 4:25 am

Re: Cuelgues amule en 18.1

Post by jmarinho » Tue Apr 18, 2017 7:31 am

Hola.

Tal vez podrías probar esta solución que aporté en otro hilo:
viewtopic.php?f=68&t=230236&p=1228816#p1228816
No es muy ortodoxa pero a mi me funciona. Lo que pasa es que si no tienes mucha experiencia con GNU/Linux te puedes meter en líos porque la solución que te sugiero ahí es que instales la versión de Ubuntu 14.04 (en lugar de la de Ubuntu 16.04 que es la que tienes) y sus dependencias.
Básicamente tendrías que hacer esto:

1º Desinstala amule y sus dependencias. Abre el terminal y lanza este comando:

Code: Select all

sudo apt remove amule && sudo apt autoremove
2º Bájate los paquetes necesarios para instalar la versión de amule de Ubuntu 14.04. Te dejo los enlaces a packages.ubuntu.com que es de donde los debes bajar:
http://packages.ubuntu.com/trusty/amule
http://packages.ubuntu.com/trusty/amule-common
http://packages.ubuntu.com/trusty/libcrypto++9 (De este paquete te hablaré más abajo)
http://packages.ubuntu.com/trusty/libwxbase2.8-0
http://packages.ubuntu.com/trusty/libwxgtk2.8-0
Tienes que escojer el apropiado para tu ordenador (supongo que amd64 o i386)
Aquí te aconsejaría crear una carpeta en el directorio principal de tu usuario (junto a Documentos, Descargas, Escritorio, Imágenes, etc) llámala amule_debs por exemplo y pon todos los paquetes que te bajaste de packages.ubuntu.com en ella.
3º Inserta los siguientes comandos en el terminal:

Code: Select all

cd ~/amule_debs

Code: Select all

sudo dpkg -i *.deb
Con esto tendrías que tener instalada la versión 2.3.1 de amule que venía en Ubuntu 14.04 y en los Linux Mint 17.x y que funcionaba bastante bien.
El único problema que se te puede plantear aquí viene dado por la librería libcrypto++9. La que trae Ubuntu 16.04 y los Linux Mint 18.x es la versión 9.5 y entra en conflicto con la 9, es decir que no pueden convivir en una misma instalación. O tienes una o la otra. Si ahora o en el futuro, tienes en tu sistema un programa que te pida la versión 9.5 no podrías usar esta solución o bien tendrías que optar entre amule 2.3.1 y ese programa que necesite libcrypto++9.5.
Así que por si instalas amule 2.3.1 y después por lo que sea quieres desinstalarlo puedes hacerlo desde synaptic y acuérdate de elmiminar tambien las dependencias que tenga.
Otra cosa muy importante es que como instalas una versión anterior te va a aparecer en el gestor de actualizaciones una actualización para amule. Cuando te aparezca, dale al botón derecho del ratón y marca "ignorar actualizaciones para este paquete", porque si no volveríamos otra vez a la versión de amule que te está fallando.

butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Re: Cuelgues amule en 18.1

Post by butiflauta » Fri Apr 21, 2017 2:50 pm

Gracias por la respuesta. Antes de verla navegando encontré esto que entiendo es muy similar a lo que propones: http://www.ubuntu-es.org/node/190924#.WPpBJ0ekK2w

Lo he intentado y todo correcto hasta que después de forzar versión en el paquete amule-common (ha ido bien), hago lo mismo con el paquete amule y al forzar y seleccionar la versión 2.3.1 no deja instalarlo porque se tendría que corregir paquetes rotos.
No entiendo muy bien como solucionarlo la verdad, me dice:

E: No se pueden corregir los problemas, tenéis paquetes retenidos que están rotos.
E: Error, pkgProblemResolver::Resolve ha generado pausas, puede estar causado por los paquetes retenidos
E: No se han podido corregir las dependencias
E: No se puede blocar el directorio de listas

jmarinho
Level 1
Level 1
Posts: 28
Joined: Mon Apr 11, 2016 4:25 am

Re: Cuelgues amule en 18.1

Post by jmarinho » Sat Apr 22, 2017 5:42 am

Ya, pero al final ¿qué método seguiste? ¿el que te puse yo o el que enlazas?
Es que si seguiste el que enlazas no sé si te podré ayudar porque no sé exactamente lo que estás instalando ahí, porque estás metiendo ppa's por el medio y eso ya es más complicado.
Las dependencias que pide la versión de amule que venía en Ubuntu 14 y Linux Mint 17 ya te específiqué en el post anterior junto con los enlaces donde puedes descargarlas.
Para poder ayudarte necesitaría saber los pasos que has dado. Por lo de pronto estoy probando en una máquina virtual, he instalado el Y PPA Manager y he buscado ppa's de amule y me salen estas dos:
Selección_003.png
¿Cual de ellas has seleccionado tu?
Trataré de reproducir lo que has hecho en la máquina virtual para localizar el problema y ver que solución puede haber.
Saludos

butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Re: Cuelgues amule en 18.1

Post by butiflauta » Sun Apr 23, 2017 8:34 am

jmarinho wrote:Ya, pero al final ¿qué método seguiste? ¿el que te puse yo o el que enlazas?
Es que si seguiste el que enlazas no sé si te podré ayudar porque no sé exactamente lo que estás instalando ahí, porque estás metiendo ppa's por el medio y eso ya es más complicado.
Las dependencias que pide la versión de amule que venía en Ubuntu 14 y Linux Mint 17 ya te específiqué en el post anterior junto con los enlaces donde puedes descargarlas.
Para poder ayudarte necesitaría saber los pasos que has dado. Por lo de pronto estoy probando en una máquina virtual, he instalado el Y PPA Manager y he buscado ppa's de amule y me salen estas dos:
Selección_003.png
¿Cual de ellas has seleccionado tu?
Trataré de reproducir lo que has hecho en la máquina virtual para localizar el problema y ver que solución puede haber.
Saludos
De verdad que te agradezco la ayuda. He seguido el que yo puse en el post porque lo encontré antes de ver tu respuesta. Escogí la primera opción que pone en la imagen. Creí que esa era la que se debía escoger... :?

Y me pregunto..., no sería más fácil instalar la versión 2.3.2 que dicen estable que aparece en la página de amule? Tengo descargado el archivo aMule-2.3.2.tar.xz pero no soy experto en linux y no sé como debería proceder.

jmarinho
Level 1
Level 1
Posts: 28
Joined: Mon Apr 11, 2016 4:25 am

Re: Cuelgues amule en 18.1

Post by jmarinho » Sun Apr 23, 2017 3:55 pm

Mi consejo es que desinstales lo que hayas instalado desde ese ppa y que la elimines. Puedes hacerlo desde YPPA-Manager o desde Synaptic, supongo que mejor desde el primero, aunque yo normalmente no lo uso así que no sé explicarte exactamente como va. Una vez resuelto eso, yo de ti haría lo que yo te indiqué más arriba, porque lo que hay en la página web para descargar es el codigo fuente y eso hay que compilarlo y es muy difícil.

User avatar
JerryF
Level 11
Level 11
Posts: 3881
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cuelgues amule en 18.1

Post by JerryF » Sun Apr 23, 2017 4:34 pm

[quote="butiflauta"][/quote]

Descargé el paquete de Amule y como dijo jmarinho, tiene que ser compilado, lo cual es difícil de hacer si no tienes experiencia. No sé cómo compilar, por desgracia.

Instalé Amule desde el Administrador de software y lo instalé pero recibí este mensaje al actualizar la lista. La mía está en inglés. Mi mensaje se traduce utilizando Google.
Capture_001.jpg
IF your problem has been solved, please edit your ORIGINAL post and add [SOLVED] to the beginning of the Subject Line. It helps other members when browsing posts.

butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Re: Cuelgues amule en 18.1

Post by butiflauta » Thu Apr 27, 2017 6:12 am

He conseguido instalar la versión 2.3.2 sin compilar ni nada por el estilo siguiendo estas instrucciones (http://forum.amule.org/index.php?topic=21361.0):

1) Uninstall aMule v.2.4.0-svn:

sudo apt-get remove amule amule-common amule-utils

2) Downgrade to the latest amule-stable release "aMule v2.3.2"

Install the ".deb" packages of a stable amule release by going to this site https://pkgs.org/download/amule and downloading the ".deb" packages for "Debian Sid" (the packages for Ubuntu 16.10 are the same, and the packages for Ubuntu 17.04 were finally updated but won't install). Then use GDebi to install each of the main packages, amule, amule-common, amule-utils. GDebi will complain of unmet dependencies, but no worries. On the download page there is a "requires" tab. Click on that tab and dl each of the unmet dependencies GDebi complains about until you've managed to install the entire bundle. If you want "amule-utils" or "amule-utils-gui" then you'll have to enter "amule-utils" into the search bar on that webpage and do the same thing. I'm running Ubuntu 16.04 MATE, so for me it looked like this:

1) libcrypto++6_5.6.4-6_amd64.deb
2) libboost-system1.62.0_1.62.0+dfsg-4_amd64.deb
3) amule-common_2.3.2-1_all.deb
4) amule_2.3.2-1+b2_amd64.deb
5) libreadline7_7.0-2_amd64.deb
6) amule-utils_2.3.2-1+b2_amd64.deb

This will likely be the same for you, but may vary slightly by Ubuntu flavor. So you may have to dl a few different dependencies before GDebi will install aMule for you. In total, once I figured out what to do, this took me no more than 10-20 mins to complete. I've been running v2.3.2 for over a week now with my ports open and a hi-ID, and not a single crash so far.

It's a shame that nobody from the (still very much supported) Ubuntu's LTS team has decided to fix this well know problem by updating the repo's from "aMule v.2.4.0-svn" to a newer version of amule where this problem was long ago fixed. But for now, downgrading to a stable release is a simple solution. Hope this help
s.

La cosa es que está instalado pero al abrirlo al cabo de poco se queda congelado, colgado vaya. Sigue la batalla...

butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Re: Cuelgues amule en 18.1

Post by butiflauta » Thu Apr 27, 2017 9:18 am

Sigo observando y en esta versión 2.3.2 no peta sino que se me queda congelado y sigue bajando lo que tengo en descargas. He observado que se queda congelado cuando la velocidad de descarga pasa de unos 150kbps pero si lo fuerzas a apagarse y vuelves a ponerlo en marcha se ve claramente que el archivo se ha seguido bajando. He probado a bajar el número máximo de conexiones simultáneas pero nada.

ferpirineos
Level 1
Level 1
Posts: 14
Joined: Sat Jan 11, 2014 12:04 pm

Re: Cuelgues amule en 18.1

Post by ferpirineos » Thu Apr 27, 2017 12:36 pm

Hola, butiflauta.

He tenido también multiples problemas con amule, en Mint 17 se cerraba cuando le daba la gana y en Mint 18 se cuelga a los pocos minutos de iniciarlo y quiero proponerte dos soluciones alternativas que a mí me han funcionado:

1.-No complicarte y instalar emule para windows y usarlo con Wine/PlayonLinux. Ya sé que no es la solución más "ética" pero funciona. :twisted:
2.- La que llevo usando mucho tiempo y me funciona muy bien, tanto en Mint 17 como 18 es instalar amuled un demonio que gestiona amule por control remoto y amuled-utils-gui que es la intefaz gráfic a para no tener que manejarlo desde la terminal. En este enlace: http://unbrutocondebian.blogspot.com.es ... amule.html, aunque es de 2011 te explican lo básico para poder manejarte. El único problema que he encontrado en Mint 18 es que en ocasiones falla el sistema de Busquedas de archivos.

Espero servirte de ayuda y un saludo.

Fernando.

User avatar
Wibol
Level 4
Level 4
Posts: 378
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Cuelgues amule en 18.1

Post by Wibol » Thu Apr 27, 2017 3:13 pm

Hablo de memoria, lo siento. Pero recuerdo haber leído en algún sitio que los cuelgues tenían lugar cuando la velocidad de descarga alcanzaba el límite máximo establecido por el usuario. Prueba a elevarlo por encima de la capacidad de descarga de tu conexión.

Antes de realizar una consulta, no olvides:

butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Re: Cuelgues amule en 18.1

Post by butiflauta » Thu May 04, 2017 9:45 am

Gracias por los consejos, de verdad los agradezco. La solución de emular windows para un solo programa me parece excesiva cuando lo que debería pasar es que funcionase correctamente habiendo alternativa muy válida del mule para linux.

Sobre lo de la velocidad, en mi caso no es de aplicación porque no tengo fijado límite de descarga.

luistal
Level 1
Level 1
Posts: 1
Joined: Mon Jan 09, 2017 5:48 am

Re: Cuelgues amule en 18.1

Post by luistal » Thu Sep 21, 2017 5:46 pm

jmarinho wrote:Hola.

Tal vez podrías probar esta solución que aporté en otro hilo:
viewtopic.php?f=68&t=230236&p=1228816#p1228816
No es muy ortodoxa pero a mi me funciona. Lo que pasa es que si no tienes mucha experiencia con GNU/Linux te puedes meter en líos porque la solución que te sugiero ahí es que instales la versión de Ubuntu 14.04 (en lugar de la de Ubuntu 16.04 que es la que tienes) y sus dependencias.
Básicamente tendrías que hacer esto:

1º Desinstala amule y sus dependencias. Abre el terminal y lanza este comando:

Code: Select all

sudo apt remove amule && sudo apt autoremove
2º Bájate los paquetes necesarios para instalar la versión de amule de Ubuntu 14.04. Te dejo los enlaces a packages.ubuntu.com que es de donde los debes bajar:
http://packages.ubuntu.com/trusty/amule
http://packages.ubuntu.com/trusty/amule-common
http://packages.ubuntu.com/trusty/libcrypto++9 (De este paquete te hablaré más abajo)
http://packages.ubuntu.com/trusty/libwxbase2.8-0
http://packages.ubuntu.com/trusty/libwxgtk2.8-0
Tienes que escojer el apropiado para tu ordenador (supongo que amd64 o i386)
Aquí te aconsejaría crear una carpeta en el directorio principal de tu usuario (junto a Documentos, Descargas, Escritorio, Imágenes, etc) llámala amule_debs por exemplo y pon todos los paquetes que te bajaste de packages.ubuntu.com en ella.
3º Inserta los siguientes comandos en el terminal:

Code: Select all

cd ~/amule_debs

Code: Select all

sudo dpkg -i *.deb
Con esto tendrías que tener instalada la versión 2.3.1 de amule que venía en Ubuntu 14.04 y en los Linux Mint 17.x y que funcionaba bastante bien.
El único problema que se te puede plantear aquí viene dado por la librería libcrypto++9. La que trae Ubuntu 16.04 y los Linux Mint 18.x es la versión 9.5 y entra en conflicto con la 9, es decir que no pueden convivir en una misma instalación. O tienes una o la otra. Si ahora o en el futuro, tienes en tu sistema un programa que te pida la versión 9.5 no podrías usar esta solución o bien tendrías que optar entre amule 2.3.1 y ese programa que necesite libcrypto++9.5.
Así que por si instalas amule 2.3.1 y después por lo que sea quieres desinstalarlo puedes hacerlo desde synaptic y acuérdate de elmiminar tambien las dependencias que tenga.
Otra cosa muy importante es que como instalas una versión anterior te va a aparecer en el gestor de actualizaciones una actualización para amule. Cuando te aparezca, dale al botón derecho del ratón y marca "ignorar actualizaciones para este paquete", porque si no volveríamos otra vez a la versión de amule que te está fallando.


Genial. Me ha funcionado perfectamente a la primera. En cuanto a las dependencias, si necesito el libcrypto++9.5 ya intentaremos encontrar la solución. Por ahora no hace falta. Muchas gracias, jmarinho

User avatar
JCSenar
Level 10
Level 10
Posts: 3186
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Cuelgues amule en 18.1

Post by JCSenar » Fri Sep 22, 2017 2:57 am

luistal wrote:Genial. Me ha funcionado perfectamente a la primera. En cuanto a las dependencias, si necesito el libcrypto++9.5 ya intentaremos encontrar la solución. Por ahora no hace falta. Muchas gracias, jmarinho
Estupendo. Ahora solo te falta editar tu primer mensaje (icono del lápiz) y añadir [SOLUCIONADO] al título. :D
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

butiflauta
Level 2
Level 2
Posts: 86
Joined: Sat Jan 16, 2016 11:23 am

Re: Cuelgues amule en 18.1

Post by butiflauta » Thu Jan 24, 2019 12:01 pm

A mi no se me solucionó, he tenido el mismo problema desde entonces y se ha planteado de nuevo el problema en este hilo al ser otra versión de Linux Mint: viewtopic.php?f=68&t=286461&p=1584616#p1584616

Post Reply

Return to “Español (Spanish)”