Posible problema con wpa_supplicant V2.4

Spanish Forum

Moderator: JCSenar

Post Reply
Temearious3
Level 1
Level 1
Posts: 5
Joined: Mon Oct 31, 2016 10:52 am

Posible problema con wpa_supplicant V2.4

Post by Temearious3 » Fri Jun 02, 2017 10:23 pm

Hola a todos.

Les cuento que sigo teniendo problemas con la conexión WiFi desde que instalé Linux Mint 18 Cinnamon. Network-Manager se conecta normal, funciona durante horas, y de repente simplemente se desconecta, y aparece este mensaje:

«Falló el suplicante 802.1.x»

Ya comenté en una entrada anterior que probé muchas cosas que encontré y que resolví el problema instalando Wicd. Pero al reconfigurar dhcp, Wicd dejó de funcionar y volví a lo de antes. La solución que estoy usando actualmente es detener y reiniciar el servicio 'Network-Manager', que en ocasiones no resulta y me obliga a reiniciar el equipo.

Llevo meses haciendo pruebas de ensayo/error y por inducción/deducción parece que me voy acercando, y lo que tengo hasta ahora es que hay un bug en la versión 2.4 de wpa_supplicant que viene con ubuntu 16.04, ya que la versión 2.3 que viene con la versión estable de Debian al parecer no da problemas.

Recientemente también advertí que en el Foro en inglés de LM aparece este problema como solucionado, pero no atacan la causa raíz, y básicamente usan trucos parecidos a los que uso yo para tratar de reconectar sin tener que reiniciar.

Mi inquietud es si ustedes han escuchado de algún problema similar, y cómo hago para que el posible bug de wpa_supplicant le llegue a los desarrolladores, pues aunque el problema tiene trucos que ayudan a sobrellevarlo, no deja de ser un lastre para la experiencia de uso. Sospecho que este problema sólo afecta a pocos usuarios de LM, pues no he encontrado muchas referencias.

Gracias.

User avatar
JOPETA
Level 13
Level 13
Posts: 4714
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Posible problema con wpa_supplicant V2.4

Post by JOPETA » Sat Jun 03, 2017 5:32 am

Parace el tipico problema de desconexión aleatoria. Mira este hilo, por ejemplo con una WIFI similar.

Volvemos a la casilla de salida de de mi primera respuesta a tu hilo anterior (apartado 1).

Si una vez instalado el último kernel de la serie 4.4 ( apartado 2) y elegir el canal más adecuado (apartado 3.1) no lo soluciona, prueba con el enlace final a la solución de Austin.texas y si no la solución (según JeremyB) parece pasar por localizar el chip de la WIFI (devuelve el resultado del siguiente código de precisar ayuda)
  • Code: Select all

    lspci -nnk | grep -iA2 net; lshw -c net; iwconfig
y aplicarle cambios a la configuración del network-manager para prevenir que se desactive por el gestor de energía)
  • Code: Select all

    sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
y en la del propio controlador (reemplaza iwl3945 por tu controlador).
  • Code: Select all

    echo "options iwl3945 ips=N fwlps=N" | sudo tee /etc/modprobe.d/iwl3945.conf
    .
PD: Cuando obtengas errores proporciona el resultado completo de la terminal usando la opción Code.

Post Reply

Return to “Español (Spanish)”