Page 1 of 1

¡Controladores AMDGPU en Linux Mint 17, 18 y 19! ¡Mira aquí antes de hacer nada!

Posted: Mon Jun 26, 2017 7:18 am
by linux123
Este post es una traducción del originalmente escrito por Citizen 229. He eliminado el párrafo referido a "Sticky" pues nuestro foro lo organizamos de otra forma.

Para APU/móvil:
  • El primer problema que más se repite es para GPUs móviles, así como APUs (procesador AMD con chip gráfico incorporado). Si tienes estos dispositivos de vídeo en Mint 18.x, sólo tendrás la opción de activar el controlador de código abierto en el gestor de controladores. No lo intentes con ningún otro controlador, puesto que no funcionará.
  • Para la Mint 17.3, tenemos una historia diferente. Estos dispositivos tienen una segunda opción para los controladores FGLRX en el gestor de controladores. No lo intentes con ningún otro controlador aparte de estos dos, no funcionará. Esto sólo se recomienda hasta el final del ciclo de vida de Linux Mint 17.3.
Para gráficas independientes o dedicadas:
  • Para los escritorios tenemos mejores opciones, pero AMD causó una gran confusión, ya que sólo hay un número seleccionado de tarjetas que son compatibles con sus nuevos controladores.
  • La lista de tarjetas compatibles con los nuevos controladores es:

Code: Select all

​Radeon RX 5xx graphics
Radeon™ RX 480 Graphics
​Radeon™ RX 470 Graphics
​Radeon™ RX 460 Graphics
AMD Radeon™ R9 Fury X Graphics
AMD Radeon™ R9 Fury Graphics
​AMD Radeon™ R9 Nano Graphics
​AMD Radeon™ R9 390X Graphics
AMD Radeon™ R9 390 Graphics ​
AMD Radeon™ R9 380X Graphics
​​AMD Radeon™ R9 380 Graphics

AMD Radeon™ R9 M395X Graphics
AMD Radeon™ R9 M385 Graphics
AMD Radeon™ R9 M380 Graphics
AMD Radeon™ R9 M270X Graphics
AMD Radeon™ R9 360 Graphics
​AMD Radeon™ R9 290X Graphics
​AMD Radeon™ R9 290 Graphics
AMD Radeon™ R9 285 Graphics
​AMD Radeon™ R7 260X Graphics
AMD Radeon™ R7 260 Graphics
Si tu tarjeta NO está en esta lista, NO INTENTES INSTALAR EL AMDGPU-PRO desde el sitio web de AMD. Estás atascado con los controladores de código abierto en Linux Mint 18, no te queda otra. Para Mint 17 las tarjetas que no están en la lista todavía pueden usar los controladores FGLRX desde el administrador de controladores.

Para aquellos cuya tarjeta está en la lista:
  • Para Mint 17, pueden utilizar el controlador de código abierto o FGLRX desde el administrador de controladores.
  • Para Mint 18 pueden usar el controlador de código abierto que viene de forma predeterminada. Para utilizar el controlador AMDGPU-PRO, deben actualizar primero al Kernel 4.8 (y reiniciar) antes de instalar el controlador (y reiniciar de nuevo).
  • Cada driver tiene ciertos requisitos en el kernel. Cuando utilices los controladores suministrados por AMD, se te pedirá que actualices el kernel en el futuro. Esto se indica en la web de AMD.
  • En el futuro la lista puede llegar a ser inexacta. Y puede que deje fuera a algunas tarjetas. Y es obvio que añadirán nuevas tarjetas a medida que salen.
Nota Para aquellos que necesiten instrucciones OPEN CL 2 (ejemplo: folding @ home): Los controladores Open Source y FGLRX no las tienen. El controlador AMDGPU-PRO sí.

Tutorial para los problemas con el controlador AMDGPU-PRO: viewtopic.php?f=59&t=242474. No se sabe durante cuánto tiempo esto será válido.

Para instalar el controlador AMDGPU PRO: Cómo instalar el controlador AMDGPU Pro en Linux Mint 18.X

ACTUALIZACIÓN: Estas reglas siguen siendo de aplicación a la edición de Mint 19. Mint no controla los controladores que AMD desarrolla. Las tarjetas no soportadas nunca más tendrán controladores, no importa cuantas ediciones de Mint salgan.

EDITADO: Lo primero que debes hacer es conocer la tarjeta que tienes. Esto es lo más necesario en el caso de PCs de escritorio. Las tarjetas listadas a continuación no muestran las series HDXXXX . Una rápida ojeada a la wikipedia mostrará la arquitectura GCN de tu tarjeta. Si tu tarjeta está listada como GCN de primera generación, NO se considera incluida en el listado. Si es de segunda generación (GCN 1.2) o posterior SÍ se considera. includa.

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Mon Jun 26, 2017 7:19 am
by linux123
Tras la respuesta de JOPETA: viewtopic.php?p=1333517#p1333517, he decidido traducir el post. Espero que sea correcto.

Saludos.

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Tue Jun 27, 2017 5:32 am
by JOPETA
Si admites una sugerencia, creo que le sobra un poco de automatismo en la traducción (driver=controlador no conductor, EOL=End of live= finalización del soporte o abandono,etc) que dificulta un poco la compresión del texto. Puedes resumir, desarrollar o personalizar lo que quieras siempre que redunde en su comprensión , es decir no ajustarte a la traducción literal ya que el original es un poco enrevesado en la forma de expresarse..¿Le das una vuelta y lo propongo como tema de interés en sustitución del ingles?. Así cuando JCSenar vuelva al curro tendrás menos cosas de las que preocuparte, para pasar a ser Tutorial oficial. :lol:

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Tue Jun 27, 2017 7:22 am
by linux123
JOPETA wrote:Si admites una sugerencia, creo que le sobra un poco de automatismo en la traducción (driver=controlador no conductor, EOL=End of live= finalización del soporte o abandono,etc) que dificulta un poco la compresión del texto. Puedes resumir, desarrollar o personalizar lo que quieras siempre que redunde en su comprensión , es decir no ajustarte a la traducción literal ya que el original es un poco enrevesado en la forma de expresarse..¿Le das una vuelta y lo propongo como tema de interés en sustitución del ingles?. Así cuando JCSenar vuelva al curro tendrás menos cosas de las que preocuparte, para pasar a ser Tutorial oficial. :lol:
Gracias por las sugerencias, a ver qué te parece ahora :wink:

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Tue Jun 27, 2017 9:46 am
by JOPETA
Entiendo que la distinción es entre graficas integradas y de portátiles ( APU/AMD móvil), frente a las gráficas de PCs de escritorio y aún queda un conductor sin autobus pero a mi me vale. :D

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Tue Jun 27, 2017 9:56 am
by linux123
JOPETA wrote:Entiendo que la distinción es entre graficas integradas y de portátiles ( APU/AMD móvil), frente a las gráficas de PCs de escritorio y aún queda un conductor sin autobus pero a mi me vale. :D
El conductor ya tiene autobús. He corregido la distinción, pues ahora que lo dices no está clara, he puesto "para gráficas independientes o dedicadas".

Saludos.

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Tue Jun 27, 2017 10:06 am
by JOPETA
Gracias y suerte. :D

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Fri Jan 05, 2018 9:49 am
by JCSenar
¿Y si añadimos al tema un enlace al tutorial Cómo instalar el controlador AMDGPU Pro en Linux Mint 18.X ? :D

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Sat Jan 06, 2018 2:19 pm
by linux123
JCSenar wrote:¿Y si añadimos al tema un enlace al tutorial Cómo instalar el controlador AMDGPU Pro en Linux Mint 18.X ? :D

Buena idea!!! Hecho queda :D

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Sun Feb 10, 2019 3:14 pm
by JOPETA
Habría que considerar la posibilidad de actualizar este hilo destacado en la misma medida que lo ha hecho el original , incluido el título (añadiendo el " y ahora 19" )Traduciendo de aquella manera los añadidos:
ACTUALIZACION: Estas reglas siguen siendo de aplicación a la edición de Mint 19. Mint no controla los controladores que AMD desarrolla. Las tarjetas no soportadas nunca mas tendrán controladores, no importa cuantas ediciones de Mint salgan.

EDITADO: Lo primero que debes hacer es conocer la tarjeta que tienes. Esto es lo más necesario en el caso de PCs de escritorio. Las tarjetas listadas a continuación no muestran las series HDXXXX . Una rápida ojeada a la wikipedia mostrará la arquitectura GCN de tu tarjeta. Si tu tarjeta está listada como GCN de primera generación, NO se considera incluida en el listado. Si es de segunda generación (GCN 1.2) o posterior SI se considera includa.

Re: ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada!

Posted: Sun Feb 17, 2019 3:14 pm
by linux123
JOPETA wrote:
Sun Feb 10, 2019 3:14 pm
Habría que considerar la posibilidad de actualizar este hilo destacado en la misma medida que lo ha hecho el original , incluido el título (añadiendo el " y ahora 19" )Traduciendo de aquella manera los añadidos:
ACTUALIZACION: Estas reglas siguen siendo de aplicación a la edición de Mint 19. Mint no controla los controladores que AMD desarrolla. Las tarjetas no soportadas nunca mas tendrán controladores, no importa cuantas ediciones de Mint salgan.

EDITADO: Lo primero que debes hacer es conocer la tarjeta que tienes. Esto es lo más necesario en el caso de PCs de escritorio. Las tarjetas listadas a continuación no muestran las series HDXXXX . Una rápida ojeada a la wikipedia mostrará la arquitectura GCN de tu tarjeta. Si tu tarjeta está listada como GCN de primera generación, NO se considera incluida en el listado. Si es de segunda generación (GCN 1.2) o posterior SI se considera includa.
Hecho, gracias por la notificación :D

Re: ¡Controladores AMDGPU en Linux Mint 17, 18 y 19! ¡Mira aquí antes de hacer nada!

Posted: Sun Feb 17, 2019 6:15 pm
by JOPETA
Gracias a ti resalao. :D