Page 1 of 1

(Solucionado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Mon Jul 10, 2017 6:38 pm
by Ghermain
Gracias por este tutorial amigo @JCSenar pero tengo algunos inconvenientes que no he podido resolver y usando tus imágenes te muestro cuales son los problemas para ver si me das una ayuda con ellos.

Re: VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Tue Jul 11, 2017 11:24 am
by JCSenar
@Ghermain:
REGLAS DEL FORO: Si tienes algún problema con este tutorial no lo plantees aquí. Abre un tema nuevo para ello. Gracias.
1a imagen:

Algo ha cambiado en la(s) última(s) versiones de VirtualBox. Siempre instalo la última cuando sale (ahora mismo, la 5.1.22) y me pasa algo parecido a tí pero no exacto. Llevando el ratón a la parte baja de la pantalla ya no aparece la barra. No aparece nada:
Pantallazo-Windows 7 [Corriendo] - Oracle VM VirtualBox2.jpg
Para poder volver a ver mi escritorio de Linux Mint solo tengo la opción de hacer CtrlDcho + F. Habrá que ver si es un problema de esta versión de VirtualBox o lo van a mantener.... :shock: :shock: (ya he actualizado esta información en el propio tutorial. Gracias Ghermain :D ).

2a y 3a imagen:

Tiene toda la pinta de que no has hecho alguno, o los dos, pasos 9 y 10 del VIRTUALBOX (I): Instalación en Linux Mint. Es el paso que afecta posteriormente a los USBs:
9.- Una vez terminada la instalación, y para poder utilizar distintas opciones (dispositivos USB, carpetas compartidas, etc.), añadimos nuestro usuario al nuevo grupo que se ha creado en el sistema. Abrimos el Terminal y ejecutamos el siguiente comando: sudo adduser usuario vboxusers:

Image

10.- Hecho esto, reiniciamos el ordenador.

Re: VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Wed Jul 12, 2017 9:59 am
by Ghermain
Gracias @JCSenar Había hecho todo pero lo único que no había realizado era reiniciar el equipo, pensé que con cerrar y abrir sesión bastaba pero parece que siempre hay que reiniciar para que tome los cambios que hacemos en VirtualBox. Poco apago el portátil, solo cierro la tapa y ya está.
:o

Re: VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Wed Jul 12, 2017 1:53 pm
by JCSenar
¿Podemos dar el problema por solucionado?

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Wed Jul 12, 2017 4:24 pm
by Ghermain
Pues no tanto como solucionado pero si Aclarado en lo que concierne a los puertos USB porque lo de la primera imagen sigo buscando hacerlo funcionar o que el foro de VirtualBox tenga alguna solución o respuesta y me la envíe.
:roll:

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Thu Jul 13, 2017 2:26 pm
by JCSenar
En Linux Mint 18.1, con el kernel original (4.4.0-53) y Virtualbox 5.1.22, funciona correctamente:
Virtualbox.jpg
Luego el problema (en mi caso) viene de cuando instalé el kernel 4.4.0-79 por aquello de probar cosas nuevas.

Mi conclusión es que la barra inferior en modo pantalla completa aparecerá/funcionará o no según qué cambios hayamos hecho en el sistema. Es posible que haya unos kernels más compatibles que otros. :shock:

¿Has cambiado el kernel desde que instalaste el sistema?

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Thu Jul 13, 2017 7:28 pm
by Ghermain
Cuando tenía Linux Mint 18.1, con el kernel original (4.4.0-53) y Virtualbox 5.1.22, no me funcionaba esa barra y además tenía intermitencias con el wifi, razón por la cual le puse el kernel 4.11 y mejoró mucho, ya no tengo problemas con el wifi y, otras aplicaciones me funcionaron mejor pero, no modificó la barra inferior de VirtualBox y, ahora que uso Mint 18.2 con su kernel original, no funciona la barrita y tampoco mejoró al ponerle el kernel 4.11, hoy probé con el kernel 4.8.0-58 que vino como actualización y no funciona tampoco.
Cuando me pedía que ejecutara como "root" el comando: /sbin/vboxconfig lo hacía por el nuevo kernel y cuando quería probar, la barra no mostraba los menús. El sistema virtual funciona sin problema pero la barrita queda inactivada.
:x

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Fri Jul 14, 2017 6:45 am
by linux123
Jamás imaginé que un simple menú pudiese depender del kernel :shock: :?:

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Fri Jul 14, 2017 10:08 am
by JCSenar
linux123 wrote:Jamás imaginé que un simple menú pudiese depender del kernel :shock: :?:
Pues ya no se qué pensar....
Ghermain wrote:Cuando tenía Linux Mint 18.1, con el kernel original (4.4.0-53) y Virtualbox 5.1.22, no me funcionaba esa barra (...) ahora que uso Mint 18.2 con su kernel original, no funciona la barrita y tampoco mejoró al ponerle el kernel 4.11, hoy probé con el kernel 4.8.0-58 que vino como actualización y no funciona tampoco.
En la partición de pruebas que tengo (donde ayer probé con Mint 18.1 y funcionaba) hoy he probado con Mint 18.2 y funciona perfecto tanto con el kernel original (4.8.0-53) como con el último actualizado (4.8.0-58). Siempre con VirtualBox 5.1.22. :shock: :shock: :
Pantallazo-2017-07-14 15-40-42.jpg
Me sigue sin funcionar en mi sistema principal: LM 17 + kernel 4.4.0-79 :?:

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sat Jul 15, 2017 7:49 am
by linux123
JCSenar wrote:Pues ya no se qué pensar....
¿Cómo? No te entiendo... :?:

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sat Jul 15, 2017 10:51 am
by JCSenar
linux123 wrote:
JCSenar wrote:Pues ya no se qué pensar....
¿Cómo? No te entiendo... :?:
En las mismas condiciones (misma versión de LM, mismo kernel y misma versión de VB) a mí me funciona y a Ghermain no.

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sat Jul 15, 2017 3:32 pm
by linux123
JCSenar wrote:
linux123 wrote:
JCSenar wrote:Pues ya no se qué pensar....
¿Cómo? No te entiendo... :?:
En las mismas condiciones (misma versión de LM, mismo kernel y misma versión de VB) a mí me funciona y a Ghermain no.
Ah vale, ya entiendo. Simplemente me extrañó que sospechaseis de kernel.

No se si os servirá, pero he leído que ese menú se puede asomar con Host+C o Host+Inicio (host es la tecla Ctrl derecho por defecto).

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sat Jul 15, 2017 4:59 pm
by JCSenar
linux123 wrote:No se si os servirá, pero he leído que ese menú se puede asomar con Host+C o Host+Inicio (host es la tecla Ctrl derecho por defecto).
A mí, esto, me sigue sin funcionar.

Re: (Aclarado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sun Jul 16, 2017 6:39 am
by linux123
Pues es que ya tampoco yo se qué pensar :( No se me ocurre nada.

Re: (Solución parcial) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Mon Jul 24, 2017 9:51 am
by Ghermain
A cambio de KDE Sonya 18.2 x64 instalé Cinnamon Sonya 18.2 x64 en la misma máquina y luego instale W7 en VirtualBox 5.1.24 y me funciona perfecto, todos los menús que no hacían nada en KDE ahora se muestran correctamente en Cinnamon; los sub-menús muestran los ítems y son aplicables.
Otro punto a favor para el cambio, además tanto la máquina física como la virtual van más fluidas en Cinnamon que en KDE.
:wink:

Re: (Solucionado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Tue Jul 25, 2017 2:11 am
by JCSenar
¡Buena noticia! :D

Re: (Solucionado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sat Jul 29, 2017 2:21 pm
by Ghermain
Otra Buena Noticia con RAREZA incluida...
Por estar probando Mageia y Rosa ambas con KDE y no llenar mis expectativas, volví a instalar Sonya 18.2 KDE x64 en la misma máquina que me daba el problema y... ¡Oh sorpresa! Ahora funciona VirtualBox sin problema. Lo hice con la misma imagen grabada en USB y lo único que modifiqué de la primera instalación fue instalar la última versión de VirtualBox la 5.1.26... Misterios del sistema, del hardware y de...
:mrgreen:

Re: (Solucionado) VIRTUALBOX (IV): Problema con ajustes post-instalación

Posted: Sat Jul 29, 2017 3:53 pm
by JCSenar
Ghermain wrote:Otra Buena Noticia con RAREZA incluida...
Por estar probando Mageia y Rosa ambas con KDE y no llenar mis expectativas, volví a instalar Sonya 18.2 KDE x64 en la misma máquina que me daba el problema y... ¡Oh sorpresa! Ahora funciona VirtualBox sin problema. Lo hice con la misma imagen grabada en USB y lo único que modifiqué de la primera instalación fue instalar la última versión de VirtualBox la 5.1.26... Misterios del sistema, del hardware y de...
:mrgreen:
La versión 5.1.26 ha sido publicada sospechosamente rápido con respecto a la 5.1.24. Es posible que hubieran detectado algunos fallos.

En cualquier caso, ¡enhorabuena! :D