gnome-keyring-daemon no responde [SOLUCIONADO]

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

gnome-keyring-daemon no responde [SOLUCIONADO]

Post by EvaEva »

GNOME: LinuxMint 2 (betsy) 64 bit
Kernel: 3.16.0-4-amd64 (#1 SMP Debian 3.16.43-2+deb8u3 (2017-08-15))
GCC versión: 4.9.2 (x86_64-linux-gnu)

Desde hace unos meses, después de alguna actualización, al salir de Linux me aparece este mensaje:

Aún se está ejecutando un programa
gnome-keyring-daemon
No responde

Esperando a que los programas finalicen. Interrumpir estos progamas puede producir la pérdida de su trabaja.

Con tres botones debajo [Bloquear pantalla] [Cancelar] [Apagar de todas formas]

Tengo que pulsar el botón [Apagar de todas formas] para poder apagar, y tarda bastantes segundos es apagarse.
Lo mismo ocurre si intento reiniciar.

¿Como puedo solucionar esto?
Gracias.
Last edited by EvaEva on Thu Sep 21, 2017 4:59 am, edited 2 times in total.
User avatar
hatteras
Level 10
Level 10
Posts: 3261
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: gnome-keyring-daemon no responde

Post by hatteras »

Puedes probar a ejecutar con permisos de root la interfaz gráfica de gnome-keyring: alt+f2 y luego: gksu seahorse
y ver si ahí tienes algún problema.
O ejecutar el comando sudo seahorse desde la terminal y ver si en la terminal te aparece algún mensaje de error

Edita el titulo de tu primer mensaje y cambia kayring ( con a ) por keyring ( con e )
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

Re: gnome-keyring-daemon no responde

Post by EvaEva »

Con la interfaz gráfica de gnome-keyring: alt+f2 y luego: gksu seahorse se abre bien la ventana de Contraseñas y claves y aparece solo esto a la izquierda:
Certificados
System Trust
Claves PGP
Claves Gnu PG
Shel segura
Claves OpenSSH

Abriendo una terminal y tecleando sudo seahorse también se abre la misma ventana de Contraseñas y claves, pero en la terminal ha aparecido este mensaje:
(seahorse:3959): Gtk-WARNING **: Symbolic icon pan-down-symbolic-ltr of size 16 is in an icon theme directory of size 128

He vuelto a repetirlo y ahora no me sale ningún mensaje.

...............
¿Hay alguna forma de poner aquí un gráfico png de capturas de pantalla?, no veo como.
User avatar
JOPETA
Level 17
Level 17
Posts: 7384
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: gnome-keyring-daemon no responde

Post by JOPETA »

EvaEva wrote:¿Hay alguna forma de poner aquí un gráfico png de capturas de pantalla?, no veo como.
Una lectura recomendada para futuras dudas respecto a crear un post en el foro [TUTORIAL] Una guía sobre cómo crear un post en el foro que incluye un apartado (3.1) sobre añadir imágenes en los post y que remite al tema destacado de Hatteras (los de arriba del foro) [TUTORIAL sobre el foro] Incrustar imágenes en comentario de este foro para profundizar sobre esto que solicitas.
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

Re: gnome-keyring-daemon no responde

Post by EvaEva »

Gracias JOPETA
Pruebo a ver si me sale.
ContraseClaves.png
Parece que si que me ha salido
Mensaje.png
User avatar
JCSenar
Level 11
Level 11
Posts: 3616
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: gnome-keyring-daemon no responde

Post by JCSenar »

EvaEva wrote:He vuelto a repetirlo y ahora no me sale ningún mensaje.
Si lo has solucionado, solo te queda editar tu primer mensaje y añadir [SOLUCIONADO] al título. :wink:
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

Re: gnome-keyring-daemon no responde

Post by EvaEva »

No he solucionado nada, sigue este error:
Error al apagar linux.png
He comprobado que si enciendo el ordenador e inmediatamente vuelvo a apagar, no sale ningún error.

Respecto a lo que me recomendó halteras:
Entro en una terminal ... abro Contraseñas y claves ... cierro Contraseñas y claves sin hacer nada ... no hay ningún mensaje en la terminal.
Pero ...
Entro en una terminal ... abro Contraseñas y claves ... trasteo por opciones y menús ... salgo ... y aparecen en la terminal mensajes de error como estos:
Error al apagar linux.jpg
User avatar
JOPETA
Level 17
Level 17
Posts: 7384
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: gnome-keyring-daemon no responde

Post by JOPETA »

Las advertencias que obtienes con seahorse creo que nada tiene que ve con tu problema con gnome-keyring (si ejecutas "gksudo" en vez de "sudo" desapareceran la mayoría), son sólo advertencias y hacen referencias a problemas en la creación de la interfaz (GUI) de seahorse, nada importante. Aunque la útima imagen, no la primera, muestra advertencias de java que si podrían tener relación como se comenta más adelante (sevidores, virtuales o VM).

Respecto, al problema de no poder finalizar el processo gnome-keyring, la advertencia de que puedes perder el trabajo realizado es común cuando al cerrar no se puede cerrar un proceso/aplicación (quizás iniciado como root) y si estás seguro de que cerraste todo bien no entraña peligro. Si realmente tarda en apagar es que existe un proceso de fondo activo que implica al gnome-keyring o PAM o trata de acabar con un proceso no iniciado. ¿Has probado la opción de bloquear pantalla? (al tener que logearte luego para desbloquear lo mismo...)

Repasando un poco los casos en los que aparece este problema, sería preciso que proporcionaras detalles de como inicias, si es una VM, si usas VPN, si es servidor o si inicias escritorios remotos, si abres sesión como otro usuario (no cerrar sesión sino cambiar de usuario) o abres varias sesiones de un mismo usuario o bares sesión gráfica de usuario después de hacerlo desde consola (por ejemplo desde tty (Alt+Ctrl+F1+F2 y luego startx) o abres sesión del root. Tal vez el sistema trate de cerrar una proceso que ni siquiera se inició o no es accesible para el usuario que cierra la sesión.

En el caso mas sencillo, escritorio es mono-usuario ,
  • -Si usas el auto-login o inicio automático, desactívalo (Menú>Centro de control>ventana de inicio>Inicio de sesión automático>desactiva el inicio de sesión automático y en su caso el inicio temporizado) y reinicia. Luego y vuelve a activarlo tras el reinicio para comprobar que ha desaparecido el problema.

    -Si no usas auto-login (siguiendo en el supuesto de entorno mono-usuario), otras veces basta con cambiar de contraseña o hacer que tu usuario pertenezca al grupo de Admiministradores (Adm) (Menú>Centro de Control>Usuarios y grupos). Si no pusiste contraseña al instalar este es el momento de hacerlo.
En otros casos la soluciones son mas trabajosas como indican en este hilo primero localizar el problema leyendo el log (grep "gnome-keyring-daemon" /var/log/syslog)y creando el .desktop ausente. Si embargo el origen puede ser muy diverso por lo que comentan en la wiki de arch. Si lees este enlace podrías recabar mas pistas si aún no has atado cabos. :wink:
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

Re: gnome-keyring-daemon no responde

Post by EvaEva »

Hola JOPETA, Pongo los detalles de como inicio:
VM: (¿máquina virtual?), NO
VPN: (¿red privada virtual?, NO, eso es lo que creo.
Servidor: que yo sepa NO
NO inicio escritorios remotos
NO abro sesión como otro usuario porque solo existe un usuario. Si pruebo con la opción del menú Cambiar usuario NO da ningún error, en cambio con la opción Cerrar la sesión o Apagar SI da el error. NO da tampoco el error con las opciones Hibernar y Suspender.
NO abro varias sesiones de un mismo usuario.
NO uso autologin.
Siempre enciendo y abro de la misma forma, así:
LMD2 está en una de las tres particiones que hay en el disco, enciendo y en el menú GRUB es la que tengo activada por defecto, carga y me aparece el único usuario que hay tomas, pongo la contraseña que me pide y si la pongo correcta entro sin problemas.
Solo hay un usuario cuyo tipo de cuenta es Aministrador
Hay varios grupos que son los que se crearon automáticamente al instalar y uno más que yo añadidí firebird, y que está añadido casi desde la instalación y no ha dado ningún problema.
Voy a probar cambiando la contraseña (si encuentro donde se hace), a ver si se arregla y si no leeré los enlaces que me mandas.
Gracias.
User avatar
JOPETA
Level 17
Level 17
Posts: 7384
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: gnome-keyring-daemon no responde

Post by JOPETA »

Perdona EvaEva pero con LMDE2 soy un zote. Si fuera LM Cinnamon bastaría la ruta indicada en el post anterior Menú>Centro de Control>Usuarios y grupos introduces la contraseña requerida para acceder y luego clic en la contraseña actual para cambiarla. Esta sería la forma recomendable.
cambiar contraseña.png
Desde la consola sería

Code: Select all

sudo passwd evaeva
En entornos mono-usuarios (dependiendo de los grupos a los que pertenezca tu usuario) en ocasiones se produce una rotura de lo que hasta ahora estaba unido (la coincidencia de contraseñas entre usuario y root). Si para realizar operaciones que requieran derechos de root la nueva contraseña no es válida deberás, si quieres que vuelvan a ser idénticas, cambiar cambien la contraseña del root con

Code: Select all

sudo passwd root
Espero que no ocurra siendo administrador. :D
Last edited by JOPETA on Fri Sep 15, 2017 9:41 am, edited 1 time in total.
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

Re: gnome-keyring-daemon no responde

Post by EvaEva »

Cambiando las contraseñas no me ha funcionado, y seguía dando el error. He entrado en el hilo que me indicas y he hecho lo que ahí pone y parece que el problema se ha solucionado. Anoche probando y ahora otro rato no me ha dado ningún problema. Voy a esperar 2 o 3 días más para confirmar que todo se ha arreglado y si es así explico lo que he hecho y doy por solucionado el tema.
Muchas gracias por la ayuda.
Un saludo.
EvaEva
Level 1
Level 1
Posts: 36
Joined: Tue Jun 03, 2014 12:47 pm

Re: gnome-keyring-daemon no responde [SOLUCIONADO]

Post by EvaEva »

Lleva unos cuantos días sin aparecer el error por lo que doy por solucionado el problema.
Pongo aquí lo que he hecho siguiendo el hilo que me recomendó JOPETA.

Creo un archivo de texto con nombre gnome-keyring-daemon.desktop y con este contenido:

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Exec=/usr/bin/gnome-keyring-daemon
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name=Gnome Keyring Daemon
Comment=Load gnome keyring daemon
Name[es_ES]=gnome-keyring-daemon.desktop


Guardo este fichero en el directorio ~/.config/autostart
( /home/tunombredeusuario/.config/autostart/gnome-keyring-daemon.desktop )
Es un directorio oculto, para verlo pulsar Ctrl/h o activar la opción del Meńu ... Ver ... Mostrar archivos ocultos

Con esto ya no me aparece ningún mensaje de error al cerrar..
User avatar
JOPETA
Level 17
Level 17
Posts: 7384
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: gnome-keyring-daemon no responde [SOLUCIONADO]

Post by JOPETA »

Gracias por el aporte EvaEva. :D
vaca
Level 2
Level 2
Posts: 83
Joined: Thu Jul 12, 2018 1:58 pm
Location: Barcelona Spain

Re: gnome-keyring-daemon no responde [SOLUCIONADO]

Post by vaca »

Buenas , os comento mi experiencia resulta que aplique un lote de actualizaciones y me salto este error medio misterioso con efectos secundarios.

Como mi portatil tiene wifi interna , decidi darle uso ya que para conectarme uso un usb tplink 722n perfectamente reconocido cuando instale el sistema.

El uso es con el interno crear un punto de acceso para mi movil en casa , y fantastico solo que cuando me salto este error a partir de entonces la secuencia normal era entrar en el sistema login y escritorio saliendo el wifi ext como punto de acceso , en preferencias de red lo quito y se conecta a internet normalmente .
Con el interno esta al entrar como punto de acceso y mi movil excelente señal que recibe por toda la casa.

El efecto secundario es al cerrar o hacer reboot el mensaje de error y forzar su cierre.

VIsto lo cual probe las soluciones aportadas , pensando reflexivamente todo empezo al actualizar , ergo algo mal esta configurado no es normal que entres y mi wifi ext salga punto de acceso por defecto y quizás de ahi el error o no.

Bueno entonces , uso mi pendrive de redobackup y restauro el disco entero de mint , lo tengo instalado en un disco usb ext de 250 gb y de rendimiento excelente , para que os hagais una idea copiar archivos de video pesados me da una tasa sostenida de 41 mb/s bajo usb 2.0

Uso redo porque acronis es un desastre con ext4 me copia sector por sector y es evidente el desperdicio de espacio.
Como voy justo de discos usb la copia por el momento siempre es en el disco de backup en ntfs , razón por la que lo uso .

No es perfecta , a veces no reconoce la interpretacion de la geometria del disco y falla restaurando , hay que asegurarse que este en mbr y tener la unidad de destino usb como ext4 , bajo esas condiciones restaura como la seda y rapido mas que acronis de velocidad.

Asi que decido restaurar y obviamos luego restaurados determinadas actualizaciones , borro las redes y las vuelvo a crear , con una salvedad me di cuenta que tengo escrito en un fichero de texto de windows mis claves , yo hasta ahora me limitaba a copiarla al crear la red y es eso quizas un espacio que se yo que no reconocia , porque me voivio a salir.

Vuelvo a repetir la secuencia perooooooo lo escribo directamente tanto la conexion internet como el punto de acceso y escritura manual nada de copiar y pegar desde el fichero .

Sorpresa y prueba de fuego jejeje , cierro y reinicia y voila ningun mensaje y vuelvo a entrar en el sistema y perfecto redes montadas correctamente sin perder ninguna .

Moraleja a veces hacemos mal las cosas sin darnos cuenta , siempre en casos de errores sin sentido mejor restaurar y intentar paso a paso..

Adjunto la info de mi sistema de referencia....Asus X550C

Code: Select all

System:    Host: jv-X550CC Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: X550CC v: 1.0
           Mobo: ASUSTeK model: X550CC v: 1.0
           Bios: American Megatrends v: X550CC.217 date: 10/16/2013
CPU:       Dual core Intel Core i3-3217U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7183
           clock speeds: max: 1800 MHz 1: 864 MHz 2: 891 MHz 3: 841 MHz
           4: 863 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 04:00.2
           IF: enp4s0f2 state: down mac: <filter>
           Card-3: Atmel usb-ID: 001-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
           Card-4:  Atheros AR9271 802.11n usb-ID: 003-005
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 750.2GB (4.1% used)
           ID-1: /dev/sda model: WDC_WD5000LPCX size: 500.1GB
           ID-2: USB /dev/sdb model: HTS543225L9A300 size: 250.1GB
Partition: ID-1: / size: 222G used: 22G (11%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 8.06GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2500
Info:      Processes: 199 Uptime: 30 min Memory: 1109.6/3769.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Pongo mi sistema actual de referencia
Post Reply

Return to “Español (Spanish)”