No puedo montar el disco HDD con Linux [SOLUCIONADO]

Spanish Forum

Moderator: JCSenar

Prometheus-co
Level 1
Level 1
Posts: 3
Joined: Sun Nov 12, 2017 6:21 am

No puedo montar el disco HDD con Linux [SOLUCIONADO]

Postby Prometheus-co » Sun Nov 12, 2017 7:32 am

Buenos dias:
Es la primera vez que escribo ya que normalmente encuentro soluciones buscando en San Google, pero esta vez me sobrepasa y os pido ayuda. Soy incapaz de encontrar nada que funcione.
Estoy intentando montar un disco ya que no lo hace automácicamente al iniciar pero me da un error que no existe el dispositivo.
Selección_001.png

El disco que quiero montar el el sdb.
Selección_002.png

Creo la carpeta y al poner el comando no lo encuentra.
He probado forzando, sin forzar y nada funciona.
También he visto en algunos sitios que el problema es que Windows no desmonta el disco y por eso Linux no puede acceder a el, aunque ya he desactivado el fast boot de Windows incluso desmontado con cmd el disco manualmente. Linux sigue sin aceptar el disco.
Por favor, estoy desesperado.
Muchísimas gracias de antemano
Last edited by Prometheus-co on Tue Nov 14, 2017 10:48 am, edited 1 time in total.

User avatar
JOPETA
Level 11
Level 11
Posts: 3824
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: No puedo montar el disco HDD con Linux

Postby JOPETA » Sun Nov 12, 2017 12:00 pm

Hola Prometheus-co. ¡Bienvenido al foro! :D

No es el fast boot (a nivel de UEFI/BIOS) es el fast start-up (inicio rápido)/hibernación en Windows como indica JCSenar aquí lo que debes desactivar. Hazlo ante de nada (no desmontes la unidad en Windows, ni nada por el estilo. Aunque si es un disco externo (USB), que no lo dejas claro, si debes extraerlo de forma segura antes de iniciar Linux.

Por otro parte, aunque esto debe haber variado por lo que veo, fdisk hasta ahora por lo menos en la versión incorporada a LM 17.X y anteriores no soportaba partionado GPT y eso me sigue diciendo a mi
AVISO: GPT (Tabla de partición GUID) detectado en '/dev/sda'! La utilidad fdisk no soporta GPT. Use GNU Parted.

Puede que se trate de eso de una mala lectura del particionado ¿Que muestran los siguientes códigos en la terminal? Copia y pega uno cada vez seguido de Intro. No hace falta que hagas una captura puedes copiar el resultado de la terminal y devolverla usando la opción Code como se indica aquí)

Code: Select all

sudo parted -l
sudo blkid

Devuelve también el resultado del siguiente código de la misma forma para conocer más sobre tu tu sistema (no incorporarás ningún dato sensible si lo haces)

Code: Select all

inxi -Fxznrd


Por último ¿has probado a montarlo directamente con la herramienta gráfica Discos (Menú>Accesorios>Discos) o con gparted?

Quizás debas instalar este último antes con apt install gparted o desde el gestor de paquetes Synaptic). Si además instalas part al usar gparted (gksudo gparted) te indicarán si encuentra algún problema en la estructura de las tablas de ese disco y te propondrá alguna solución.

Devuelve este aviso si se produce o cualquier otro error que te ocasione el montaje de la unidad (Seleccionas el disco correcto en el menú>clic derecho sobre la partición>Montar). Ahora si acompaña de una captura si observas algo extraño en la imagen de gparted (signo de exclamación,...) :wink:
Si unas prisas acude al chat #linuxmint-help (te atenderán en cualquier idioma) o si quieres simplemente charlar exclusivamente en español #linux-es

Prometheus-co
Level 1
Level 1
Posts: 3
Joined: Sun Nov 12, 2017 6:21 am

Re: No puedo montar el disco HDD con Linux

Postby Prometheus-co » Sun Nov 12, 2017 1:30 pm

Muchas gracias por la bienvenida :)
perdon por poner fast boot que me he liado si jeje lo que he desactivado es el fast start-up.
Lo de desmontar desde comandos era ya a la desesperada y el disco es interno.
Lo del GPT no tengo problemas para el dual boot, incluso me deja desde linux ver la partición donde tengo instalado Windows. El problema lo tengo desde las últimas actualizaciones de Win10.
Para poner en antecedentes, tengo un SSD donde están Windows y Linux. El otro es un HDD que lo tengo para almacenar lo que sea, el cual es al que no puedo accerer desde Linux.

Aquí dejo la primera salida que me pides:

Code: Select all

prometheus@prometheus-msi ~ $ sudo parted -l
[sudo] password for prometheus:
Modelo: ATA KINGSTON SMS200S (scsi)
Disco /dev/sda: 120GB
Tamaño de sector (lógico/físico): 512B/512B
Tabla de particiones: gpt
Disk Flags:

Numero  Inicio  Fin     Tamaño  Sistema de archivos  Nombre                        Banderas
 1      17,4kB  134MB   134MB                        Microsoft reserved partition  msftres
 2      135MB   607MB   472MB   ntfs                 Basic data partition          oculta, diag
 3      607MB   712MB   105MB   fat32                EFI system partition          arranque, esp
 4      712MB   83,5GB  82,8GB  ntfs                 Basic data partition          msftdata
 5      83,5GB  84,0GB  525MB   ntfs                                               oculta, diag
 6      84,0GB  96,6GB  12,6GB  linux-swap(v1)
 7      96,6GB  120GB   23,4GB  ext4                 Linux


Modelo: ATA WDC WD7500BPKX-2 (scsi)
Disco /dev/sdb: 750GB
Tamaño de sector (lógico/físico): 512B/4096B
Tabla de particiones: gpt
Disk Flags:

Numero  Inicio  Fin    Tamaño  Sistema de archivos  Nombre  Banderas
 1      20,5kB  750GB  750GB   ntfs                         msftdata



Aquí la segunda:

Code: Select all

prometheus@prometheus-msi ~ $ sudo blkid
/dev/sda2: LABEL="RecuperaciM-CM-3n" UUID="7476719D76716132" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7901b660-2acb-46f0-ad07-7a473fdf44a1"
/dev/sda3: UUID="7272-B47A" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="42f90da6-eb54-4943-86ae-1547ee8162ed"
/dev/sda4: UUID="96489EAD489E8C1D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ec89232f-709f-42fb-acc9-e76eb23ffb17"
/dev/sda5: UUID="4E5E292C5E290DF1" TYPE="ntfs" PARTUUID="941078f1-45f3-46b4-a143-852448cb895c"
/dev/sda6: UUID="0ff5259a-6ca0-4e16-8690-6bb7cef14bde" TYPE="swap" PARTUUID="18b833e6-3985-405a-a3d0-25195dd74b9d"
/dev/sda7: UUID="5771118c-2d9c-4cf7-b6c5-a1f572d1673a" TYPE="ext4" PARTLABEL="Linux" PARTUUID="bdbeb960-f84c-4710-9e9e-e62878b86d27"
/dev/sda1: PARTLABEL="Microsoft reserved partition" PARTUUID="4cb6a17a-1594-4ea7-8f2b-b30ac3018c9b"
/dev/sdb: PTUUID="dc439645-c8f4-4cf6-b41f-2476ab54398d" PTTYPE="gpt"


Y la tercera:

Code: Select all

prometheus@prometheus-msi ~ $ inxi -Fxznrd
System:    Host: prometheus-msi Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.8 (Qt 5.6.1) Distro: Linux Mint 18.2 Sonya
Machine:   System: Micro-Star product: GE60 2PE v: REV:1.0
           Mobo: Micro-Star model: MS-16GF v: REV:0.B Bios: American Megatrends v: E16GFIMS.513 date: 03/03/2014
CPU:       Quad core Intel Core i7-4700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19156
           clock speeds: max: 3400 MHz 1: 982 MHz 2: 897 MHz 3: 922 MHz 4: 900 MHz 5: 833 MHz 6: 927 MHz
           7: 910 MHz 8: 900 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GM107M [GeForce GTX 860M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.10hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 05:00.0
           IF: wlp5s0 state: up mac: <filter>
Drives:    HDD Total Size: 870.2GB (11.4% used) ID-1: /dev/sda model: KINGSTON_SMS200S size: 120.0GB temp: 46C
           ID-2: /dev/sdb model: WDC_WD7500BPKX size: 750.2GB temp: 41C
           Optical: /dev/sr0 model: HL-DT-ST DVDRAM GTA0N rev: 1.00 dev-links: cdrom,cdrw,dvd,dvdrw
           Features: speed: 24x multisession: yes
           audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 22G used: 9.3G (46%) fs: ext4 dev: /dev/sda7
           ID-2: swap-1 size: 12.58GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: 27.8C gpu: 40.0
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/noobslab-macbuntu-xenial.list
           deb http://ppa.launchpad.net/noobslab/macbuntu/ubuntu xenial main
           deb-src http://ppa.launchpad.net/noobslab/macbuntu/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-themes-xenial.list
           deb http://ppa.launchpad.net/noobslab/themes/ubuntu xenial main
           deb-src http://ppa.launchpad.net/noobslab/themes/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirrors.evowise.com/linuxmint/packages sonya main upstream import backport
           deb http://ubuntu.cica.es/ubuntu xenial main restricted universe multiverse
           deb http://ubuntu.cica.es/ubuntu xenial-updates main restricted universe multiverse
           deb http://ubuntu.cica.es/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-defaults.list
           deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-java-xenial.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
           deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
Info:      Processes: 251 Uptime: 1 day Memory: 2076.6/7901.3MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


Al lanzar Gparted también me reconoce lo que sería el disco físico pero no me deja montarlo porque está sombreado en gris e inhabilitado ( por cierto, lo he lanzado como root :) ).
Cuando intento verificar la partición, esto es lo que dice:
Selección_003.png


Por eso estoy tan desesperado :(

User avatar
JOPETA
Level 11
Level 11
Posts: 3824
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: No puedo montar el disco HDD con Linux

Postby JOPETA » Sun Nov 12, 2017 7:37 pm

Yo realizaría el chequeo de la unidad pero en Windows, ya que has realizados acciones en este sistema, por si quedan pendientes algunas comprobaciones. Una vez comprobado que el dispositivo se monta sin problemas y que el Administrador de Discos de Windows identifica de forma correcta tanto el sitema de archivos como el particionado, tipo de partición). En este hilo encontraras repartidos en varios post algunas recomendaciones para asegurar mínimamente el uso compartido en dual boot, por supuesto empezando por deshabilitar el inicio rápido (fast start-up/hibernación) y siguiendo por deshabilitar la vigilancia de cambios por parte de Windows la indización, permisos/seguridad, papelera de reciclaje, protección del sistema para la unidad.

Por supuesto, si no lo solicita al iniciar Windows, hacerle un análisis y si fuera preciso desfragmentar la unidad. También puedes hacerlo desde la shell corriendo chkdsk /f X: donde X: es la letra de la unidad en la que monta Windows el disco duro, normalmente en D:). Luego reinicia un par de veces Windows para comprobar que todo va bien.

Desde mi perspectiva el empleo de herramientas gráficas (tambien en Linux) evitan cometer algunos fallos y al menos en esta ocasión debes asegurar.

Una vez realizadas las acciones aconsejadas en Windows y la UEFI/BIOS de ser necesario (deshabilitar fast boot y secure boot este sólo habría impedido quizas lo sucedido), en relación a Linux Mint, deberías confirmar en primer lugar que no tienes definida ninguna opción de automontaje de la unidad en /etc/fstab si es así edita el archivo y devuelve su contenido usando la opción code.

Si no es así y el problema persiste pese a todo, te comento:

    1)La falta de eficacia de gparted para corregir el problema aduciendo a que no existe la partición tampoco haría viable la opción sudo ntfsfix /dev/sdb1No obstante este hecho apunta a un problema de corrupción de las tablas, para los que GNU-parted es mas sensible, no así Discos del que no comentas haberlo probado.

    2)Aunque no he encontrado nada coincidente (bueno si pero se soluciona de forma espontánea en un caso al actualizar el kernel y en el otro desde windows) con la causa del error (6) si fuera debido a esto el uso de gdisk se demuestra eficaz en muchos casos parecidos. En Mint creo que viene preinstalado por defecto (por lo menos en el live) por lo que deberías ejecutarlo desde la terminal con
    gdisk al iniciar te muestra la tabla de particiones de la unidad y una vez reconocido como GPT acepta la reparación propuesta (posiblemente la de usar la copia de seguridad de la tabla de particiones GUI al tener la tabla inicial corrupta o inaccesible) y asegúrate de escribirla (opción w para escribir la tabla de particiones legible ).

    3)sobre el intento de montaje desde de la terminal con ntfs-3g te comento que está disponible una nueva versión estable en Tuxera cuyo manual también recoge recomendaciones interesantes sobre su uso, sobre el uso compartido de particiones, y sobre los permisos por si tuviera algo que ver con la dificultad para encontrar la partición sdb1 de no haberlo resuelto con lo anterior.
Si unas prisas acude al chat #linuxmint-help (te atenderán en cualquier idioma) o si quieres simplemente charlar exclusivamente en español #linux-es

Prometheus-co
Level 1
Level 1
Posts: 3
Joined: Sun Nov 12, 2017 6:21 am

Re: No puedo montar el disco HDD con Linux

Postby Prometheus-co » Tue Nov 14, 2017 10:43 am

Buenas tardes.
Tengo que decir que con alegria lo he podido solucionar, en realidad por pura suerte diria yo y me explico.
Tras probar todas las opciones propuestas por Jopeta y ver que no funcionaba nada, ya daba por supuesto que lo tenía que formatear por posibles problemas en la tabla de particiones tal como el me comentaba.
Reallmente ese era basicamente el problema pero muy traicionero ya que el fallo estaba en el tipo de partición, que aunque lo ponia como msftdata, este tenía algún problema que no lo " ejecutaba " correctamente.
La solución digo que ha sido por pura casualidad, porque cuando estaba preparado para eliminar la tabla de particiones con Gparted, se me ocurrió hacer una "tonteria" que era hacer boton derecho en la partición -- Gestionar Opciones -- y reseleccionar msftdata con la única intención de quitar el tipo.
Para mi sorpresa, automáticamente me apareció la capacidad del disco y los porcentages y así es como ha vuelto a la normalidad.

Jopeta, te doy las gracias ya que en estos dias he aprendido bastante de las particiónes y por perder tu tiempo en las clases :wink:

User avatar
JOPETA
Level 11
Level 11
Posts: 3824
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: No puedo montar el disco HDD con Linux [SOLUCIONADO]

Postby JOPETA » Tue Nov 14, 2017 2:12 pm

Algo raro habría en la tabla de particiones. Había leido en un post que le ponían el flag msftdata a la partición, pero en aquel caso es que la partición no era reconocida (en tu caso si pero luego como que la olvidaba). En todo caso enhorabuena y de nada. :D
Si unas prisas acude al chat #linuxmint-help (te atenderán en cualquier idioma) o si quieres simplemente charlar exclusivamente en español #linux-es


Return to “Español (Spanish)”