Problema de dependencias incumplidas instalando zabbix en LM 17 KDE [SOLUCIONADO]

Spanish Forum

Moderator: JCSenar

User avatar
el_miki
Level 3
Level 3
Posts: 116
Joined: Wed Dec 19, 2012 4:28 am
Location: Ciudad Real

Problema de dependencias incumplidas instalando zabbix en LM 17 KDE [SOLUCIONADO]

Postby el_miki » Thu Nov 23, 2017 4:07 am

Hola, estoy intentando montar zabbix y me encuentro el siguiente error:

Code: Select all

inf_linux@FTPLINUX:~ > sudo apt-get install zabbix-server-mysql zabbix-frontend-php
[sudo] password for inf_linux:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 zabbix-server-mysql : Depende: libodbc1 (>= 2.3.1) pero no va a instalarse
                       Depende: libsnmp30 (>= 5.7.2.1+dfsg-1~dfsg) pero 5.7.2~dfsg-8.1ubuntu3.2 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


Tengo Linux Mint 17 Qiana KDE 64 bit - 3.13.0-24-generic #47-Ubuntu

Ya he probado:

sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get update
sudo apt-get -f install

Alguna idea?
Muchas gracias.
Last edited by JCSenar on Sun Dec 10, 2017 10:19 am, edited 2 times in total.
Reason: Añadido [SOLUCIONADO]
Linux Mint 17.3 (ROSA) KDE

User avatar
JCSenar
Level 8
Level 8
Posts: 2224
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problema de dependencias incumplidas

Postby JCSenar » Thu Nov 23, 2017 11:28 am

el_miki wrote:Hola, estoy intentando montar zabbix y me encuentro el siguiente error:.

En Linux Mint 17 Mate (kernel 4.4.0-98), siguiendo estas instrucciones y probando directamente desde el tercer paso, aparentemente va bien:

Code: Select all

juancar@LM17M ~ $ wget http://repo.zabbix.com/zabbix/3.0/ubuntu/pool/main/z/zabbix-release/zabbix-release_3.0-1+trusty_all.deb
--2017-11-23 16:18:44--  http://repo.zabbix.com/zabbix/3.0/ubuntu/pool/main/z/zabbix-release/zabbix-release_3.0-1+trusty_all.deb
Resolviendo repo.zabbix.com (repo.zabbix.com)... 162.243.159.138
Conectando con repo.zabbix.com (repo.zabbix.com)[162.243.159.138]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 2694 (2,6K) [application/x-debian-package]
Grabando a: “zabbix-release_3.0-1+trusty_all.deb”

100%[======================================>] 2.694       --.-K/s   en 0s     

2017-11-23 16:18:44 (18,8 MB/s) - “zabbix-release_3.0-1+trusty_all.deb” guardado [2694/2694]

juancar@LM17M ~ $ sudo dpkg -i zabbix-release_3.0-1+trusty_all.deb
[sudo] password for juancar:
Lo sentimos, vuelva a intentarlo.
[sudo] password for juancar:
Seleccionando el paquete zabbix-release previamente no seleccionado.
(Leyendo la base de datos ... 169758 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar zabbix-release_3.0-1+trusty_all.deb ...
Desempaquetando zabbix-release (3.0-1+trusty) ...
Configurando zabbix-release (3.0-1+trusty) ...
juancar@LM17M ~ $ sudo apt-get update
Obj http://ppa.launchpad.net trusty InRelease
Des:1 http://security.ubuntu.com trusty-security InRelease [65,9 kB]           
Ign http://archive.ubuntu.com trusty InRelease                                 
Obj http://ppa.launchpad.net trusty InRelease                                 
Des:2 http://archive.ubuntu.com trusty-updates InRelease [65,9 kB]             
Ign http://archive.canonical.com trusty InRelease                             
Ign http://extra.linuxmint.com qiana InRelease                                 
Ign http://packages.linuxmint.com qiana InRelease                             
Obj http://ppa.launchpad.net trusty/main Sources                               
Des:3 http://security.ubuntu.com trusty-security/main amd64 Packages [694 kB] 
Obj http://archive.canonical.com trusty Release.gpg                           
Des:4 http://repo.zabbix.com trusty InRelease [6.798 B]                       
Obj http://extra.linuxmint.com qiana Release.gpg                               
Obj http://packages.linuxmint.com qiana Release.gpg                           
Obj http://archive.ubuntu.com trusty Release.gpg                               
Obj http://ppa.launchpad.net trusty/main amd64 Packages                       
Obj http://archive.canonical.com trusty Release                               
Des:5 http://archive.ubuntu.com trusty-updates/main amd64 Packages [1.039 kB] 
Obj http://ppa.launchpad.net trusty/main i386 Packages                         
Des:6 http://security.ubuntu.com trusty-security/restricted amd64 Packages [14,1 kB]
Obj http://extra.linuxmint.com qiana Release                                   
Obj http://ppa.launchpad.net trusty/main Translation-en                       
Obj http://packages.linuxmint.com qiana Release                               
Des:7 http://security.ubuntu.com trusty-security/universe amd64 Packages [197 kB]
Obj http://archive.canonical.com trusty/partner amd64 Packages                 
Obj http://ppa.launchpad.net trusty/main Sources                               
Des:8 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4.795 B]
Des:9 http://security.ubuntu.com trusty-security/main i386 Packages [636 kB]   
Obj http://archive.canonical.com trusty/partner i386 Packages                 
Obj http://ppa.launchpad.net trusty/main amd64 Packages                       
Des:10 http://repo.zabbix.com trusty/main Sources [866 B]                     
Obj http://extra.linuxmint.com qiana/main amd64 Packages                       
Des:11 http://security.ubuntu.com trusty-security/restricted i386 Packages [13,9 kB]
Obj http://archive.canonical.com trusty/partner Translation-en                 
Obj http://ppa.launchpad.net trusty/main i386 Packages                         
Des:12 http://security.ubuntu.com trusty-security/universe i386 Packages [195 kB]
Obj http://packages.linuxmint.com qiana/main amd64 Packages                   
Obj http://ppa.launchpad.net trusty/main Translation-en                       
Des:13 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4.935 B]
Des:14 http://security.ubuntu.com trusty-security/main Translation-en [371 kB]
Obj http://extra.linuxmint.com qiana/main i386 Packages                       
Des:15 http://security.ubuntu.com trusty-security/multiverse Translation-en [2.564 B]
Des:16 http://repo.zabbix.com trusty/main amd64 Packages [2.443 B]             
Des:17 http://security.ubuntu.com trusty-security/restricted Translation-en [3.542 B]
Des:18 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [17,2 kB]
Obj http://packages.linuxmint.com qiana/upstream amd64 Packages               
Des:19 http://security.ubuntu.com trusty-security/universe Translation-en [112 kB]
Des:20 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [435 kB]
Obj http://packages.linuxmint.com qiana/import amd64 Packages                 
Des:21 http://repo.zabbix.com trusty/main i386 Packages [2.445 B]             
Des:22 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14,9 kB]
Des:23 http://archive.ubuntu.com trusty-updates/main i386 Packages [982 kB]   
Obj http://packages.linuxmint.com qiana/main i386 Packages                     
Obj http://packages.linuxmint.com qiana/upstream i386 Packages                 
Des:24 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [17,0 kB]
Des:25 http://archive.ubuntu.com trusty-updates/universe i386 Packages [434 kB]
Des:26 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [15,3 kB]
Obj http://packages.linuxmint.com qiana/import i386 Packages                   
Des:27 http://archive.ubuntu.com trusty-updates/main Translation-en [513 kB]   
Des:28 http://archive.ubuntu.com trusty-updates/multiverse Translation-en [7.760 B]
Des:29 http://archive.ubuntu.com trusty-updates/restricted Translation-en [4.031 B]
Des:30 http://archive.ubuntu.com trusty-updates/universe Translation-en [235 kB]
Obj http://archive.ubuntu.com trusty Release                                   
Obj http://archive.ubuntu.com trusty/main amd64 Packages                       
Obj http://archive.ubuntu.com trusty/restricted amd64 Packages                 
Obj http://archive.ubuntu.com trusty/universe amd64 Packages                   
Obj http://archive.ubuntu.com trusty/multiverse amd64 Packages                 
Ign http://extra.linuxmint.com qiana/main Translation-es_ES                   
Obj http://archive.ubuntu.com trusty/main i386 Packages                       
Obj http://archive.ubuntu.com trusty/restricted i386 Packages                 
Ign http://extra.linuxmint.com qiana/main Translation-es                       
Obj http://archive.ubuntu.com trusty/universe i386 Packages                   
Obj http://archive.ubuntu.com trusty/multiverse i386 Packages                 
Ign http://extra.linuxmint.com qiana/main Translation-en                       
Obj http://archive.ubuntu.com trusty/main Translation-es                       
Obj http://archive.ubuntu.com trusty/main Translation-en                       
Obj http://archive.ubuntu.com trusty/multiverse Translation-es                 
Obj http://archive.ubuntu.com trusty/multiverse Translation-en                 
Obj http://archive.ubuntu.com trusty/restricted Translation-es                 
Obj http://archive.ubuntu.com trusty/restricted Translation-en                 
Obj http://archive.ubuntu.com trusty/universe Translation-es                   
Obj http://archive.ubuntu.com trusty/universe Translation-en                   
Ign http://archive.ubuntu.com trusty/main Translation-es_ES                   
Ign http://archive.ubuntu.com trusty/multiverse Translation-es_ES             
Ign http://archive.ubuntu.com trusty/restricted Translation-es_ES             
Ign http://archive.ubuntu.com trusty/universe Translation-es_ES               
Ign http://repo.zabbix.com trusty/main Translation-es_ES                       
Ign http://repo.zabbix.com trusty/main Translation-es                         
Ign http://repo.zabbix.com trusty/main Translation-en                         
Ign http://packages.linuxmint.com qiana/import Translation-es_ES               
Ign http://packages.linuxmint.com qiana/import Translation-es                 
Ign http://packages.linuxmint.com qiana/import Translation-en                 
Ign http://packages.linuxmint.com qiana/main Translation-es_ES                 
Ign http://packages.linuxmint.com qiana/main Translation-es                   
Ign http://packages.linuxmint.com qiana/main Translation-en                   
Ign http://packages.linuxmint.com qiana/upstream Translation-es_ES             
Ign http://packages.linuxmint.com qiana/upstream Translation-es               
Ign http://packages.linuxmint.com qiana/upstream Translation-en               
Descargados 6.107 kB en 9seg. (625 kB/s)                                       
Leyendo lista de paquetes... Hecho
juancar@LM17M ~ $ sudo apt-get install zabbix-server-mysql php5-mysql zabbix-frontend-php
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  apache2 apache2-bin apache2-data fping libaio1 libapache2-mod-php5 libapr1
  libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libcurl3
  libdbd-mysql-perl libdbi-perl libhtml-template-perl libiksemel3
  libmysqlclient18 libodbc1 libopenipmi0 libterm-readkey-perl mysql-client-5.6
  mysql-client-core-5.6 mysql-common mysql-common-5.6 mysql-server-5.6
  mysql-server-core-5.6 php5 php5-cli php5-common php5-gd php5-json php5-ldap
  php5-readline snmpd
Paquetes sugeridos:
  apache2-doc apache2-suexec-pristine apache2-suexec-custom apache2-utils
  php-pear libmldbm-perl libnet-daemon-perl libplrpc-perl
  libsql-statement-perl libipc-sharedcache-perl libmyodbc odbc-postgresql
  tdsodbc unixodbc-bin mailx tinyca php5-user-cache
Paquetes recomendados:
  virtual-mysql-server
Se instalarán los siguientes paquetes NUEVOS:
  apache2 apache2-bin apache2-data fping libaio1 libapache2-mod-php5 libapr1
  libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libcurl3
  libdbd-mysql-perl libdbi-perl libhtml-template-perl libiksemel3
  libmysqlclient18 libodbc1 libopenipmi0 libterm-readkey-perl mysql-client-5.6
  mysql-client-core-5.6 mysql-common mysql-common-5.6 mysql-server-5.6
  mysql-server-core-5.6 php5 php5-cli php5-common php5-gd php5-json php5-ldap
  php5-mysql php5-readline snmpd zabbix-frontend-php zabbix-server-mysql
0 actualizados, 36 se instalarán, 0 para eliminar y 59 no actualizados.
Necesito descargar 32,2 MB de archivos.
Se utilizarán 213 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n]

Aceptando la instalación de los paquetes el proceso de instalación y configuración empieza con normalidad:

Image

El título del tema quedaría mejor añadiendo "instalando zabbix en LM 17 KDE"
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
JOPETA
Level 11
Level 11
Posts: 3822
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema de dependencias incumplidas

Postby JOPETA » Fri Nov 24, 2017 5:02 am

Tengo Linux Mint 17 Qiana KDE 64 bit - 3.13.0-24-generic #47-Ubuntu
Esa versión del kernel 3.13 es muy antigua y presenta muchas de las vulnerabilidades descubiertas durante el pasado año y el presente, entre ellas dirty cow, cuyo parche se empieza a introducir a partir del 3.13.0-100 (y el 4.4.0-45).

Acualiza el kernel al mas reciente de la serie 3.13 haciéndolo de modo gráfico como se describe aquí, y/o prueba con el último de la serie 4.4, como implícitamente sugiere JCSenar. :wink:
Si unas prisas acude al chat #linuxmint-help (te atenderán en cualquier idioma) o si quieres simplemente charlar exclusivamente en español #linux-es

User avatar
el_miki
Level 3
Level 3
Posts: 116
Joined: Wed Dec 19, 2012 4:28 am
Location: Ciudad Real

Re: Problema de dependencias incumplidas instalando zabbix en LM 17 KDE

Postby el_miki » Tue Nov 28, 2017 9:00 am

Hola, lo primero... infinitas gracias por vuestra ayuda!!!

He instalado el kernel kernel 4.4.0-98.

He hecho un update y he intentado empezar a instalar los paquetes:

Code: Select all

inf_linux@FTPLINUX:~ > sudo apt-get install zabbix-server-mysql zabbix-frontend-php
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 zabbix-server-mysql : Depende: libodbc1 (>= 2.3.1) pero no va a instalarse
                       Depende: libsnmp30 (>= 5.7.2.1+dfsg-1~dfsg) pero 5.7.2~dfsg-8.1ubuntu3.2 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


Y recibo el mismo error, el enlace que ha puesto @JCSenar no me funciona.

Alguna idea?

Muchas gracias.
Linux Mint 17.3 (ROSA) KDE

User avatar
JCSenar
Level 8
Level 8
Posts: 2224
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problema de dependencias incumplidas instalando zabbix en LM 17 KDE

Postby JCSenar » Tue Nov 28, 2017 9:34 am

el_miki wrote:He hecho un update y he intentado empezar a instalar los paquetes:

¿Has añadido previamente el repositorio con el comando:

Code: Select all

wget http://repo.zabbix.com/zabbix/3.0/ubuntu/pool/main/z/zabbix-release/zabbix-release_3.0-1+trusty_all.deb

seguido de:

Code: Select all

sudo dpkg -i zabbix-release_3.0-1+trusty_all.deb
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
el_miki
Level 3
Level 3
Posts: 116
Joined: Wed Dec 19, 2012 4:28 am
Location: Ciudad Real

Re: Problema de dependencias incumplidas instalando zabbix en LM 17 KDE

Postby el_miki » Wed Nov 29, 2017 7:23 am

JCSenar wrote:
el_miki wrote:He hecho un update y he intentado empezar a instalar los paquetes:

¿Has añadido previamente el repositorio con el comando:

Code: Select all

wget http://repo.zabbix.com/zabbix/3.0/ubuntu/pool/main/z/zabbix-release/zabbix-release_3.0-1+trusty_all.deb

seguido de:

Code: Select all

sudo dpkg -i zabbix-release_3.0-1+trusty_all.deb



Pensaba que ya estaba hecho!!! Que tonto...

Ya funciona! Muchísimas gracias.
Un Saludo.
Linux Mint 17.3 (ROSA) KDE

User avatar
JCSenar
Level 8
Level 8
Posts: 2224
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problema de dependencias incumplidas instalando zabbix en LM 17 KDE

Postby JCSenar » Wed Nov 29, 2017 8:34 am

el_miki wrote:Ya funciona! Muchísimas gracias.
Un Saludo.

De nada :D

Ahora solo falta que añadas [SOLUCIONADO] en el título de tu primer mensaje.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.


Return to “Español (Spanish)”