sin wifi en mi notebook

Spanish Forum

Moderator: JCSenar

Post Reply
CarlosGianelli
Level 1
Level 1
Posts: 2
Joined: Sun Dec 31, 2017 3:41 pm

sin wifi en mi notebook

Post by CarlosGianelli » Sun Dec 31, 2017 5:02 pm

Buenas gente, hace unos dias estuve experimentando para ver si podia crackear la contraseña de mi propia red, y como me tiraba errores estuve metiendo mano donde no debía, la cuestion es que ahora no hay forma de que me pueda conectar a traves del wifi. Hace como 5 dias que estoy buscando la solucion y no encuentro ningun post de alguien que tenga exactamente el mismo problema que yo.

Tengo una notebook MSI MS-16GN con LinuxMint Sylvia Cinnamon, por ahora estoy usando mi celular como modem usb

cuando ejecuto el comando lspci -v en el terminal me da este resultado:

Code: Select all

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
	Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
	Flags: bus master, fast devsel, latency 0, IRQ 24
	I/O ports at e000 [size=256]
	Memory at d0004000 (64-bit, prefetchable) [size=4K]
	Memory at d0000000 (64-bit, prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8169
	Kernel modules: r8169

05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
	Subsystem: AzureWave AW-NE139H Half-size Mini PCIe Card
	Flags: bus master, fast devsel, latency 0, IRQ 11
	I/O ports at d000 [size=256]
	Memory at fea00000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel modules: ndiswrapper
por lo que puedo entender me reconoce la tarjeta de wifi que seria de realtek RTL8188CE, pero despues de haber vuelto a instalar los drivers y firmwares no logro que aparezca la opción de conectarme a través del wifi, creo que es un problema de interface, pero todavia no lo comprendo del todo

el comando ifconfig me arroja estos resultados:

Code: Select all

enp0s18f2u1 Link encap:Ethernet  HWaddr 6a:32:82:71:19:d1  
          inet addr:192.168.42.110  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::6641:8fc5:aadb:c014/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1002157 errors:7 dropped:0 overruns:0 frame:7
          TX packets:503478 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1487054328 (1.4 GB)  TX bytes:57977117 (57.9 MB)

enp2s0    Link encap:Ethernet  HWaddr 6c:62:6d:34:5f:fc  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

enp2s0:avahi Link encap:Ethernet  HWaddr 6c:62:6d:34:5f:fc  
          inet addr:169.254.9.65  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1482 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1482 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:137484 (137.4 KB)  TX bytes:137484 (137.4 KB)
como verán enp2s0 es el puerto ethernet, enp0s18f2u1 es mi celular conectado como modem usb, pero el de wifi no figura

y este es el resultado de iwconfig

Code: Select all

enp2s0    no wireless extensions.

lo        no wireless extensions.

enp0s18f2u1  no wireless extensions.
espero que me puedan ayudar, mientras seguiré buscando

si necesitan algun otro dato mas por favor indiquenme que comando debo ejecutar para poder pasarlo, porque soy muy nuevo en esto y no comprendo del todo, desde ya muchas gracias, saludos!

User avatar
JOPETA
Level 13
Level 13
Posts: 4545
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: sin wifi en mi notebook

Post by JOPETA » Mon Jan 01, 2018 2:18 pm

¡Bienvenido al foro y Feliz año 2018!

Primero proporciona información de tu sistema como se indica aquí. Además del código citado en el enlace y de la misma forma, proporciona el resultado de los siguientes códigos para comprobar el chip de tu tarjeta y los múdulos disponibles

Code: Select all

lspci -nnk | grep 0280 -A2
lsmod | grep rtl
Sobre los detalles que se mencionan interesaría saber desde donde y cómo como instalaste el controlador (es decir el tutorial que seguiste), y que modificaste anteriormente (el archivo de configuración, rtlXXXX.cfg,..). El que aparezca como modulo cargado ndiswrapper no dice nada bueno de lo realizado (eso solo era recomendado tiempo atrás como últmo recurso para determinadas tarjetas y funcionaba con WindowsXP instalado y a veces con Windows 7 pero de 32 bits).

Quizás debas plantearte deshacer esos cambios y la desinstalación de ese controlador, ya que el kernel en la actualidad incorpora los controladores aunque requiere que instales el linux-firmware del repositorio (también conviene tener instalado los paquetes dkms y bluild-essential si necesitabas compilarlo desde la fuente). Si el controlador adecuado está presente (lsmod | grep rtl) tal vez solo tengas que descargar el módulo incorrecto (sudo modeprobe -r ndiswrapper) y reiniciar y/o cargar el adecuado (sudo modeprobe -a rtlXXXX), pero esperamos a ver los resultados anteriores antes de anticiparnos. :wink:
Last edited by JOPETA on Wed Jan 03, 2018 7:35 pm, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

CarlosGianelli
Level 1
Level 1
Posts: 2
Joined: Sun Dec 31, 2017 3:41 pm

Re: sin wifi en mi notebook

Post by CarlosGianelli » Tue Jan 02, 2018 12:46 am

Gracias y feliz año nuevo para vos también

paso la informacion del sistema:

Code: Select all

carlos@carlos-A6500 ~ $ inxi -Fxznr
System:    Host: carlos-A6500 Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Micro-Star product: A6500 v: E16GNAMR.116
           Mobo: Micro-Star model: MS-16GN v: Ver 1.000
           Bios: American Megatrends v: E16GNAMR.116 date: 07/18/2011
CPU:       Dual core AMD E-450 APU with Radeon HD Graphics (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4a ssse3 svm) bmips: 6586
           clock speeds: max: 1650 MHz 1: 1320 MHz 2: 1320 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6320]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1280x720@59.86hz, 1280x1024@60.02hz
           GLX Renderer: Gallium 0.4 on AMD PALM (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Wrestler HDMI Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
           port: d000 bus-ID: 05:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (7.2% used)
           ID-1: /dev/sda model: WDC_WD5000BEVT size: 500.1GB
Partition: ID-1: / size: 455G used: 31G (7%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 106M (24%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 3.74GB used: 0.11GB (3%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 77.2C mobo: N/A gpu: 79.0
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb cdrom:[Linux Mint 18.1 _Serena_ - Release amd64 20161213]/ xenial contrib main non-free
           Active apt sources in file: /etc/apt/sources.list.d/atareao-atareao-xenial.list
           deb http://ppa.launchpad.net/atareao/atareao/ubuntu xenial main
           deb-src http://ppa.launchpad.net/atareao/atareao/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/ed10vi86-wifi-xenial.list
           deb http://ppa.launchpad.net/ed10vi86/wifi/ubuntu xenial main
           deb-src http://ppa.launchpad.net/ed10vi86/wifi/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/playdeb.list
           deb http://archive.getdeb.net/ubuntu xenial-getdeb games
Info:      Processes: 215 Uptime: 23:31 Memory: 2327.2/3428.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 



carlos@carlos-A6500 ~ $ lspci -nnk | grep 0280 -A2
05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
	Subsystem: AzureWave AW-NE139H Half-size Mini PCIe Card [1a3b:1139]
	Kernel modules: ndiswrapper
del otro codigo lspci me dió este resultado

Code: Select all

carlos@carlos-A6500 ~ $ lspci -nnk | grep 0280 -A2
05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
	Subsystem: AzureWave AW-NE139H Half-size Mini PCIe Card [1a3b:1139]
	Kernel modules: ndiswrapper
el codigo lsmod | grep rtl no me arrojó ningun resultado, paso el resultado de ejecutar solo lsmod

Code: Select all

carlos@carlos-A6500 ~ $ lsmod
Module                  Size  Used by
rndis_host             16384  0
cdc_ether              16384  1 rndis_host
usbnet                 45056  2 rndis_host,cdc_ether
pci_stub               16384  1
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               454656  3 vboxnetadp,vboxnetflt,vboxpci
appletalk              36864  0
ipx                    28672  0
p8023                  16384  1 ipx
p8022                  16384  1 ipx
psnap                  16384  2 ipx,appletalk
llc                    16384  2 p8022,psnap
binfmt_misc            20480  1
rtsx_usb_ms            20480  0
memstick               20480  1 rtsx_usb_ms
msi_wmi                16384  0
sparse_keymap          16384  1 msi_wmi
kvm_amd                65536  0
kvm                   540672  1 kvm_amd
irqbypass              16384  1 kvm
snd_hda_codec_realtek    86016  1
snd_hda_codec_hdmi     53248  1
snd_hda_codec_generic    77824  1 snd_hda_codec_realtek
joydev                 20480  0
input_leds             16384  0
serio_raw              16384  0
snd_hda_intel          40960  5
ndiswrapper           286720  0
snd_hda_codec         135168  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           73728  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
shpchp                 36864  0
snd_hwdep              16384  1 snd_hda_codec
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
k10temp                16384  0
snd_pcm               106496  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
i2c_piix4              24576  0
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              16384  1 snd
mac_hid                16384  0
cfg80211              626688  0
compat                 20480  1 cfg80211
parport_pc             32768  0
ppdev                  20480  0
lp                     20480  0
parport                49152  3 lp,ppdev,parport_pc
autofs4                40960  2
btrfs                 987136  0
xor                    24576  1 btrfs
raid6_pq              102400  1 btrfs
dm_mirror              24576  0
dm_region_hash         24576  1 dm_mirror
dm_log                 20480  2 dm_region_hash,dm_mirror
pata_acpi              16384  0
rtsx_usb_sdmmc         28672  0
rtsx_usb               24576  2 rtsx_usb_sdmmc,rtsx_usb_ms
amdkfd                131072  1
amd_iommu_v2           20480  1 amdkfd
radeon               1515520  4
i2c_algo_bit           16384  1 radeon
ttm                    94208  1 radeon
drm_kms_helper        155648  1 radeon
syscopyarea            16384  1 drm_kms_helper
psmouse               131072  0
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
r8169                  81920  0
fb_sys_fops            16384  1 drm_kms_helper
mii                    16384  2 r8169,usbnet
drm                   364544  7 ttm,drm_kms_helper,radeon
ahci                   36864  2
pata_atiixp            16384  0
libahci                32768  1 ahci
wmi                    20480  1 msi_wmi
fjes                   28672  0
video                  40960  1 msi_wmi

Con respecto a de donde instale los controladores la verdad que probe tantas formas de tantos post en distintos foros de linux, ubuntu, etc. que no sabría decirte, te puedo decir que algunos procesos eran todo a traves del terminal, usaban por ejemplo el comando rfkill que nunca me arrojó ningun resultado, y otra de las formas que instalé el driver fue a traves del programa "Wireless network drivers" donde instalé con los archibos .inf que se incluia en los drivers descargado de la pagina de realtek y de otra pagina de drivers que no recuerdo, me figuran dos drivers instalados pero uno dice que no tiene el hardware conectado, adjunto imagen del mismo:
captura.jpg
Otra cosa que queria aclarar es que cuando el wifi funcionaba, en el menú de administrador de redes ubicado en la bandeja de sistema me aparecia la opción de encender o apagar el wifi pero ahora no, y cuando abría la preferencias de red me figuraba "red inalambrica" y ahora no:
captura.jpg
Archivo .cfg no recuerdo haber modificado ninguno (al menos de forma manual), ejecuté los comandos que me indicas al final y el resultado es este "modeprobe" no me funcionaba y el terminal me sugirió "modprobe", el de ndiswrapper no me arrojó ningun resultado:

Code: Select all

carlos@carlos-A6500 ~ $ sudo modprobe -r ndiswrapper
carlos@carlos-A6500 ~ $ sudo modprobe -a rtl8188
modprobe: WARNING: Module rtl8188 not found in directory /lib/modules/4.4.0-53-generic
Attachments
wwd.jpg
wwd.jpg (54.11 KiB) Viewed 255 times

User avatar
JOPETA
Level 13
Level 13
Posts: 4545
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: sin wifi en mi notebook

Post by JOPETA » Thu Jan 04, 2018 12:19 pm

Lo de activar el modulo rtl era en caso de que apareciera listado como digo
Jopeta wrote: Si el controlador adecuado está presente (lsmod | grep rtl) tal vez solo tengas que descargar el módulo incorrecto (sudo modeprobe -r ndiswrapper) y reiniciar y/o cargar el adecuado (sudo modeprobe -a rtlXXXX), pero esperamos a ver los resultados anteriores antes de anticiparnos. :wink:
.

Prueba, aunque no parece posible que puedas, crear una conexión inalámbrica desde cero y(clic en el icono de la red del panel> (comprueba que no puedes conectar o no aparece la red inalámbrica)>conexiones de red>Añadir>elegir un tipo de conexión>Inalámbrica>Crear y completa la configuración) ya que requiere que tengas una tarjeta de red WIFI plenamente operativa en el sistema.

Yo comenzaría por
  • 1) comprobar que en la BIOS no existe ninguna función que deshabilite el manejo de la WIFI (WLAN) por parte del sistema operativo y/o que desactive las teclas de función/botones de la WIFI. Si aún sigues con Windows comprueba que tienes acceso a la WIFI y que el controlador cargado es el original procedente de MSI. En la web de Intel dice claramente que el software y los controladores instalados con este van contra de los controladores proporcionados por los fabricantes (OEM).

    2)En segundo lugar, comprobar que el Live de Mint es capaz de manejar la WIFI sin problemas, si no lo hiciste en su día, por lo que toda la parafernalia instalada (como el "Wireless network drivers" y sobre todo el ndiswrapper) es innecesaria (error común de los usuarios procedentes de Windows tratar de instalar controladores privativos recurriendo al fabricante en el mejor de los casos cuando el kernel y el repositorio proporciona lo necesario la mayoría de las veces por defecto).

    3)Ya desde el Linux Mint instalado asegurate que posees conexión a internet por cable y procede a desinstalar completamente todo lo instalado de forma superflua Primero el Controladaro de la WIFI con el Wireles Network Driver y luego este software finalizando con el ndiswrapper. Además de los anteriores tambien desintala si instalaste otro gestor de red como wicd,...). Será interesante conocer la forma exacta en que instalaste ya que así sabríamos la forma más conveniente de desinstalación. Proporciona el enlace al tutorial seguido si no sabes como proceder.
    • Por ejemplo, de estar presente en Synaptic estos paquetes habría que desinstalarlos completamente. En el caso de ndiswrapper la alternativa usando la terminal podría ser
        • Code: Select all

          sudo apt-get remove --purge ndiswrapper-common ndiswrapper-utils-* ndiswrapper-modules-*
      o quizás mejor mediante Aptitude
        • Code: Select all

          sudo aptitude purge ndiswrapper-common ndiswrapper-utils-* ndiswrapper-modules-*
      . También es posible que puedas localizarlos mediante Menú> Centro de Control>Orígenes del software>Mantenimiento>Eliminar paquetes externos o revertir paquetes externos y actualizar la caché.

      Aprovecha y deshabilita los repositorios backport de Ubuntu y PPAs , como ed10vi86-wifi, que una vez instalado el software que querías no harán mas que crear problemas. Sigue el resto de las recomendaciones de Pjtor. Luego actualiza la caché y recarga Synaptic o refresca el Administrador de actualizaciones.
    4)Posteriormente reinstala en network-manager
      • Code: Select all

        sudo service network-manager stop
        sudo apt-get install --reinstall network-manager
        sudo service network-manager start 
    5)Por último actualiza el kernel de la forma indicada aquí . Desconozco el motivo de usar el kernel 4.4. pero fíjate en las temperaturas que te gastas señal de que no anda bien con él) prueba con el último 4.10. Tras esto instala el paquete linux-firmware y actualiza los identificadores de las tarjetas con
      • Code: Select all

        apt install linux-firmware
        sudo update-pciids
        sudo update-usbids


    6)Tras reiniciar comprueba el resultado y de ser necesario devuelve el resultado del código solicitado en el post anterior
(Editado)
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”