Montar carpetas NAS

Spanish Forum

Moderator: JCSenar

Post Reply
gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Montar carpetas NAS

Post by gamor » Sat Jan 27, 2018 6:20 am

He actualizado a Linux Mint 18 y me encuentro que no soy capaz de montar correctamente las carpetas de un NAS Synology. Sigo los pasos que tengo anotados y que había hecho con la versión anterior y que me funcionaba, pero ahora me falla. El problema es que al montar las carpetas me cambia los permisos de estas y solo root puede añadir archivos o carpetas.

Estos son los pasos que he seguido:

- Instalo sudo apt-get install nfs-common

- Creo en /mnt la carpeta nas y dentro de ella las carpetas documentos, fotos, etc

- Cambio el propietario y permisos de grupo de todas esas carpetas:

sudo chown gamor /mnt/nas
sudo chown gamor /mnt/nas/documentos
sudo chown gamor /mnt/nas/fotos

sudo chgrp gamor /mnt/nas
sudo chgrp gamor /mnt/nas/documentos
sudo chgrp gamor /mnt/nas/fotos

Después en /etc/fstab incluyo las siguiente lineas:

192.168.0.2:/volume1/documentos /mnt/nas/documentos nfs nouser,atime,auto,rw,dev,exec,suid 0 0
192.168.0.2:/volume1/photo /mnt/nas/fotos nfs nouser,atime,auto,rw,dev,exec,suid 0 0

Reinicio la maquina o ejecuto sudo mount -a

Y veo que las carpetas tienen archivos y carpetas (entiendo que porque las ha montado), pero el propietario y grupo es root

Este es el resultado al ejecutar ls -l en la carpeta /mnt/nas

drwxrwxrwx 22 root root 4096 ene 27 10:56 documentos
drwxrwxrwx 25 root root 4096 ene 13 13:17 photo

¿¿¿ ???
Last edited by gamor on Sun Jan 28, 2018 1:52 pm, edited 2 times in total.
Linuxmint 17.3 Cinnamon 64bits.

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Montar carpetas NAS

Post by Wibol » Sun Jan 28, 2018 11:30 am

También uso NFS para compartir recursos desde un servidor, pero veo varias diferencias con respecto a mi procedimiento:
  • Yo no cambio los permisos, propietarios o grupos de las carpetas creadas en /mnt.
  • Utilizo las opciones defaults para el montaje:

    Code: Select all

    192.168.0.2:/volume1/documentos /mnt/nas/documentos nfs defaults 0 0
  • Estás montando 2 veces el mismo contenido compartido /volume1/documentos en dos carpetas locales diferentes: /mnt/nas/documentos y /mnt/nas/fotos.
  • El comando ls -l lanza el nombre de carpeta "photo" en lugar de "fotos".
También sería de ayuda que proporcionaras el contenido del archivo exports del servidor.

Para más info: [TUTORIAL] Compartir archivos mediante NFS

Antes de realizar una consulta, no olvides:

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Sun Jan 28, 2018 1:41 pm

He intentando poniendo

192.168.0.2:/volume1/documentos /mnt/nas/documentos nfs defaults 0 0

pero me hace lo mismo.

El error de montar 2 veces documentos es el post...habia copiado solo una linea y después modificado la otra...pero se ve que no acabe de modificarla toda. :(

De lo que me acabo de dar cuenta que en /mnt/documentos no puedo crear carpetas nuevas o archivos, pero en las carpetas que contiene si entro en ellas si me deja crear carpetas o archivos nuevos. ¿?

Lo de mostrar el contenido del archivo exports del servidor...no se como hacerlo ya que es un nas. Y no se como llegar a ese archivo.

Gracias por la ayuda.
Linuxmint 17.3 Cinnamon 64bits.

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Montar carpetas NAS

Post by Wibol » Sun Jan 28, 2018 3:05 pm

El archivo export está en la carpeta /etc y puedes ver su contenido con nano /etc/exports en el terminal del servidor. Si no puedes acceder a él, teclea en el terminal del cliente showmount -e 192.168.0.2. Cualquiera de las 2 opciones son válidas para conocer los nombres exactos de las carpetas compartidas.

Si comprobado todo sigue igual, podríamos intentar montarlos mediante autofs, que es más eficiente.

Antes de realizar una consulta, no olvides:

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Mon Jan 29, 2018 4:08 am

Lo miraré esta noche cuando llegue a casa...

Lo de autofs me interesa ya que tengo un portatil con Ubuntu que no consigue montar las carpetas con fstab. Creo que porque se conecta mediante wifi y debe intentar montarlas antes de que la conexión wifi este lista. Por este motivo tarda al arrancar mas de 1:30 minutos. Me indicaron que lo mejor era usar autofs. Pero este problema lo tenía aparcado ya que me apareció el otro con el ordenador principal, y me corre mas prisa solucionar este problema.

Gracias, por el interés.
Linuxmint 17.3 Cinnamon 64bits.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Mon Jan 29, 2018 3:21 pm

Esto es lo que aparece al ejecutar showmount -e 192.168.0.2

Export list for 192.168.0.2:
/volume1/Test 192.168.0.0/24
/volume1/Torrents 192.168.0.0/24
/volume1/documentos 192.168.0.0/24
/volume1/music 192.168.0.0/24
/volume1/video 192.168.0.0/24
/volume1/Incoming 192.168..01.0/24
/volume1/photo 192.168.0.0/24
/volume1/Backup_home_desktop 192.168.0.0/24
/volume1/NetBackup DiskStation
Linuxmint 17.3 Cinnamon 64bits.

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Montar carpetas NAS

Post by Wibol » Mon Jan 29, 2018 8:16 pm

Como es la forma mas eficiente de montar recursos compartidos y además estás interesado por el tema del portátil, te comento como lo tengo configurado yo y que pasos hay que seguir para la transición de fstab a autofs usando los datos que proporcionas:
  1. Desmontamos TODO de /mnt: sudo umount /mnt/*
  2. Eliminamos TODOS los directorios de /mnt ya que autofs los crea cada vez que los monta: sudo rm -d /mnt/*
  3. Hacemos una copia de seguridad de fstab: sudo cp /etc/fstab /etc/fstab.bck
  4. Editamos fstab y eliminamos todo lo relacionado con montajes de red: sudo nano /etc/fstab
  5. Para guardar y salir, pulsamos Control + O, Intro, Control + X.
  6. Instalamos autofs: sudo apt-get install autofs
  7. Editamos el archivo auto.master con sudo nano /etc/auto.master y añadimos /mnt/nas /etc/auto.shares --time-out=5 --ghost en la penúltima línea justo antes de +auto.master.
    automaster.png
  8. Para guardar y salir, pulsamos Control + O, Intro, Control + X.
  9. Hacemos una copia de auto.misc con otro nombre: sudo cp /etc/auto.misc /etc/auto.shares
  10. Editamos el archivo recién creado con sudo nano /etc/auto.shares y sustituimos cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom por:

    Code: Select all

    documentos -fstype=nfs,rw,soft,retry=0 192.168.0.2:/volume1/documentos
    fotos -fstype=nfs,rw,soft,retry=0 192.168.0.2:/volume1/photo
    autoshares.png
  11. Para guardar y salir, pulsamos Control + O, Intro, Control + X.
  12. Habilitamos el servicio autofs para el inicio del sistema y lo ponemos en marcha: sudo systemctl enable autofs && sudo systemctl start autofs
Este procedimiento lo he realizado desde cero en un Mint 18.3 (Sylvia), por lo que debería funcionar. Si aún así sigues con problemas para crear/modificar/eliminar archivos, debe estar relacionado con los permisos de las carpetas del servidor o con los especificados en el archivo exports del mismo.

Antes de realizar una consulta, no olvides:

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Tue Jan 30, 2018 3:07 pm

Estoy probando la configuración de autofs en el portatil (Ubuntu 16.04) y todo OK hasta que intento habilitar el servicio...al ejecutar el comando me sale el siguiente mensaje:

autofs.service is not a native service, redirecting to systemd-sysv-install
Executing /lib/systemd/systemd-sysv-install enable autofs
Linuxmint 17.3 Cinnamon 64bits.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Tue Jan 30, 2018 3:10 pm

He reiniciado el equipo y si me aparecen las carpetas en /mnt pero me sigue el mismo problema, no me deja crear carpetas en la carpeta inicial, pero si en las restantes...¿¿??
Linuxmint 17.3 Cinnamon 64bits.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Tue Jan 30, 2018 3:16 pm

Bueno no sé que ha pasado...ahora me esta dejando crear carpetas o archivos en la carpeta principal....

Lo único que he hecho fue abrir un archivo de la carpeta principal, lo modifique y lo guardé. Comprobe que todo estaba OK. Abrí LibreOffice y guarde un archivo nuevo en la carpeta principal. A partir de ese momento entro con nautilus en la carpeta y ya me permite crear carpetas o archivos nuevos desde él.

Gracias...ya tengo el portatil configurado con autofs... el siguiente paso configurar el equipo de escritorio...muchas gracias.
Linuxmint 17.3 Cinnamon 64bits.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Tue Jan 30, 2018 3:55 pm

Esta visto que no hay felicidad completa...

Ahora al apagar se queda desmontando las carpetas y no termina de desmontar las carpetas...¿¿??
Linuxmint 17.3 Cinnamon 64bits.

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Montar carpetas NAS

Post by Wibol » Tue Jan 30, 2018 4:27 pm

Tengo compartida la carpeta "logs" en el servidor con permisos de "Lectura y Escritura" para el "Usuario wibol" y "Ninguno" para el "Grupo wibol" y "Otros". Cuando accedo de un pc a otro estando iniciada la sesión "wibol" en ambos pc, no tengo ningún problema.

He creado un nuevo usuario llamado "pruebas" en el pc cliente, iniciado sesión con él y navegado hasta /nmt/Servidor y me he encontrado con que no tenia acceso a /logs. Así que he establecido los permisos para "Otros" en "Sólo lectura" y entonces la situación era exactamente la misma que tú tienes. Por último seleccioné "Lectura y Escritura" para "Otros" y finalmente he podido crear y eliminar.

Como puedes crear y eliminar en subcarpetas, doy por supuesto que esos directorios han sido compartidos desde el fichero "exports" con la opción rw (lectura y escritura). Por lo que creo que el problema surgido puede estar motivado por dos cosas:
  1. Has cambiado de usuario (con nombre diferente al que corre en el NAS).
  2. Han cambiado los permisos de "documentos" y "photo" para la raíz de estas carpetas pero no se han aplicado los cambios a los archivos y subcarpetas.
La solución consiste en acceder al NAS y establecer para esos directorios permisos de "Lectura y Escritura" para "Otros" asegurándote que los cambios se propagan a archivos y subcarpetas para no encontrar futuras sorpresas.
permisos.png

Antes de realizar una consulta, no olvides:

User avatar
JCSenar
Level 9
Level 9
Posts: 2822
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Montar carpetas NAS

Post by JCSenar » Wed Jan 31, 2018 8:19 am

Wibol wrote: Han cambiado los permisos de "documentos" y "photo" para la raíz de estas carpetas pero no se han aplicado los cambios a los archivos y subcarpetas.
Repasando el tema, los tiros pueden ir por ahí. En el primer mensaje de gamor, el comando chown solo afecta a las primeras carpetas. Le falta la opción -R para que afecte a las subcarpetas (sudo chown -R usuario /carpeta):
gamor wrote: - Cambio el propietario y permisos de grupo de todas esas carpetas:

sudo chown gamor /mnt/nas
sudo chown gamor /mnt/nas/documentos
sudo chown gamor /mnt/nas/fotos

sudo chgrp gamor /mnt/nas
sudo chgrp gamor /mnt/nas/documentos
sudo chgrp gamor /mnt/nas/fotos
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Wed Jan 31, 2018 11:29 am

No he cambiado de usuario. En todos los equipos uso el mismo usuario.

Tampoco he cambiado los permisos de las carpetas. Son carpetas que están creadas desde que he instalado el NAS y no he necesitado cambiar nada.

Y no quiero establecer para "Otros" permisos de "Lectura y Escritura" ya que hay otras personas que comparten la red y no quiero que puedan acceder a estas carpetas.

Después de enviar varias respuestas al tema del autofs he descubierto que en general todo Ok, pero hay algunas carpetas que no las reconoce...aparecen como archivo no reconocido. Al principio creí que era con alguna carpeta que en el nombre incluía ( ) pero siguiendo revisando las distintas carpetas veo que no tiene esto nada que ver.

También te comentaba, que al apagar el equipo este se quedaba intentando desmontar las carpetas y no terminaba de hacerlo. Teniendo que apagar a la fuerza el equipo. ¿¿ ??
Linuxmint 17.3 Cinnamon 64bits.

User avatar
Wibol
Level 4
Level 4
Posts: 237
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Montar carpetas NAS

Post by Wibol » Wed Jan 31, 2018 1:51 pm

Lo siento gamor pero a mí no me ocurre nada de lo que comentas. No tengo que esperar a que se desmonten las carpetas. De hecho, debería ocurrir en el momento en que cierras el explorador de archivos.

Los permisos no los habrás cambiado conscientemente, pero si aplicaste esos comandos una vez montadas las carpetas, JCSenar podría tener razón.

Deberías poder acceder a todas las carpetas que arroja el comando showmount -e 192.168.0.2, es decir: Test, Torrents, documentos, music, video, photo y Backup_home_desktop, que tienen la máscara 192.168.0.0/24 y que permiten la conexión desde cualquier equipo de la red local. Luego está la carpeta NetBackup DiskStation que aparentemente permite conexiones desde fuera de la red y por último la carpeta Incoming que usa una máscara rara (192.168..01.0/24).

Podrías intentar cambiar los permisos para "Otros" y ajustar la máscara (desde export del servidor) de las capetas para que sólo permitan conexiones desde tu IP fija. Es decir, sustituir 192.168.0.0/24 por 192.168.0.XXX, siendo XXX la IP de tu equipo cliente.

Por otra parte, te recuerdo que hicimos una copia de seguridad del archivo fstab durante el proceso y que lo puedes deshacer todo si ahora estás peor.

Antes de realizar una consulta, no olvides:

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Thu Feb 01, 2018 5:32 am

Este fin de semana le volveré a dar una vuelta.

Pero el problema de los permisos que me comentáis es al revés....yo no puedo crear nada en la carpeta principal, pero si en las que cuelgan de ella...

Gracias por la ayuda...espero solucionar el problema con vuestra ayuda.
Linuxmint 17.3 Cinnamon 64bits.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Sat Feb 03, 2018 7:45 am

Hoy por la mañana me he centrado con el problema con el equipo de escritorio y las carpetas que monta con fstab.

He borrado todas las carpetas de /mnt y las he vuelto a crear sin otorgarles ningún propietario ni grupo. Para crearlas en el terminal necesito usar "sudo".

Activo las lineas de fstab y reinicio el equipo.

Me pasa lo mismo. En las carpetas "raíz" no puedo crear carpetas/documentos desde el administrador de archivos, pero si abro por ejemplo Libreoffice y creo un documento y lo guardo en la carpeta raíz si que me deja guardarlo. ¿¿??

Entiendo que si desde el administrador de archivos no me deja crearlo, tampoco me debería dejar desde Libreoffice.

Lo de montar las carpetas lo uso para poder sincronizar las carpetas locales documentos, imágenes, música, etc con el contenido del NAS para disponer en todo momento de una copia de esos archivos. Esta sincronización la hago con Unison y programando una tarea cada cierto tiempo. Por ahora lo de los permisos no parece afectar a este funcionamiento, pero me mosquea lo que hace ya que entiendo que algo no esta bien.
Linuxmint 17.3 Cinnamon 64bits.

gamor
Level 1
Level 1
Posts: 29
Joined: Thu Sep 04, 2014 10:56 am

Re: Montar carpetas NAS

Post by gamor » Sun Feb 04, 2018 6:35 am

Hoy he vuelto a probar en una maquina virtual con Lubuntu. En esta máquina virtual se monta una carpeta x del NAS y sin ningún problema esta como siempre, puedo crear archivos/carpetas en la carpeta "raíz". He ido al NAS y he creado una nueva carpeta compartida (test) por nfs, la he configurado como la carpeta x que esta montada en este equipo. He creado en /mnt/nas la carpeta test con mkdir /mnt/nas/test (sin sudo) y me ha creado la carpeta con propietario/grupo gamor/gamor (mi usuario) activo en fstab la línea correspondiente para el inicio y al reiniciar me cambia el propietario de la carpeta a root/root ¿¿??

Anulo los cambio en fstab, reinicio. Cambio el propietario/grupo de la carpeta /mnt/nas/test con sudo chown gamor /mnt/nas/test y sudo chgrp gamor /mnt/nas/test y también cambio los permisos de control de acceso a los siguientes

- Ver contenido: Cualquiera
- Cambiar contenido: Solo el propietario
- Acceder al contenido: Cualquiera

Activo en fstab la línea correspondiente para que monte la carpeta al arrancar. Reinicio y me cambia el propietario/grupo a root/root y no me deja acceder a ella ya que indica permiso denegado. No puedo ver los permisos de control de acceso con el administrador de archivos pero con ls -l me indica lo siguiente:

d--------- 3 root root 4096 feb 4 11:18 test


Comento la linea de fstab con # y reinicio el equipo. Y veo que la carpeta /mnt/nas/test vuelve a tener como propietario/grupo gamor/gamor y los permisos de control de acceso los que yo había cambiado al principio. Vuelvo a descomentar la linea en fstab y ejecuto en el terminal sudo mount -a y veo que en el administrador de archivos sigue como propietario/grupo gamor/gamor y con los permisos de control de acceso como yo los había puesto. Pero no me deja acceder a la carpeta, me sale un mensaje que indica "permiso denegado", en el terminal ejecuto ls -l y veo que el propietario/grupo es root/root y los permisos de control de acceso son

d--------- 3 root root 4096 feb 4 11:18 test

Por hoy lo voy a dejar ya que me estoy bloqueando y ya no sé que mas probar.
Linuxmint 17.3 Cinnamon 64bits.

Post Reply

Return to “Español (Spanish)”