Page 1 of 1

Problema con WIFI BCM43228 en DELL LATITUDE E6420

Posted: Sat Mar 10, 2018 6:24 am
by Vikingo59
Tengo un portátil DELL LATITUDE E6420 al que le he instalado Linux Mint 18.3 mate 64. Durante la instalación he tenido la posibilidad de conectarme a mi red inalámbrica, pero una vez que me salgo para reiniciar y que los cambios que realice sean efectivos, al intentar conectarme a la red no me aparece como "activa" la red inalámbrica y no he sido capaz de configurar la conexión inalámbrica, tampoco me aparecen las diferentes redes a las que podría conectarse algo que sí aparece en otros portátiles que tengo y que me posibilita la configuración de la conexión. ¿Alguien puede ayudarme?

Re: Problema con WIFI en DELL LATITUDE E6420

Posted: Sat Mar 10, 2018 6:53 am
by JCSenar
Vikingo59 wrote:
Sat Mar 10, 2018 6:24 am
Tengo un portátil DELL LATITUDE E6420 al que le he instalado Linux Mint 18.3 mate 64. Durante la instalación he tenido la posibilidad de conectarme a mi red inalámbrica, pero una vez que me salgo para reiniciar y que los cambios que realice sean efectivos, al intentar conectarme a la red no me aparece como "activa" la red inalámbrica y no he sido capaz de configurar la conexión inalámbrica, tampoco me aparecen las diferentes redes a las que podría conectarse algo que sí aparece en otros portátiles que tengo y que me posibilita la configuración de la conexión. ¿Alguien puede ayudarme?
Por favor, lee este enlace y proporciona la información que en él se pide.

Por otro lado, ¿conseguiste algo con tu impresora XP-225?

Re: Problema con WIFI en DELL LATITUDE E6420

Posted: Sat May 19, 2018 3:47 pm
by Vikingo59

Code: Select all

jose@jose-Sotillo ~ $ inxi -Fxznr
System:    Host: jose-Sotillo Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Latitude E6420 v: 01
           Mobo: Dell model: 07TR3J Bios: Dell v: A21 date: 11/14/2013
CPU:       Dual core Intel Core i5-2520M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9976
           clock speeds: max: 2500 MHz 1: 2494 MHz 2: 2494 MHz 3: 2494 MHz
           4: 2494 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.99hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 4060 bus-ID: 00:19.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Broadcom BCM43228 802.11a/b/g/n
           driver: bcma-pci-bridge bus-ID: 02:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (2.3% used)
           ID-1: /dev/sda model: ST500LM012_HN size: 500.1GB
Partition: ID-1: / size: 186G used: 7.2G (5%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://ftp.cixug.es/mint/packages sylvia main upstream import backport
           deb http://ubuntu.cica.es/ubuntu xenial main restricted universe multiverse
           deb http://ubuntu.cica.es/ubuntu xenial-updates main restricted universe multiverse
           deb http://ubuntu.cica.es/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 174 Uptime: 1:15 Memory: 1018.3/3824.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
jose@jose-Sotillo ~ $

Re: Problema con WIFI en DELL LATITUDE E6420

Posted: Sat May 19, 2018 5:00 pm
by Taecita
Hola, prueba conectarte vía cable de red y en las configuraciones generales busca el administrador de controladores; por si tienes que instalar el alternativo. Me pasó con la placa de red Broadcom. En la instalación no tuve problemas, pero luego tuve que hacer lo que te comenté.

Re: Problema con WIFI en DELL LATITUDE E6420

Posted: Sat May 19, 2018 5:03 pm
by JOPETA
Antes quizas de lo que acaba de propornerte Taecita y conectado a internet por otros medios, prueba instalando el último kernel de la serie 4.13 de la forma gráfica recomendada.

De persistir el problema, sería necesario recabar mas detalles de tu tarjeta wifi. Devuelve el resultado del siguiente código desde la terminal usando la opción </> code de la forma indicada aquí.

Code: Select all

lspci -nnk | grep -iA2 net
La respuesta de Taecita da por sentado que el sistema es capaz de identificar y recomendar el controlador correcto (bcmwl-kernel-source). Por desgracia como digo en las notas de actualizacion de este hilo, no siempre es así. Es decir, a veces no basta con "acertar" (una vez comprobado el PID de la tarjeta es correcto) a instalar el controlador apropiado, eso ya lo hace el kernel 4.13, y habría que comprobar el módulo usado por el sistema con el código anterior y forzarle a usar el módulo correcto (wl en este caso) de la forma indicada. :roll:

Editado