No bootea imagen despues de instalar kernel

Spanish Forum

Moderator: JCSenar

Post Reply
Juanmac
Level 1
Level 1
Posts: 41
Joined: Thu Feb 06, 2014 12:35 pm

No bootea imagen despues de instalar kernel

Post by Juanmac » Tue Mar 20, 2018 9:00 am

Buenas que tal? actualice recientemente el kernel de LM a la ultima version 4.13.37 y sucede que no bootea ninguna imagen luego del logo de LM una vez que reinicio. Tengo una placa de video Intel hd 620.
inxi -Fxz

Code: Select all

System:    Host: juan-Inspiron-15-3567 Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell product: Inspiron 15-3567
           Mobo: Dell model: 0K99NX v: A00
           Bios: Dell v: 01.06.00 date: 03/23/2017
CPU:       Dual core Intel Core i3-7100U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2300 MHz 1: 661 MHz 2: 699 MHz 3: 703 MHz
           4: 614 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-3: Atheros usb-ID: 001-006
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (1.3% used)
           ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
Partition: ID-1: / size: 911G used: 6.5G (1%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 6.70GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 217 Uptime: 26 min Memory: 1537.4/5835.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Intente borrando los drivers viejos de Intel con este tutorial: https://sites.google.com/site/easylinux ... l-graphics y nada cambia. Probe instalando el kernel 4.13.24 que no tiene meltdown y spectre pero tampoco... alguna idea?

User avatar
hatteras
Level 9
Level 9
Posts: 2853
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: No bootea imagen despues de instalar kernel

Post by hatteras » Tue Mar 20, 2018 4:56 pm

¿No conservas el kernel que te funcionaba antes de instalar el nuevo que no te funciona ?
1-Si lo conservas, inicia desde grub, con él, desinstala el kernel que no te funciona, de forma gŕafica viewtopic.php?f=68&t=219791#p1152356
Desactiva los drivers que hayas podido activar, y las fuentes de software que hayas podido añadir a las que vienen por defecto con tu sistema.
Vuelve a instalar el kernel, de la forma gráfica que se indica en un tutorial de este blog viewtopic.php?f=68&t=219791#p1152356
Reinicia el sistema, y desde el grub prueba a ver si esta vez te funciona el nuevo kernel.
Suerte.

2-Si no lo conservas y solo tienes instalado ese kernel ( lo cual no es aconsejable, ya que siempre se aconseja tener al menos dos kernels para poder trabajar - y solucionar problemas - con uno si el otro no funciona ), quizás la solución sea iniciar el sistema desde el modo Recovery y tratar desde él de solucionar el problema.
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

Juanmac
Level 1
Level 1
Posts: 41
Joined: Thu Feb 06, 2014 12:35 pm

Re: No bootea imagen despues de instalar kernel

Post by Juanmac » Wed Mar 21, 2018 12:09 pm

hatteras wrote:
Tue Mar 20, 2018 4:56 pm
¿No conservas el kernel que te funcionaba antes de instalar el nuevo que no te funciona ?
1-Si lo conservas, inicia desde grub, con él, desinstala el kernel que no te funciona, de forma gŕafica viewtopic.php?f=68&t=219791#p1152356
Desactiva los drivers que hayas podido activar, y las fuentes de software que hayas podido añadir a las que vienen por defecto con tu sistema.
Vuelve a instalar el kernel, de la forma gráfica que se indica en un tutorial de este blog viewtopic.php?f=68&t=219791#p1152356
Reinicia el sistema, y desde el grub prueba a ver si esta vez te funciona el nuevo kernel.
Suerte.

2-Si no lo conservas y solo tienes instalado ese kernel ( lo cual no es aconsejable, ya que siempre se aconseja tener al menos dos kernels para poder trabajar - y solucionar problemas - con uno si el otro no funciona ), quizás la solución sea iniciar el sistema desde el modo Recovery y tratar desde él de solucionar el problema.
Lo hice, nada cambio. Volvi a los controladores privativos del procesador, borre y reinstale el kernel. Los de la tarjeta grafica nunca aparecieron para actualizar en "Administrador de controlodaroes" en ninguna de las instalaciones de LM que hice, creo que se actualizaron con la actualizacion de "mesa"(la verdad que no se si son los drivers de la placa de video) que no la desinstale esta vez por que ya habia probado haciendolo en otra ocacion y tampoco arranco luego de actualizar el kernel.
Ademas probe de instalar la 4.13.16 y ni siquiera me aparece el logo de LM (antes la imagen se perdia lugo del logo)
Last edited by Juanmac on Wed Mar 21, 2018 12:48 pm, edited 1 time in total.

Juanmac
Level 1
Level 1
Posts: 41
Joined: Thu Feb 06, 2014 12:35 pm

Re: No bootea imagen despues de instalar kernel

Post by Juanmac » Wed Mar 21, 2018 12:47 pm

Pregunta a parte, pero relacionada: como hago para elegir que kernel quiero que bootee pordefecto ele grub? o para hacer que me aparezca siempre apretar shift (alguno que este muy seguro de lo que me va a indicar por favor)? por que me tiene un poco cansado reiniciar el ordenador 5 veces hasta poder entrar al grub por que es bastante dificil y me bootea automaticamente la version mas actualizada del kernel que no me funciona

Juanmac
Level 1
Level 1
Posts: 41
Joined: Thu Feb 06, 2014 12:35 pm

Re: No bootea imagen despues de instalar kernel

Post by Juanmac » Wed Mar 21, 2018 12:48 pm

Juanmac wrote:
Wed Mar 21, 2018 12:09 pm
hatteras wrote:
Tue Mar 20, 2018 4:56 pm
¿No conservas el kernel que te funcionaba antes de instalar el nuevo que no te funciona ?
1-Si lo conservas, inicia desde grub, con él, desinstala el kernel que no te funciona, de forma gŕafica viewtopic.php?f=68&t=219791#p1152356
Desactiva los drivers que hayas podido activar, y las fuentes de software que hayas podido añadir a las que vienen por defecto con tu sistema.
Vuelve a instalar el kernel, de la forma gráfica que se indica en un tutorial de este blog viewtopic.php?f=68&t=219791#p1152356
Reinicia el sistema, y desde el grub prueba a ver si esta vez te funciona el nuevo kernel.
Suerte.

2-Si no lo conservas y solo tienes instalado ese kernel ( lo cual no es aconsejable, ya que siempre se aconseja tener al menos dos kernels para poder trabajar - y solucionar problemas - con uno si el otro no funciona ), quizás la solución sea iniciar el sistema desde el modo Recovery y tratar desde él de solucionar el problema.
Lo hice, nada cambio. Volvi a los controladores privativos del procesador, borre y reinstale el kernel. Los de la tarjeta grafica nunca aparecieron para actualizar en "Administrador de controlodaroes" en ninguna de las instalaciones de LM que hice, creo que se actualizaron con la actualizacion de "mesa"(la verdad que no se si son los drivers de la placa de video) que no la desinstale esta vez por que ya habia probado haciendolo en otra ocacion y tampoco arranco luego de actualizar el kernel.
Ademas probe de instalar la 4.13.16 y ni siquiera me aparece el logo de LM (con la 4.13.37 la imagen se perdia lugo del logo)

User avatar
JCSenar
Level 9
Level 9
Posts: 2703
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: No bootea imagen despues de instalar kernel

Post by JCSenar » Wed Mar 21, 2018 1:25 pm

Juanmac wrote:
Wed Mar 21, 2018 12:47 pm
Pregunta a parte, pero relacionada: como hago para elegir que kernel quiero que bootee pordefecto ele grub? o para hacer que me aparezca siempre apretar shift (alguno que este muy seguro de lo que me va a indicar por favor)? por que me tiene un poco cansado reiniciar el ordenador 5 veces hasta poder entrar al grub por que es bastante dificil y me bootea automaticamente la version mas actualizada del kernel que no me funciona
Cuando consigas arrancar con el kernel que funciona desinstala el resto desde Gestor de Actualizaciones > Ver > Kernels de Linux > Marcar > Eliminar:

Image
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
JOPETA
Level 13
Level 13
Posts: 4666
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Cambiar opción predeterminada por defecto en el menú GRUB

Post by JOPETA » Wed Mar 21, 2018 1:55 pm

Juanmac wrote:
Wed Mar 21, 2018 12:47 pm
Pregunta a parte, pero relacionada: como hago para elegir que kernel quiero que bootee por defecto el grub?
Para cambiar la opción de inicio predeterminada en GRUB:
1)Saber el orden que ocupa la opción a iniciar, por ejemplo con

Code: Select all

cat /boot/grub/grub.cfg | grep menuentry
En mi caso

Code: Select all

~ $ cat /boot/grub/grub.cfg |grep menuentry
if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
  menuentry_id_option=""
export menuentry_id_option
menuentry 'Linux Mint 18.3 Cinnamon 64-bit' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
submenu 'Opciones avanzadas para Linux Mint 18.3 Cinnamon 64-bit' $menuentry_id_option 'gnulinux-advanced-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.13.0-37-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.13.0-37-generic-advanced-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.13.0-37-generic (upstart)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.13.0-37-generic-init-upstart-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.13.0-37-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.13.0-37-generic-recovery-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-lowlatency' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-116-lowlatency-advanced-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-lowlatency (upstart)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-116-lowlatency-init-upstart-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-lowlatency (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-116-lowlatency-recovery-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-116-generic-advanced-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-generic (upstart)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-116-generic-init-upstart-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
	menuentry 'Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-116-generic-recovery-43bbef28-e3a1-4904-a28a-ee0970cd6699' {
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
Cuenta las menuentry (con kernel claro) para saber la posición que ocupa la entrada que deseas.
2)Edita el archivo /etc/default/grub con derechos administrativos

Code: Select all

gksudo xed /etc/default/grub

y reemplazar el valor de GRUB_DEFAULT=0 por el número de orden deseado menos uno.

También creo que puedes emplear entre comillas el nombre de la entrada entre '(nombre)' que aparece en el grub.cfg , por ejemplo GRUB_DEFAULT="Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.4.0-116-generic" equivale en mi caso a GRUB_DEFAULT=7.
3)No te olvides de guardar los cambios y cerrar el editor

4)Después actualizar GRUB antes de reiniciar.

Code: Select all

sudo update-grub
Last edited by JOPETA on Wed Mar 21, 2018 2:33 pm, edited 2 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

User avatar
JCSenar
Level 9
Level 9
Posts: 2703
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: No bootea imagen despues de instalar kernel

Post by JCSenar » Wed Mar 21, 2018 2:19 pm

También puede usarse Grub-Customizer.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Juanmac
Level 1
Level 1
Posts: 41
Joined: Thu Feb 06, 2014 12:35 pm

Re: Cambiar opción predeterminada por defecto en el menú GRUB

Post by Juanmac » Wed Mar 21, 2018 9:56 pm

JOPETA wrote:
Wed Mar 21, 2018 1:55 pm
Lo pude modificar poniendo por defecto el nombre del kernel, pero no el "Linux Mint 18.3 Cinnamon 64-bit, con Linux 4.10.38-generic" por ejemplo, por que al ejecutar sudo update-grub me recomendaba las varaciones validas de los nombres para elegir kernel a bootear cambiando para los Grub anteriores y posteriores al 2.0. En mi caso quedo por ejemplo :GRUB_DEFAULT="gnulinux-advanced-49e777e3-a724-403d-acff-72747b76d018>gnulinux-4.10.0-38-generic-advanced-49e777e3-a724-403d-acff-72747b76d018" que era el nombre que me recomendaba para las versiones posteriores a Grub2. Cambiar el valor numerico al nro de kernel -1 no me funciono.
Ademas comento algo que no me parece un detalle, entro mucho mas facilmente al grub apretando repetidas veces Shift izquierdo antes que manteniendo apretado como recomiendan en todos lados que se me costaba minimo 5 reinicios por no acertar el momento, que tampoco era siempre el mismo.

User avatar
JOPETA
Level 13
Level 13
Posts: 4666
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: No bootea imagen despues de instalar kernel

Post by JOPETA » Thu Mar 22, 2018 12:21 pm

Gracias por la aclaración, las cosas cambian... :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”