Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ ni ¿ ( Esta en Inglés)

Spanish Forum

Moderator: JCSenar

Post Reply
User avatar
hatteras
Level 9
Level 9
Posts: 2830
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ ni ¿ ( Esta en Inglés)

Post by hatteras » Fri Apr 13, 2018 10:18 am

Como dice el título, en el teclado virtual que viene por defecto con Cinnamon no aparece la Ñ ni el símbolo de interrogación ¿
Me parece que es un teclado Inglés.
teclado1.png
Last edited by hatteras on Sun Apr 22, 2018 4:36 pm, edited 1 time in total.
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2624
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by JCSenar » Fri Apr 13, 2018 12:09 pm

hatteras wrote:
Fri Apr 13, 2018 10:18 am
Como dice el título, en el teclado virtual que viene por defecto con Cinnamon no aparece la Ñ
Queda pendiente de solución; yo no he encontrado nada.

Sí he encontrado una alternativa: Florence (sudo apt-get install florence):

Florence.jpg
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
hatteras
Level 9
Level 9
Posts: 2830
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by hatteras » Fri Apr 13, 2018 2:32 pm

Muy bonito el teclado de Florence, igual que el que me acabo de instalar ( no pongo pues imagen )...pero no tiene la ñ
PD: Corregido , JCSenar me ha enseñado mas abajo que si que tiene la ñ, aunque solo aparece con el símbolo ~

Onboard si que tiene la ñ
onboard.png
Onboard cambia de teclado con el comando: setxkbmap
setxkbmap es teclado Español
setxkbmap us teclado de USA
setxkbmap br teclado Británico

El teclado virtual propio de Cinnamon NO parecen verse afectados por dicho comando

Sobre el comando setxkbmap: ver mis comentarios en viewtopic.php?f=68&t=264403
Last edited by hatteras on Fri Apr 13, 2018 4:30 pm, edited 3 times in total.
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2624
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by JCSenar » Fri Apr 13, 2018 3:22 pm

hatteras wrote:
Fri Apr 13, 2018 2:32 pm
Muy bonito el teclado de Florence, igual que el que me acabo de instalar ( no pongo pues imagen )...pero no tiene la ñ
Precisamente he mencionado Florence como alternativa porque sí tiene la Ñ. Se escribe con la tecla que ves resaltada aunque solo aparezca el símbolo ~:

FlorenceÑ.jpg
FlorenceÑ.jpg (10.14 KiB) Viewed 211 times
hatteras wrote:
Fri Apr 13, 2018 2:32 pm
Onboard cambia de teclado con el comando: setxkbmap
Curioso: si abro el Teclado virtual de Cinnamon a través de Menú > Accesorios > Teclado virtual me aparece sin Ñ, como en tu primera imagen:

Image.

Sin embargo, si ejecuto la orden onboard en el Terminal se me abre con la Ñ, como en tu segunda imagen :shock:

Image

¿Cómo abres tú onboard?

Así que he probado una cosa: si edito el comando que ejecuta el Teclado virtual, me da que es este:

dbus-send --print-reply --dest=org.Cinnamon /org/Cinnamon org.Cinnamon.ToggleKeyboard

Teclado1.jpg

Si sustituyo el comando por onboard (hay que cerrar/abrir sesión para que tenga efecto) ya me funciona el teclado con la Ñ directamente desde Menú > Accesorios > Teclado virtual:

Teclado2.jpg

Y no hay que utilizar el Terminal para nada 8) .
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
hatteras
Level 9
Level 9
Posts: 2830
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by hatteras » Fri Apr 13, 2018 3:49 pm

1- Ya he visto la ñ en Florence. Gracias.
Se abre desde Menu->Acceso universal-Florence
También se puede abrir añadiendo un atajo de teclado en Configuración de Cinnamon-Teclado-Atajos de teclado
2- Onboard lo abro desde Menu->Acceso universal-Onboard ( bueno en realidad lo he añadido como favorito, y lo abro desde el dock de aplicaciones Cinnadock )
También se puede abrir añadiendo un atajo de teclado en Configuración de Cinnamon-Teclado-Atajos de teclado
3- El teclado virtual de Cinnamon no lo veo en ningún sitio en el menú de aplicaciones; lo abro con la combinación de teclas: Windows+t ( es la que viene por defecto, pero se puede cambiar desde Configuración de Cinnamon-Teclado-Atajos de teclado )

El asunto que da título a este tema sigue sin solución
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2624
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by JCSenar » Fri Apr 13, 2018 4:01 pm

hatteras wrote:
Fri Apr 13, 2018 3:49 pm
3- El teclado virtual de Cinnamon no lo veo en ningún sitio en el menú de aplicaciones; lo abro con la combinación de teclas: Windows+t ( es la que viene por defecto, pero se puede cambiar desde Configuración de Cinnamon-Teclado-Atajos de teclado )
hatteras wrote:
Fri Apr 13, 2018 3:49 pm
El asunto que da título a este tema sigue sin solución
Por lo visto, en Cinnamon (LM 17.3) hay dos teclados virtuales disponibles:

El Teclado virtual que se abre con Windows+T que no incluye la Ñ y Onboard (Menú > Acceso Universal > Onboard) que sí incluye la Ñ:

Pantallazo-8.png

Por intentar centrar (y entender el problema):

1.- ¿Tu pregunta es cómo hacer que el Teclado virtual que se abre con Windows+T también incluya la Ñ? Si es así, este tema queda pendiente de solución.

2.- Pero, por otra parte, ¿por qué no utilizas Onboard y listo?

3.- Y, si quieres utilizar el atajo Windows+T, ¿no sería suficiente con cambiar el atajo de teclado para que se abra onboard con Windows+T? Funciona bien:

Pantallazo-5.jpg
Pantallazo-7.png
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
hatteras
Level 9
Level 9
Posts: 2830
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by hatteras » Fri Apr 13, 2018 4:10 pm

Siempre puedes añadir Onboard al menú de aplicaciones y/o hacer que se ejecute con una combinación de teclas.

Tanto Onboard como Florence se ven afectados por el comando setxkbmap , pero no en cambio el teclado virtual de Cinnamon
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2624
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by JCSenar » Sat Apr 14, 2018 2:34 am

hatteras wrote:
Fri Apr 13, 2018 3:49 pm
El asunto que da título a este tema sigue sin solución
He editado mi anterior mensaje.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
hatteras
Level 9
Level 9
Posts: 2830
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by hatteras » Sat Apr 14, 2018 5:24 am

Onboard no viene incluido por defecto con mint 17.3 , lo instale desde Synaptic, lo mismo que Florence.. Ambos una vez instalados se pueden abrir desde el menú de aplicaciones ( Onboard lo he tenido que añadir a mano a este menú, ya que no se porque solo aparecía.

La ventana de Configuración de Onboard no se abre ni ejecutada desde el Menú de Aplicaciones, ni desde el icono en el panel que aparece cuando abro Onboard.
Si ejecuto en la terminal la orden: onboard-settings no se abre la ventana de configuración ya que me sale un error:

(onboard-settings:4109): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error en la l�nea 1, car�cter 38: Texto codificado como UTF-8 en el nombre no v�lido; �Integraci\xf3n con el escritorio� no es v�lido

(onboard-settings:4109): Gtk-WARNING **: Invalid input string

(onboard-settings:4109): Gtk-WARNING **: Invalid input string

(onboard-settings:4109): Gtk-WARNING **: Invalid input string

(onboard-settings:4109): Gtk-WARNING **: Invalid input string
Violaci�n de segmento


Pero puedo configurar Onboard desde Dconf-editor.

Se pueden crear atajos de teclado para cualquier programa, por lo tanto podemos tener los tres teclados ( el propio de Cinnamon, Onboard y Florence ) ejecutables desde un atajo de teclado y los dos últimos o bien desde el menú de aplicaciones o con un atajo de teclado.
También me parecer raro que los dos teclados que no vienen por defecto si que se vean afectados por el comando setxkbmap , y que el que viene por defecto parece que no se altera por ello.

Pero la cosa es que me molesta que algo que viene por defecto no funcione como es debido y que haya que instalar teclados virtuales, por lo que hasta nueva orden me gustaría solucionar el asunto con el teclado virtual de Cinnamon.
En realidad ya no es cuestión de usabilidad sino de cabezonería...y soy bastante cabezota.
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

User avatar
JCSenar
Level 9
Level 9
Posts: 2624
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Teclado virtual de Cinnamon ( Mint 17.3) sin Ñ

Post by JCSenar » Sat Apr 14, 2018 6:55 am

hatteras wrote:
Sat Apr 14, 2018 5:24 am
Pero la cosa es que me molesta que algo que viene por defecto no funcione como es debido y que haya que instalar teclados virtuales, por lo que hasta nueva orden me gustaría solucionar el asunto con el teclado virtual de Cinnamon.
En realidad ya no es cuestión de usabilidad sino de cabezonería...y soy bastante cabezota.
No. Si entenderte, te entiendo. Será un bug que en LM 18.3 sigue sin corregirse :roll:

La cuestión es cuánto tiempo perder con esto teniendo alternativas (tal vez por eso onboard se incluye por defecto en LM 18.X).

Los de francés tienen el mismo problema aunque sólo he encontrado un tema al respecto. Y la solución es usar onboard... :|
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Post Reply

Return to “Español (Spanish)”