Problema con Grub En Lenovo Thinkpad13 [SOLUCIONADO]

Spanish Forum

Moderator: JCSenar

Post Reply
MIMB
Level 1
Level 1
Posts: 3
Joined: Sat May 26, 2018 9:53 am

Problema con Grub En Lenovo Thinkpad13 [SOLUCIONADO]

Post by MIMB » Sat May 26, 2018 11:07 am

Hola a todos,

Soy nuevo en Linux. Quiero empezar a dejar de usar Windows pero esta resultando una maldita tortura.

{Por si no queda claro]
NO FUNCIONA EL GRUB Y ARRANCA DIRECTAMENTE A WINDOWS 10

CREO QUE ES PROBLEMA DE LA BIOS DE LENOVO, PERO NO ESTOY SEGURO.

La tortura viene por mi laptop. Lenovo Thinkpad 13. He leído que Lenovo da muchos problemas con las instalaciones dual boot.
Lo mio es desesperante, pero no me quiero rendir.
Voy al grano. Ahora estoy desde usb live en Linux Mint Sylvia Cinnam..no seque.

En el laptop tengo Windows 10. Para instalar Linux hice una particion del ssd y luego con usb live hice de esa partición 2 mas. Una para el intercambio otra para la instalación raíz y la ultima para home.

No toque el EFI del windows. blablabla... es una instalacion en UEFI con GPT.
También leí lo del tema de la BIOS con lo de desactivar blablabla boot no se que y todo esas locuras que todos vosotros ya sabéis.

De hecho estoy escribiendo esto porque después de mirar cien videos, foros y tal... parece que la realidad es que los linuxeros no quieren que la gente que usa windows se pase a Linux.
Pero no importa, quiero usar Linux.


A ver, como soluciono el tema del Grub para que cuando inicie el pc me de a elegir entre Linux o Windows 10?

He probado lo del efiboot...no se que.. na de na.
Lo de mount /dev/sda6 en mi caso /mnt y toda la película que sigue... nada de nada.
De hecho, cuando hago lo del grub/install --root-directory=/mnt y lo que sigue, me dice que me acueste, que no puede instalar nada por no se que historias.

En fin... alguien me puede ayuda a usar Linux de base con windows o sigo con el cdlive que al final pues como que no.

Muchas gracias por vuestro tiempo.

Esto es desesperante!!
Last edited by karlchen on Sat May 26, 2018 4:22 pm, edited 2 times in total.
Reason: removed irrelevant suffixed terms from the title

User avatar
JOPETA
Level 12
Level 12
Posts: 4378
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema con Grub En Lenovo Thinkpad13 / NOVATO / RELAX / BAJARSE DE LA PARRA

Post by JOPETA » Sat May 26, 2018 12:18 pm

Entiendo tu desesperación pero debes comprender

1)Que el tema UEFI es algo que algunos fabricantes, no Linux (que no lo necesita ya que estaba protegido contra los rootkits y malwares para Windows que se instalan en el MBR), inventaron de la mano de otros sistemas operativos, MS redondeó y todos los fabricantes han adoptado de una u otra forma. El software libre ha luchado lo indecible para que Windows no cierre la posibilidad de que instales en tu máquina lo que sea que le permita que siga viva mientras el hardware lo permita, no cuando los fabricantes o MS lo decida.

2)Que el foro (este y todos) tienen unas directrices y política que, de "pura lógica" son normas de comportamiento y expresión para evitar que se escape de sus objetivos de prestar ayuda desinteresada y sea pasto de controversias incendiarias, heaters y trolls (no digo que tu lo seas).

3)Es la primera vez que veo a JCSenar (otro colaborador desinteresado) tan enfadado como para haber tenido que intervenir. Piensa que voluntarios como JCSenar se toman además la molestia de crear tutoriales fáciles de seguir como este (además de los que Mint posteriormente ha elaborado y traducido su guía a diferentes idiomas entre ellos el español sin cobrarte nada) para algo y resulta un tanto ingrato.

Si quieres replantearte formas y contenidos una indicaciones:
-Evita el blablablá y noseque,y tal..., no sólo los tacos y expresiones fuera de lugar. Por ejemplo, Linux MInt 18.3 Cinnamon 64 bits, si es que es ese, descargado desde la Web de Mint).

-Céntrate en lo importante siendo lo mas concreto posible.

-Si has intentado alguna solución proporciona el enlace,

-Sigue por ejemplo el de JCSenar y confirma por ejemplo que desactivaste el Inicio Rápido/Hibernación en Windows, etc.

-primero iniciando sin el Live de Mint, define exactamente la configuración de la BIOS/EUFI en relación al Modo de inicio (EFI), CSM (desactivado), Secure Boot (desactivado), fast boot (desactivado), Opciones de inicio que te muestra la BIOS (algunas tienen una función BBS para seleccionar con que sistema instalado en modo EFI que es identificado iniciar, otros te permite navegar para leer su cargador efi (grubx64.efi dentro de /EFI/Ubuntu/grub/)... No todas las BIOS/UEFI son tan "Unified" Extensible Firmware Interface, los fabricantes al final hacen un poco su antojo o la cagan.

-¿Cómo creaste el Live de Instalación? desde luego no es CDlive, Si es de Mint debe ser como mínimo DVD aunque lo recomendable es un USB live.

-Confirmada que la UEFI/BIOS se inicia de la forma indicada y sigue las indicaciones de JCSenar al final del tutorial para intentar solucionar el problema, si la opción de inicio Ubuntu no parece por ningún sitio de la BIOS/UEFI o aunque apararezca sólo se inicia Windows.

-Sólo en último extremo y aclarados los términos anteriores puedes plantearte una reinstalación de GRUB EFI según, por ejemplo el tutorial mencionado mas adelante .

-En cualquier caso debes confirmar que el Live se inicia en modo EFI para intentar cualquier solución.

-Se exacto en lo códigos que has usado y presta atención en los que uses (siempre es mejor copiar, modificar si quieres usando el editor de texto del Live y pegar en la terminal antes de darle al Intro que escribir), ya que no es lo mismo grub/install --root-directory=/mnt y lo que sigue que sudo grub-install . Desde luego no ha salido del tutorial propuesto por este foro para reinstalar GRUB EFI si es que es necesario.

-Una vez replantees el tema es posible que el tutorial no te sea de aplicación y en cualquier caso no la primera parte ni la última inicialmente ya que el Thinkpad no es uno de los conocidos por problemáticos (( sin el apartado A ni C inicialmente).

- NO intentes atajar o complicarás de forma innecesaria las cosas y además no habrás aprendido nada aunque funcione. Por desgracia, a poco que modifiques la BIOS/UEFI (por ejemplo activando el Secure Boot) o Windows realice una de sus actualizaciones es posible que tengas que volver a cambiar la configuración ya que puede volver a iniciarse por defecto.

Ahhh... ¡BIenvenido al foro! y pese al inicio espero que también tu colabores en lo que puedas. :D
Last edited by JOPETA on Sat May 26, 2018 1:02 pm, edited 4 times in total.
Si unas prisas acude al chat (Menú ‣ Internet ‣ HexChat) #linuxmint-help (te atenderán en cualquier idioma) o si quieres simplemente charlar exclusivamente en español #linux-es

MIMB
Level 1
Level 1
Posts: 3
Joined: Sat May 26, 2018 9:53 am

Re: Problema con Grub En Lenovo Thinkpad13 / NOVATO / RELAX / BAJARSE DE LA PARRA

Post by MIMB » Sat May 26, 2018 12:40 pm

Hola y gracias por tu respuesta.
Era lo mínimo que esperaba ver. No se hablar la jerga y hay que ser empaticos. No todos sabemos de todo.

No soy de los que a la mínima busca ayuda, y lo de crear una cuenta en un foro pues como que da pereza y no voy hacer mas uso que para solventar un problema que no he podido por mi cuenta. De hecho, si lo solvento, ya no haré mas uso de este foro, no por el inicio que he tenido, sino porque no soy de foros.

No se por donde empezar, y demasiada información para solventar el tema del Grub.

Es una USB Live, descargada la ISO de la web oficial. Si, es de 64bits la ultima version de Cinnamon 18.3.
Creado el USB para UEFI GPT
CSM (desactivado), Secure Boot (desactivado), fast boot (desactivado)

He intentado reparar o instalar el Grub con estos resultados.

Code: Select all

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1023999   1021952   499M Windows recovery environment
/dev/sda2    1024000   1228799    204800   100M EFI System
/dev/sda3    1228800   1261567     32768    16M Microsoft reserved
/dev/sda4    1265664 438675455 437409792 208.6G Microsoft basic data
/dev/sda5  438675456 500117503  61442048  29.3G Linux filesystem

Code: Select all

mint mint # mount /dev/sda5 /mnt
mint mint # grub-install --root-directory=/mnt /dev/sda
grub-probe: error: failed to get canonical path of `aufs'.
Installing for i386-pc platform.
grub-install.real: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install.real: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install.real: error: will not proceed with blocklists.
No se que mas contar.

En serio, no me apetece nada molestaros, crear una cuenta en el foro y tal para tocar los ... solo quiero solventar el problema de una vez.
SI no quieres ayudar pues tampoco pasa nada, ya preguntare un un foro ingles.

Gracias por tu tiempo.

PD. Que quede claro, cuando abro un post para pedir ayuda he leído antes y he probado antes todo lo que comentas. Repito, no busco ayuda a la minina de cambio. El tutorial de tu colaborador ya lo había leído antes y el resto que comentas.
Quizás me tomas por otro tipo de usuario. No me gusta molestar. Si haces el tutorial es porque quieres, nadie te obliga... como a mi, nadie me obliga a usar linux. PERO QUE SEPAS QUE ME LEO LOS TUTORIALES ANTES DE PREGUNTAR.

Se agradece que haya gente tan desinteresada.
Last edited by JCSenar on Sat May 26, 2018 2:03 pm, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 12
Level 12
Posts: 4378
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema con Grub En Lenovo Thinkpad13 / NOVATO / RELAX / BAJARSE DE LA PARRA

Post by JOPETA » Sat May 26, 2018 12:58 pm

También debes tener paciencia con los lentos en repasar y escribir, como yo y darnos mas tiempo. Vuelve a leer la respuesta anterior por si encuentras algo nuevo.

No veo que abandones el tono (has debido leer las normas un poco por encima). :roll:

PD: Aunque no proporcionas el enlace ya había intuido que no era el tutorial de reinstalación de grub efi de este foro, ni tampoco el que se analiza y explica más adelante de la web Pjotr. Mas bien parece un Tutorial para recuperar el GRUB de sistemas BIOS tradicionales, por lo que, detectando un particionado GPT no MBR (msdos) busca una partición BIOS Boot que usar a modo de MBR, es decir donde colocar el GRUB de toda la vida (no el grub-efi) sin éxito... lo mejor que te podría haber ocurrido. :?
grub-probe: error: failed to get canonical path of `aufs'
Installing for i386-pc platform.
grub-install.real: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
No es sólo un problema de montaje de una u otra partición, son las ordenes que se ejecutan y la repuesta que se obtiene aún errando en el montaje. El grub-install daría otros errores de haber iniciado el sistema en modo EFI estricto o aún habiendo iniciado el medio en modo BIOS o Compatible (CSM) de haber instalado los paquetes grub-efi necesarios previamente (apt install grub-efi-amd64 del tutorial o el modprobe efivars del de Pjotr).

Leer sobre el problema o tutoriales es una cosa, que te sea de aplicación es otra. Un buen tutorial es el que da por sentado que el usuario puede tener problemas para seguirlo y antes de hacer nada le propone abrir un hilo de ayuda (todos hemos sido y seguimos siendo novatos en muchos temas, nadie nace enseñado).
Last edited by JOPETA on Sat May 26, 2018 7:50 pm, edited 7 times in total.
Si unas prisas acude al chat (Menú ‣ Internet ‣ HexChat) #linuxmint-help (te atenderán en cualquier idioma) o si quieres simplemente charlar exclusivamente en español #linux-es

MIMB
Level 1
Level 1
Posts: 3
Joined: Sat May 26, 2018 9:53 am

Re: Problema con Grub En Lenovo Thinkpad13 / NOVATO / RELAX / BAJARSE DE LA PARRA

Post by MIMB » Sat May 26, 2018 2:35 pm

Hola,

Gracias por tu tiempo.

Ya lo he solucionado.
Me estaba equivocando en algo básico.
No tiene importancia y no sabría como recrear aquí. Era a la hora de realizar la instalación, no estaba indicando bien el sector de arranque.

Muchas gracias.

Post Reply

Return to “Español (Spanish)”