[Solucionado] Linux Mint anda trabado

Spanish Forum

Moderator: JCSenar

Post Reply
MrGami
Level 1
Level 1
Posts: 3
Joined: Mon Jun 04, 2018 4:45 pm

[Solucionado] Linux Mint anda trabado

Post by MrGami » Mon Jun 04, 2018 7:03 pm

Buenas, este es el primera ves que publico asi que si me equivoco en algo avisen.

Bueno sin mucha vuelta voy al problema, linux anda trabado desde que se inicia, la pantalla del login y todo se carga trabado y de arriba para abajo como si estuvieras descargando una imagen pesada con Internet lento... se entiende no?.
Espesificaciones de la notebook:
Intel® Core™ i7-7700HQ
RAM 16 GB DDR4 2400MHZ
Disco rígido 1 TB SATA 3
Unidad SSD 240 GB M.2 SDD
Nvidia GeForce® GTX 1060 6GB GDDR5

Instale no me acuerdo cual versión de linux mint con escritorio mate y lo actualice a la 18 Sarah (andaba trabado antes y después de actualizar). Tengo instalado la raíz y el swap en el ssd y el home en el disco rígido.
Creí que era problema de la gráfica al tener la integrada y la gtx 1060 e intente instalar los driver de Nvidia pero no pude por el siguiente error:

ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com

Ese error no lo pude solucionar aun pero al ir al centro de controladores me aparecen los controladores open-software y los privativos, que con ninguno de los 2 se soluciona el problema. Al parecer se traba mas cuando quiere refrescar la imagen al cambiar de un programa al otro, al abrirlo o hacer scroll en alguna pagina web.... siempre refresca la imagen trabado y como explique arriba.
Alguna idea de que es lo que puede ser? Muchas gracias de antemano.

EDIT 1: al parecer el problema no es solo con refrescar la imagen el problema, todo lo que genere procesamiento en general hace que ande trabado. Cuando estaba booteado del pendrive antes de instalar no me hacia este problema.
Last edited by MrGami on Tue Jun 05, 2018 3:17 pm, edited 2 times in total.

User avatar
JOPETA
Level 12
Level 12
Posts: 4464
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint anda trabado

Post by JOPETA » Mon Jun 04, 2018 7:40 pm

¡Hola MrGami , Bienvenido al foro! :wink:

Proporciona información completa de tu sistema. Abre una terminal (Alt+Ctrl+T o clic en el icono del panel), copia y pega el siguiente código y devuelve el resultado usando la opción </> code como se indica aquí.

Code: Select all

inxi -Fxnzr
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

MrGami
Level 1
Level 1
Posts: 3
Joined: Mon Jun 04, 2018 4:45 pm

Re: Linux Mint anda trabado

Post by MrGami » Mon Jun 04, 2018 7:58 pm

Gracias ^^
aca esta la info:

Code: Select all

System:    Host: gami-GAMER-GM-Z Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: MATE 1.14.1 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18 Sarah
Machine:   System: BANGHO (portable) product: GAMER GM-Z
           Mobo: BANGHO model: GAMER GM-Z
           Bios: American Megatrends v: 1.05.07RPC date: 08/30/2017
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22466
           clock speeds: max: 2801 MHz 1: 900 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz 5: 900 MHz 6: 800 MHz 7: 800 MHz 8: 900 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 1c20 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia,fbdev,intel,nouveau (unloaded: vesa)
           Resolution: 1920x1080@77.00hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
           Card-3: Atheros usb-ID: 001-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (2.3% used)
           ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
           ID-2: /dev/sda model: WDC_WD10SPZX size: 1000.2GB
Partition: ID-1: / size: 47G used: 6.6G (15%) fs: ext4 dev: /dev/nvme0n1p5
           ID-2: /home size: 148G used: 494M (1%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 16.38GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sarah main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 243 Uptime: 3 min Memory: 965.5/15927.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

User avatar
JOPETA
Level 12
Level 12
Posts: 4464
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint anda trabado

Post by JOPETA » Mon Jun 04, 2018 8:39 pm

Tienes instalado y en uso un kernel muy desactualizado y sin parcheo contra las últimas vulnerabilidades (meltdown y spectre). Se trata de un equipo muy reciente, demasiado para cualquier versión actualizada del kernel 4.4.

1) Desinstala el actual controlador de Nvidia. Sea cual sea no parece haber tenido éxito y es lo normal con ese kernel. Abre una terminal y simplemente copia y pega una línea cada vez seguid de Intro

Code: Select all

apt purge nvidia-*
sudo reboot
No te sorprendas si se atasca. Vuelve a iniciar. Ahora estás otra vez con el controlador libre Nouveau y si obtienes una pantalla negra mira este hilo e inicia con el modificador recomendado (nomodeset)
2)Instala, de la forma gráfica recomendada, el más reciente 4.15 que esté disponible.

3)Luego (tarda un poco en instalar) reinicia sudo reboot.

4)Cuando reinicies con el nuevo kernel (opción preseleccionada por defecto) vuelve a instalar el controlador semi-privativo de Nvidia (384 o 390??) recomendado en el Administrador de controladores,

5) Reinica de nuevo. Devuelve el resultado del código solicitado en el post anterior otra vez. Suerte. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

MrGami
Level 1
Level 1
Posts: 3
Joined: Mon Jun 04, 2018 4:45 pm

Re: Linux Mint anda trabado

Post by MrGami » Tue Jun 05, 2018 12:05 pm

Mil gracias :D era ese el problema, ya anda genial la maquina ahora (aunque aun no la probe mucho) y el error de xserver que tira nvidia con la vercion 390 sigue estando pero al menos el administrador de controladores me deja poner la 384... supongo que tocara googlear bastante si quiero solucionar eso jajaja.
Te dejo los resultados de inixi:

Code: Select all

System:    Host: gami-GAMER-GM-Z Kernel: 4.15.0-22-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.14.1 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18 Sarah
Machine:   System: BANGHO (portable) product: GAMER GM-Z
           Mobo: BANGHO model: GAMER GM-Z
           Bios: American Megatrends v: 1.05.07RPC date: 08/30/2017
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 3634 MHz 2: 3601 MHz 3: 3408 MHz
           4: 3405 MHz 5: 3405 MHz 6: 3405 MHz 7: 3749 MHz 8: 3793 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 1c20 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia,nouveau,intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.02hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-22-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
           Card-3: Atheros usb-ID: 001-005
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1016.4GB (3.1% used)
           ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
           ID-2: /dev/sda model: WDC_WD10SPZX size: 1000.2GB
           ID-3: USB /dev/sdb model: DataTraveler_2.0 size: 16.2GB
Partition: ID-1: / size: 47G used: 7.2G (17%) fs: ext4 dev: /dev/nvme0n1p5
           ID-2: /home size: 148G used: 600M (1%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 16.38GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 62.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sarah main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 233 Uptime: 0 min Memory: 553.9/15921.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Mil gracias nuevamente :D

User avatar
JOPETA
Level 12
Level 12
Posts: 4464
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint anda trabado

Post by JOPETA » Tue Jun 05, 2018 1:10 pm

Mil de nadas :D

Puede que te evites ese error si partes de purgar la nvidia anterior (apt purge nvidia-* desde una consola Alt+Ctrl+F1 o F2 parando antes el servicio dm sudo service mdm stop si no has cambiado a lightdm) antes de instalar la nueva.Mira este hilo y reemplaza el controlardor por el que vayas a probar (390, 396..) También puedes probar con los nuevos controladores disponibles en la ppa graphic drivers (396, te parecerán en el Administrador de Controladores y luego volverá a aparecer el instalado una vez Ubuntu lo haga oficial en el Admisnitrador de actualizaciones).

Aunque si funciona bien con el 384, ya sabes si no está roto... :roll:

Si crees que el tema está solucionado por favor edita el título del primer post (clic en el icono del lápiz) y añada [Solucionado]. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”