Mint 18.3 no detecta Broadcom BCM4311

Spanish Forum

Moderator: JCSenar

Post Reply
mariolan
Level 1
Level 1
Posts: 11
Joined: Sat Apr 21, 2018 12:46 pm

Mint 18.3 no detecta Broadcom BCM4311

Post by mariolan » Wed Jun 06, 2018 7:43 pm

Estimados, poseo una laptop Dell Inspiron 1526 con dual boot Windows 7 y Linux Mint 18.3
Con Windows 7 conecta a internet sin inconvenientes.
En Linux Mint no detecta la placa Broadcom BCM4311

Les paso algunos comandos de configuración

inxi -N
Network: Card: Broadcom BCM4311 802.11b/g WLAN driver: b43-pci-bridge

Code: Select all

inxi Fxy
CPU~Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) speed/max~800/2000 MHz Kernel~4.10.0-38-generic x86_64 Up~17 min Mem~519.6/1870.8MB HDD~250.1GB(3.7% used) Procs~160 Client~Shell inxi~2.2.35  
plv@plc-lumen ~ $ inxi -Fxz
System:    Host: plc-lumen Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 1526
           Mobo: Dell model: 0WP019 Bios: Dell v: A16 date: 10/27/2009
CPU:       Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 6384
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]
           bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,vesa (unloaded: fbdev,radeon)
           Resolution: 1024x768@61.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series]
           driver: snd_hda_intel bus-ID: 01:05.2
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Broadcom BCM4311 802.11b/g WLAN
           driver: b43-pci-bridge bus-ID: 0b:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (3.7% used)
           ID-1: /dev/sda model: WDC_WD2500BEVS size: 250.1GB temp: 43C
Partition: ID-1: / size: 22G used: 5.8G (28%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.26GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A fan-2: 0 fan-3: 0
Info:      Processes: 160 Uptime: 18 min Memory: 520.1/1870.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Code: Select all

sudo iwlist scan
lo        Interface doesn't support scanning.

Code: Select all

ifconfig -a
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1712 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1712 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:136529 (136.5 KB)  TX bytes:136529 (136.5 KB)
El gestor de paquetes Synaptic me indica que poseo instalados los siguientes paquetes siguentes:
firmware-b43-instaler
b43-fwcutter

Soy nuevo en Linux y traté de hacer todo lo que está a mi alcance antes de consultarlos
Alguien me puede dar una mano? Gracias
Last edited by JCSenar on Thu Jun 07, 2018 10:34 am, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4667
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by JOPETA » Thu Jun 07, 2018 5:47 am

Despues de realizar lo comentado en el otro hilo realativo a buscar una conexión a la red por otros medios y cambiar el kernel y devolver el nuevo inxi, de seguir con los problemas de la WIFI BCM, mira este hilo y procede según lo indicado allí. Comenta cualquier duda que tengas al respecto y proprociona el resultado de los códigos que se indican. :wink:

Releyendo el post y dado que pareces tener lo instalado todo lo necesario tal vez sólo tengas que
a)Confirmar el ID del chip

Code: Select all

lspci -nn -d 14e4:
Si el resultado contiene el ID correcto
Broadcom Corporation ....[14e4:4311]
b)cargar el módulo b43

Code: Select all

sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
sudo modprobe b43
sudo rfkill unblock all 
Espera unos minutos para ver que ocurre y si es necesario reinicia y devuelve el resultado de

Code: Select all

lspci -vvnn | grep -A 9 Network
sudo rfkill list all 
En el enlace que se propociona, es decir este, encontaras los problemas que tienena algunos equipos y usarios con diferente chips y cómo lo resolvieron.

Comprueba de todas formas antes que en la BIOS no tienes desactivadas las opciones correspondientes a la LAN y WLAN :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

mariolan
Level 1
Level 1
Posts: 11
Joined: Sat Apr 21, 2018 12:46 pm

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by mariolan » Fri Jun 08, 2018 9:52 pm

Estimado Jopeta, primero te paso la configuracón con el comando que me indicaste

Code: Select all

plv@plc-lumen ~ $ inxi -Fxznr
System:    Host: plc-lumen Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 1526
           Mobo: Dell model: 0WP019 Bios: Dell v: A16 date: 10/27/2009
CPU:       Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 3191
           clock speeds: max: 2000 MHz 1: 800 MHz 2: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]
           bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,vesa (unloaded: fbdev,radeon)
           Resolution: 1024x768@61.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series]
           driver: snd_hda_intel bus-ID: 01:05.2
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Broadcom BCM4311 802.11b/g WLAN bus-ID: 0b:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 265.7GB (4.2% used)
           ID-1: /dev/sda model: WDC_WD2500BEVS size: 250.1GB temp: 39C
           ID-2: USB /dev/sdb model: DataTraveler_2.0 size: 15.6GB temp: 0C
Partition: ID-1: / size: 22G used: 5.7G (28%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.26GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A fan-2: 0 fan-3: 0
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 156 Uptime: 18 min Memory: 446.6/1870.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Respecto de tus recomendaciones para hacer funcionar la placa Broadcom, te adjunto el resultado de los comandos indicados.
Se puede apreciar que la placa coincide con la indicada en el post inicial y con los drivers que he conseguido.
Sin embargo ya a partir del segundo comando recomendado aparece el error y todavía no he podido conectarme a internet por WIFI o por cable

Code: Select all

plv@plc-lumen ~ $ lspci -nn -d 14e4:
0b:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

Code: Select all

plv@plc-lumen ~ $ sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma 
[sudo] password for plv: 
modprobe: FATAL: Module wl not found.

Code: Select all

plv@plc-lumen ~ $ sudo modprobe -r b43 ssb w1 brcmfmac brcmsmac bcma 
modprobe: FATAL: Module w1 not found
Podrás ayudarme?
Gracias
Last edited by JCSenar on Sat Jun 09, 2018 4:31 am, edited 2 times in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4667
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by JOPETA » Sat Jun 09, 2018 6:28 am

Sin cambiar de Kernel vamos mal. Mira mi respuesta en el otro hilo (apartados A y B). Así tal como estás solo se me ocurre que desinstales el controlador bcmwl-kernel-source apt purge bcmwl-kernel-sourcer y reinstales el controlador firmware-b43-instaler (apt install --reinstall firmware-b43-instaler) y repitas el proceso pero sin garantías.

De todas formas no observo que pruebes con el módulo b43 propuesto y no puedo creer que no te puedan prestar un USB WIFI por un rato o que no puedas disponer de media hora de conexión a la red por cable para actualizar el sistema de forma conveniente. :shock:

La alternativa, por muy poco dinero puedes adquirir un USB WIFI, aunque cuando soluciones el problema lo tengas guardando polvo por ahí, como yo tuve que hacer en su momento... :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

mariolan
Level 1
Level 1
Posts: 11
Joined: Sat Apr 21, 2018 12:46 pm

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by mariolan » Tue Jun 12, 2018 12:29 pm

Luego de probar con distintas versiones de Mint (las indicadas en post anteriores), todas generándome iguales inconvenientes (congelado de pantalla de inicio y falta de conexión a internet); decidí instalar la versión 19 del Mint.
Para mi sorpresa, instaló sin inconvenientes y no tuve más inconvenientes respecto del congelamiento de pantalla.
Ahora solo me queda un inconveniente que es la conexión a internet la cual luego de aplicar diferentes comandos, tampoco funciona.
La placa WIFI funciona correctamente en Windows 7, aunque no logro conectarme por cable (vaya uno a saber porque)

Los comandos de configuración dicen lo siguiente

Code: Select all

plv@plv-Inspiron:~$ inxi -Fxznr
System:    Host: plv-Inspiron Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: portable System: Dell product: Inspiron 1526 serial: N/A
           Mobo: Dell model: 0WP019 serial: N/A
           BIOS: Dell v: A16 date: 10/27/2009
Battery    BAT0: charge: 7.2 Wh 17.1% condition: 42.1/48.8 Wh (86%)
           model: SMP DELL WK status: N/A
CPU:       Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) 
           arch: K8 rev.F+ cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 6383
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]
           bus-ID: 01:05.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.00hz
           OpenGL: renderer: ATI RS690
           version: 2.1 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series]
           driver: snd_hda_intel bus-ID: 01:05.2
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card: Broadcom Limited BCM4311 802.11b/g WLAN bus-ID: 0b:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (3.2% used)
           ID-1: /dev/sda model: WDC_WD2500BEVS size: 250.1GB
Partition: ID-1: / size: 91G used: 7.5G (9%) fs: ext4 dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A fan-2: 0 fan-3: 0
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com tara main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 147 Uptime: 34 min Memory: 432.8/1866.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Code: Select all

plv@plv-Inspiron:~$ sudo iwlist scan
[sudo] password for plv: 
lo        Interface doesn't support scanning.

Code: Select all

plv@plv-Inspiron:~$ ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1954  bytes 130986 (130.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1954  bytes 130986 (130.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Los comandos solicitados en post anteriores son los siguientes:

Code: Select all

plv@plv-Inspiron:~$ lspci -nn -d 14e4:
0b:00.0 Network controller [0280]: Broadcom Limited BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

Code: Select all

plv@plv-Inspiron:~$ sudo modprobe -r b43 ssb wl brcmfmac brcmsmac
plv@plv-Inspiron:~$ sudo modprobe b43
plv@plv-Inspiron:~$ sudo rfkill unblock all

El administrador de actualizaciones solicita actualizar:
Kernel de linux 4.15.0.20.23
xdg-desktop-portal
xdg-desktop-portal-gtk

Hasta ahi llego mi conocimento

Habrá algo mas que pueda hacer?
Las actualizaciones harán que me conecte a internet?
De donde las puedo bajar?
Gracias
Last edited by JCSenar on Tue Jun 12, 2018 3:03 pm, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4667
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by JOPETA » Wed Jun 13, 2018 6:32 am

No se. Estás yendo a tu bola... ahora instalando una beta... sin conexión a internet...Tu mismo. Suerte :wink: .
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

JeremyB
Level 19
Level 19
Posts: 9058
Joined: Fri Feb 21, 2014 8:17 am

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by JeremyB » Wed Jun 13, 2018 7:29 am


mariolan
Level 1
Level 1
Posts: 11
Joined: Sat Apr 21, 2018 12:46 pm

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by mariolan » Wed Jun 13, 2018 12:53 pm

Excelente, JeremyB!! Luego del procedimiento indicado se pudo conectar sin reiniciar
En unico problema es que cuando reinicio se no vuelve a conectarse automaticamente
Es necesario realizar el comando:

sudo modprobe b43

User avatar
j8a
Level 1
Level 1
Posts: 24
Joined: Mon Dec 11, 2017 10:58 am

Re: Mint 18.3 no detecta Broadcom BCM4311

Post by j8a » Fri Jun 29, 2018 5:22 pm

Hola mariolan,
La próxima vez que tengas problemas con adaptadores wireless también puedes buscar si están soportados por linux en esta página.
https://wireless.wiki.kernel.org/en/users/drivers/b43
Allí podrás ver los adaptadores broadcom tienen insuficiente soporte en linux.
Además, deberías marcar el problema como resuelto [SOLVED] para que otros puedan ejecutar con éxito y seguridad la receta que propuso JeremyB
Saludos

Post Reply

Return to “Español (Spanish)”