Linux Mint arroja pantalla negra antes de finalizar la carga

Spanish Forum

Moderator: JCSenar

Post Reply
mariolan
Level 1
Level 1
Posts: 11
Joined: Sat Apr 21, 2018 12:46 pm

Linux Mint arroja pantalla negra antes de finalizar la carga

Post by mariolan » Wed Jun 06, 2018 7:58 pm

Estimados, poseo una laptop Dell Inspiron 1526 con dual boot Windows 7 y Linux Mint 18.3
Con Windows 7 funcionan correctamente los drivers de video
En Linux Mint, antes de terminar de cargar, la pantalla queda en negro.
La única forma de iniciar en linux es Iniciar el sistema a prueba de fallos gráficos: A la línea de comando del grub hay que agregarle antes de "--", eliminando quite splash, añadiendo nomodeset xforcevesa y presionando F10 para iniciar

Les paso algunos comandos de configuración

Code: Select all

inxi Fxy
CPU~Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) speed/max~800/2000 MHz Kernel~4.10.0-38-generic x86_64 Up~17 min Mem~519.6/1870.8MB HDD~250.1GB(3.7% used) Procs~160 Client~Shell inxi~2.2.35 
plv@plc-lumen ~ $ inxi -Fxz
System: Host: plc-lumen Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: Dell (portable) product: Inspiron 1526
Mobo: Dell model: 0WP019 Bios: Dell v: A16 date: 10/27/2009
CPU: Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 svm) bmips: 6384
clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1600 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]
bus-ID: 01:05.0
Display Server: X.Org 1.18.4 drivers: ati,vesa (unloaded: fbdev,radeon)
Resolution: 1024x768@61.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series]
driver: snd_hda_intel bus-ID: 01:05.2
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card: Broadcom BCM4311 802.11b/g WLAN
driver: b43-pci-bridge bus-ID: 0b:00.0
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 250.1GB (3.7% used)
ID-1: /dev/sda model: WDC_WD2500BEVS size: 250.1GB temp: 43C
Partition: ID-1: / size: 22G used: 5.8G (28%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 3.26GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 61.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A fan-2: 0 fan-3: 0
Info: Processes: 160 Uptime: 18 min Memory: 520.1/1870.8MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
El gestor de paquetes Synaptic me indica que poseo instalados los siguientes paquetes siguientes:
xserver-xorg-video-amdgpu
xserver-xorg-video-intel

Soy nuevo en Linux y traté de hacer todo lo que está a mi alcance antes de consultarlos
Me podrán dar una mano? Gracias
Last edited by JCSenar on Thu Jun 07, 2018 10:34 am, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4831
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint arroja pantalla negra antes de finalizar la carga

Post by JOPETA » Thu Jun 07, 2018 5:36 am

Debería indicar si el LM 18.3 procede de una instalación limpia o de actualizar desde una edición anterior y en tal caso si reemplazaste el gestor de sesiones (es decir mdm por lightdm) y algunos detalles como lo que muestra la pantalla antes de quedarse oscura o los cambios realizados y/o los enlaces a los tutoriales que seguiste.

Deberás asegurar antes de nada que tienes conexión a internet por otros medios ya que la WIFI BCM no te funciona. Puedes usar la conexión de cable o alguno de los chismes USB que pareces tener por lo que comentas en otros hilos. Que no se se muestre esta tarjeta en el listado puede suponer que la hayas desactivado a nivel de BIOS o un claro problema con el kernel actual.

1)Inicia como estás haciendo hasta ahora ya que parece que no tienes más remedio.
a)Deshaz los cambios que hayas hecho en los archivos del sistema. Por ejemplo ,si has añadido los modificadores al archivo /etc/default/grub , como el que indicas de nomodeset xforcevesa .Si lo hiciste este último elimina todo menos las comillas (ni siquiera por ahora restituyas el quiet splash).

b)Desinstala completamente desde el Gestor de paquetes Synaptic el xserver-xorg-video-intel (no tienes intel tienes AMD) y también el xserver-xorg-video-amdgpu, para ver cual carga el kernel por defecto.
2)Cambia el kernel e instalar uno con soporte actual. El último 4.4 parece el indicado (Kernel de Ubuntu xenial 16.04 LTS en que se basa MInt mas estable para los equipos de una cierta edad). Hazlo de la forma gráfica recomendada. Deberás buscarlo al principio de la relación de kernels. Tendrás que iniciar, tras instalarlo (debido a su menor numeración) desde la opciones avanzadas. Asegúrate que es la opción" generic" sólo nada de modo recuperación, etc.
a)Comprueba como se comporta el sistema con el nuevo kernel. No te sorprendas si el primer inicio es un poco accidentado. Reinicia y observa el comportamiento en ese segundo inicio.

b)Tanto si todo va bien como si debes recurrir de nuevo al inicio a prueba de fallos gráficos (por cienrto que deberías intentar sin el xforcevesa y si no lo hiciste ya, instala el amd64-microcode desde Synaptic de no estar disponible en el Administrador de controladores
3)Si la pantalla negra vuelve a ocurrir:
a) indica si se produce después de efectuar el logín (parará en este punto unos segundos de ser así) y/o lo que muestra la consola en ese momento.

b)Si simplemente desaparece la consola, trata de redirigir la salida de video usando las teclas de función (Fn+la F que muestra una pantallita). Hazlo una, dos o tres veces para asegurar que no es debido a esto.

c)También comprueba que no puedes abrir una línea de ordenes (Ctrl+F2) Si lo hace trata de recargar gestor de ventanas con marco --replace o metacity --replace

d)Si no tienes acceso a la línea de ordenes comprueba que puedes acceder a la ventana de login con Ctrl+Alt+Backspace (borrado hacia atrás)

e)Tanto si lo logras como si no, puedes comprobar que inicias consola en este punto (Alt+Ctrl+F1 o F2). SI lo hace logeate y trata de iniciar sesión gráfica recargando el Xserver con los siguientes códigos (si sigues teniendo mdm reemplaza en el primer código lightdm por mdm).

Code: Select all

sudo service lightdm restart 
Quizás te pida en este punto volver a logaerte, hazlo y luego

Code: Select all

startx

Por el contrario si el primer código te muestra error (o tal vez te comunique que no se encuentra tal o cual cosa). Mira el resultado de

Code: Select all

systemctl status lightdm.service
y si se encuentran procesos activos pero no lightdm como tal

Code: Select all

systemctl start lightdm.service
Después trata de iniciar sesión gráfica con

Code: Select all

startx


Por supuesto comenta los errores que se produzcan al ejecutar cualquiera de los códigos anteriores (si remiten a un inicia en modo emergencia, si conducen a un error de Xserver,...
4)SI fue una forma de abreviar lo entiendo, pero el código inxi cuyo resultado tratas de mostrar no es el correcto, como tampoco lo es la forma de devolver los resultado. Usa el siguiente código (una vez hayas cambiado el kernel como se propone más adelante) y devuelve el resultado de la forma indicada aquí.

Code: Select all

inxi -Fxznr

Aunque puedes probar con kernels mas recientes (4.13 o 4.15 si piensas en actulizar a LM 19 desde LM 18.3 cuando sea posible repitiendo en proceso, parace que el problema es recurrente en esta gráfica y si la solución no se incorpora a las actulzaciones de la serie 4.4. (kernel mas estable) es dificl que lo puedan hacer en las series posteriores.

La solución para no tener que andar editando cada vez el menú de GRUB suele ser incoporarlo es editar el /etc/default/grub con permisos adminsitrativos e incorporar el modificador nomodeset en lugar del quiet splash, mateniendo las comillas. Posteriormente actualizar grub (sudo update-grub). No obstante esto dificulta la instalación y carga de las nuevas versiones del kernel que quieras probar, por lo que lo recomendable es deshacer el cambio antes.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

mariolan
Level 1
Level 1
Posts: 11
Joined: Sat Apr 21, 2018 12:46 pm

Re: Linux Mint arroja pantalla negra antes de finalizar la carga

Post by mariolan » Fri Jun 08, 2018 10:10 pm

La instalación de LMint en limpia.
El resultado del comando que indicaste es el siguiente:

Code: Select all

plv@plc-lumen ~ $ inxi -Fxznr
System:    Host: plc-lumen Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 1526
           Mobo: Dell model: 0WP019 Bios: Dell v: A16 date: 10/27/2009
CPU:       Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 3191
           clock speeds: max: 2000 MHz 1: 800 MHz 2: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]
           bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,vesa (unloaded: fbdev,radeon)
           Resolution: 1024x768@61.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series]
           driver: snd_hda_intel bus-ID: 01:05.2
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Broadcom BCM4311 802.11b/g WLAN bus-ID: 0b:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 265.7GB (4.2% used)
           ID-1: /dev/sda model: WDC_WD2500BEVS size: 250.1GB temp: 39C
           ID-2: USB /dev/sdb model: DataTraveler_2.0 size: 15.6GB temp: 0C
Partition: ID-1: / size: 22G used: 5.7G (28%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.26GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A fan-2: 0 fan-3: 0
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 156 Uptime: 18 min Memory: 446.6/1870.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
La realidad es que describí mal el inconveniente. La pantalla no queda negra, en realidad queda frizada con el logo de Linux Mint.
Por ello ninguna combinación de teclas (para salir de la pantalla frizada, produjo resultado satisfactorio). Pido disculpas por ser impreciso.
No realicé ningun cambio en el sistema, no añadí nada al GRUB.
El cambio del Grub (nomodeset xforseversa) lo debo realizar en cada inicio y no queda grabado.
Desinstalé completamente desde el Gestor de paquetes Synaptic el xserver-xorg-video-intel y también el driver xserver-xorg-video-amdgpu. Pero al desisntalar este ultimo también lo hizo lo mismo con el driver xserver-xorg-video-all
Habrá alguna forma de hacer algo sin cambiar el Kernel?
Gracias
Last edited by JCSenar on Sat Jun 09, 2018 4:31 am, edited 1 time in total.
Reason: Añadido el formato [code]

User avatar
JOPETA
Level 13
Level 13
Posts: 4831
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint arroja pantalla negra antes de finalizar la carga

Post by JOPETA » Sat Jun 09, 2018 6:08 am

mariolan wrote:
Fri Jun 08, 2018 10:10 pm
también lo hizo lo mismo con el driver xserver-xorg-video-all
No te he pedido que desinstales ese paquete.
mariolan wrote:
Fri Jun 08, 2018 10:10 pm
Habrá alguna forma de hacer algo sin cambiar el Kernel?
A)Aún tienes la posibilidad de considerar la alternativa reisntalar LM 17.2 o LM 17.3 y estar operativo un año. Si la instalación fué incompleta porque la realizaras sin instalación a la red las alternativas que se desccriben en el apartado C pueden ser un suplicio por las dependencias y faltas de paquetes instalados.
En tu hilo se concentran varios errores que sin animo de hacer escarnio voy a resumir:

1)Descargar una ISO sin estar seguro cual es la edición recomendada. Te habría recomendado la edición LM 17.2 que aún hoy en día te garantiza un año sin problemas o la LM 17.3 ( limitaría tu problema de producirse solo a la WIFI y te permitiría probar el resultado de instalar el kernel 4.4. para hacer la transicción a LM 18.3 menos traumática). Tambien te habría sugerido la posibilidad probar la edición de 64Bits ya que tu procesador lo es.

2)Instalar sin probar a fondo que todo funciona bien o aunque no funcione. Tener que iniciar el lIve de instalación en modo a prueba de fallos gráficos ya te habría sugerido algún problema y a poco que buscaras información tendrías que haberte planteado el punto anterior y sin conexión WIFI más aún. Los problemas de la gráfica los tienes descritos en el hilo ¡Controladores AMDGPU en Linux Mint 17 y 18! ¡Mira aquí antes de hacer nada! y los de la WIFI ya lo conoces.
B) En defecto de la anterior sugerencia reconsidera el cambio de kernel. No considerar el cambio de kernel supone asumir las limitaciones gráficas, como te digo en el punto anterior. y la imposibilidad de que se solucionaran o por lo menos mejore su comportamiento en el futuro.
Si lo que te preocupa/limita en esto es la falta de conexión a red aquí puedes descarga tanto el kernel como los paquetes relacionados (desde Windows por ejemplo)que necesites para tu arquitectura (386) y procesador (AMD). copias los archivos descargados en un directorio del usuario y ejecuta su instalación haciendo clic sobre ello o mediante la terminal. Por ejemplo si los copiaste en Descargas abre la terminal (Ctrl+Alt+T o clic en el icono y copia y pega los siguiente códigos una línea cada vez seguido de Intro.

Code: Select all

cd ~/Descargas
sudo dpkg -i *.deb
Cuando finalice de instalar

Code: Select all

sudo update-grub
sudo reboot
Como ya te he dicho por la menor numeración tendrás que iniciarlo desde el menú de opciones avanzadas hasta que no elimines el actual kernel 4.10 de la forma gráfica recomendada.

Esto por si mismo puede que no resuelva tu problema gráfico (que ya deberás saber que es debido al abandono del soporte por parte de AMD) pero te garantiza que dispondrás de unas librerías actualizadas y compatibles con el kernel instalado para probar otras soluciones y tal vez te permita resolver el problema de la WIFI con ciertas garantías.
C)Otras cosas que puedas probar están descritas en varias wiki como la propia de Ubuntu (que se limita a sugerirte que instales Ubuntu xenial de forma implícita) o la de a de Arch a poco que busques por ATI o RADEON. Se basan conseguir aceleración básica suficiente, problema que no pareces tener mediante instalación de librerías (xf86-video-ati, mesa-utils, vdpau-*..) y/o modificar los archivos de configuración. La experiencia de otros usuarios incluso con kernel con soporte y con gráficas y equipos mas actualizados y no son muy prometedoras. Sin conexión a la red puedes recurrir a la descarga manual de las librerías que no tengas instaladas en la página anterior realizando la búsqueda del paquete en cuestión para xenial.

D) En las actuales condiciones, tanto si te parecen suficientes las capacidades gráfica que obtienes al iniciar con el nomodeset o de probar con lo expuestos en esas webs y no obtener mejores resultados, es conseguir un inicio menos traumático.
-Prueba a iniciar sólo eliminando quiet splash (por si el problema es el Plymouth el logo de animación) por si logras un inicio gráfico practicable sin modificar la carga del kernel y si esto no da resultado sin el xforcevesa.
-Modifica el archivo /etc/default/grub

Code: Select all

 gksudo xed /etc/default/grub
eliminar quite splash y añadir el modificador nomodesetting
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
-Guarda el archivo modificado cierra el aditor
-Actualiza GRUB

Code: Select all

sudo update-grub
-Reinicia.

Code: Select all

sudo reboot
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”