Problemas con Teclado Y Touchpad

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
NormanBrandon
Level 1
Level 1
Posts: 1
Joined: Sat Jun 30, 2018 5:01 pm

Problemas con Teclado Y Touchpad

Post by NormanBrandon » Sat Jun 30, 2018 5:40 pm

Llevaba usando Linux Mint en mi Portatil desde hace ya 7 meses, sin dual boot.
Hasta hace un par de semanaa no me habia dado ningun problema mi pc. Un dia que deje mi pc sin usar por una hora, como de costumbre se puso la pantalla de bloqueo de pantalla e intente acceder pero resulta que no respondia el teclado ni el touchpad.La reinicie y seguia sin funcionar. El mouse USB no da problemas.
Intente varias cosas, encontre que cambiando una linea del archivo del grub GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux"
me volvio a funcionar, sin embargo cuando se bloqueaba la pantalla volvia dejaba de reponder el teclado y touch pad de nuevo, aun accediendo con el teclado en pantalla (usando el mouse usb). Solo reiniciando volvia a funcionar. Lo curioso es que si detecta el teclado en la BIOS y en el grub.
Instale un live cd en una usb con mint y no detecta en teclado, solo lo detecta en las opciones de instalacion(antes de la carga del SO).
Luego me harte y pase todos mis archivos a una particion de respaldo que tengo en formato NTFS.
Y luego borre todas las particiones menos las de respaldo, esto desde live cd usando teclado en pantalla mouse usb. No se soluciono el problema, seguia exactamente en las mismas, asi que lo desisntale de nuevo. Instale windows 10 y sin problemas me detecta el teclado. Depues instale ArchLinux en usb y para tratar dd instalarlo con dual boot , el teclado funcio a cuando me pide que eliga una opcion antes de instalar, pero cuando carga el SO ya no me detecta teclado.
No he encontrado muchos casos similares al mio, no se como solucionarlo.No quiero dejar linux.

User avatar
JOPETA
Level 15
Level 15
Posts: 5665
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con Teclado Y Touchpad

Post by JOPETA » Tue Jul 03, 2018 6:08 am

Aunque al final no me queda claro qué tienes ahora instalado( no ya edición de Mint y escritorio, ni siquiera de qué distro), por lo menos te daré la bienvenida a foro (¡Hola NormanBrandon!) y recomendarte la lectura de este tema destacado para que procedas a proporcionar la información necesaria de la forma indicada. :D

El problema de touchpad es conocido, además del problema previsto en la mayoría de las notas de lanzamiento (apartado touchpad drivers). Entre los otros detalles necesarios en tu caso está conocer el controlador que tienes por defecto devolviendo de la misma manera (usando la opción </> code) el resultado del código y proceder de la forma indicada en el enlace si procede.

Code: Select all

grep -i "Using input driver" /var/log/Xorg.0.log
Un problema más común que afecta a una gran variedad de portátiles con independencia del controlador, por lo general se suele solucionar recurriendo al dconf editor.

Dependiendo de la distro/escritorio tal vez tendrás que instarlo antes. Una vez inicies este editor deberás confirma y en su caso modificar la siguiente configuración en el caso de Cinnamon Org>Cinnamon>Setting deaemon>Periphericals>Touchpad>Touchpad-enable (marcar)
touchpad.png
En el caso de Mate la ruta es Org>Mate>desktop>periphericals>touchpad>>touchpad-enable (marcar).

En espera de los datos solicitados y de los resultados anteriores, lo del teclado mas bien debe atender a la configuración de la BIOS pero sin saber de qué portátil se trata, es tontería ni planteárselo.

Si el problema general tiene que ver con la suspensión por inactividad puedes, mientras tanto, modificar la configuración de la energía (por ejemplo siguiendo el supuesto cinnamon Menú>Centro de control>Gestión de energía>Energía>Suspender tras un inactividad de> nunca y en Brillo activar la atenuación del brillo por inactividad), además de los ajustes del salvapantallas (Menú>Centro de control>Salvapantallas), para que se apague sólo la pantalla y evitar la suspensión...¡chimpón!. :D
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”